Références

Active+ Software

Depuis plusieurs années Active+ Software développe des utilitaires système destinés à faciliter le travail des administrateurs sur les serveurs et les applications Windows NT, 2000, XP et 2003. Nous nous sommes particulièrement penchés sur l'amélioration de l'administration, la stabilité des plate-formes et la réduction de la charge de travail.

Notre idée fondamentale a toujours été d'utiliser les performances internes du système Windows pour résoudre les problèmes d'exploitation de l'architecture des Services Windows.

Nous avons conçu toute une série d'utilitaires système. Ces utilitaires permettent de transformer les applications, les programmes batch en Services Windows. Ces applications s'exécutent alors en arrière-plan en tant que services, sans la nécessité d'une session utilisateur. Elles peuvent alors être (tout comme les services classiques) planifiées, surveillées et réparées à distance avec un seul et unique outil entièrement automatisé.

Aujourd'hui, grâce aux utilitaires d'Active+ Software, des applications critiques sont lancées en tant que services sur des milliers de systèmes Windows NT, 2000, XP et 2003, facilitant et améliorant leur administration. Que ce soit dans des entreprises gouvernementales, des multinationales, dans des centres de données, sur des serveurs de développeurs ou sur des postes de travail de professionnels IT, ces utilitaires s'intègrent parfaitement à Windows.

Les utilitaires d'Active+ Software :

  • Console Service+ :
    Service+ est un utilitaire indispensable pour tous les professionnels utilisant Windows NT, 2000, XP et 2003. Il remplace la console originale de gestion des Services, avec un aspect similaire mais des fonctions d'administration enrichies : état des services en temps réel, sélection de plusieurs services pour édition et contrôle simultanés, tri avancé, gestion des services à distance, édition des dépendances des services, possibilité de terminer le processus d'un service ne répondant plus - sans avoir besoin de redémarrer l'ordinateur !
  • Service+ en ligne de commande :
    Un gain de temps pour les administrateurs qui gèrent leurs machines Windows en réseau. Cet utilitaire en ligne de commande permet le contrôle et l'édition des services d'un nombre illimité d'ordinateurs sur tout un domaine, en utilisant les jokers.
  • Utilitaire de services ServiceMill :
    La façon la plus rapide et la plus simple de transformer vos applications Java, code script, fichiers batch, applications graphiques ou applications console en Service Natif Windows. Lancez vos applications critiques ou client-serveur en tant que service sans session utilisateur. Cachez vos applications sensibles en les exécutant en tâche de fond, en tant que service, sans utilisateur connecté sur l'ordinateur. Contrôlez, surveillez et réparez vos applications aussi facilement et efficacement que des services (avec ServiceKeeper).
  • Contrôle ActiveX ServiceMill Control :
    Transforme votre propre application en Service Natif Windows. Votre programme VB ou Delphi est alors exécuté en arrière-plan au travers du thread primaire du processus tout en bénéficiant de l'accès au Journal d'Evénements. Le contrôle (Démarrage, arrêt, mise en pause et terminaison du processus) peut être effectué soit au travers de Service+ soit par l'intermédiaire du composant enfichable de gestion des services MMC.
  • Utilitaire de surveillance des services ServiceKeeper :
    La solution absolue pour empêcher les terminaisons anormales de services et les arrêts de serveurs qui peuvent être fatals. ServiceKeeper fournit des outils d'administration qui permettent de planifier l'exécution des services, de détecter les pannes en utilisant une large gamme de méthodes, d'avertir les administrateurs grâce à différents moyens de notification et de réparer les services défaillants ou en panne selon des procédés variés. L'administration et le contrôle de services installés sur des ordinateurs distants sont possibles.
Enregistrement de votre logiciel : les versions d'évaluation des logiciels Active+ Software sont valables 30 jours. Vous devez re-télécharger le logiciel pour entrer la clé d'enregistrement. Cette clé vous est envoyée par email lors de votre commande.

Voir aussi

A propos des Services

© 1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Service+

Présentation de Service+

Les utilisateurs Windows ont pu constater que les limitations de l'interface standard entraînent souvent la répétition de certaines tâches et par conséquent des pertes de temps. Ceci s'applique particulièrement aux services et à la façon dont ils sont contrôlés par le SCP.

Par exemple, quand un service Windows ne répond plus, la seule option proposée par une configuration standard est de redémarrer l'ordinateur, une action trop radicale si la machine exécute des applications critiques. L'administration des services de plusieurs ordinateurs d'un réseau oblige l'administrateur à se connecter tour à tour sur chaque ordinateur, ce processus pourrait être accélérer en exécutant des opérations en ligne de commande utilisant des jokers.

Service+ est un utilitaire d'administration de services conçu pour fournir aux administrateurs un niveau de contrôle incomparable sur les services. Ses fonctionnalités sont supportées par tous les systèmes NT. Service+ se substitue au SCP de services standard qui reste accessible depuis la commande Démarrer/Exécuter/services.msc (pour le composant enfichable MMC sous Windows 2000, XP et 2003). Le tableau ci-dessous indique les fonctionnalités supplémentaires proposées par Service+ :

 | Service+ | Standard Windows Services SCP
 | Windows NT/200x/XP | Windows XP | Windows 200x | Windows NT
Administrer les services à distance | OUI | OUI | OUI | NON
Gestion des services de plusieurs serveurs au travers d'une seule vue | OUI | NON | NON | NON
Creation de vues personnalisées | OUI | NON | NON | NON
Terminer le processus d'un service | OUI | NON | NON | NON
Afficher l'état en temps réel | OUI | NON | NON | NON
Contrôler simultanément des services | OUI | NON | NON | NON
Editer simultanément des propriétés | OUI | NON | NON | NON
Trier des services par propriétés | OUI | OUI | OUI | NON
Supprimer des services | OUI | NON | NON | NON
Installer un service | OUI | NON | NON | NON
Visualiser l'état des drivers | OUI | NON | NON | NON
Editer les dépendances des services | OUI | NON | NON | NON
Surveillance et réparation | ServiceKeeper | OUI | OUI | NON
Attacher un débogueur aux services | OUI | NON | NON | NON
Produits associés :
Service+ CL : la version ligne de commande de Service+ qui utilise des jokers pour contrôler les services à travers tous les domaines.
ServiceMill : l'utilitaire qui permet de transformer vos applications Java, code script, fichiers batch, applications graphiques ou applications console en Service Natif Windows. Inclut Service+.
ServiceKeeper : l'utilitaire qui planifie, contrôle et répare les services Windows et les applications critiques. Inclut Service+.

Configuration :

Service+ est une application Unicode disponible en anglais et français.
Configuration minimum :
  • Windows 2000, Windows XP (32-bit & 64-bit), Windows Server 2003 (32-bit & 64-bit), Windows Vista
  • 10 MB d'espace disque
Note : Supporte les plates-formes Intel x86, Intel Itanium et AMD x64.

Installation :

Décompresser svcplus.zip dans un répertoire temporaire, puis lancer setup.exe et suivre les instructions. Notez qu'en installant Service+, le SCP de services d'origine ne sera pas supprimé de votre système.

Licences :

  • 1 Utilisateur
  • 10 Utilisateurs
  • Licence Site (nombre illimité d'utilisateurs sur un même site)
Nous contacter pour des licences spécifiques OEM
Note : Service+ est inclus avec ServiceMill et ServiceKeeper. Vous n'avez pas besoin de l'installer si vous utilisez déjà l'un d'eux.

Voir aussi

Surveillance avancée des services et des ressources serveurs avec ServiceKeeper
Transformer un fichier exécutable en un service avec ServiceMill
La console Service+


La console Service+

Le but du SCP est de fournir des ordres aux services par l'intermédiaire du SCM. Service+ est un SCP amélioré. Le SCM reste le 'services.exe' faisant partie de votre système d'exploitation.

Les commandes habituelles des processus de service sont Démarrer, Arrêter, Pause et Redémarrer, Service+ inclut en plus les commandes Tuer (terminer le processus d'un service qui ne répond plus), Supprimer et Déboguer.

Service+ affiche les services dans une console MMC similaire à celle du SCP de services d'origine. Le noeud Services dans l'arborescence regroupe les services par serveur.

La console Service+ peut être exécutée de trois façon différentes:

  • Cliquer sur le raccourci Service+ sur le bureau.
  • Au moyen du menu Outils d'administration/Service+.
  • ou en tapant a l'invite de commande "c:\Program Files\Active+\Utilitaires\Service+\svcplus.exe".

Propriétés des services :

L'icône devant chaque service indique son état en temps réel :
Service démarré Service en pause En attente Service surveillé La dernière réparation a échoué Une erreur a été détectée
  • Nom : chaîne de caractères. Le nom est stocké dans la base de registres en tant que paramètre DisplayName et peut être édité avec Service+.
  • Description : chaîne de caractères. La description du service (jusqu'à 1024 octets) est stockée dans la base de registres sous le paramètre Description et peut être édité avec Service+.
  • Serveur : nom du serveur sur lequel le service est installé
  • Etat : indique l'état du service : Démarrage en attente / En cours de démarrage / Démarré / Arrêt en cours. Service+ affiche l'état du service en temps réel; vous n'avez pas besoin de rafraîchir la vue.
  • Démarrage : indique la configuration de démarrage du service : automatique, manuel ou désactivé. Stocké dans la base de registres en tant que paramètre Start, il peut être édité avec Service+.
  • Alias : l'alias identifie de manière unique le service dans la base de données des services. Il ne peut pas être édité.
  • Compte : indique sous quel compte le service est lancé. Le compte esttocké dans la base de registres sous le paramètre ObjectName et peut être édité avec Service+.
  • Dépendances : indique le nom du(des) service(s) qui doivent être démarrés pour que ce service puisse être démarré. Les dépendances sont stockées dans la base de registres sous le paramètre DependOnService et peuvent être éditées avec Service+. Notez que le paramètre DependOnGroup qui spécifie les groupes de services dépendants (habituellement les pilotes) n'est pas éditable avec Service+.
  • Les services dépendants sont: indique la liste des services qui ne peuvent être lancés que si le service est démarré.
  • Chemin : indique le chemin d'accès au fichier exécutable du service. Stocké dans la base de registres sous le paramètre ImagePath, il peut être édité avec Service+.
  • Type de Processus : indique le type de processus du service. Stocké dans la base de registres sous le paramètre Type, il est spécifié au moment de la création du service avec Service+ ou ServiceMill.
  • Gestion d'erreur : spécifie comment le processus de démarrage se comporte quand une erreur se produit. Stocké dans la base de registres sous le paramètre ErrorControl et spécifié au moment de la création du service avec Service+ ou ServiceMill. Ce paramètre ne peut être édité que dans la base de registres (avec prudence).
  • CPU : indique l'utilisation CPU du processus du service.
  • Util. mémoire : indique l'utilisation mémoire du processus du service.
  • Taille MV : indique la taille de la mémoire virtuelle allouée au processus du service.
  • Disponibilité : indique le pourcentage de temps pendant lequel la ressource a été disponible (c'est à dire le temps pendant lequel ServiceKeeper n'a pas détecté de panne).
Note: vous pouvez trier les colonnes de la vue en cliquant sur l'entête de chaque colonne.

Les actions:

La plupart des actions peuvent être effectuées sur plusieurs services à la fois. Pour sélectionner plusieurs éléments à la fois, cliquez sur plusieurs éléments dans la liste des services en utilisant les touches Maj ou Ctrl. Les actions sont accessibles au travers du menu Action, de la barre d'outils ou par un clic droit sur un service dans la liste.

Propriétés
Pour éditer les propriétés et les dépendances du service.
Démarrer
Démarre un service arrêté. Tous les services arrêtés dont le service démarré dépend seront démarrés. Pour communiquer les paramètres de démarrage du service, appuyez en même temps sur la touche Maj. et le bouton Démarrer.
Arrêter
Arrête un service démarré. Si un autre service dépend de ce service, il sera également arrêté.
Pause
Met en pause un service démarré (le processus reste chargé). Mettre un service en pause agira également sur tous les autres services dépendants. Notez que la plupart des services n'accepte pas l'état "Pause". Quand vous mettez le service "Serveur" en pause, seuls les membres des groupes "Administrateur" et "Opérateurs de Serveur" peuvent se connecter à la machine. Cliquez sur Continuer pour reprendre le processus du service.
Redémarrer
Redémarre un service lancé (Arrêter/Démarrer). Redémarrer un service arrêtera et redémarrera les services dépendants précédemment démarrés.
Supprimer

Supprime un service. Le service doit d'abord être arrêté avant d'être supprimé. Utilisez cette fonction avec beaucoup de prudence. Vérifiez que vous ne supprimez pas un service dont dépendent d'autres services.

Cette fonction est disponible uniquement pour les services de la machine locale.
Arrêter le processus
Cette fonctionnalité est très utile pour stopper les services qui ne répondent plus, sans avoir à redémarrer l'ordinateur. Vous ne devez utiliser cette fonction que lorsque la commande d'arrêt de service ne fonctionne pas ou est désactivée. Attention au fait que les services dépendants ne seront pas stoppés et peuvent se terminer anormalement. Cette fonction est disponible uniquement pour les services de la machine locale.
Déboguer le processus
Si un débogueur qui supporte le "Just in time debugging" est installé sur votre système, vous pouvez utiliser cette fonction pour lancer le débogueur et l'attacher au processus du service.

(A l'attention des programmeurs Visual C++ : ceci est équivalent à la commande msdev /p pid)

Cette fonction est disponible uniquement pour les services de la machine locale.
Sélectionner l'ordinateur
Sélectionne l'ordinateur sur lequel sont installés les services que vous voulez contrôler. Vous devez avoir les droits administrateur sur la machine distante pour exécuter ces commandes, sinon vous ne pourrez que voir les services distants.
Ajouter une nouvelle vue personnalisée
Cette option vous permet de créer une nouvelle vue personnalisée. Elle est accessible en sélectionnant le noeud Services ou le noeud Ressources Surveillées dans l'arborescence de la console.
Ajouter de nouveaux éléments à la vue courante
Cette option vous permet d'ajouter de nouveaux éléments à la vue courante. Elle est accessible lorsqu'une vue est sélectionnée dans l'arborescence de la console.
Supprimer les éléments sélectionnés de la vue
Cette option vous permet de supprimer des éléments de la vue courante. Les éléments sont retirés de l'affichage dans la vue. Ils ne sont pas supprimés de l'ordinateur. Cette option est accessible lorsqu'un ou plusieurs éléments sont sélectionnés dans une vue de l'arborescence de la console.
Installer un nouveau service ServiceMill
Cette action n'est active que si vous avez acquis une licence ServiceMill et installé le logiciel ServiceMill. Elle vous permet d'installer un service créé à l'aide de ServiceMill. ServiceMill est un logiciel qui vous permet d'exécuter n'importe quel programme en tant que service Windows.

Paramètres de démarrage : Vous pouvez passer des paramètres de démarrage en cliquant sur le menu Action/Démarrer... ou en cliquant sur MAJ + le bouton Démarrer [image] de la barre d'outils. Si le service est un fichier de commande batch exécuté au travers de ServiceMill, cette action vous permet de spécifier des paramètres de démarrage pour le fichier de commande.

Voir aussi

Modifier les options de la console


Editer les options de la console

Pour modifier les options de la console Service+, ouvrez la console et sélectionnez le noeud Service+ de l'arborescence puis cliquez avec le bouton droit de la souris et sélectionnez le menu Propriétés.

  • Afficher l'icône Service+ dans la barre de tâche
    Cette option ajoute l'icône Service+ dans la barre de tâche lorsque Service+ est lancé.
  • Démarrer Service+ au lancement de Windows
    Lorsque cette option est cochée, Service+ démarre automatiquement à l'ouverture de chaque session Windows.
  • Utiliser le mode de détection rapide des ordinateurs distants (PING)
    Lorsque cette option est cochée, Service+ envoie une requête PING avant de tenter de se connecter à la base de données des services d'un serveur distant. Cette méthode permet de détecter plus rapidement si un ordinateur est présent ou non sur le réseau (Note : TCP/IP doit être activé pour que ce mode fonctionne).

Voir aussi

La console Service+

© 1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques .


Modifier la sécurité du Service Control Manager

Pour changer la sécurité du Service Control Manager, ouvrez la console et sélectionnez le noeud Service+ de l'arborescence puis cliquez avec le bouton droit de la souris, cliquez sur Propriétés et sélectionnez l'onglet Sécurité du Service Control Manager.

Note : cette fonctionnalité n'est disponible qu'à partir de Windows 2003 SP1 ou ultérieur.
  • Groupes et utilisateurs : liste les groupes et les utilisateurs qui sont autorisés ou pas à accéder au Service Control Manager. Les droits suivants peuvent être assignés :
    • Contrôle Total : l'utilisateur ou le groupe a tous les droits sur le Service Control Manager.
    • Se connecter au Service Control Manager : requis pour pouvoir se connecter au Service Control Manager.
    • Créer un service : requis pour pouvoir créer un service et l'ajouter à la base de données des services.
    • Enumérer les services : requis pour pouvoir énumérer les services qui sont dans la base de données.
    • Verrouiller la base de données des services : requis pour pouvoir verrouiller la base de données des services (la base de données des services doit être vérouillée, par exemple, quand la configuration d'un service est modifiée).
    • Demander l'état du verrou de la bd des services : requis pour pouvoir demander l'état du verrou sur la base de données des services.
    • Modifier la dernière configuration valide : requis pour pouvoir sauvegarder la dernière configuration valide.
    • Demander le descripteur de sécurité du SCM : requis pour pouvoir afficher le descripteur de sécurité du Service Control Manager. Si un utilisateur n'a pas ce droit, il ne pourra pas afficher la page 'Sécurité du Service Control Manager'.
    • Modifier le descripteur de sécurité du SCM : requis pour pouvoir modifier le descripteur de sécurité du Service Control Manager. Si un utilisateur n'a pas ce droit, il ne pourra pas appliquer les changements effectués dans la page 'Sécurité du Service Control Manager'.
    • Modifier le propriétaire et les groupes du SCM : requis pour modifier le propriétaire et les groupes du Service Control Manager.
  • Réinitialiser : cliquez sur ce bouton si vous voulez réinitialiser la sécurité du Service Control Manager à la sécurité par défaut.

Voir aussi

Sécurité d'un Service

© 1997-2007 Active+ Software . All trademarks property of their owners. Send us feedback.


Les vues personalisées

Les vues personnalisées

Service+ offre une fonctionnalité unique au travers des vues personnalisées. Une vue personnalisée vous permet de rassembler un ensemble restreint de services que vous voulez surveiller ou maintenir dans une vue particulière. Vous pouvez créer autant de vue que vous le désirez, chacune regroupant une sélection spécifique de services.

Par exemple, vous pourriez créer une vue regroupant tous les services collaborant à la bonne marche de votre application CRM gérant votre centre d'appel.

  • Les vues sont personnalisées au travers de la création de "filtres de sélection de ressources". Chaque filtre détermine si une ressource appartient ou est exclue de la vue.
  • Une même vue peut regrouper des services lancés sur des serveurs différents.
  • Il y a deux types de vues: les Vues Personnalisées standards et les Vues Ordinateur.

Voir aussi

Qu'est ce qu'une vue ordinateur?
Créer une vue personnalisée
Ajouter des éléments à une vue
Les propriétés d'une vue
Supprimer une vue personnalisée


Qu'est ce qu'une vue ordinateur ?

Une vue ordinateur est une vue personnalisée particulière qui regroupe tous les services installés sur un même ordinateur. Les vues ordinateur proposent simplement une manière plus rapide de regrouper les services d'un serveur particulier.

La vue Ordinateur Local est une vue ordinateur créée automatiquement lorsque Service+ est lancé.

Les vues ordinateur disposent d'une icône particulière [image].

Un filtre de selection de ressource bien particulier définit une vue ordinateur. Ce filtre sélectionne tous les services d'un même ordinateur. Le filtre ci-dessous définit une vue du serveur "Mailsvr01".

Si vous changez le filtre de sélection de ressource d'une vue, la vue devient une vue personnalisée standard et son icône change également.

Voir aussi

Créer une vue ordinateur
Editer un filtre de sélection de ressource
Les vues personnalisées


Créer une vue personnalisée

Pour créer une vue personnalisée

1. Sélectionnez le noeud Services de l'arborescence de la console.

2. Cliquez avec le bouton droit de la souris sur le noeud Services et sélectionnez Nouveau/Vue personnalisée, ou cliquez sur le bouton Ajouter une nouvelle vue personnalisée [image] de la barre d'outils, ou sélectionnez le menu Action/Nouveau/Vue personnalisée.

3. Entrez un nom et une description pour la vue et cliquez Suivant pour continuer.

4. Sélectionnez le type de vue que vous souhaitez créer puis cliquez sur Suivant pour continuer.

  • Une vue vide
    Créer une vue sans que vous ayez à éditer les filtres de sélection de ressources. La vue est vide mais vous pourrez ajouter et retirer des éléments à la vue ultérieurement.
  • A partir d'un filtre de sélection de ressources
    Opter pour ce choix si vous souhaitez éditer les filtres de sélection de ressources.

Voir aussi

Ajouter des éléments à une vue
Editer un filtre de sélection de ressource
Les vues personnalisées


Créer une vue ordinateur

Pour créer une vue ordinateur

1. Sélectionnez le noeud Services de l'arborescence de la console.

2. Cliquez avec le bouton droit de la souris sur le noeud Services et sélectionnez Nouveau/Vue ordinateur, ou cliquez sur le bouton Ajouter une nouvelle vue ordinateur [image] de la barre d'outils, ou sélectionnez le menu Action/Nouveau/Vue ordinateur.

3. Choisissez l'ordinateur que vous souhaitez afficher.

Voir aussi

Qu'est ce qu'une vue ordinateur ?
Editer un filtre de sélection de ressource
Les vues personnalisées


Ajouter des éléments à une vue

Une vue personnalisée est faite pour regrouper les services ou les ressources surveillées de votre choix. Vous avez plusieurs méthodes pour ajouter ou supprimer des éléments d'une vue.

Ajouter des éléments en utilisant le glisser/lacher.

1. Sélectionnez dans l'arborescence de la console une vue contenant les éléments que vous voulez déplacer. Cela peut être tout type de vue.

2. Sélectionnez le(s) élément(s) à déplacer (utilisez la combinaison de touches Maj et CTRL pour sélectionner plusieurs éléments de la vue).

3. Glissez et déplacez votre sélection sur la vue destination.

Ajouter des éléments via les menus ou la barre de tâches

1. Sélectionnez dans l'arborescence de la console la vue dans laquelle vous voulez ajouter des éléments (services ou ressources surveillées). Cela peut être tout type de vue.

2. Cliquez avec le bouton droit de la souris sur le noeud représentant la vue et choisissez Toutes les tâches/Ajouter des éléments à la vue, ou cliquez sur le bouton Ajouter des éléments à la vue [image] de la barre de tâche, ou sélectionnez le menu Action/Toutes les tâches/Ajouter des éléments à la vue.

3. Sélectionnez un ordinateur sur lequel sont installés les services ou les ressources surveillées que vous voulez ajouter.

4. Sélectionnez les services ou les ressources surveillées à ajouter (utilisez la combinaison de touches Maj et CTRL pour sélectionner plusieurs éléments).

Ajouter des éléments à une vue en éditant les filtres de sélection de ressources

Voir Editer les filtres de sélection de ressources

Voir aussi

Editer les filtres de sélection de ressources
Les vues personnalisées


Editer les filtres de sélection de resources

Editer les filtres de sélection de ressources

Quand vous ajoutez ou supprimez des éléments à des vues via la barre d' outils, les menus ou par un glisser/lacher, vous ajoutez, supprimez ou modifiez des filtres de sélection de ressources. Il est également possible d'éditer ces filtres directement.

Pour éditer les filtres de sélection de ressources

1. Sélectionnez la vue que vous souhaitez modifier dans l'arborescence de la console.

2. Cliquez avec le bouton droit de la souris sur le noeud représentant la vue et choisissez Propriétés, ou sélectionnez le menu Action/Propriétés. Alternativement vous pouvez cliquez sur le bouton Propriétés [image] de la barre de tâches.

Les filtres existants de la vue sont listés au bas de la page.

  • \\MAILSVR01\W3SVC est un filtre qui ajoute le service IIS à la vue.
  • \\MAILSVR01\IISADMIN est un filtre qui ajoute le service d'administration d'IIS à la vue.
  • \\MAILSVR01\SMTPSVC est un filtre qui ajoute le service SMTP à la vue.
  • \\MAILSVR01\CRM est un filtre qui ajoute le service CRM à la vue.

Depuis cette page, vous pouvez Ajouter, Supprimer ou Modifier les filtres de sélection de ressources de la vue.

Voir aussi

Ajouter un filtre de sélection de ressources
Modifier un filtre de sélection de ressources
Supprimer un filtre de sélection de ressources

Les vues personnalisées

Ajouter des éléments à une vue


Ajouter un filtre de sélection de ressources

Pour ajouter un nouveau filtre

1. Sélectionnez la vue que vous souhaitez modifier dans l'arborescence de la console.

2. Cliquez avec le bouton droit de la souris sur le noeud représentant la vue et choisissez Propriétés, ou sélectionnez le menu Action/Propriétés. Alternativement vous pouvez cliquez sur le bouton Propriétés [image] de la barre de tâches.

3. Cliquez sur le bouton Nouveau filtre [image].

2. Saisissez directement le filtre de votre choix ou cliquez sur le bouton de navigation pour sélectionner un ordinateur. Lorsque vous sélectionnez un ordinateur, Service+ crée automatiquement un filtre ajoutant tous les ressources (services ou ressources surveillées) de l'ordinateur en utilisant le caractère joker * comme dans \\MAILSVR01\*.

Vous pouvez éditer le filtre pour inclure ou exclure des services ou des ressources surveillées en utilisant éventuellement les caractères jokers (* et ?). Par exemple, vous pourriez sélectionner tous les services ayant rapport avec le service de gestion de disques avec le filtre \\Mailsvr01\dm* sachant que ces services sont dmserver et dmadmin.

Note: Par défaut les alias sont utilisés dans les filtres de sélection de services mais vous pouvez utiliser le nom long des services en modifiant le paramètre se trouvant sur la page de propriétés de la vue.

Si vous cochez l'option exclure ces ressources du filtre de sélection de ressources, les ressources surveillées ou les services correspondants seront exclus de la vue. Par exemple, vous pourriez partir d'une vue ordinateur et exclure les services que vous ne souhaitez plus voir dans la vue.

Note: Les filtres "incluant" des ressources ou des services montre une icône jaune "+" à la gauche de la chaîne de caractère de sélection. Les filtres "excluant" des services ou des ressources montre une icône jaune "-" à la même place.

Voir aussi

Modifier un filtre de sélection de ressources
Supprimer un filtre de sélection de ressources
Les vues personnalisées
Ajouter des éléments à une vue


Supprimer un filtre de sélection de ressources

Pour supprimer un filtre de sélection de ressources

1. Sélectionnez la vue que vous souhaitez modifier dans l'arborescence de la console.

2. Cliquez avec le bouton droit de la souris sur le noeud représentant la vue et choisissez Propriétés, ou sélectionnez le menu Action/Propriétés. Alternativement vous pouvez cliquez sur le bouton Propriétés [image] de la barre de tâches.

3. Sélectionnez le filtre que vous voulez supprimer et cliquez sur le bouton Supprimer [image].

Voir aussi

Ajouter un filtre de sélection de ressources
Modifier un filtre de sélection de ressources
Les vues personnalisées
Ajouter des éléments à une vue


Modifier un filtre de sélection de ressources

Pour modifier un filtre de sélection de ressources

1. Sélectionnez la vue que vous souhaitez modifier dans l'arborescence de la console.

2. Cliquez avec le bouton droit de la souris sur le noeud représentant la vue et choisissez Propriétés, ou sélectionnez le menu Action/Propriétés. Alternativement vous pouvez cliquez sur le bouton Propriétés [image] de la barre de tâches.

3. Double-cliquez sur le filtre que vous souhaitez modifier.

Vous pouvez éditer le filtre pour inclure ou exclure des services ou des ressources surveillées en utilisant éventuellement les caractères jokers (? et *). Par exemple, vous pourriez sélectionner tous les services ayant rapport avec le service de gestion de disques avec le filtre \\Mailsvr01\dm* sachant que ces services sont dmserver et dmadmin.

Note: Par défaut les alias sont utilisés dans les filtres mais vous pouvez utiliser le nom long des services en modifiant le paramètre se trouvant sur la page de propriétés de la vue.

Si vous voulez éditer un filtre excluant des services ou des ressources surveillées, vous devez ajouter le caractère "!" devant la chaîne constituant votre filtre.

Exemple: !\\Mailsvr01\TapiSrv exclue le service Telephony de la vue.

Note: Les filtres "incluant" montre une icône jaune "+" à la gauche de la chaîne de caractère de sélection.. Les filtres "excluant" montre une icône jaune "-" à la même place.

Voir aussi

Ajouter un filtre de sélection de ressources
Supprimer un filtre de sélection de ressources
Les vues personnalisées
Ajouter des éléments à une vue

© 1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques

.


Supprimer des éléments d'une vue

Pour supprimer des éléments d'une vue.

1. Sélectionnez dans l'arborescence de la console Service+ la vue à laquelle vous souhaitez retirer des éléments (services ou ressources surveillées).

2. Sélectionnez les éléments (utilisez la combinaison de touches Maj et CTRL pour sélectionner plusieurs services).

3. Cliquez avec le bouton droit de la souris sur votre sélection et choisissez Supprimer de la vue, ou sélectionnez le menu Action/Supprimer de la vue ou cliquez sur le bouton [image] de la barre de tâches.

Note: Supprimer un service ou une ressource surveillée d'une vue ne désinstalle pas le service. Les services supprimés de la vue pourront être ajoutés à nouveau dans cette même vue ou dans une autre vue de la console.

Voir aussi

Ajouter des éléments à une vue
Les vues personnalisées


Propriétés d'une vue

Editer les propriétés d'une vue

Pour éditer les propriétés d'une vue

1. Sélectionnez la vue dans l'arborescence de la Console Service+.

2. Cliquez avec le bouton droit de la souris sur la vue et sélectionnez Propriétés, ou cliquez sur le bouton Propriétés [image] de la barre de tâches, ou sélectionnez le menu Action/Propriétés.

  • Nom : Nom de la vue.
  • Description : Vous pouvez entrer une description.
  • Type de ressources : indique le type de ressources que la vue affiche (services, ressources surveillées ou les deux).
  • Filtre de sélection de ressources : affiche la liste actuelle des filtres de sélection de ressources. Voir Editer les filtres de sélection de ressources.
  • Filtrer les services par : détermine si les services sont désignés par leur Alias ou leur Nom.

Voir aussi

Editer les filtres de sélection de ressources
Les vues personnalisées


Supprimer une vue personnalisée

Pour supprimer une vue personnalisée

1. Sélectionnez la vue dans l'arborescence de la Console Service+.

2. Cliquez avec le bouton droit de la souris sur la vue et sélectionnez Supprimer, ou cliquez sur le bouton Supprimer [image] de la barre de tâches, ou sélectionnez le menu Action/Supprimer.

3. Répondre Oui pour continuer et supprimer la vue. Cette action est irréversible.

Voir aussi

Les vues personnalisées


Modifier les propriétés d'un service

Editer les propriétés d'un service

Pour éditer les propriétés d'un service

1. Sélectionnez une vue dans l'arborescence de la console Service+.

2. Sélectionnez un ou plusieurs services. Vous pouvez sélectionner plusieurs services grâce à la combinaison de touches Maj et Ctrl.

3. Cliquez avec le bouton droit de la souris sur la sélection et choisissez Propriétés, ou sélectionnez le menu Action/Propriétés ou cliquez sur le bouton Propriétés [image] de la barre de tâches.

  • Type de démarrage
    indique comment le processus du service doit être démarré.
    • Automatique : lance le processus du service automatiquement au démarrage de l'ordinateur.
    • Manuel : le processus est lancé manuellement ou quand un service dépendant est lancé.
    • Désactiver : empêche qu'un utilisateur ou un service dépendant ne démarre le service.
  • Se connecter en tant que
    spécifie si le service utilise le compte système ou un compte utilisateur pour se lancer. La plupart des services ouvrent leur session avec le compte système. Les services qui nécessitent un accès à des ressources externes (par exemple des ressources réseau) utilisent un compte utilisateur ayant les droits d'accès nécessaires aux ressources.
    • Compte Système : le service sera lancé dans le contexte de sécurité LocalSystem. Lorsque l'option "Interagir avec l'écran" est cochée et que le service est démarré, l'interface graphique du service est visible par tous les utilisateurs locaux de l'ordinateur.
    • Ce Compte : permet au service de se lancer dans le contexte de sécurité d'un utilisateur.
  • Interagir avec l'écran
    Cette option vous permet de faire interagir le service avec une session utilisateur.
    Les services interactifs sous Windows Vista : Considérant que les services pouvaient être utilisés pour exécuter des virus, Microsoft a décidé de les isoler dans une session 0 dans Windows Vista. Service+ est le seul utilitaire d'administration des services à proposer une solution efficace à cette limitation en continuant à vous permettre de réellement faire interagir une application lancée en tant que service avec une session utilisateur (exécutez vos applications en tant que services avec ServiceMill).
    Visitez le site de Microsoft pour obtenir plus de détails sur les changements apparus dans Windows Vista.
  • Alias
    Nom du Service. Ce champ ne peut être modifié.
  • Nom
    Nom d'affichage du Service, éditable.
  • Description
    Permet d'entrer un texte décrivant le service. La description d'un service n'est pas disponible si vous êtes connecté à un ordinateur sous Windows NT 4.0 ou une version plus ancienne.
  • Exécutable
    Chemin d'accès au programme du service. En éditant ce champ vous pouvez déplacer l'exécutable d'un service dans un autre répertoire sans avoir à réinstaller ou à changer les paramètres de ligne de commande.
Note : les propriétés ci-dessus sont stockées sous paramètres de service dans la base de registres.

Voir aussi

Editer les dépendances d'un service
Editer la sécurité d'un service

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Editer les dépendances d'un service

Pour éditer les dépendances d'un service.

1. Sélectionnez une vue dans l'arborescence de la console Service+.

2. Sélectionnez un service.

3. Cliquez avec le bouton droit de la souris sur la sélection et choisissez Propriétés, ou sélectionnez le menu Action/Propriétés ou cliquez sur le bouton Propriétés [image] de la barre de tâches.

4. Sélectionnez l'onglet Dépendances.

  • Le Service est dépendant de :
    Liste tous les services qui doivent être lancés pour que le service démarre. Le fait de rendre un service dépendant est utile si vous désirez lancer un service après qu'un autre service ait été lancé (par exemple lancer un programme batch en tant que service avec ServiceMill après que le service contrôlé par le batch soit lui même lancé). Soyez prudent lorsque vous supprimez un service de la liste.

    Service+ offre la possibilité de spécifier des dépendances sur des pilotes de périphérique aussi bien que sur des services.
Note: rendre le service dépendant du service poste de travail résout souvent les problèmes de service non démarré pendant le processus de mise en route.
  • Les services dépendants sont
    Liste des services qui ne peuvent démarrer que si le service est lancé.
Dépendances : les dépendances de service sont stockées dans la base de registres en tant que paramètre DependOnService. Ne pas les éditer dans l'éditeur de base de registres. Il est plus sûr d'utiliser Service+.

Voir aussi

Editer les propriétés d'un service
Editer la sécurité d'un service


Editer la sécurité d'un service

Pour éditer la sécurité d'un service

1. Sélectionnez une vue dans l'arborescence de la console Service+.

3. Cliquez avec le bouton droit de la souris sur la sélection et choisissez Propriétés, ou sélectionnez le menu Action/Propriétés ou cliquez sur le bouton Propriétés [image] de la barre de tâches.

4. Sélectionnez l'onglet Sécurité.

  • Groupes et utilisateurs : liste les groupes et les utilisateurs qui sont autorisés ou pas à accéder au service. Les droits suivants peuvent être assignés sur un service :
    • Contrôle total : l'utilisateur ou le groupe a tous les droits sur le service.
    • Demander la configuration du service : requis pour demander la configuration du service (par exemple pour afficher les propriétés du service dans Service+).
    • Modifier la configuration du service : requis pour changer la configuration du service (par exemple pour changer le type de démarrage du service ou sa description).
    • Demander l'état du service : requis pour demander l'état du service au Service Control Manager.
    • Enumérer les services dépendants : requis pour énumérer tous les services dépendants du service.
    • Démarrer le service : requis pour démarrer le service. Un utilisateur doit aussi avoir le droit 'Demander l'état du service' pour pouvoir déterminer quand est ce que le service a correctement démarré.
    • Arrêter le service : requis pour arréter le service. Un utilisateur doit aussi avoir le droit 'Demander l'état du service' pour pouvoir déterminer quand est ce que le service s'est correctement arrêté et le droit 'Enumérer les services dépendants' pour pouvoir déterminer quels sont les services dépendents à arrêter.
    • Mettre en pause et continuer le service : requis pour mettre en pause et continuer le service. Un utilisateur doit aussi avoir le droit 'Demander l'état du service' pour pouvoir déterminer quand est ce que le service s'est correctement mis en pause ou a correctement repris son exécution.
    • Interroger le service : requis pour pouvoir demander au service de reporter son état immédiatement.
    • Envoyer des contrôles utilisateur : requis pour pouvoir envoyer des contrôles personnalisés au service.
    • Supprimer le service : requis pour pouvoir supprimer le service.
    • Demander le descripteur de sécurité du service : requis pour pouvoir afficher le descripteur de sécurité du service. Si un utilisateur n'a pas ce droit, il ne pourra pas afficher la page 'Sécurité'.
    • Modifier le descripteur de sécurité du service : requis pour pouvoir modifier le descripteur de sécurité du service. Si un utilisateur n'a pas ce droit, il ne pourra pas appliquer les changements effectués dans la page 'Sécurité'.
    • Modifier le propriétaire et les groupes du service : requis pour modifier le propriétaire et les groupes du service.
  • Réinitialiser : cliquez sur ce bouton si vous voulez réinitialiser la sécurité du service à la sécurité par défaut d'un service.
Note : A partir de Windows 2003 SP1, vous pouvez également modifier la Sécurité du Service Control Manager.

Voir aussi

Editer les propriétés d'un service
Editer les dépendances d'un service

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Installer un service

Avec Service+ vous pouvez installer des services. Habituellement, lorsqu'une application nécessite un service, ce dernier est installé en même temps que la dite application. Avec Service+, vous n'avez pas besoin de réinstaller les applications pour mettre à jour ou réparer les services du système.

Installer un Service ServiceMill :

Cette option est activée si ServiceMill est installé. Les services ServiceMill peuvent être créés et contrôlés à partir de Service+.

Installer un Service :

Seuls les exécutables étant déjà des services peuvent être installés avec cette option. Si vous voulez lancer des programmes classiques en tant que services, vous devez installer ServiceMill et utiliser l'option ci-dessus.

Pour installer un service, cliquez avec le bouton droit de la souris sur une vue ordinateur ou personnalisée et sélectionnez Toutes les tâches/Installer un service ou sélectionnez le menu Action/Toutes les tâches/Installer un service.

Il existe trois méthodes différentes pour installer un service dans Service+ :

1. Créer un nouveau service vous permet de créer un nouveau service en spécifiant les paramètres principaux du service :

  • Alias : Alias du service. L'alias est la clef unique qui identifie le service dans la base de registres.
  • Nom : Nom affiché dans la fenêtre principale, éditable dans les propriétés du service.
  • Description : Vous pouvez ajouter un descriptif du service.
  • Exécutable : Chemin d'accès au programme, éditable dans les propriétés du service.
  • Type du Service : permet de spécifier le type de processus du service. Attention, ce paramètre ne pourra pas être changé via Service+ une fois le service installé.
    • Processus propre : le service est lancé dans un processus qui n'héberge que ce service.
    • Processus partagé : le service est lancé dans un processus qui héberge plusieurs services.
  • Démarrage Permet de spécifié comment le processus de service doit démarrer :
    • Automatique : le service démarre automatiquement lorsque le système démarre.
    • Manuel : le service est démarré manuellement ou automatiquement par un service qui dépend de lui.
    • Désactiver : interdit le démarrage du service.
  • Se connecter en tant que : définit si le service démarre en utilisant le compte système ou un compte utilisateur. Généralement les services utilisent le compte système. Un compte utilisateur peut être nécessaire pour accéder à des ressources réseau protégées.
    • Compte Système : le service sera lancé dans le contexte de sécurité LocalSystem. Lorsque l'option "Interagir avec l'écran" est cochée et que le service est démarré, l'interface graphique du service est visible par tous les utilisateurs locaux de l'ordinateur.
    • Ce Compte : vous permet de spécifier un compte utilisateur qui sera utilisé par le service. Spécifiez un compte utilisateur si le service nécessite des droits particuliers pour fonctionner correctement (par exemple, s'il doit accéder à des ressources réseau).
  • Gestion d'erreur : spécifie le comportement du processus de démarrage quand une erreur se produit. Attention, une fois le service installé, vous ne pourrez plus modifier ce paramètre avec Service+.
    • Normale : un avertissement est affiché quand le service signale une erreur.
    • Ignorer : le gestionnaire I/O ignore les retours du service. Aucun avertissement n'est enregistré ou affiché.
2. Importer un service à partir du presse-papier vous permet de créer un service à partir d'une configuration de service en XML préalablement placée dans le presse-papier. Pour exporter un service dans le presse-papiers, cliquez avec le bouton droit de la souris sur le service et sélectionnez Exporter le service/dans le presse-papiers dans le menu.

3. Importer un service à partir d'un fichier de configuration XML vous permet de créer un service à partir d'un fichier de configuration XML. Pour exporter un service dans un fichier de configuration XML, cliquez avec le bouton droit de la souris sur le service et sélectionnez Exporter le service/dans un fichier de configuration XML dans le menu.

Voir aussi

Supprimer un service


Supprimer un service

Supprimer un service désinstalle le service de l'ordinateur.

Note: Attention, soyez certain de ne pas supprimer un service dont vous aurez besoin et que vous ne pouvez pas réinstaller.

Pour supprimer un service

1. Sélectionnez une vue de l'arborescence de la Console Service+.

2. Sélectionnez un ou plusieurs services. Vous pouvez sélectionner plusieurs services en utilisant la combinaison de touches Maj et Ctrl.

3. Cliquez avec le bouton droit de la souris sur la sélection et choisissez Supprimer, ou sélectionnez le menu Action/Supprimer ou cliquez sur le bouton Supprimer [image] de la barre de tâches.

Remarque: si vous supprimer un service et ne pouvez redémarrer l'ordinateur, il vous sera peut-être possible de le démarrer en mode sécurisé. Dés lors vous pourrez rétablir la configuration originale.

Voir aussi

Installer un service


Abort shutdown

Stopper le redémarrage d'un ordinateur

Cette option abandonnera le processus InitiateSysIntemShutdown d'une application. Par exemple, elle permet de tester une action planifiée de récupération de redémarrage du système, initiée par ServiceKeeper , sans réellement redémarrer le système.

Dans la plupart des cas, lors d'un redémarrage du système initié par une application, un message informe l'utilisateur du redémarrage imminent. L'utilisateur dispose alors d'un certain délais pour effectuer toute action corrective. C'est typiquement à ce moment que vous pouvez utiliser cette fonction de Service+.

Pour stopper le redémarrage d'un ordinateur

1. Sélectionnez le noeud Service+ dans l'arborescence de la console Service+.

2. Cliquer avec le bouton droit de la souris sur le noeud Service+ et sélectionnez Toutes les tâches/Abandonner le redémarrage, ou sélectionnez le menu Action/Toutes les tâches/Abandonner le redémarrage.


Installation silencieuse

Tous les utilitaires de services Active+ partage le programme d'installation. Ce programme peut être exécuté en mode silencieux et sans intervention de l'utilisateur. Il peut aussi être exécuté et piloté automatiquement à l'aide de commandes et de paramètres. Ces commandes et paramètres sont entrés à l'invite de commande ou à l'aide d'un fichier texte.

Pour installer Service+, ServiceMill ou ServiceKeeper en mode silencieux

A l'invite de commande, lancer setup.exe avec les paramètres pertinents.

Paramètres et commutateurs d'installation:

Les commutateurs suivants vous permettent de déterminer le comportement de setup.exe pendant l'installation du logiciel.

/i ou /install ou /setup
Installation de logiciel. Setup.exe peut aussi désinstaller un logiciel. Dans ce cas voyez la section suivante concernant le commutateur /u. Il s'agit du mode par défaut. Ce commutateur est donc optionnel.
/s
Mode silencieux: utiliser ce commutateur pour éviter toute interface utilisateur pendant l'exécution de setup.exe.
/InitFile=chemin vers le fichier texte contenant les commutateurs
Si vous souhaitez utiliser un fichier texte pour passer les commutateurs à setup.exe plutôt que d'utiliser l'invite de commande, vous devez spécifier le chemin de ce fichier à l'aide de ce commutateur.
/IconInTaskbar
L'icône Service+ est ajoutée à la barre d'outils lorsque la console Service+ est lancée.
/RunOnStartup
Service+ démarre automatiquement quand l'ordinateur démarre.
/ShortcutOnDesktop
Un raccourci vers Service+ est créé sur le bureau.
/InstallAdmTools
Installe la console d'administration Service+. Ce commutateur vous permet d'installer la console d'administration sans installer les services des logiciels Active+ comme ServiceKeeper ou ServiceMill.
/InstallServices
Installe les services des logiciels Active+. Ce commutateur vous permet d'installer les services des logiciels Active+ comme ServiceKeeper ou ServiceMill sans installer la console d'administration Service+.
/StartService+
La console d'administration Service+ démarre automatiquement a la fin de l'installation.
/InstallDir=Chemin
Répertoire d'installation: spécifie le répertoire ou les fichiers doivent être installés.
/CustomerId=JDupond
Permet de préciser la partie Identifiant client de votre licence.
/CustomerKey=1111AAA
Permet de préciser la partie Clef de votre licence.
/Account = Domaine\compte de service
Permet de spécifier le compte utilisateur utilisé par ServiceKeeper pour démarrer.
/Password = mot de passe
Permet de spécifier le mot de passe du compte utilisateur utilisé par ServiceKeeper pour démarrer.

Paramètres et commutateurs de désinstallation:

Les commutateurs suivants vous permettent de déterminer le comportement de setup.exe pendant la suppression du/des logiciel(s).

/u ou /uninstall ou /remove
Suppression de logiciels. Ce commutateur indique à setup.exe qu'il faut supprimer les logiciels spécifiés.
/Service+
Utiliser ce commutateur pour supprimer seulement Service+.
/ServiceMill
Utiliser ce commutateur pour supprimer seulement ServiceMill.
/RemoveServiceMillServices
Utiliser ce commutateur pour supprimer tous les services qui ont été créés à l'aide de ServiceMill.
/ServiceKeeper
Utiliser ce commutateur pour supprimer seulement ServiceKeeper.

Exemple:

A l'invite de commande entrer:

setup.exe /s /IconInTaskbar /RunOnStartup /ShortcutOnDesktop /InstallAdmTools /InstallServices /StartServicePlus /CustomerID=ABC
/CustomerKey=123ABC /Account=domaine\compte /Password=mot de passe

ou

setup.exe /InitFile=c:\temp\setup.txt

Où setup.txt est un fichier texte contenant les mêmes commutateurs.


Service+ Ligne de Commande

Service+® CL Help

Service+ CL est la version Ligne de Commande de Service+. En utilisant l'interpréteur de commande, vous pouvez administrer vos services Windows sur n'importe quel ordinateur à travers tous vos domaines. Vous pouvez arrêter un service qui ne répond plus sans avoir besoin de redémarrer vos ordinateurs. D'une simple commande, vous pouvez spécifier le compte utilisateur et le mot de passe d'un service sur tous vos serveurs.

Service+ CL représente un gain de temps considérable pour les administrateurs qui doivent gérer plusieurs serveurs Windows NT, 2000 et XP. Les droits administrateurs sont nécessaires sur tous les ordinateurs dont vous voulez contrôler les services avec Service+ CL.

Pour utiliser Service+ CL, lancer l'interpréteur de commande depuis Démarrer/Programmes/Accessoires puis tapez sp

Configuration requise :

Service+ CL est une application 100% Unicode disponible en anglais et en français.

  • Windows NT 4.0 (Service pack 3 ou supérieur recommandé), Windows 2000 ou Windows XP.
  • 200KB d'espace disque.
Note: supporte les plates-forme Intel et Alpha (NT 4.0).

Installation :

Décompresser spcl.zip dans un répertoire temporaire, puis lancer install.bat et suivre les instructions.

Licences :

  • 1 Utilisateur
  • 10 Utilisateurs
  • Licence Site (nombre illimité d'utilisateurs sur un même site géographique).
Nous contacter pour des licences spécifiques / OEM.
Enregistrement de votre logiciel : utiliser la commande REGISTER pour entrer votre clé. Une clé vous est envoyée par email lors de l'achat du logiciel. Vous ne pouvez pas entrer la clé dans la version d'évaluation de 30 jours, vous devez télécharger la version commerciale, l'installer et entrer la clé.

Service+ CL ligne de commande

Toutes les commandes de Service+ CL doivent se conformer à la syntaxe suivante :
sp command [[\\servername\]servicename] [/parameters]
Où les éléments entre crochets sont optionnels.
  • sp
    Précède toute commande. Il indique à l'interpréteur de commande qu'une ligne de commande Service+ CL va suivre.
    >sp
  • command
    N'importe quelle commande Service+ CL listée ci-dessous. Se place derrière sp avec un espace.
    >sp command
  • servername
    Optionnel. Utilisé pour contrôler les services sur n'importe quelle machine Windows NT/2000/XP en réseau. Le servername est le nom de l'ordinateur sur le Réseau Microsoft Windows. Notez que pour certaines commandes vous n'avez pas besoin des droits administrateurs sur la machine distante (ex : LIST), alors que pour d'autres ils sont nécessaires (ex : START). De plus certaines commandes ne sont pas disponibles pour un contrôle à distance (ex : KILL). Vous pouvez également utiliser les jokers * (toute chaîne de caractères) et ? (tout caractère).
  • >sp command \\servername\
    Applique la commande à la machine appelée servername sur le réseau.
    >sp command \\*\
    Applique la commande à toutes les machines du réseau.
    >sp command \\server?\
    Applique la commande sur toutes les machines appelées server(x) sur le réseau.
  • servicename
    Optionnel. Utilisé pour appliquer une commande à un service. Le servicename est l'alias du service que vous pouvez retrouver dans le composant du Panneau de Configuration "Services". En utilisant le paramètre /DN vous pouvez spécifier le Nom du Service au lieu de l'Alias. Vous pouvez également utiliser les jokers * et ?.
  • >sp command \\servername\servicename
    Applique la commande au service appelé servicename (alias) sur la machine appelée servername.
    >sp command \\servername\*
    Applique la commande à tous les services sur la machine appelée servername.
    >sp command servicename
    Applique la commande au service appelé servicename (sur la machine où est installé Service+ CL).
    >sp command *
    Applique la commande à tous les services sur la machine où est installé Service+ CL.
  • Paramètres
    La plupart des commandes Service+ CL acceptent des paramètres. Bien que la plupart d'entre-eux soient spécifiques à la commande utilisée, un petit nombre peut être employé avec la plupart des commandes :

    /Q
    Mode silencieux. Répond OUI à toutes les demandes de confirmation.
    Exemple: >sp kill _? /Q terminera le processus tous les services appelés _(x) sur la machine où est installé Service+ CL, sans demander confirmation pour chaque service.

    /DOMAIN=
    Seuls seront considérés les ordinateurs membres du domaine spécifié.
    Exemple: >sp stop servicename /DOMAIN=HeadQuarters arrêtera le service appelé "servicename" sur toutes les machines du domaine HeadQuarters.

    /DN
    Permet de préciser le Nom du Service plutôt que son Alias. Notez que les utilisateurs peuvent changer le nom du service (celui affiché) dans les propriétés du service, il est donc plus prudent d'utiliser l'Alias qui lui ne peut pas être modifié.
    Exemple: >sp start \\*\MERCUR SMTP-Service /DN démarrera le service smtp Mercur sur toutes les machines du réseau.

Liste des commandes Service+ CL

sp [ LIST | CONFIG | START | RESTART | STOP | PAUSE | CONTINUE | CONTROL | QUERY | CREATE | REMOVE | MODIFY | KILL | DEBUG | REGISTER | HELP ]
  • LIST
    Liste l'état d'un (des) service(s) (Démarré, Arrêté, Lancé, En Pause).
    Syntaxe: sp LIST [[\\servername\]servicename] [/Domain=]
    Exemple: >sp list \\*\spooler listera l'état de tous vos services Spooler sur toutes vos machines Windows NT/2000/XP.
  • CONFIG
    Affiche les informations sur la configuration du (des) service(s) (nom du service, état, type, type de démarrage, contrôle d'erreur, chemin d'accès, dépendances, nom affiché, compte).
  • Syntaxe: sp CONFIG [[\\servername\]servicename] [/Domain=]
    Exemple: >sp config \\*\spooler affichera la configuration de tous vos services Spooler sur toutes vos machines Windows NT/2000/XP.
  • START
    Démarre les(s) service(s). Il est possible de spécifier des paramètres (comme des chaînes de caractères), transmis au service quand il démarre.
    Syntaxe: sp START[=Startup Parameters] [\\servername\]servicename
    Exemple: >sp start \\server\spooler démarrera le service Spooler sur l'ordinateur "server".
  • RESTART
    Redémarre (stopper / démarrer) le(s) service(s). Il est possible de spécifier des paramètres, transmis au service quand il redémarre.
    Syntaxe: sp RESTART[=Startup Parameters] [\\servername\]servicename
    Exemple: >sp restart \\server\spooler redémarrera le service Spooler sur l'ordinateur "server".
  • STOP
    Arrête le(s) service(s).
    Syntaxe: sp STOP [\\servername\]servicename
    Exemple: >sp stop \\server\spooler arrêtera le service Spooler sur l'ordinateur "server".
  • PAUSE
    Met en pause le(s) service(s).
    Syntaxe: sp PAUSE [\\servername\]servicename
    Exemple: >sp pause \\server\spooler mettra le service Spooler en pause.
  • CONTINUE
    Interrompt la pause.
    Syntaxe: sp CONTINUE [\\servername\]servicename
    Exemple: >sp continue \\server\spooler reprendra l'exécution du service Spooler sur l'ordinateur "serveur".
  • CONTROL
    Envoi un code de control privé au service.
    Syntaxe: sp CONTROL=Code servicename
    Le code doit avoir une valeur entre 128 et 255
    Exemple: >sp control=128 myservice
  • QUERY
    Interroge sur l'état d'un service.
    Syntaxe: sp QUERY [\\servername\]servicename [/Domain=]
    Cette commande retournera dans la variable d'environnement ErrorLevel l'état du service :
    0 Le service n'est pas installé
    1 Le service est arrêté
    2 Le service est en train de démarrer
    3 Le service est en train de s'arrêter
    4 Le service est démarré
    5 Le service continue
    6 Le service est en train de se mettre en pause
    7 Le service est en pause
    L'exemple suivant montre comment écrire un fichier batch (.bat) qui demande l'état du spooler, le lance s'il est arrêté et l'arrête s'il est démarré :
    sp QUERY Spooler
    if ErrorLevel 1 sp START Spooler
    sp QUERY Spooler
    if ErrorLevel 4 sp STOP Spooler
  • CREATE
    Créé un (des) service(s). Notez que cette commande ne transformera pas un exécutable en service, mais l'enregistrera en tant que tel uniquement. L'exécutable devra donc avoir le comportement d'un service pour être administré et contrôlé en tant que tel (consultez ServiceMill pour voir comment transformer n'importe quel exécutable en service).
    Syntaxe: sp CREATE [\\servername\]servicename /PATH=Path to executable
    Le chemin d'accès de l'exécutable est un paramètre obligatoire. Les autres paramètres disponibles sont :
    [/DISPLAYNAME= ] spécifie le nom du service. C'est le nom éditable du service, par opposition à l'Alias qui ne peut être modifié.
    [/ACCOUNT=Domain\User][/PASSWORD=] permet de spécifier le compte utilisateur (identifiant et mot de passe) utilisé par le service.
    [/INTERACT=1,0] permet de spécifier le mode d'interaction avec l'écran quand le service utilise le compte système.
    [/STARTUP=MANUAL,AUTO,DISABLED] indique le mode de démarrage du service.
    [/TYPE=OwnProcess,SharedProcess] indique si le service s'exécute dans un processus séparé ou s'il partage un même processus avec d'autres services.
    [/ERRORCONTROL=Ignore,Normal,Severe,Critical] détermine la façon dont le processus doit être traité si il y des problèmes au démarrage.
    Exemple: >sp create \\server\myservice /path=c:\svcitocx\sample\service.exe
    enregistrera l'exécutable service.exe sur l'ordinateur "server" sous l'alias myservice.
  • REMOVE
    Supprime un (des) service(s). Notez que l'exécutable ne sera plus enregistré en tant que service, mais ne sera pas supprimé.
    Syntaxe: sp remove [\\servername\]servicename
    Exemple: >sp remove \\server\myservice supprimera le service myservice sur l'ordinateur "server".
  • MODIFY
    Pour modifier les paramètres d'un (de) service(s). Les paramètres sont stockés dans la base de registres.
    Syntaxe: sp MODIFY [[\\servername\]servicename]
    Paramètres disponibles :
    [/ACCOUNT=Domain\User /PASSWORD=xyz] permet de changer le compte utilisateur que le service utilise pour s'exécuter. Vous devrez fournir le mot de passe.
    [/STARTUP=MANUAL,AUTO,DISABLED] permet de modifier les options de démarrage du service.
    [/DISPLAYNAME="Service Display Name"] permet de modifier le nom du service.
    [/PATH="Service Name"] permet de modifier le chemin d'accès à l'exécutable du service.
    [/DEPEND=] permet de modifier les dépendances du service (DependsOnService).
    [/INTERACT=1,0] permet de modifier le mode d'interaction. Les services qui s'exécutent sous le compte système peuvent interagir avec l'écran.
    Exemple: >sp modify myservice /interact=1
    permettra au service "myservice" d'interagir avec l'écran s'il s'exécute sous le compte système.
  • KILL
    Termine le processus du service. Cette commande ne peut pas être utilisée à distance et ne peut être appliquée que sur les services de l'ordinateur sur lequel est installé Service+ CL.
    Syntaxe: sp KILL servicename
    Exemple: >sp kill spooler tuera le spooler.
  • DEBUG
    Démarre le service et lance le débogueur. Cette commande ne peut pas être utilisée à distance et vous devez avoir le code source de l'exécutable qui s'exécute en tant que service.
    Syntaxe: sp DEBUG servicename
    Exemple: >sp debug MyService Démarrera MyService et le lancera en mode de déboguage.
  • REGISTER
    Installe la clé d'enregistrement du produit.
    Syntaxe: sp REGISTER /ID=YourID /Key=YourKey
    Exemple: >sp register /ID="Active+ Software" /Key=12345
  • HELP
    Affiche l'aide de Service+ CL dans la fenêtre de l'interpréteur de commande.
    Pour plus d'information sur une commande : >sp command /help

Voir aussi
Service+
ServiceMill
ServiceKeeper

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


ServiceMill

Fichiers d'Aide ServiceMill®

ServiceMill transforme instantanément les applications 16 bit / 32 bit, les fichiers batch, les scripts ainsi que vos propres applications en Services Windows natifs. En quelques clics et sans modification du code source, exécutez vos applications en tant que services.

ServiceMill vous permet de lancer vos exécutables en arrière-plan, en toute sécurité, sans session utilisateur. Vous pouvez exécuter votre service sous un compte utilisateur afin qu'il puisse accéder aux ressources réseau, tout en conservant l'interaction avec l'écran. ServiceMill vous permet de spécifier la position de la fenêtre au démarrage, de lancer vos applications à intervalles prédéfinis et de les redémarrer automatiquement quand un utilisateur se déconnecte.

Les applications de service ServiceMill informent le journal des événements et une priorité de processus (haute, normale, basse) leur est attribuée. Toutes les unités réseau sont rétablies quand le processus démarre. ServiceMill maintient à jour la liste des processus enfants évezntuellement crées par l'application lancée en tant que service; ainsi aucun processus n'est jamais orphelin quand ce service est arrêté.

Les applications de service ServiceMill sont administrées comme n'importe quelle autre service, et dépendent des même outils administratifs : composant enfichable MMC, composant du panneau de configuration de service, ligne de commande. Le SCP enrichi de Service+ est inclus avec ServiceMill, permettant l'administration à distance de vos services. Il est également facile de planifier, surveiller et réparer vos exécutables grâce à ServiceKeeper. Le tableau ci-dessous vous indique les plus de ServiceMill par rapport à Srvany.

 | ServiceMill | SRVANY |
Interface graphique utilisateur | OUI | NON | Créer des services en quelques clics
Intégration à MMC | OUI | NON | Contrôler et éditer les propriétés avec MMC
Administration à distance | Service+ | NON | Arrêter les services sans redémarrer !
Interface Ligne de Commande | OUI | NON | Automatiser l'installation de service sur de larges réseaux
Création d'un service depuis un ordinateur distant | OUI | NON | Déployer facilement les services sur le réseau
Interaction avec l'écran depuis le compte système | OUI | OUI | Le service interagit avec les entrées utilisateur
Interaction avec l'écran depuis un compte utilisateur | OUI | NON | Le Service peut accéder aux ressources réseau
Spécifier la fenêtre de démarrage | OUI | NON | Pour les applications en interaction avec l'écran
Redirection des Entrée/Sortie du fichier | OUI | NON | Pour les applications de type console
Support journal des événements | OUI | NON | Permet le contrôle par filtrage d'événements (ServiceKeeper)
Support processus enfant | OUI | NON | PAS de processus orphelin après l'arrêt
Arrêt du service proprement | OUI | NON | PAS de TerminateProcess() brutal
Spécification des variables d'environnement | OUI | NON | Pour les applications Java exécutées en tant que service
Planification, surveillance et réparation | ServiceKeeper | NON | Outils d'automatisation pour protéger vos services
Redémarrage automatique à intervalles réguliers | OUI | NON | Détecte lorsque le service est stoppé
Produits associés :
Service+ : le SCP de service livré avec ServiceMill.
ServiceKeeper : l'utilitaire qui planifie, contrôle et répare tous les services Windows. Inclut Service+.

Configuration requise :

ServiceMill est une application 100% Unicode disponible en anglais, français et coréen.

  • Windows NT 4.0 (SP4 minimum), Windows 2000, Windows XP ou Windows 2003
  • Microsoft Management Console (MMC) version 1.1 ou ultérieure
  • Internet Explorer version 4.0 ou ultérieure
  • 2 MO d'espace disque
Note : versions disponibles pour Intel X86, Intel Itanium et Alpha (NT 4.0)

Installation :

Déziper svcmill.zip dans un répertoire temporaire, puis lancer setup.exe et suivre les instructions. Service+ est installé avec ServiceMill et les exécutables sont réunis tous ensemble.

Licences :

Licences pour Windows NT Serveur, Windows 2000 Serveur et Advanced Serveur :
  • 1 serveur
  • Jusqu'à 10 serveurs
  • Jusqu'à 25 serveurs
  • Licence Site (nombre illimité de serveurs sur un même site géographique) .
Licences pour Windows NT Workstation, Windows 2000 Professionnel, Windows XP Home et Professionnelle :
  • 1 machine
  • Jusqu'à 10 machines
  • Jusqu'à 25 machines
  • Licence Site (nombre illimité de machines sur un même site géographique) .
Nous contacter pour des licences spécifiques OEM.
Note: Service+ est inclus avec ServiceMill. Vous n'avez pas à l'installer et à l'enregistrer séparément.

Rubriques principales du Fichier d'Aide :

Créer un service
Configuration des propriétés générales
Configuration des propriétés de redirection des E/S
Configuration des variables d'environnement
Configuration des évènements
Planification de l'exécution de l'application
Configuration des propriétés avancées
Service+
ServiceKeeper

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Créer un Service

ServiceMill est un service hébergeant des applications standard, qui lit ses paramètres dans la branche "services" de la base de registres : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services key. Quand le SCM démarre un service ServiceMill, l'application hébergée est lancée en tant que processus enfant de ServiceMill, elle hérite donc du contexte de sécurité et de la configuration interactive. Le contexte de sécurité est déterminé par le compte (utilisateur ou système) utilisé par le service, défini, par l'intermédiaire d'un SCP, dans les propriétés du service.

ServiceMill permet de spécifier la priorité du processus. Chaque application installée en tant que service ServiceMill est liée à une instance différente de ServiceMill et s'exécute dans un processus séparé.

Quand le service est stoppé, l'exécutable reçoit un message WM_CLOSE et se termine proprement. L'exécutable qui ne s'arrête pas dans les 10 secondes qui suivent la commande sera stoppé avec l'API TerminateProcess(), une façon plus radicale de terminer une application.

Quand on exécute une application GUI en tant que service ServiceMill sous une session utilisateur, l'application reçoit un message WM_QUERYENDSESSION et WM_ENDSESSION. Votre application ne doit pas se terminer lorsqu'elle reçoit ces messages afin de ne pas s'arrêter lors de la déconnexion de l'utilisateur. Si vous ne pouvez pas contrôler le comportement de votre application à la déconnexion, vous pouvez mettre la propriété Redémarrer automatiquement à 1 seconde pour qu'elle soit redémarrée automatiquement après la déconnexion de l'utilisateur.

Installer un service ServiceMill

Dans la console MMC Service+, cliquez avec le bouton droit de la souris sur une vue ordinateur puis sélectionnez "toutes les tâches/Installer un service ServiceMill..." :

Il existe trois méthodes différentes pour installer un service ServiceMill dans Service+ :

1. Créer un nouveau service ServiceMill vous permet de créer un nouveau service ServiceMill en spécifiant les paramètres principaux du service :

  • Alias
    Entrer le nom du service. Eviter les espaces et utiliser un nom concis. Ce sera l'Alias stocké dans la base de registres.
  • Nom
    Entrer le Nom du service.
  • Description
    Entrer la Description du service
2. Importer un service ServiceMill à partir du presse-papier vous permet de créer un service ServiceMill à partir d'une configuration de service en XML préalablement placée dans le presse-papier. Pour exporter un service ServiceMill dans le presse-papiers, cliquez avec le bouton droit de la souris sur le service et sélectionnez Exporter le service/dans le presse-papiers dans le menu.

3. Importer un service ServiceMill à partir d'un fichier de configuration XML vous permet de créer un service ServiceMill à partir d'un fichier de configuration XML. Pour exporter un service ServiceMill dans un fichier de configuration XML, cliquez avec le bouton droit de la souris sur le service et sélectionnez Exporter le service/dans un fichier de configuration XML dans le menu.

Cliquer sur Suivant pour définir les propriétés générales.

Note : toutes les erreurs seront reportées dans le Journal d'événements. Si vous désirez reporter les erreurs d'un programme batch exécuté en tant que service dans le journal d'événements, utilisez la ligne de commande suivante :

svcit /Service="Your Service Name" /Type=Error /Message="The error message"

Exécutez svcit.exe /? | more pour plus d'informations sur les paramètres de ServiceMill en Ligne de Commande.
Voir aussi
Configuration des propriétés générales
Configuration des propriétés de redirection des E/S
Configuration des variables d'environnement
Configuration des évènements
Planification de l'exécution de l'application
Configuration des propriétés avancées
ServiceMill

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Configuration des Propriétés Générales

La boîte de dialogue Propriétés du service vous permet de spécifier le chemin d'accès du programme et de définir la fenêtre de démarrage. Vous pouvez également modifier les configurations d'un service ServiceMill existant avec cette boîte de dialogue, en sélectionnant le service dans la fenêtre principale de Service+, en cliquant sur "Propriétés", et en sélectionnant l'onglet ServiceMill :
  • Exécutable
    Indique le chemin d'accès de l'application que vous désirez exécutée en tant que service. La chaîne peut inclure des variables d'environnement (ex : %SystemRoot%).
  • Paramètres
    Spécifie les paramètres passés à l'application. La chaîne peut inclure des variables d'environnement. Vous pouvez passer des paramètres additionnels au démarrage du service en utilisant les paramètres de démarrage dans Service+ (Service/Start...).
  • Répertoire
    Indique le répertoire du processus. S'il n'est pas spécifié, le répertoire par défaut sera le répertoire de l'application. La chaîne peut inclure des variables d'environnement.
  • Fenêtre de démarrage
    Indique le placement de la fenêtre (Normale, Minimisée, Maximisée, etc.).
  • Redémarrer automatiquement......
    Indique le temps (en secondes) à attendre avant de relancer un processus qui s'est stoppé. Cette option est utile si vous désirez planifier l'exécution d'un programme batch ou d'un exécutable périodiquement. Cette propriété est également utile pour relancer les applications GUI qui ne survivent pas à la déconnexion de l'utilisateur.
  • Montrer l'icône dans la barre des tâches
    Indique qu'une icône doit être ajoutée dans la barre des tâches pour contrôler le service. Pour que cette option fonctionne, le service doit interagir avec l'écran.
  • Cacher lors de la fermeture
    Indique, si une application est fermée, qu'elle sera cachée au lieu d'être tuée. En double-cliquant sur la barre des tâches l'application sera rétablie sur le bureau.

Voir aussi
Créer un service
Configuration des propriétés de redirection des E/S
Configuration des variables d'environnement
Configuration des évènements
Planification de l'exécution de l'application
Configuration des propriétés avancées
ServiceMill

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Redirection des Entrées/Sorties

Configuration des Propriétés de Redirection des E/S

Sélectionnez le service ServiceMill dans la fenêtre principale de Service+, cliquer sur Propriétés, ServiceMill, Entrées/Sorties.
  • Redirection des Entrées/Sorties
    Permet de rediriger les entrées/sorties standard vers des fichiers. Cette fonctionnalité a été conçue tout particulièrement pour les applications de type console, par exemple, vous pouvez rediriger la sortie standard d'un programme batch exécuté en tant que service ServiceMill, si vous souhaitez la réutiliser dans une autre application. D'autre part lorsque un fichier d'entrée est spécifié, les entrées console utilisateur sont remplacées par le contenu texte du fichier sélectionné (ce qui correspond à la commande <). Si un fichier de sortie est spécifié, les sorties console seront imprimées à la fois à l'écran (dans la console) et dans le fichier choisi.

Voir aussi
Créer un service
Configuration des propriétés générales
Configuration des variables d'environnement
Configuration des evènements
Planification de l'exécution de l'application
Configuration des propriétés avancées
ServiceMill

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Configuration des Variables d'Environnement

Certains programmes utilisent les variables d'environnement pour découvrir la configuration et les paramétrages de l'ordinateur sur lequel il s'exécutent. Ces variables sont de deux types : Système et Utilisateur. Les variables d'environnement de type système ne peuvent être ajoutées, modifiées ou supprimées qu'à partir du compte système. Vous pouvez lister l'ensemble des variables présentes sur votre système en tapant la commande set dans un interpréteur de commandes ou en cliquant sur "Système/Avancé/Variables d'environnement" dans le panneau de configuration.

Avec ServiceMill vous pouvez créer des variables d'environnement spécifiques au processus du service. Ces variables ne sont ni de type Système, ni de type Utilisateur et sont visibles par le processus du service quel que soit le compte qu'utilise le service pour s'exécuter.

Sélectionnez le service ServiceMill dans la fenêtre principale de Service+, cliquez sur Propriétés/ServiceMill/Environnement

  • Variables d'environnement
    Entrez un nouveau nom de variable et sa valeur, puis cliquez sur "Fixer la valeur". Sélectionnez la variable dans la liste et cliquez sur "Supprimer" pour la retirer.
Variables et compte du service : si votre service s'exécute sur le compte système, les variables Utilisateur ne seront pas visibles par le processus. Dans ce cas, vous pouvez créer des variables spécifiques au service comme décrit ci-dessus et leur attribuer les valeurs des variables utilisateur que vous désirez utiliser.
Voir aussi
Créer un service
Configuration des propriétés générales
Configuration des propriétés de redirection des E/S
Configuration des évènements
Planification de l'exécution de l'application
Configuration des propriétés avancées
ServiceMill

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Configuration des évènements

Sélectionnez le service ServiceMill dans la Fenêtre principale de Service+, cliquez sur Propriétés/ServiceMill/Evènements.
  • OnServiceStarting : cet évènement est appelé par le service au démarrage.
  • OnApplicationStarting : cet évènement est appelé par le service juste avant de lancer l'application.
  • OnApplicationStarted : cet évènement est appelé par le service quand l'application a été lancée.
  • OnApplicationTerminated : cet évènement est appelé par le service quand l'application se termine de manière inattendue.
  • OnServiceStopping : cet évènement est appelé par le service quand une demande d'arrêt du service a été effectuée. A ce moment, l'application lancée est toujours en vie.
  • OnApplicationStop : cet évènement est appelé par le service juste avant qu'il tente d'arrêter l'application.
  • OnApplicationStopped : cet évènement est appelé par le service quand l'application a été stoppée.

Voir aussi

Créer un service
Configuration des propriétés générales
Configuration des propriétés de redirection des E/S
Configuration des variables d'environnement
Planification de l'exécution de l'application
Configuration des propriétés avancées
ServiceMill

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Planification de l'exécution de l'application

Sélectionnez le service ServiceMill dans la Fenêtre principale de Service+, cliquez sur Propriétés/ServiceMill/Planification.
Vous pouvez, dans cette page de propriétés, planifier l'exécution de l'application lancée en tant que service. Si votre application consomme de la mémoire, vous pouvez la redémarrer, par exemple une fois par jour, afin de libérer la mémoire perdue. Vous pourrez également stopper votre application pendant vos processus de sauvegarde automatique ou pendant le week-end.

Voir aussi

Créer un service
Configuration des propriétés générales
Configuration des propriétés de redirection des E/S
Configuration des variables d'environnement
Configuration des évènements
Configuration des propriétés avancées
ServiceMill

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Configuration des Propriétés Avancées

Sélectionnez le service ServiceMill dans la Fenêtre principale de Service+, cliquez sur Propriétés/ServiceMill/Avancées
  • Activer Pause/Continuer
    Les commandes pause et continuer du service sont activées. Grâce à cela, vous pourrez interrompre et reprendre l'exécution du thread principal du processus.
  • Interagir avec l'écran
    Sous Windows NT/2000/XP/2003, un service qui interagit avec l'écran doit utiliser le compte système, et, par conséquent, ne peut pas accéder aux ressources réseau. En activant cette option, ServiceMill permet à vos applications GUI d'interagir avec l'écran lorsque le service est configuré pour utiliser un compte utilisateur et donc d'accéder aux ressources réseau simultanément (le compte sur lequel s'exécute le service est défini dans la boîte de dialogue Propriétés de Service+).

    Les services interactifs sous Windows Vista : Considérant que les services pouvaient être utilisés pour exécuter des virus, Microsoft a décidé de les isoler dans une session 0 dans Windows Vista. ServiceMill est le seul utilitaire d'administration des services à proposer une solution efficace à cette limitation en continuant à vous permettre de réellement faire interagir une application lancée en tant que service avec une session utilisateur.
    Visitez le site de Microsoft pour obtenir plus de détails sur les changements apparus dans Windows Vista.

  • Reconnecter les unités réseau
    Si l'application que vous exécutez en tant que service ne peut pas utiliser les chemins UNC pour accéder aux ressources réseau, sélectionnez cette option. Tous les lecteurs réseau mappés par le service seront rétablis.
  • Priorité du processus
    Sélectionner la priorité de base de l'application (Basse, Normale ou Haute).
  • Processeur
    Sur les systèmes multi-processeurs, ceci vous permet de sélectionner le processeur sur lequel vous désirez que l'application soit exécutée. Si votre application ne fonctionne pas correctement sur des machines multi-processeurs, cliquer sur CPU 0 devrait résoudre votre problème.
  • Indiquer que le service......
    Indiquer dans ce champ le temps que l'application lancée mettra pour s'initialiser. Cette configuration est utile quand le service a des services dépendants qui ne doivent être lancés que quand le service est complètement démarré.

Voir aussi
Créer un service
Configuration des propriétés générales
Configuration des propriétés de redirection des E/S
Configuration des variables d'environnement
Configuration des évènements
Planification de l'exécution de l'application
ServiceMill

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Présentation de ServiceKeeper®

Les administrateurs exigent de leurs serveurs des fonctionnalités que les utilisateurs normaux n'exigeraient pas de leur système d'exploitation. Les plates-forme Windows offrent cependant le même niveau de fonctionnalités en matière d'administration du système et la même interface utilisateur pour tous. Cette standardisation de produit a entraîné le développement d'utilitaires système tiers conçus pour surmonter les limitations qu'elle a engendrées.

Les Services représentent la partie la plus importante de l'architecture NT, c'est pourquoi la planification, la surveillance et la réparation des processus de services renforcent fortement la plate-forme elle même. ServiceKeeper est pour les administrateurs un outil centralisé et intégré d'automatisation du système, qui permet de conserver en fonctionnement permanent des serveurs hébergeant des applications critiques.

Le redémarrage de services critiques peut-être planifié afin de libérer régulièrement les ressources système utilisées. Vous pouvez également surveiller le comportement de services et ainsi, par un grand nombre de méthodes, détecter une éventuelle panne pouvant entraîner un arrêt imprévu du système d'exploitation. Enfin, vous pouvez automatiser l'exécution d'actions correctives pour réparer un service en panne sans redémarrer l'ordinateur.

En association avec ServiceMill, ces outils performants peuvent être utilisés pour planifier, surveiller et réparer n'importe quelle application exécutée en tant que service; l'utilitaire d'administration Service+ intégré avec ServiceKeeper, permettant encore plus de contrôle sur vos services. Le tableau suivant vous indique les fonctionnalités supplémentaires apportées sur votre système par ServiceKeeper.

 | ServiceKeeper | Outils Services standard Windows
Versions Windows | Windows NT/W2K/XP | Windows XP | Windows 200x | Windows NT
Planifier les services | OUI | NON | NON | NON
Contrôler à distance | OUI | NON | NON | NON
Méthodes de détection |  |  |  |
Contrôle de l'état du service | OUI | OUI | OUI | NON
Activité du réseau | OUI | NON | NON | NON
Contrôle du journal d'événements | OUI | NON | NON | NON
Contrôle de compteurs NT | OUI | NON | NON | NON
Contrôle du code de retour d'un script value | OUI | NON | NON | NON
Contrôle du code de retour d'un programme | OUI | NON | NON | NON
Méthodes de notification |  |  |  |
Envoi d'un email | OUI | NON | NON | NON
Envoi d'une alerte administrative | OUI | NON | NON | NON
Lancement d'un programme ou d'un batch | OUI | NON | NON | NON
Envoi d'un trap SNMP | OUI | NON | NON | NON
Exécuter un script | OUI | NON | NON | NON
Ecrire dans un journal d'événements html | OUI | NON | NON | NON
Méthodes de réparation |  |  |  |
Redémarrer le service | OUI | OUI | OUI | NON
Redémarrer un autre service | OUI | NON | NON | NON
Lancer un programme ou un batch | OUI | OUI | OUI | NON
Exécuter un script | OUI | NON | NON | NON
Redémarrer l'ordinateur | OUI | OUI | OUI | NON
Produits associés :

Service+ : le SCP amélioré livré avec ServiceKeeper.

ServiceMill : l'utilitaire qui transforme instantanément n'importe quele application, fichier batch, programme script en service Windows; que vous pouvez ainsi planifier, surveiller et réparer avec ServiceKeeper.

Configuration Requise :

ServiceKeeper est une application 100% Unicode disponible en anglais, français et coréen.

Configuration minimum :

  • Windows 2000, Windows XP (32-bit & 64-bit), Windows Server 2003 (32-bit & 64-bit), Windows Vista
  • 16 MO d'espace disque
Note : Supporte les plates-formes Intel x86, Intel Itanium et AMD x64.

Installation :

Décompressez skeeper.zip dans un répertoire temporaire, puis lancez setup.exe et suivez les instructions.

Licences :

  • Jusqu'à 2 serveurs contrôlés
  • Jusqu'à 5 serveurs contrôlés
  • Jusqu'à 10 serveurs contrôlés
  • Jusqu'à 25 serveurs contrôlés
  • Licence Site (nombre illimité de serveurs sur un même site géographique)
Vous pouvez installer ServiceKeeper sur toutes les machines qui doivent être surveillées. Par exemple, si vous installez ServiceKeeper (2 serveurs contrôlés) sur une machine, vous pouvez contrôler 2 serveurs à partir de cette machine. Si vous installez ServiceKeeper sur 2 serveurs, vous n'aurez accès aux fonctions de surveillance que sur la machine sur laquelle il est installé.

Nous contacter pour des licences spécifiques OEM.

Note : Service+ est inclus avec ServiceKeeper. Vous n'avez pas besoin de l'installer et de l'enregistrer séparément.
Voir aussi
Paramétrer ServiceKeeper
Surveiller des services
Planifier des services
Surveiller des ressources
Planifier la surveillance des ressource
Service+
ServiceMill


Configurer ServiceKeeper

ServiceKeeper est un service, qui ajoute ses propres onglets Planifier et Surveiller à la console Service+ ainsi qu'à la console MMC standard de gestion des services livrée par Microsoft. Pour l'afficher, sélectionnez un service dans la liste et sélectionnez "Propriétés".

Pour configurer ServiceKeeper, lancez la console Service+ et double-cliquez sur le service ServiceKeeper.

  • Ordinateurs surveillés : liste de tous les ordinateurs dont les services sont surveillés. Quand ServiceKeeper surveille un serveur, les onglets Planifier et Surveiller sont ajoutés aux Propriétés de tous les services installés sur le serveur. Pour ajouter un ordinateur vous devez avoir les droits administrateur sur la machine et la licence de ServiceKeeper appropriée.
  • Diagnostics : défini le nombre et les types de message qui seront reportés au journal d'événements Windows. Définir le niveau : Minimum ne retournera que les erreurs majeures, Normal les erreurs majeures et les avertissements, Maximum les messages d' informations, les avertissements et les erreurs.
  • Notification des Erreurs : vous pouvez définir les méthodes de notification pour chacun des services en le sélectionnant et en cliquant sur les onglets Surveiller / Notification.

Voir aussi
Présentation de ServiceKeeper


Surveiller les Services

ServiceKeeper propose un jeu complet d'outils pour surveiller et contrôler les services. Une surveillance efficace est celle qui est capable d'assurer automatiquement les fonctions suivantes sans que le service soit interrompu :
  • Détecter les défaillances ou les anomalies qui peuvent entraîner la terminaison anormale du service.
  • Corriger le problème ou prendre des mesures pour le contourner quand la réparation est impossible.
  • Informer des incidents, des défaillances et des mesures prises pour corriger ces problèmes.
Avant d'utiliser ServiceKeeper vous devez définir la stratégie qui sera la plus appropriée aux services que vous voulez surveiller et aux capacités de votre réseau. Par exemple, si vous pouvez compter sur des serveurs redondants, la bonne approche serait probablement de configurer vos services remplaçants afin qu'ils démarrent sur une autre machine, avant d'appliquer les mesures correctives au service en panne.

Sous Windows, il existe des moyens très simple qui vous permettent de déterminer et d'analyser les performances des processus qui s'exécutent sur l'ordinateur. Par exemple, lorsque une application ne ferme pas correctement ses handles ou génère des fuites mémoire, vous pouvez déterminer le taux d'utilisation des ressources système dans l'analyseur de performances par l'intermédiaire des compteurs, ou bien détecter, en utilisant le journal d'événements, des messages d'avertissement caractéristiques d'une situation instable récurrente. Toutes ces informations peuvent être utilisées par ServiceKeeper pour entreprendre, de la manière la plus précise possible, des actions préventives.

Voir aussi
Détecter les défaillances de Service
Récupérer les services défaillants
Configurer les notifications
Planifier les services
Configuration avancée
Présentation de ServiceKeeper


Statistiques de ServiceKeeper

Les pages de statistiques de ServiceKeeper sont disponibles à partir des propriétés de ServiceKeeper, des services et des resources surveillées. Ces statistiques proposent un récapitulatif des pannes détectées et des actions de réparation entreprises. Vous pouvez ainsi déterminer la disponibilité globale de votre système ainsi que la disponibilité de chacune de vos resources (ou services) surveillés.

Voir aussi
Détecter les défaillances de Service
Récupérer les services défaillants
Configurer les notifications
Planifier les services
Configuration avancée
Présentation de ServiceKeeper


Planifier les Services

Après un certain temps d'exécution, il arrive que certains processus se terminent anormalement. Ces arrêts, pouvant être dus à un grand nombre de raisons, sont à la source de la plupart des défaillances des serveurs et des applications. Par exemple, une application ne libérant pas la mémoire utilisée peut provoquer une saturation de la mémoire et par conséquent une panne du système. La méthode la plus couramment utilisée par les administrateurs pour remédier ou éviter de tels incidents a toujours été de redémarrer périodiquement les systèmes.

Vous pouvez utiliser ServiceKeeper pour planifier des actions de maintenance, en relançant régulièrement des services potentiellement gênants pour libérer les ressources, tout en laissant les autres processus opérationnels.

Vous pouvez également utiliser ServiceKeeper pour arrêter certains services pendant les opérations de sauvegarde, afin d'éviter le blocage des ressources ou pour arrêter certains services en dehors des heures ouvrables et limiter ainsi l'accès aux données.

Pour planifier les services

Lancez Service+, sélectionnez le service dont vous souhaitez planifier l'exécution, cliquez sur Propriétés puis sélectionnez l'onglet Plage Horaire. Choisissez l'état du service à l'aide des boutons de sélection puis sélectionnez à l'aide de la souris la plage horaire à laquelle vous voulez que cet état soit appliqué.

Note : Par défaut, l'état d'un service dont l'exécution est planifiée est mis en cohérence avec l'état spécifié dans la plage horaire correspondante toutes les 30 secondes. Si une tentative de mise en cohérence échoue, ServiceKeeper informe l'administrateur en utilisant les méthodes de notification définies dans la configuration du service ou dans la configuration par défaut de ServiceKeeper. Ce scénario est appliqué même si la surveillance du service planifié n'a pas été activée. Pour modifier le comportement de ServiceKeeper, activez la surveillance du service et sélectionnez les actions à entreprendre dans la liste des actions de réparation.

Etat d'un service planifié :

Vert Clair : le service est démarré.

Si le service dépend d'autres services, ces services seront également démarrés.

Rouge : le service est arrêté.

Les services dépendants seront également stoppés. Attention de ne pas installer des programmations conflictuelles sur des services dépendants (ex. : A dépend de B, B est programmé pour s'arrêter alors que A est programmé pour démarrer).

Orange : le service est en pause.

Cet état est pratique pour les tâches de maintenance et la limitation de l'accès aux ressources de l'ordinateur pendant les heures non travaillées. Par exemple, quand le service "server" est en pause, seuls les utilisateurs ayant des privilèges administrateur peuvent se connecter.

Blanc : l'état du service est ignoré.

Programmation par défaut de tous les services. Si vous programmez un service qui a des dépendances, assurez-vous que l'état des services dépendants est ignoré. Ou alors, si vous programmez un service dépendant d'un autre, contrôlez que l'état suivant est ignoré.

Bleu : le service n'est démarré qu'une seule fois pendant cette période de 1/2 heure.

Etat de programmation utile pour lancer des tâches telles que les Sauvegardes ou les transferts d'Emails.

Vert Foncé : le service est relancé une fois durant cette période de 1/2 heure.

Ceci peut être utilisé pour relancer des services qui ne libèrent pas toutes leurs ressources (Mémoire, Handle....).
  • Paramètres de démarrage : quand un service est lancé vous pouvez spécifier les options de démarrage. Cette option est équivalente à celle de la boîte de dialogue de Service+ que vous obtenez en pressant sur la touche Maj. et le bouton Démarrer en même temps.
  • Démarrer les service dépendants : vous pouvez démarrer les services dépendants du service courant configurés en démarrage automatique. Si le service B est dépendant du service A, quand A s'arrête, B s'arrêtera également. Lorsque A redémarre, B redémarre également.
  • Démarrer les dépendances précédemment démarrées : Vous pouvez demander a ServiceKeeper de démarrer les services qui dépendent du service courrant mais seulement s'ils étaient déjà démarrés auparavant. Si le service B dépend du service A et était démarré, lorsque A s'arrête, B s'arrête. Si A est à nouveau démarré, B sera aussi démarré.
  • Tuer le processus du service si le service ne peut être stoppé : vous pouvez demander à ServiceKeeper de tuer le ou les processus d'un service qui ne s'arrêterait pas. ServiceKeeper détermine qu'un service ne s'arrête pas après le dépassement du délais Délais d'attente max. sur état en instance qui peut être configuré dans le choix Avancé de l'onglet Surveillance des Propriétés d'un service.

    Note: Seuls les processus exécutés sur l'ordinateur ou ServiceKeeper est exécuté peuvent être tués par ServiceKeeper.

  • Délais avant le démarrage des dépendances: Ce paramètre indique à ServiceKeeper qu'il faut attendre le temps spécifié avant de démarrer les dépendances.

Voir aussi
Présentation de ServiceKeeper
Paramètres avancés


Détecter les pannes de services

ServiceKeeper propose plusieurs méthodes pour détecter les pannes de service, méthodes que vous pouvez combiner en fonction des comportements spécifiques des services surveillés. Le meilleur moyen pour trouver le bon mix consiste à essayer différentes configurations et à les tester dans le temps. L'Analyseur de Performances et le Journal d'Evénements devraient également pouvoir vous donner des informations sur l'usage des ressources système et les événements associés au service que vous désirez surveiller.

Pour éditer la configuration des détections de pannes

1. Sélectionnez une vue de l'arborescence de la Console Service+ puis sélectionnez un service.

2. Cliquez avec le bouton droit de la souris sur le service à surveiller et sélectionnez Propriétés ou double-cliquez sur le service.

3. Cliquez sur l'onglet Surveiller et le choix Détecter pour accéder à la liste règles de détections existantes.

Vous pouvez ajouter, modifier, supprimer ou réordonner des règles de détections.

Chaque règle peut être activée ou désactivée individuellement.

Services planifiés : ServiceKeeper utilise par défaut l'action de détection de l'état du service pour contrôler les services dont l'exécution est planifiée dans le temps.
Voir aussi
Ajouter une règle de détection de panne
Modifier une règle de détection de panne
Réordonner les règles de detection de panne
Supprimer une règle de détection de panne
Surveiller les services


Ajouter une règle de détection

Pour ajouter une règle de détection

1. Cliquez sur l'onglet Surveiller et le choix Détecter dans la fenêtre des propriétés d'un service pour accéder aux règles de détection existantes.

2. Cliquez sur bouton [image] pour lancer l'assistant de création de règle de détection.

3. Sélectionnez le type de détection que vous souhaitez ajouter et cliquez sur Suivant.

4. Entrer une nouvelle description si vous le souhaitez et cliquer sur Suivant.

5. Réglez les paramètres de la règle.

Chaque type de détection possède ses propres paramètres spécifiques. Consultez les pages listées ci-dessous pour plus de précision sur chacun des types de détection.

Types de détection

Surveiller l'état d'un service Surveiller un site web Surveiller un site FTP Surveiller un serveur SMTP Surveiller un serveur POP3 Surveiller un serveur NNTP Surveiller des composants réseaux Surveiller les ports TCP/IP Surveiller les journaux d'évènements Surveiller les compteurs de performance Surveiller l'utilisation mémoire d'un service Surveiller l'utilisation CPU d'un service Utiliser les valeurs de retour des fonctions script Utiliser le code de retour d'un programme Surveiller le système de fichiers

Voir aussi

Détecter les défaillances de services


Modifier une règle de détection

Pour modifier une règle de détection

1. Cliquez sur l'onglet Surveiller et le choix Détecter dans la fenêtre des propriétés d'un service pour accéder aux règles de détection existantes.

2. Sélectionnez la règle que vous souhaitez modifier.

3. Cliquez sur le bouton Propriétés [image] ou double-cliquez sur la règle.

4. L'onglet Général vous permet d'éditer les paramètres de la règle choisie.

  • Opérateur
    Vous devez d'abord choisir un opérateur logique qui va déterminer la manière dont cette règle sera associée logiquement avec les autres règles de la liste des règles de détection.
OU | Quand des règles sont combinées logiquement à l'aide de l'opérateur OU, il suffit que l'une d'elles détecte une défaillance pour qu'une détection de panne soit rapportée.
ET | Quand elles sont combinées logiquement à l'aide de l'opérateur ET, les règles doivent toutes détecter une défaillance pour qu'une détection de panne soit rapportée.
OU Exclusif | Quand des règles sont combinées logiquement à l'aide de l'opérateur OU exclusif, il faut que l'une d'elles et seulement l'une d'elle détecte une défaillance pour qu'une détection de panne soit rapportée.

L'ordre de priorité des opérateurs est tel que les ET sont évalués avant les OU qui sont évalués avant les opérateurs OU Exclusifs. En d'autres termes, A OU B OU C ET D OU E ET F ET G est évalué A OU B OU (C ET D) OU ((E ET F) ET G).

Chaque type de détection possède ses propres paramètres spécifiques. Consultez les pages listées ci-dessous pour plus de précision sur chacun des types de détection.

Types de détection

Surveiller l'état d'un service Surveiller un site web Surveiller un site FTP Surveiller un serveur SMTP Surveiller un serveur POP3 Surveiller un serveur NNTP Surveiller des composants réseaux Surveiller les ports TCP/IP Surveiller les journaux d'évènements Surveiller les compteurs de performance Surveiller l'utilisation mémoire d'un service Surveiller l'utilisation CPU d'un service Utiliser les valeurs de retour des fonctions script Utiliser le code de retour d'un programme Surveiller le système de fichiers

5. Sélectionnez l'onglet Fréquence de détection pour modifier les paramètres définissant la fréquence des détections.

Voir aussi

Détecter les défaillances de services
Fréquence de détection


Réordonner les règles de détection

L'ordre d'exécution d'une règle de détection de panne est déterminé par sa position dans la liste des règles detections de panne d'un service. En ordonnant cette liste d'une manière différente, vous changez l'ordre d'exécution des règles.

Pour réordonner les règles de détection

1. Sélectionnez l'onglet Surveillance et le choix Détecter pour accéder à la liste des détections existantes.

2. Sélectionnez une règle dont vous souhaitez changer la position dans la liste et cliquez sur les boutons Haut [image] ou Bas [image] pour repositionner la règle à la position souhaitée.

Voir aussi

Détecter les défaillances de services


Spécifier la fréquence de détection

L'onglet fréquence de détection vous permet de définir la fréquence à laquelle ServiceKeeper effectue ses détections. Il vous permet également de définir si une défaillance est rapportée comme telle dès qu'elle est détectée ou si elle doit être détecter successivement à plusieurs reprises pendant une période de temps donnée pour être rapportée.

Pour spécifier la fréquence de détection

1. Sélectionnez l'onglet Surveillance et le choix Détecter pour accéder à la liste des détections existantes.

2. Sélectionnez la règle que vous souhaitez modifier.

3. Cliquez sur le bouton Propriétés [image] ou double-cliquez sur la règle choisie.

4. Sélectionnez l'onglet Fréquence de détection.

  • Lancer une détection toute les ...
    Vous utilisez ce paramètre pour définir la fréquence à laquelle ServiceKeeper évalue la condition définie dans l'onglet Général de la règle.
  • Détection des pannes dans le temps
    Vous utilisez cette option pour indiquer à ServiceKeeper qu'il doit évaluer les conditions un certain nombre de fois et qu'il doit indiquer une défaillance que si un certain pourcentage d'erreurs est atteint.
  • Nombre de tests
    Il s'agit du nombre d'évaluation que ServiceKeeper doit faire avant de pouvoir rapporter une défaillance.
  • Signaler un erreur lorsque le taux de panne atteint 100 %
    Vous spécifiez dans ce champ le taux d'erreurs qui doit être atteint pour qu'une défaillance soit rapportée.
Exemple: Dans l'exemple ci-dessus, ServiceKeeper enregistre toutes les 10 secondes l'etat du service 'World Wide Web publishing service'. Si au cours de 3 enregistrements consécutifs l'état du service n'est qu'une seule fois 'Démarré', ServiceKeeper rapportera une défaillance car le taux de panne aura été dépassé (2 tentatives échouées représente 66% de taux de panne).

Voir aussi

Détecter les défaillances de services
Modifier une règle de détection


Supprimer une règle de détection

Pour supprimer une règle de détection

1. Sélectionnez l'onglet Surveillance et le choix Détecter pour accéder à la liste des règles de détection existantes.

2. Sélectionnez la règle que vous souhaitez supprimer et cliquez sur le bouton Supprimer [image] ou appuyez sur la touche Suppr de votre clavier.

Voir aussi

Détecter les défaillances de services


Surveiller l'état d'un service

Cette option détecte quand un service n'est pas démarré ou que son état n'est pas en accord avec l'état planifié. L'état du service est contrôlé à intervalles réguliers, définis dans l'onglet Fréquence de détection de la configuration d'une règle de détection. Le Service Control Manager renvoie l'état du service à ServiceKeeper.

Propriétés de la règle 'Détection de l'état du service'

  • Description : vous pouvez spécifier une description particulière pour votre règle.
Note: Contrôler l'état du service ne détectera pas forcément les conditions dans lesquelles le service s'est arrêté. Il est fortement conseillé d'utiliser cette méthode pour corriger des incohérences avec le statut de services sains, et de la combiner avec par exemple les méthodes compteurs et/ou journal d'événements, qui peuvent permettre de détecter des problèmes relatif au service.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller un site web

Cette méthode permet de contrôler la disponibilité d'un site web en initiant une connexion HTTP avec ce dernier. Vous pouvez choisir un site web IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre site web.

Propriétés de la règle 'Surveiller un site web'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (w3svc) lorsque le site web ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : Lorsque cette option est cochée, ServiceKeeper détectera également les erreurs relative au protocole HTTP (erreurs 4xx ou 5xx)
L'onglet Recherche textuelle vous permet de rechercher un texte dans la page web retournée par la requête HTTP et ainsi contrôler la validité de la page web retournée.

Note : vous pouvez demander à ServiceKeeper d'ouvrir une page en particulier sur votre site web. Vous pouvez, par exemple entrer l'addresse http://www.activeplus.com/fr/products/ServiceKeeper/default.asp

Voir aussi

Surveiller l'état d'un service
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller un site FTP

Cette méthode permet de contrôler la disponibilité d'un site FTP en initiant une connexion avec ce dernier. Vous pouvez choisir un site FTP IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre site FTP.

Propriétés de la règle 'Surveiller un serveur FTP'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (MSFTPSVC) lorsque le site FTP ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur FTP et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller un serveur SMTP

Cette méthode permet de contrôler la disponibilité d'un serveur SMTP en initiant une connexion avec ce dernier. Vous pouvez choisir un serveur SMTP IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre serveur SMTP.

Propriétés de la règle 'Surveiller un serveur SMTP'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (SMTPSVC) lorsque le serveur SMTP ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur SMTP et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller un serveur POP3

Cette méthode permet de contrôler la disponibilité d'un serveur POP3 en initiant une connexion avec ce dernier. Vous pouvez choisir un serveur POP3 IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre serveur POP3.

Propriétés de la règle 'Surveiller un serveur POP3'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (POP3SVC) lorsque le serveur POP3 ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur POP3 et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller un serveur NNTP

Cette méthode permet de contrôler la disponibilité d'un serveur NNTP en initiant une connexion avec ce dernier. Vous pouvez choisir un serveur NNTP IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre serveur NNTP.

Propriétés de la règle 'Surveiller un serveur NNTP'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (NNTPSVC) lorsque le serveur NNTP ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur NNTP et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller les composants réseaux (PING)

Cette méthode permet de contrôler la disponibilité de composants réseaux (ordinateur, routeurs, pares-feu, etc...) par l'envoi d'une requête PING.
Pour cela, vous devez entrer l'adresse IP ou le nom du composant réseau que vous souhaitez contrôler ainsi que le délai maximum de réponse (correspond à l'option -w de la commande PING). Vous pouvez également entrer la taille des paquets qui seront envoyés par la requête (correspond à l'option -l de la commande PING).

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller les ports TCP/IP

Cette méthode contrôle les connexions TCP/IP (WinSock) aux serveurs, à différents intervalles de temps définis dans fréquence de détection. ServiceKeeper vérifie qu'une session TCP est correctement ouverte sur le "socket" défini.

ServiceKeeper vous permet également de surveiller ces protocoles sur des plate-formes différentes de Windows. Dans ce cas, il faut utiliser les Ressources surveillées.

Propriétés de la règle 'Surveiller les services TCP/IP'

  • Hôte(s) : Entrer le nom ou l'adresse IP du serveur hébergeant le service TCP que vous voulez surveiller (le nom de l'ordinateur surveillé sera mis par défaut). Vous pouvez spécifier plusieurs hôtes en utilisant des virgules comme séparateurs. Exemple : www.site1.com,www.site2.com,123.123.123.123
    Note : vous pouvez spécifier un port TCP particulier en même temps que le nom d'hôte ou l'adresse IP. Exemple: server.site1.com:8080
  • Port : Vous pouvez spécifier n'importe quel port que vous voulez contrôler.
  • Délai : spécifie le délai maximum en millisecondes que doit mettre le serveur à répondre.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller le journal d'événements

Utilisez cette méthode pour surveiller le journal d'événements et filtrer les événements spécifiques qui déclencheront une tentative de réparation. Les événements sont enregistrés dans des registres séparés : Application, Security et System logs (Windows XP), auxquels on peut ajouter les registres Directory et File Replication service logs si l'ordinateur est un contrôleur de domaine, et un DNS server log si l'ordinateur est également un serveur DNS.

On peut consulter le Journal d'événements dans l' "Event Viewer". Les 3 types d'événements principaux sont les suivants : Erreur, Avertissement, Informations.

Propriétés de la règle 'Surveiller le journal d'évènements'

  • Journal : Services, applications et pilote reportant des messages dans chacun des journaux.
  • Source : habituellement identique au nom du service. Vous pouvez visualiser le nom de la source d'un service en vous reportant aux différents journaux d'événements de l'Event Viewer (champ Source), et le comparer à la liste fournie par ServiceKeeper.
  • Détecter une panne quand le journal contient :
    • au moins une erreur : le journal sera surveillé pour détecter les erreurs éventuelles. Les événements erreurs sont importants, ce peut être des pertes de données ou de fonctionnalités. Par exemple si un service n'est pas lancé au démarrage, une erreur sera enregistrée.
    • au moins un avertissement : le journal sera surveillé pour détecter les avertissements éventuels. Les avertissements ne sont pas nécessairement importants, mais ils peuvent indiquer un problème futur possible. Par exemple, quand il reste peu d'espace disque, un avertissement sera enregistré.
    • Parmi les événements suivants : vous pouvez faire surveiller le journal pour n'importe quel événement en fournissant son ID (identifiant) qui peut être consulté dans l'Event Viewer (champ Événement). Ceci est pratique lorsque l'on veut détecter un ou plusieurs événements de type erreur, avertissement ou information, pour un service contrôlé.

Voir aussi
Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller les compteurs de performances

Windows propose des compteurs de performance qui permettent de visualiser les données représentant les aspects spécifiques du système. Ces compteurs peuvent être utilisés pour détecter précisément toutes sortes d'erreurs intervenant sur les composants du système ainsi que des situations d'exécution critiques.

On peut consulter les compteurs de performance et les analyser depuis Démarrer/Paramètres/Panneau de configuration/Outils d'Administration/Analyseur de Performance

Propriétés de la règle 'Surveiller des compteurs de performance

Dans l'exemple ci-dessus, le processus de service du spooler sera détecté comme défaillant si plus de 500 handles sont alloués.
  • Sélectionnez un compteur en utilisant le bouton [...] à droite du champ.
  • Indiquez la condition de défaillance (Egal, Plus grand, Différent....etc.).

Sélection d'un compteur

Les compteurs les plus communément utilisés sont listés dans le tableau ci-dessous. Pour une description complète des données fournies par un compteur particulier associé à objet de performance, cliquer sur Expliquer dans la boîte de dialogue Parcourir les compteurs :

  • Sélectionner l'ordinateur sur lequel sont lancés les services que vous voulez surveiller. Pour cela il faut que vous ayez les droits appropriés et la licence ServiceKeeper adéquate. Indiquer le Niveau de détail pour déterminer la définition des compteurs disponibles.
  • Sélectionnez l'Objet de performance. Voir le tableau ci-dessous.
  • Sélectionnez le compteur disponible pour l'objet surveillé. Certains compteurs nécessitent que l'on spécifie les Instances. Voir le tableau ci-dessous.
Objet de Performance | Compteur | Valeurs
Mémoire
Pages/s | Les pages/s sont le nombre de pages lues à partir du disque ou écrites sur le disque afin de résoudre des défauts de page matériels. (Les défauts de page matériels se produisent lorsqu'un processus nécessite du code ou des données qui ne sont ni dans son jeu de pages de travail ni dans la mémoire physique et doivent être récupérés sur le disque.) Ce compteur a été créé pour indiquer le type de fautes qui causent des délais au niveau du système. C'est la somme des pages entrées/s et des pages sorties/s de l'objet Mémoire. Cette somme est le nombre de pages, pour pouvoir être comparée à d'autres comptes de pages, tels que Défauts de page/s sans conversion. Ce compteur inclut le trafic des pages pour le compte du cache système afin d'accéder aux données des fichiers pour les applications. Cette valeur inclut aussi les pages de et vers des fichiers de mémoire mappée non-cachés. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Pages en entrée/sec | Pages en entrée/s est le nombre de pages lues sur le disque pour résoudre des défauts de page matériels. (Les défauts de page matériels se produisent lorsqu'un processus nécessite du code ou des données qui ne sont ni dans son jeu de pages de travail ni dans la mémoire physique et doivent être récupérés sur le disque.) Ce compteur a été créé pour indiquer le type de fautes qui causent des délais au niveau du système. Il inclut les pages récupérées pour satisfaire les défauts dans le cache du système de fichiers (habituellement demandés par les applications) et dans les fichiers de mémoire mappée non-cachés. Ce compteur dénombre les pages et peut être comparé sans conversion à d'autres décomptes de pages, tels que Défauts de page/s de l'objet Mémoire. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Défauts de page/s | Les défauts de page/s sont le taux global de défauts de page traités par le processeur. Il est mesuré en nombre de défauts de page par seconde. Un défaut de page intervient lorsqu'un processus nécessite du code ou des données qui ne se trouve pas dans son jeu de pages de travail en mémoire centrale (espace de la mémoire physique). Ce compteur inclut les défauts matériels (nécessitant un accès au disque) et les défauts logiciels (si le défaut de page est trouvé ailleurs qu'en mémoire physique.) La plupart des processeurs peuvent traiter de grands nombres de défauts logiciels sans conséquence. Cependant, un défaut matériel peut causer des délais significatifs. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Objets
Processus | Le processus est le nombre de processus dans l'ordinateur au moment du sondage. Notez que ceci constitue un décompte instantané et non pas une moyenne sur un intervalle de temps. Chaque processus représente l'exécution d'un programme.
Threads | Les threads sont le nombre de threads dans l'ordinateur au moment du sondage. Notez que ceci constitue un décompte instantané et non pas une moyenne sur un intervalle de temps. Une thread est l'entité exécutable de base pouvant exécuter des instructions sur un processeur.
Disque physique
Lectures disque/s | Les lectures disque/s sont le taux d'opérations de lecture sur le disque.
Ecritures disque/s | Les écritures disque/s sont le taux d'opérations d'écriture sur le disque.
Processus
% Temps processeur | Le % Temps processeur est le pourcentage du temps écoulé passé par le processeur à exécuter les instructions de toutes les threads de ce processus. Une instruction est l'unité d'exécution de base d'un ordinateur, une thread est l'objet qui exécute les instructions, et un processus est l'objet créé lorsqu'un programme s'exécute. Le code exécuté pour gérer des interruptions dues au matériel et gérer des conditions de déroutement est inclus dans ce compte. Sur les ordinateurs multi-processeurs, la valeur maximale de ce compteur est 100 % fois le nombre de processeurs.
ID du processus créateur | La valeur ID du processus créateur est l'ID du processus qui a créé le processus. Remarquez que ce processus créateur peut s'être terminé depuis la création du nouveau processus et donc, cette valeur peut identifier un processus qui n'est plus en cours d'exécution.
N° du processus | Le Nº du processus est l'identificateur unique de ce processus. Notez que les numéros de processus sont réutilisés de façon à ce qu'ils n'identifient qu'un seul processus pendant la durée de vie de celui-ci.
Défaut de page/s | Les défauts de page/s sont le taux de défauts de page générés par les threads s'exécutant dans ce processus. Un défaut de page intervient lorsqu'un processus fait référence à une page de mémoire virtuelle qui ne se trouve pas dans son jeu de pages de travail en mémoire centrale. Un défaut de page ne causera pas sa recherche sur disque si cette page est dans la liste En attente, et donc déjà en mémoire centrale, ou si elle est utilisée par un autre processus avec lequel la page est partagée.
Jeu de travail | Le jeu de travail est le nombre actuel d'octets qu'il y a dans le jeu de travail de ce processus. Le jeu de pages de travail est le jeu de pages mémoire touchées récemment par les threads de ce processus. Si la mémoire disponible de l'ordinateur est au-dessus d'un seuil, les pages sont laissées dans le jeu de pages de travail d'un processus même si elles ne sont pas utilisées. Lorsque la mémoire disponible tombe en dessous d'un seuil, les pages sont retirées du jeu de travail. Si elles s'avèrent nécessaires, elles seront ramenées après un défaut de page logiciel dans le jeu de travail avant qu'elles ne quittent la mémoire centrale.
Processeur
% Temps processeur | Le % Temps processeur est le pourcentage de temps pendant lequel le processeur est occupé à exécuter des threads actives. Il est calculé en mesurant le temps passé à exécuter la thread du processus inactif dans un intervalle de temps et en soustrayant la valeur de 100%. (Chaque processeur a une thread inactive qui consomme des cycles lorsque aucune autre thread n'est prête à s'exécuter.) Il peut être considéré comme le pourcentage de temps sur l'intervalle échantillon passé à faire un travail utile. Ce compteur affiche le pourcentage moyen de temps.
Interruptions/s | Les interruptions/s sont le nombre d'interruptions matérielles reçues et traitées par le processeur à chaque seconde. Ce compteur n'inclut pas les DPC, qui sont dénombrés séparément. Il indique indirectement l'activité des périphériques qui génèrent des interruptions, tels que les horloges système, la souris, les pilotes de disques, les lignes de communication de données, les cartes d'interface réseau et d'autres périphériques. Ces périphériques interrompent normalement le processeur lorsqu'ils ont terminé une tâche ou lorsqu'ils ont besoin d'assistance. L'exécution normale des threads est suspendue pendant les interruptions. La plupart des horloges système interrompent le processeur toutes les 10 millisecondes, créant un fond d'activité d'interruption. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Serveur
Total des octets/s | Le total octets/s est le nombre d'octets envoyés et reçus sur le réseau. Cette valeur fournit une indication générale de l'activité du serveur.
Blocs de contexte en attente/s | Les blocs de contexte en attente/s sont le taux auquel les blocs de contextes de travail ont dû être mis dans la file FSP du serveur en attendant d'être traitées.
Erreurs d'autorisation d'accès | Les erreurs d'autorisation d'accès sont le nombre de fois que des ouvertures pour des clients ont échoué avec le statut STATUS_ACCESS_DENIED. Cela peut indiquer si quelqu'un tente d'accéder à des fichiers au hasard en espérant en trouver un qui n'était pas protégé correctement.
Fichiers ouverts | Les fichiers ouverts sont le nombre de fichiers actuellement ouverts sur le serveur. Cela indique l'activité courante du serveur.
Total des fichiers ouverts | Le total des fichiers ouverts est le nombre de tentatives réussies d'ouverture réalisées par le serveur pour ses clients. Cela est utile pour déterminer le nombre d'E/S fichier, le temps perdu pour des opérations basées sur des chemins et l'efficacité des verrous optionnels.
Total des ouvertures de sessions | Le total des ouvertures de session inclut toutes les sessions interactives, les sessions réseau, les sessions de service, les sessions qui ont réussi, et celles qui ont échoué depuis le dernier redémarrage de l'ordinateur.
Ouvertures de sessions/s | Ouvertures de sessions/s est le taux de toutes les ouvertures de sessions du serveur.
Sessions serveur | Les sessions serveur sont le nombre de sessions actuellement actives dans le serveur. Cela indique l'activité courante du serveur.
Système
Opérations de fichier/s | Les opérations de fichier/s sont le taux combiné des opérations de lecture et d'écriture sur tous les disques logiques de l'ordinateur. C'est l'inverse des Opérations de contrôle de fichier/s de l'objet Système. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Opérations de lecture de fichier/s | Les opérations de lecture fichier/s sont la combinaison du taux de requêtes de lecture du système de fichiers à tous les périphériques de l'ordinateur, y compris les requêtes de lecture à partir du cache du système de fichiers. Ce compteur est mesuré en nombre de lectures. Il affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Opérations d'écriture de fichier/s | Les opérations d'écriture fichier/s sont la combinaison du taux de requêtes d'écriture du système de fichiers à tous les périphériques de l'ordinateur, y compris les requêtes d'écriture dans le cache du système de fichiers. Ce compteur est mesuré en nombre d'écritures. Il affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Temps d'activité système | Le temps d'activité du système est le temps écoulé (en secondes) pendant lequel le système a été en marche depuis le dernier démarrage. Ce compteur affiche la différence entre l'heure de démarrage et l'heure actuelle.
Thread
% Temps processeur | Le % Temps processeur est le pourcentage du temps écoulé passé par le processeur à exécuter les instructions de cette thread. Une instruction est l'unité d'exécution de base d'un processus et une thread est l'objet qui exécute les instructions. Le code exécuté pour gérer des interruptions dues au matériel et gérer des conditions de déroutement est inclus dans ce compte.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller l'utilisation mémoire d'un service

Grâce à cette méthode de détection, vous pourrez facilement traquer les éventuelles fuites mémoire de vos services.
  • Indiquez la condition de défaillance (Egal, Plus grand, Différent....etc.).
  • Spécifiez si ServiceKeeper doit additioner la mémoire utilisée et la taille de la mémoire virtuelle allouée au processus du service (pagefile.sys).

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller l'utilisation CPU d'un service

Une utilisation abusive de la CPU par un service est très souvent synonyme de panne et entraine de forts ralentissements des autres applications lancées sur le serveur. Contrôler, avec cette méthode, l'utilisation CPU de vos services.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Utiliser les valeurs de retour des fonctions script

Cette fonction vous permet d'écrire votre propre code VBScript pour détecter des pannes éventuelles. Vous pouvez par exemple écrire un script qui se connecte à une base de données avec ADO, et qui vérifie s'il y a plus de x enregistrements en attente de traitement. Vous pouvez également utiliser votre script avec des objets WMI qui vous permettent d'accéder aux éléments du système (journal d'événements, base de registre, composants, etc.)

Propriétés de la règle 'Utiliser les valeurs de retour des fonctions script'

Les paramètres suivants sont disponibles :
  • Info.Computer : chaîne de caractères correspondant au nom de l'ordinateur sur lequel le service est installé.
  • Info.Name : chaîne de caractères correspondant à l'Alias du service.
  • Info.DisplayName : chaîne de caractères correspondant au nom du service.
  • Info.FailCount : nombre entier indiquant combien de fois le service a été détecté comme défaillant.
  • Info.DesiredServiceState : nombre entier indiquant l'état désiré pour le service. (1 pour Arrêté, 4 pour Lancé, 7 pour Pause)

La fonction doit retourner False si une panne a été détectée. Vous pouvez également stocker un message d'erreur dans la variable Info.Error

Directives de pré-compilation

Ces directives peuvent être inclues dans le texte au sein des commentaires.
  • '$$typelib:[file_name]pour accéder à des constantes définies dans une Type Library.
    Exemple : des constantes ADO peuvent être utilisées si ce qui suit est inséré au début du script :
    '$$typelib: c:\program files\common files\system\ado\msado15.dll
    or
    '$$typelib: c:\program files\common files\system\ado\msado25.tlb
  • '$$object: (ProgID|CLSID) : name pour ajouter un objet nommé dans le contexte du script :
    Exemple : Si MyRecorset est défini, il peut être utilisé ainsi :
    '$$object:ADODB.Recordset:MyRecordset
  • '$$include:[file_name] pour inclure du code externe. La ligne de texte est remplacée par le contenu du [file_name]
Plus d'information sur le scripting : vous trouverez des ressources expliquant WMI, ADSI, et Windows Scripting sur les sites Microsoft pour les développeurs : Windows Script Technologies et Active Directory Service Interfaces.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de services


Utiliser le code de retour d'un programme

La plupart des exécutables retournent un code permettant de déterminer si une erreur s'est produite. Cette fonctionnalité vous permet d'exécuter un programme afin de vérifier si le service fonctionne correctement.

Propriétés de la règle 'Utiliser le code de retour d'un programme'

  • Programme : spécifier le chemin d'accès de votre exécutable dont vous voulez tester le code de retour.
  • Paramètres : paramètres de ligne de commande de votre programme.
  • Répertoire : spécifie le répertoire par défaut dans lequel le programme est exécuté.
  • Détecter une panne... : spécifie les conditions de défaillance en fonction du code de retour renvoyé.
  • Attendre l'arrêt du processus pendant xxx secondes : ServiceKeeper tuera le processus s'il ne se termine pas dans la période de temps spécifiée et reportera une erreur.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Surveiller le système de fichiers
Détecter les défaillances de services


Surveiller le système de fichiers

Vous pourrez, grâce aux fonctionnalités de cette option, surveiller le système de fichiers. En effet, vous aurez la possibilité d'observer les fluctuations du nombre ou de la taille des fichiers dans un répertoire, de contrôler l'espace disque sur vos différents volumes, de détecter d'éventuelles pannes en examinant les dernières dates d'accès et/ou de modifications de certains fichiers.

Note : Les propriétés suivantes ne sont accessible que dans le mode avancé. Le mode assistant ne permet que de contrôler l'espace disponible restant d'un disque.

Propriétés de la règle 'Surveiller le système de fichiers'

  • Rechercher les fichiers nommés : spécifiez le nom du fichier recherché. Vous pouvez utiliser les jokers * (toute chaîne de caractères) et ? (tout caractère).
  • Rechercher dans : spécifiez le répertoire dans lequel vous souhaitez rechercher les fichiers. Vous pouvez également utiliser les jokers * et ? pour spécifier plusieurs répertoires (Les caractères jokers ne sont admis que dans le dernier sous-répertoire, par exemple : c:\smtp\domaines\domaine*com).
  • Détecter une panne quand : déterminez ici la condition de panne à détecter.
  • Rechercher dans les sous-répertoires : cette option vous permet de determiner si la recherche doit aussi porter sur les sous-répertoires du répertoire spécifié dans la propriété Rechercher dans.
  • Au moins un des fichiers satisfait la condition spécifiée ci-dessus : lorsque cette propriété est cochée, une erreur sera retournée dès qu'un fichier satisfait la condition de détection de panne saisie.
  • Tous les fichiers doivent satisfaire la condition spécifiée ci-dessus : lorsque cette propriété est cochée, tous les fichiers retournés par la recherche devront satisfaire la condition de panne saisie pour qu'une erreur soit retournée.

Voir aussi

Surveiller l'état d'un service
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un service
Surveiller l'utilisation CPU d'un service
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Détecter les défaillances de services

© 1997-2007 Active+ Software . All trademarks property of their owners. Send us feedback.


Réparer les services défaillants

ServiceKeeper propose plusieurs méthodes de récupération qui peuvent être combinées pour réparer ou contourner les services défaillants. Vous pouvez définir l'ordre dans lequel les différentes méthodes seront appliquées, et utilisez plusieurs jeux de méthodes pour des stratégies de secours si la récupération automatique est impossible.

Pour modifier les règles de réparation des défaillances

1. Sélectionnez une vue de l'arborescence de la Console Service+ puis sélectionnez un service.

2. Cliquez avec le bouton droit de la souris sur le service à surveiller et sélectionnez Propriétés ou double-cliquez sur le service.

3. Cliquez sur l'onglet Surveiller et le choix Réparer pour accéder à la liste des actions de réparation existantes.

Vous pouvez ajouter, modifier, supprimer ou réordonner les actions de réparation. Chaque règle peut être activée ou désactivée individuellement. ServiceKeeper exécutera successivement les règles de réparation actives jusqu'à ce que le service soit réparé ou que les tentatives de réparation soient abandonnées.

Voir aussi

Ajouter une règle de réparation
Modifier une règle de réparation
Supprimer une règle de réparation
Surveiller les services


Ajouter une action de réparation

Pour ajouter une action de réparation

1. Cliquez sur l'onglet Surveillance et le choix Réparer de la fenêtre des propriétés pour accéder à la liste des actions de réparation existantes.

2. Cliquez sur le bouton [image] pour lancer l'assistant de création des actions de réparations.

3. Sélectionnez l'action que vous voulez ajouter et cliquez sur Suivant.

4. Entrez une description pour votre action de réparation (facultatif). Cliquez sur Suivant.

5. Editez les paramètres de l'action de réparation.

Chaque action possède des paramètres qui lui sont propres. Consultez les pages listées ci-dessous pour obtenir plus d'information sur les paramètres spécifiques à chacune des actions.

Types d'action

Ne pas réparer mais notifier Redémarrer le service Démarrer un autre service Lancer un exécutable Exécuter un script Réparer le système de fichiers Redémarrer l'ordinateur Arrêter la surveillance d'un service

Voir aussi

Réparer les services défaillants


Modifier une règle de réparation

Pour modifier une règle de réparation

1. Cliquez sur l'onglet Surveillance et le choix Réparer de la fenêtre des propriétés pour accéder à la liste des actions de réparation existantes.

2. Sélectionnez l'action de réparation que vous voulez modifier.

3. Cliquez sur le bouton Propriétés [image] ou double-cliquez sur la règle que vous désirez modifier.

Chaque règle possède des paramètres qui lui sont propres. Consultez les pages listées ci-dessous pour obtenir plus d'information sur les paramètres spécifiques à chaque règle.

Types d'action

Ne pas réparer mais notifier Redémarrer le service Démarrer un autre service Lancer un exécutable Exécuter un script Réparer le système de fichiers Redémarrer l'ordinateur Arrêter la surveillance d'un service

Voir aussi

Réparer les services défaillants


Supprimer une règle de réparation

Pour supprimer une règle de réparation

1. Cliquez sur l'onglet Surveillance et le choix Réparer de la fenêtre des propriétés pour accéder à la liste des actions de réparation existantes.

2. Sélectionnez l'action de réparation à supprimer et cliquez sur le bouton Supprimer [image] ou appuyez sur la touche Suppr de votre clavier.

Voir aussi

Réparer les services défaillants


Ne pas réparer mais notifier

Seules les actions de notifications seront exécutées lors de la détection d'une panne. L'action "Ne pas réparer mais notifier" n'échouant jamais, elle peut être utilisée comme porte de sortie d'un jeu d'actions, c'est pourquoi l'ordre de la liste des actions est important.

Cette méthode est très pratique pour les administrations à distance, lorsqu'elle est utilisée avec la méthode de notification écrire dans un journal d'événements HTML. Tant que le service demeure en panne, cette action peut-être exécutée même dans le second jeu d'actions, ainsi de nouvelles entrées seront insérées dans le journal d'événements HTML, qui lui peut être consulté depuis Internet.

Propriétés de l'action 'Ne pas réparer mais notifier'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.

Voir aussi

Redémarrer le service
Démarrer un autre service
Lancer un exécutable
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'un service
Réparer les services défaillants


Redémarrer le service

Redémarrer un service en panne est la méthode de récupération standard. Elle nettoie les ressources et devrait résoudre les problèmes de processus liés aux fuites de mémoire dans des services qui sans cela seraient sains. Vous pouvez la spécifier comme première méthode de récupération.

Propriétés de l'action 'Redémarrer un service'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deus valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Paramètres de démarrage (optionnel) : entrez les valeurs passées en paramètre au démarrage du service.
  • Démarrer les dépendances configurées... : vous pouvez démarrer des services configurés en démarrage automatique qui dépendent du service courant. Si le service B dépend du service A, quand A est arrêté, B sera également arrêté. Si A est redémarré, ServiceKeeper redémarrera également B (si l'option est cochée).
  • Démarrer les dépendances... : Quand il relance le service courant, ServiceKeeper mémorisera tous les services dépendants démarrés et les redémarrera aussi.
  • Tuer le processus... : Lorsqu'un service est en panne, il ne répond pas toujours correctement à une demande d'arrêt. En cochant cette option, ServiceKeeper terminera le processus du service, sans avoir besoin de redémarrer l'ordinateur. Notez que cette méthode de récupération n'est disponible que pour des services installés sur le même ordinateur que ServiceKeeper.
  • Délais d'attente... : ServiceKeeper attendra le nombre de minutes/secondes spécifié avant de redémarrer les services dépendants.

Voir aussi

Ne pas réparer mais notifier
Démarrer un autre service
Lancer un exécutable
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'un service
Réparer les services défaillants


Démarrer un autre service

Lance un service spécifique sur la machine locale ou une machine distante. Cette méthode est utile en dernier recours pour lancer un service redondant sur la machine locale ou sur un système distant.

Propriétés de l'action 'Démarrer un autre service'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Ordinateur : nom de l'ordinateur sur lequel le service à démarrer est installé. Vous devez avoir les droits administrateur. Il n'est pas nécessaire que ServiceKeeper soit installé sur cette machine.
  • Service : service à démarrer. Le menu déroulant vous propose tous les services listés par ordre alphabétique sous leur Alias.
  • Paramètres : paramètres de démarrage du service (optionnel).
  • Redémarrer le service... : le service redémarrera s'il est déjà lancé.

Voir aussi
Ne pas réparer mais notifier
Redémarrer le service
Lancer un exécutable
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'un service
Réparer les services défaillants


Lancer un exécutable

Utilisez cette méthode pour lancer un programme ou un batch personnalisé qui se chargera de l'action de réparation appropriée.

Propriétés de l'action 'Lancer un exécutable'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Programme : chemin d'accès de l'exécutable. Notez que vous ne pouvez pas pointer sur un lecteur réseau mappé (ordinateur distant). Si l'exécutable est sur une autre machine, utilisez le chemin UNC.
  • Paramètres : vous pouvez utiliser les paramètres suivants :
    • %FailCount% : Nombre de fois que le service tombe en panne.
    • %FailReason% : Cause de la défaillance.
      • 1 Service non démarré/non planifié
      • 2 Code de retour d'un processus
      • 3 Service TCP/IP
      • 4 Compteurs de performance
      • 5 Journal d'événements
      • 6 Code de retour d'un script
      • 7 Système de fichiers
    • %FailComputer% : Ordinateur sur lequel est lancé le service défaillant.
    • %FailService% : Alias du service.
    • %FailServiceDisplayName% : Nom du service.
    Ces mots clés sont également disponibles en tant que variables d'environnement.
  • Répertoire : Répertoire courant du processus.
  • Attendre l'arrêt du processus pendant xxx secondes : ServiceKeeper tuera le processus s'il ne se termine pas dans la période de temps spécifiée. Si vous ne voulez pas attendre la fin du processus, entrez 0 comme valeur.

Voir aussi

Ne pas réparer mais notifier
Redémarrer un service or planifier
Démarrer un autre service
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'un service
Réparer les services défaillants


Exécuter un script

Avec cette option vous avez la possibilité d'écrire un script (VBScript) pour réparer vos services défaillants. Vous pouvez par exemple écrire un script qui nettoierait certains fichiers avant de relancer le service.

Propriétés de l'action 'Exécuter un script'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.

Les objets et paramètres suivants sont disponibles pour le script :

  • Info.Computer : chaîne de caractères indiquant le nom de l'ordinateur sur lequel le service est exécuté.
  • Info.Name : chaîne de caractères indiquant l'Alias du service.
  • Info.DisplayName : chaîne de caractères correspondant au nom du service.
  • Info.FailCount : nombre entier indiquant combien de fois le service a été détecté comme défaillant.
  • Info.FailReason : nombre entier indiquant quelle méthode a été déclenchée pour effectuer la réparation. Ce peut être l'une des méthodes suivantes :
    • 1 Service non démarré/non planifié
    • 2 Code de retour d'un processus
    • 3 Service TCP/IP
    • 4 Compteurs de performance
    • 5 Journal d'événements
    • 6 Code de retour d'un script
    • 7 Système de fichiers
  • Info.DesiredServiceState : nombre entier indiquant l'état désiré pour le service. (1 pour Arrêté, 4 pour Lancé, 7 pour Pause)

Si la réparation échoue, False doit être retourné et Info.Error peut être défini avec un texte décrivant l'erreur.

Directives de Pré-compilation

Ces directives peuvent être inclues dans le texte au sein des commentaires.
  • '$$typelib:[file_name] pour accéder à des constantes définies dans une Type Library.
    Exemple : des constantes ADO peuvent être utilisées si ce qui suit est inséré au début du script :
    '$$typelib: c:\program files\common files\system\ado\msado15.dll
    or
    '$$typelib: c:\program files\common files\system\ado\msado25.tlb
  • '$$object: (ProgID|CLSID) : name pour ajouter un objet nommé dans le contexte du script :
    Exemple : Si MyRecorset est défini, il peut être utilisé ainsi :
    '$$object:ADODB.Recordset:MyRecordset
  • '$$include:[file_name] pour inclure du code externe. La ligne de texte est remplacée par le contenu du [file_name]
Plus d'information sur le scripting : vous trouverez des ressources expliquant WMI, ADSI, et Windows Scripting sur les sites Microsoft pour les développeurs : Windows Script Technologies et Active Directory Service Interfaces.

Voir aussi

Ne pas réparer mais notifier
Redémarrer le service
Lancer un exécutable
Démarrer un autre service
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'un service
Réparer les services défaillants


Réparer le système de fichiers

Avec cette fonctionnalité, vous pourrez entreprendre diverses actions sur le système de fichiers comme copier, déplacer ou supprimer un ensemble de fichiers.

Propriétés de l'action 'Réparer le système de fichiers

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Les fichiers nommés : spécifiez le(s) fichier(s) que vous souhaitez copier, déplacer ou supprimer. Vous pouvez utiliser les jokers * (toute chaîne de caractères) et ? (tout caractère).
  • De : spécifiez le répertoire source à partir duquel vous voulez copier, déplacer ou supprimer les fichiers.
  • Vers : spécifiez le répertoire destination vers lequel vous souhaitez copier ou déplacer les fichiers.
  • Envoyer le(s) fichier(s) dans la corbeille : si vous sélectionnez l'action Supprimer le(s) fichier(s), vous avez la possibilité de déplacer le(s) fichier(s) vers la corbeille.
    Note : Chaque utilisateur possédant sa propre corbeille, les fichiers seront déplacés dans la corbeille du compte utilisateur utilisé par ServiceKeeper pour se lancer.
    Attention : Si vous sélectionnez un répertoire source qui n'est pas situé sur un disque local, les fichiers ne pourront pas être déplacés vers la corbeille et seront détruits.
  • Rechercher dans les sous-répertoires : grâce à cette option, vous pourrez copier, déplacer ou supprimer les fichiers présents dans les sous-répertoires du répertoire spécifié dans la propriété De.
  • Ignorer les erreurs : lorsque cette option est activée, ServiceKeeper ignore les fichiers qu'il ne peut pas traiter (copier, déplacer ou supprimer). Par contre, si cette option n'est pas cochée, ServiceKeeper stoppe le traitement et retourne une erreur dès qu'il rencontre le moindre problème avec un des fichiers traité.
  • Effectuer l'action sur les fichiers respectant la condition suivante : cette condition vous permet d'agir uniquement sur un sous-ensemble des fichiers présents dans un répertoire. Par exemple, vous pouvez souhaiter ne supprimer que les fichiers qui n'ont pas été accédé depuis une semaine ou archiver les fichiers qui n'ont été retouchés depuis deux jours.

Voir aussi

Ne pas réparer mais notifier
Redémarrer un service
Lancer un exécutable
Démarrer un autre service
Exécuter un script
Redémarrer l'ordinateur
Arrêter la surveillance d'un service
Réparer les services défaillants

© 1997-2007 Active+ Software . All trademarks property of their owners. Send us feedback.


Redémarrer l'ordinateur

Vous pouvez utiliser cette option en dernier ressort, si toutes les autres actions de récupération ont échoué. Tous les processus, y compris les applications client-serveur, seront interrompus brutalement.

Propriétés de l'action 'Redémarrer l'ordinateur'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Terminer les applications de force : ceci fermera les applications même si elles attendent une action utilisateur comme par exemple "Voulez-vous enregistrer vos modifications ?"

Voir aussi

Ne pas réparer mais notifier
Redémarrer un service
Lancer un exécutable
Démarrer un autre service
Exécuter un script
Réparer le système de fichiers
Arrêter la surveillance d'un service
Réparer les services défaillants


Arrêter la surveillance d'un service

Cette option indique à ServiceKeeper qu'il doit arrêter de surveiller le service. L'état courant du service est ignoré tant que les paramètres de surveillance du service ne sont pas modifiés ou que le service ServiceKeeper n'est pas redémarré.

Propriétés de l'action 'Arrêter la surveillance d'un service'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.

Voir aussi

Ne pas réparer mais notifier
Redémarrer un service or planifier
Lancer un exécutable
Démarrer un autre service
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Réparer les services défaillants


Paramétrer les notifications

ServiceKeeper vous permet de choisir entre différentes méthodes de notification d'erreur que vous pouvez combiner afin d'être sûr d'être notifié des incidents survenus sur votre serveur quel que soit l'endroit où vous vous trouvez.

Pour configurer les notifications

1. Sélectionnez une vue de l'arborescence de la Console Service+ puis sélectionnez un service.

2. Cliquez avec le bouton droit de la souris sur le service à surveiller et sélectionnez Propriétés ou double-cliquez sur le service.

3. Cliquez sur l'onglet Surveiller et le choix Notification pour accéder à la liste des méthodes de notification offertes par ServiceKeeper.

Sélectionnez la méthode de notification et cliquez sur le bouton Propriétés [image] ou double-cliquez la sélection.

Chaque méthode de notification possède ses propres paramètres de configuration. Consultez les pages listées ci-dessous pour plus d'information sur chacune d'entre elles.

Méthodes de notification

Envoi d'un email (SMTP) Envoi d'une alerte administrative Lancer un exécutable Envoi d'un trap SNMP Exécuter un script Ecrire dans un journal d'évènements HTML Ecrire dans un fil RSS Notification vocale (Expérimentation)

Voir aussi

A propos de la surveillance des services


Envoi d'un email

A chaque détection d'erreur un email sera envoyé, après que les actions de réparation ait été entreprises. L'information, contenue dans le corps du message comme dans un fichier journal, contient les erreurs détectées ainsi que le actions de réparation entreprises, précédées de l'Alias du service surveillé ainsi que du nom de l'ordinateur.

Pour éditer les propriétés de la notification 'Envoi d'un email'

1. Depuis la liste des notifications sélectionnez Envoi d'un email (SMTP) et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • De : adresse e-mail de l'émetteur du message.
  • A : adresse du destinataire qui recevra la notification d'erreur. Vous pouvez entrer plusieurs adresses en séparant les adresses par des virgules.
  • Sujet : sujet du message.
  • Charset (Table de caractères) : encodage MIME. Si "Pas d'encodage" est sélectionné, le message ne sera pas encodé. Cette option est utile lorsque l'on envoie un message à des clients mail non compatibles avec du contenu MIME (Pager, SMS, etc.).
  • Format : sélectionnez le format dans lequel le message sera envoyé (Note : "envoyer uniquement le sujet" ajoutera le message de notification dans le sujet).
  • Serveur SMTP : nom d'hôte du serveur SMTP pour les mails sortants. Vous pouvez également entrer l'adresse IP de votre serveur.
  • Authentification : sélectionner la méthode d'authentification et entrer les informations d'ouverture de session. Consultez votre administrateur réseau pour plus d'information.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle le service a commencé à être surveillé
    • %UpTime% : la durée pendant laquelle le service a été en marche
    • %DownTime% : la durée pendant laquelle le service a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) du service
    • %LastKnownRunningState% : la date à laquelle le service a été détecté en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur le service
    • %FailureCountSinceRestart% : le nombre de panne détectées sur le service depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si le service est en marche au moment de la notification (0 s'il est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Envoi d'une alerte administrative

Cette méthode de notification affichera une alerte avec les services Messenger et Alerter. Ces 2 services doivent être démarrés sur l'ordinateur de réception si les alertes administratives sont envoyées sur une autre machine.

Pour éditer une notification 'Envoi d'une alerte administrative'

1. Depuis la liste des notifications, sélectionnez Envoi d'une alerte administrative et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

2. Entrer le nom du compte utilisateur ou le nom de l'ordinateur qui doit recevoir le message. Vous pouvez spécifier plusieurs comptes utilisateur ou ordinateurs en utilisant des virgules (ex : Admin, Vincent, Daniel)

3. Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :

  • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
  • %Date% : la date à laquelle la notification a été lancée
  • %Time% : l'heure à laquelle la notification a été lancée
  • %StartMonitoringDate% : la date à partir de laquelle le service a commencé à être surveillé
  • %UpTime% : la durée pendant laquelle le service a été en marche
  • %DownTime% : la durée pendant laquelle le service a été en panne
  • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) du service
  • %LastKnownRunningState% : la date à laquelle le service a été détecté en marche pour la dernière fois
  • %LastFailureDate% : la date à laquelle est survenue la dernière panne
  • %FailureCount% : le nombre de panne détectées sur le service
  • %FailureCountSinceRestart% : le nombre de panne détectées sur le service depuis le redémmarrage de ServiceKeeper
  • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
  • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
  • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
  • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
  • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
  • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
  • %Running% : 1 si le service est en marche au moment de la notification (0 s'il est en panne)
  • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
  • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
  • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'un email (SMTP)
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Lancer un exécutable

Cette méthode de notification peut être utilisée pour lancer un programme qui a une interface en ligne de commande.

Pour éditer une notification 'Lancer un exécutable'

1. Depuis la liste des notifications, sélectionnez Lancer un exécutable et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Programme : indique le chemin complet d'accès à l'exécutable. Notez que vous ne pouvez pas pointer sur un disque mappé (ordinateur à distance). Si l'exécutable est sur une autre machine, vous devez utiliser le chemin UNC.
  • Paramètres : vous pouvez transmettre les paramètres suivants à votre exécutable :
    • %MessageFile% sera remplacé par le nom d'un fichier qui contient le message d'erreur.
    • %Message% sera remplacé par le message d'erreur exact. Les retours chariot sont remplacés par des espaces.
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle le service a commencé à être surveillé
    • %UpTime% : la durée pendant laquelle le service a été en marche
    • %DownTime% : la durée pendant laquelle le service a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) du service
    • %LastKnownRunningState% : la date à laquelle le service a été détecté en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur le service
    • %FailureCountSinceRestart% : le nombre de panne détectées sur le service depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si le service est en marche au moment de la notification (0 s'il est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)
  • Répertoire : répertoire du processus.
  • Attendre l'arrêt du processus pendant xxx secondes : ServiceKeeper tuera le processus s'il ne se termine pas dans la période de temps spécifiée. Si vous ne voulez pas attendre la fin du processus, entrez 0 comme valeur.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle le service a commencé à être surveillé
    • %UpTime% : la durée pendant laquelle le service a été en marche
    • %DownTime% : la durée pendant laquelle le service a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) du service
    • %LastKnownRunningState% : la date à laquelle le service a été détecté en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur le service
    • %FailureCountSinceRestart% : le nombre de panne détectées sur le service depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si le service est en marche au moment de la notification (0 s'il est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Envoi d'un trap SNMP

SNMP (Simple Network Management Protocol) est un protocole réseau qui permet de fournir des informations sur l'état d'un hôte dans un réseau TCP/IP. Un trap est un message envoyé au système de gestion par un agent exécuté sur un hôte lorsqu'un événement s'est produit. ServiceKeeper est un agent SNMP qui reporte les défaillances de vos ressources surveillées à votre système de gestion SNMP.

Les traps de ServiceKeeper contiennent le message d'erreur reporté au journal d'événements. L'identifiant SMI Network Management Private Enterprise d'Active+ Software est 6792. Le TRAP a 1 paramètre de type OCTETSTRING. L'OID de ce paramètre est .1.3.6.1.4.1.6792.1.1.0.

Pour éditer une notification 'Envoi d'un trap SNMP'

1. Depuis la liste des notifications sélectionnez Envoi d'un trap SNMP et cochez la case pour activer la notification. Il n'y a pas de configuration pour cette méthode.

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Exécuter un script

Avec cette fonctionnalité, vous pouvez écrire un script (VBScript) pour envoyer les notifications d'erreurs.

Pour éditer une notification 'Exécuter un script'

1. Depuis la liste des notifications, sélectionnez Exécuter un script et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle le service a commencé à être surveillé
    • %UpTime% : la durée pendant laquelle le service a été en marche
    • %DownTime% : la durée pendant laquelle le service a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) du service
    • %LastKnownRunningState% : la date à laquelle le service a été détecté en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur le service
    • %FailureCountSinceRestart% : le nombre de panne détectées sur le service depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si le service est en marche au moment de la notification (0 s'il est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

L'objet suivant est accessible au script:

  • Info.Message : chaîne qui contient le message d'erreur, et qui peut inclure CR LF.
    Si la notification échoue, la fonction doit retourner False et Info.Error peut être défini avec un texte décrivant l'erreur.
  • Cliquez sur Editer pour lancer l'application associée à l'édition de fichiers .vbs. Vous pouvez associer l'extension .vbs à votre éditeur de source favori.

Directives de Pré-compilation :

Les directives de pré-compilation suivantes peuvent être inclues dans le code source au sein de commentaires.
  • '$$typelib:[file_name] pour accéder à des constantes définies dans une Type Library.
    Exemple : des constantes ADO peuvent être utilisées si ce qui suit est inséré au début du script :
    '$$typelib: c:\program files\common files\system\ado\msado15.dll
    ou
    '$$typelib: c:\program files\common files\system\ado\msado25.tlb
  • '$$object: (ProgID|CLSID) : name pour ajouter un objet nommé dans le contexte du script :
    Exemple : Si MyRecorset est défini, il peut être utilisé ainsi :
    '$$object:ADODB.Recordset:MyRecordset
  • '$$include:[file_name] pour inclure du code externe. La ligne de texte est remplacée par le contenu du [file_name]
Plus d'information sur le scripting : vous trouverez des ressources expliquant WMI, ADSI, et Windows Scripting sur les sites Microsoft pour les développeurs : Windows Script Technologies et Active Directory Service Interfaces

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Ecrire dans un journal d'événements HTML

Cette méthode de notification permet à un administrateur de consulter le journal d'événements de ServiceKeeper à partir de n'importe quel navigateur web.

Pour éditer une notification 'Ecrire dans un journal d'événements HTML'

1. Depuis la liste des notifications sélectionnez Ecrire dans un journal d'événements HTML et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Fichier HTML : chemin d'accès au fichier HTML qui contient le journal. Pour pouvoir consulter le journal depuis l'extérieur, le fichier doit être placé dans un répertoire accessible depuis un site web. On peut utiliser un chemin UNC pour stocker le fichier sur un serveur distant. Si le fichier n'existe pas, il sera créé automatiquement; s'il existe, les événements seront ajoutés à la fin du fichier.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle le service a commencé à être surveillé
    • %UpTime% : la durée pendant laquelle le service a été en marche
    • %DownTime% : la durée pendant laquelle le service a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) du service
    • %LastKnownRunningState% : la date à laquelle le service a été détecté en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur le service
    • %FailureCountSinceRestart% : le nombre de panne détectées sur le service depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si le service est en marche au moment de la notification (0 s'il est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Notification vocale (expérimentation)

Cette méthode permet à un administrateur d'être notifié par Microsoft Agent ou par un appel téléphonique lorsqu'une panne a été détectée.

Pour éditer une notification 'Notification vocale'

1. Depuis la liste des notifications sélectionnez Notification vocale (Expérimentation) et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Utiliser Microsoft Agent: cette option vous permet d'être notifié par Microsoft Agent. Sélectionnez le personnage de l'agent et cliquez sur le bouton Propriétés [image] pour modifier les paramètres de l'agent.

    - Propriétés de l'agent :

    • Voix : sélectionnez la voix que vous souhaitez donner à l'agent. Vous pouvez visiter le site de Microsoft Agent pour télécharger de nouvelles voix.
    • Intervalle de temps entre deux notifications : entrez la valeur en minutes séparant deux notifications. Les messages sont empilés et délivrés toutes les x minutes.
    • Planification des notifications : grâce à la planification, vous avez la possibilité de définir des plages horaires durant lesquelles vous ne souhaitez pas être notifié (par exemple la nuit, aux heures des repas). Coloriez en rouge les plages horaires durant lesquelles vous ne souhaitez pas être notifié par Microsoft Agent.
  • Téléphoner : choisissez cette option si vous désirez être appelé au téléphone lorsqu'une panne intervient sur l'un de vos serveurs. Sélectionnez le destinataire de l'appel téléphonique et cliquez sur le bouton Propriétés [image] pour modifier les paramètres du destinataire. Vous pouvez créer un nouveau destinataire en sélectionnant 'Ajouter un destinataire ...'.

    - Propriétés du destinataire d'un appel téléphonique :

    • Nom : le nom du destinataire.
    • Description : la description du destinataire.
    • Voix : sélectionnez la voix que vous souhaitez donner à ServiceKeeper lors de la notification. Notez qu'il n'est pas possible de lister les voix disponibles sur une machine distante. Ainsi, si vous tentez de configurer ServiceKeeper à partir d'un autre ordinateur, vous devrez saisir la voix que vous désirez utiliser.
    • Modem : sélectionnez le modem que ServiceKeeper utilisera pour appeler le destinataire de la notification. Notez qu'il n'est pas possible de lister les modem installés sur une machine distante. Ainsi, si vous tentez de configurer ServiceKeeper à partir d'un autre ordinateur, vous devrez saisir le modem que vous désirez utiliser.
    • N° de tel : le numéro de téléphone du destinataire de la notification.
    • Intervalle de temps minimum entre deux appels : entrez la valeur en minutes séparant deux notifications. Les messages seront empilés et délivrés toutes les x minutes.
    • Planification des appels : grâce à la planification, vous avez la possibilité de définir des plages horaires durant lesquelles vous ne souhaitez pas être notifié (par exemple la nuit, aux heures des repas). Coloriez en rouge les plages horaires durant lesquelles vous ne souhaitez pas receovoir d'appels téléphoniques de la part de ServiceKeeper.

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Paramétrer les notifications


Ecrire dans un fil RSS

Cette méthode de notification permet à un administrateur d'être notifier au travers de son lecteur de fils RSS des évènements qui sont intervenus sur son système surveillé par ServiceKeeper.

Pour éditer une notification 'Ecrire dans un fil RSS'

1. Depuis la liste des notifications sélectionnez Ecrire dans un fil RSS et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Fichier du fil RSS : chemin d'accès au fichier RSS (XML) qui contient le fil. Pour pouvoir consulter le journal depuis l'extérieur, le fichier doit être placé dans un répertoire accessible depuis un site web. On peut utiliser un chemin UNC pour stocker le fichier sur un serveur distant. Si le fichier n'existe pas, il sera créé automatiquement; s'il existe, les événements seront ajoutés à la fin du fichier.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle le service a commencé à être surveillé
    • %UpTime% : la durée pendant laquelle le service a été en marche
    • %DownTime% : la durée pendant laquelle le service a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) du service
    • %LastKnownRunningState% : la date à laquelle le service a été détecté en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur le service
    • %FailureCountSinceRestart% : le nombre de panne détectées sur le service depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si le service est en marche au moment de la notification (0 s'il est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Notification vocale (Expérimentation)
Paramétrer les notifications


Paramètres avancés

Les paramètres avancés vous donnent accès à un paramétrage fin des surveillances.

Pour modifier les paramètres avancés

1. Sélectionnez une vue de l'arborescence de la Console Service+ puis sélectionnez un service.

2. Cliquez avec le bouton droit de la souris sur le service à surveiller et sélectionnez Propriétés ou double-cliquez sur le service.

3. Cliquez sur l'onglet Surveiller et le choix Avancé.

  • Délai entre chaque tentative de réparation : après une action de réparation, ServiceKeeper attendra le temps spécifié avant de poursuivre avec la prochaine action.
  • RAZ du compteur de panne au bout de : après que le service est fonctionné correctement pendant le temps spécifié, le compteur de détections de défaillance est remis à zéro. Le compteur de détection de défaillance est utilisé pour déterminer quelles actions de réparation doivent être exécutées à un moment donné. Si la défaillance n'est pas corrigée, elle est détectée continuellement de façon récursive. Le compteur de défaillance est incrémenté. De ce fait sa valeur augmente et peut déterminer l'exécution de nouvelles actions.
  • Délai d'attente maximum... : si un service reste en instance plus longtemps que le nombre de minutes ou secondes indiqué, le service sera arrêté (processus tué). Un service est en instance au moment du démarrage, de l'arrêt ou de la mise en pause. La défaillance en instance la plus courante est celle où le service est arrêté et reste toujours en instance d'arrêt.

Voir aussi

Réparer les services défaillants


Surveiller des ressources

ServiceKeeper propose un jeu complet d'outils pour surveiller et contrôler des ressources autres que les services Windows sur votre réseau. Les socket TCP/IP, le comportement de protocole, des compteurs de performance, des codes d'erreurs remontés par des exécutables ou des scripts peuvent être surveillés par ServiceKeeper indépendamment de la surveillance des services. Active+ Software ajoutera régulièrement de nouveaux types de ressources pouvant être surveillées par ServiceKeeper.

Une surveillance efficace est celle qui est capable d'assurer automatiquement les fonctions suivantes sans que la ressource soit interrompue :

  • Détecter les défaillances ou les anomalies qui peuvent affecter les ressources.
  • Corriger le problème ou prendre des mesures pour le contourner quand la réparation est impossible.
  • Informer des incidents, des défaillances et des mesures prises pour corriger ces problèmes.

Sous Windows, il existe des moyens très simple qui vous permettent de déterminer et d'analyser les performances des processus qui s'exécutent sur l'ordinateur. Par exemple, lorsque une application ne ferme pas correctement ses handles ou génère des fuites mémoire, vous pouvez déterminer le taux d'utilisation des ressources système dans l'analyseur de performances par l'intermédiaire des compteurs, ou bien détecter, en utilisant le journal d'événements, des messages d'avertissement caractéristiques d'une situation instable récurrente. Toutes ces informations peuvent être utilisées par ServiceKeeper pour entreprendre, de la manière la plus précise possible, des actions préventives.

Les ressources à surveiller sont matérialisées par des objets appelés "ressource surveillée". Voyez Créer un objet ressource surveillée pour plus d'information concernant la création de ces objets.

Voir aussi

Créer un objet ressource surveillée
Détecter les défaillances de ressources
Réparer les ressources défaillantes
Configurer les notifications
Configuration avancée
Planifier la surveillance des ressources
Présentation de ServiceKeeper


Créer un objet Ressource Surveillée

Un objet Ressource Surveillée représente une ressource que vous souhaitez surveiller. Il contient tous le paramétrage concernant la surveillance de cette ressource. Les ressources surveillées sont visualisées dans les vues que l'on trouve sous le noeud Ressources Surveillées de la console Service+. Voyez Les vues personnalisées pour plus d'information sur les vues personnalisées.

Pour créer un objet Ressource Surveillée, cliquez avec le bouton droit de la souris sur une vue de ressources surveillées et sélectionnez Nouveau/Ressource Surveillée, ou sélectionnez le menu Action/Nouveau/Ressource Surveillée.

Il existe trois méthodes différentes pour installer un service dans Service+ :

1. Créer une nouvelle ressource surveillée :

L'assistant continue en vous proposant de créer la première règle de détection de panne pour votre ressource. Pour plus d'information, voyez détecter les défaillances des ressources et ajouter une règle de détection de défaillance.

Une fois l'objet créé, vous pouvez éditer ses propriétés et ajouter de nouvelles règles de détection, de nouvelles actions de réparation et configurer les notifications.

2. Importer une ressource surveillée à partir du presse-papier vous permet de créer une ressource surveillée à partir d'une configuration de ressource surveillée en XML préalablement placée dans le presse-papier. Pour exporter une ressource surveillée dans le presse-papiers, cliquez avec le bouton droit de la souris sur la ressource surveillée et sélectionnez Exporter la ressource surveillée/dans le presse-papiers dans le menu.

3. Importer une ressource surveillée à partir d'un fichier de configuration XML vous permet de créer une ressource surveillée à partir d'un fichier de configuration XML. Pour exporter une ressource surveillée dans un fichier de configuration XML, cliquez avec le bouton droit de la souris sur la ressource surveillée et sélectionnez Exporter la ressource surveillée/dans un fichier de configuration XML dans le menu.

Voir aussi

Détecter les défaillances des ressources
Ajouter une règle de détection
Les ressources surveillées


Statistiques de ServiceKeeper

Les pages de statistiques de ServiceKeeper sont disponibles à partir des propriétés de ServiceKeeper, des services et des resources surveillées. Ces statistiques proposent un récapitulatif des pannes détectées et des actions de réparation entreprises. Vous pouvez ainsi déterminer la disponibilité globale de votre système ainsi que la disponibilité de chacune de vos resources (ou services) surveillés.

Voir aussi
Créer un objet ressource surveillée
Détecter les défaillances de ressources
Réparer les ressources défaillantes
Configurer les notifications
Configuration avancée
Planifier la surveillance des ressources
Présentation de ServiceKeeper


Planifier la surveillance des ressources

Vous pouvez planifier la surveillance des ressources. Par exemple, vous pourriez ne pas souhaiter que certaines ressources soient surveillées à des moments particuliers comme lorsque des processus sont arrêtés pendant l'exécution de certaines sauvegardes.

Pour éditer les paramètres de planification de la surveillance de ressources

1. Démarrez la console Service+ et sélectionnez la ressource dont vous souhaitez modifier la planification de surveillance. Cliquez sur le bouton Propriétés pour afficher la fenêtre des propriétés de la planification de la surveillance de la ressource.

2. Sélectionnez l'onglet Plage horaire

3. Par défaut, les ressources sont surveillées continuellement à intervalles réguliers. Vous pouvez modifier ce comportement en définissant des plages horaires pendant lesquelles la surveillance est active et des plages horaires pendant lesquelles la surveillance n'est pas active. Sélectionnez une zone voulue après avoir choisi d'activer ou non la surveillance à l'aide des boutons.

Vert:
La ressource est surveillée.
Blanc:
La ressource n'est pas surveillée.

Voir aussi
Présentation de ServiceKeeper
La surveillance des ressources


Détecter les pannes de ressources

ServiceKeeper propose plusieurs méthodes pour détecter les pannes des ressources surveillées, méthodes que vous pouvez combiner en fonction des comportements spécifiques de ces ressources. Le meilleur moyen pour trouver le bon mix consiste à essayer différentes configurations et à les tester dans le temps. L'analyseur de Performances et le Journal d'événements devraient également pouvoir vous donner des informations sur l'usage des ressources système et les événements associés aux ressource que vous désirez surveiller.

Vous pouvez visualiser les listes des ressources surveillées dans les vues situées sous le noeud Ressources Surveillées de la console Service+

Pour éditer la configuration des détections de pannes

1. Sélectionnez une vue sous le noeud Ressources Surveillées de l'arborescence de la console Service+ (Voir Les vues personnalisées pour plus d'information sur les vues personnalisées).

2. Double-cliquez sur la ressource surveillée que vous souhaitez éditer ou sélectionnez la et cliquez sur le bouton Propriétés [image] de la barre d'outils.

3. Vous pouvez changer la description correspondant à votre ressource.

4. Cliquez sur l'onglet Surveiller et le choix Détecter pour accéder à la liste des règles de détections existantes.

Vous pouvez ajouter, modifier, supprimer or réordonner les règles de détection.

Chaque règle de détection peut être activée ou désactivée individuellement à l'aide de la case à cocher qui l'accompagne.

Voir aussi
Ajouter une règle de détection de panne
Modifier une règle de détection de panne
Réordonner les règles de détection de panne
Supprimer une règle de détection de panne
Les ressources surveillées


Ajouter une règle de détection

Pour ajouter une règle de détection

1. Cliquez sur l'onglet Surveiller et le choix Détecter dans la fenêtre des propriétés d'une ressource surveillée pour accéder aux règles de détection existantes.

2. Cliquez sur le bouton [image] pour lancer l'assistant de création de règle de détection de panne.

3. Sélectionnez le type de détection que vous souhaitez ajouter et cliquez sur Suivant.

4. Entrez une nouvelle description (facultatif) et cliquez sur Suivant.

5. Régler les différents paramètres de la règle de détection de panne.

Chaque type de détection possède ses propres paramètres spécifiques. Consultez les pages listées ci-dessous pour plus de précision sur chacun des types de détection.

Types de détection

Surveiller un site web Surveiller un site FTP Surveiller un serveur SMTP Surveiller un serveur POP3 Surveiller un serveur NNTP Surveiller des composants réseaux Surveiller les services TCP/IP Surveiller les journaux d'évènements Surveiller les compteurs de performance Surveiller l'utilisation mémoire d'un processus Surveiller l'utilisation CPU d'un processus Utiliser les valeurs de retour des fonctions script Utiliser le code de retour d'un programme Surveiller le système de fichiers

Voir aussi
Détecter les défaillances des ressources surveillées


Modifier une règle de détection

Pour modifier une règle de détection

1. Cliquez sur l'onglet Surveiller et le choix Détecter dans la fenêtre des propriétés d'une ressource surveillée pour accéder aux règles de détection de panne existantes.

2. Sélectionnez la règle que vous souhaitez modifier

3. Cliquez sur le bouton Propriétés [image] ou double-cliquez sur la règle.

4. L'onglet Général vous permet d'éditer les paramètres de la règle choisie.

  • Opérateur
    Vous devez d'abord choisir un opérateur logique qui va déterminer la manière dont cette règle sera associée logiquement avec les autres règles de la liste des règles de détection.
OU | Quand des règles sont combinées logiquement à l'aide de l'opérateur OU, il suffit que l'une d'elles détecte une défaillance pour qu'une détection de panne soit rapportée.
ET | Quand elles sont combinées logiquement à l'aide de l'opérateur ET, les règles doivent toutes détecter une défaillance pour qu'une détection de panne soit rapportée.
OU Exclusif | Quand des règles sont combinées logiquement à l'aide de l'opérateur OU exclusif, il faut que l'une d'elles et seulement l'une d'elle détecte une défaillance pour qu'une détection de panne soit rapportée.

L'ordre de priorité des opérateurs est tel que les ET sont évalués avant les OU qui sont évalués avant les opérateurs OU Exclusifs. En d'autres termes, A OU B OU C ET D OU E ET F ET G est évalué A OU B OU (C ET D) OU ((E ET F) ET G).

Chaque type de détection possède ses propres paramètres spécifiques. Consultez les pages listées ci-dessous pour plus de précision sur chacun des types de détection.

Types de détection

Surveiller un site web Surveiller un site FTP Surveiller un serveur SMTP Surveiller un serveur POP3 Surveiller un serveur NNTP Surveiller des composants réseaux Surveiller les services TCP/IP Surveiller les journaux d'évènements Surveiller les compteurs de performance Surveiller l'utilisation mémoire d'un processus Surveiller l'utilisation CPU d'un processus Utiliser les valeurs de retour des fonctions script Utiliser le code de retour d'un programme Surveiller le système de fichiers

5. Sélectionnez l'onglet Fréquence de détection pour modifier les paramètres définissant la fréquence des détections.

Voir aussi
Détecter les défaillances des ressources surveillées
Fréquence de détection


Réordonner les règles de détection

L'ordre d'exécution d'une règle de détection de panne est déterminé par sa position dans la liste des règles d'une ressource surveillée. En ordonnant cette liste d'une manière différente, vous changez l'ordre d'exécution des règles.

Pour réordonner les règles de détection

1. Sélectionnez l'onglet Surveillance et le choix Détecter pour accéder à la liste des détections existantes.

2. Sélectionnez une règle dont vous souhaitez changer la position dans la liste et cliquer sur les boutons Haut [image] ou Bas [image] pour repositionner la règle à la position souhaitée.

Voir aussi

Détecter les défaillances de services


Set the Detection Polling Frequency

Spécifier la fréquence de détection

L'onglet fréquence de détection vous permet de définir la fréquence à laquelle ServiceKeeper effectue ses détections. Il vous permet également de définir si une défaillance est rapportée comme telle dès qu'elle est détectée ou si elle doit être détectée successivement à plusieurs reprises pendant une période de temps donnée pour être rapportée.

Pour spécifier la fréquence de détection

1. Sélectionnez l'onglet Surveillance et le choix Détecter pour accéder à la liste des détections existantes.

2. Sélectionnez la règle que vous souhaitez modifier.

3. Cliquez sur le bouton Propriétés [image] ou double-cliquez sur la règle choisie.

4. Sélectionnez l'onglet Fréquence de détection.

  • Lancer une détection toute les ... : vous utilisez ce paramètre pour définir la fréquence à laquelle ServiceKeeper évalue la condition définie dans l'onglet Général de la règle.
  • Détection des pannes dans le temps : vous utilisez cette option pour indiquer à ServiceKeeper qu'il doit évaluer les conditions un certain nombre de fois et qu'il doit indiquer une défaillance que si un certain pourcentage d'erreurs est atteint.
  • Nombre de tests : il s'agit du nombre d'évaluation que ServiceKeeper doit faire avant de pouvoir rapporter une défaillance.
  • Signaler un erreur lorsque le taux de panne atteint 100 % : vous spécifiez dans ce champ le taux d'erreurs qui doit être atteint pour qu'une défaillance soit rapportée.
Exemple : Dans l'exemple ci-dessus, ServiceKeeper tente de se connecter au site Web CRM toutes les 10 secondes. Si, au cours de 3 tentatives consécutives, une seule se déroule correctement, ServiceKeeper rapportera une défaillance car le taux de panne aura été dépassé (2 tentatives échouées représente 66% de taux de panne).

Voir aussi

Détecter les défaillances des ressources surveillées
Modifier une règle de détection


Supprimer une règle de détection

Pour supprimer une règle de détection

1. Sélectionnez l'onglet Surveillance et le choix Détecter pour accéder à la liste des détections existantes.

2. Sélectionnez la règle que vous souhaitez supprimer et cliquez sur le bouton Supprimer [image] ou appuyez sur la touche Suppr de votre clavier.

Voir aussi

Détecter les défaillances de services


Surveiller un site web

Cette méthode permet de contrôler la disponibilité d'un site web en initiant une connexion HTTP avec ce dernier. Vous pouvez choisir un site web IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre site web.

Propriétés de la règle 'Surveiller un site web'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (w3svc) lorsque le site web ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : Lorsque cette option est cochée, ServiceKeeper détectera également les erreurs relative au protocole HTTP (erreurs 4xx ou 5xx)
L'onglet Recherche textuelle vous permet de rechercher un texte dans la page web retournée par la requête HTTP et ainsi contrôler la validité de la page web retournée.

Note : vous pouvez demander à ServiceKeeper d'ouvrir une page en particulier sur votre site web. Vous pouvez, par exemple entrer l'addresse http://www.activeplus.com/fr/products/ServiceKeeper/default.asp

Voir aussi

Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller un site FTP

Cette méthode permet de contrôler la disponibilité d'un site FTP en initiant une connexion avec ce dernier. Vous pouvez choisir un site FTP IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre site FTP.

Propriétés de la règle 'Surveiller un site FTP'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (MSFTPSVC) lorsque le site FTP ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur FTP et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller un site web
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller un serveur SMTP

Cette méthode permet de contrôler la disponibilité d'un serveur SMTP en initiant une connexion avec ce dernier. Vous pouvez choisir un serveur SMTP IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre serveur SMTP.

Propriétés de la règle 'Surveiller un serveur SMTP'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (SMTPSVC) lorsque le serveur SMTP ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur SMTP et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller un serveur POP3

Cette méthode permet de contrôler la disponibilité d'un serveur POP3 en initiant une connexion avec ce dernier. Vous pouvez choisir un serveur POP3 IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre serveur POP3.

Propriétés de la règle 'Surveiller un serveur POP3'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (POP3SVC) lorsque le serveur POP3 ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur POP3 et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller un serveur NNTP

Cette méthode permet de contrôler la disponibilité d'un serveur NNTP en initiant une connexion avec ce dernier. Vous pouvez choisir un serveur NNTP IIS installé sur un serveur de votre réseau local ou entrer directement l'adresse de votre serveur NNTP.

Propriétés de la règle 'Surveiller un serveur NNTP'

  • Surveiller le service Windows associé (Mode assistant uniquement) : configure automatiquement une action de réparation qui redémarre le service IIS correspondant (NNTPSVC) lorsque le serveur NNTP ne répond plus.
  • Détecter les erreurs relatives au protocole (Mode propriétés uniquement) : si cette option est cochée, ServiceKeeper analisera la réponse du serveur NNTP et détectera une erreur lorsque le code retourné n'est pas un code de succès.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller les composants réseaux (PING)

Cette méthode permet de contrôler la disponibilité de composants réseaux (ordinateur, routeurs, pares-feu, etc...) par l'envoi d'une requête PING.
Pour cela, vous devez entrer l'adresse IP ou le nom du composant réseau que vous souhaitez contrôler ainsi que le délai maximum de réponse (correspond à l'option -w de la commande PING). Vous pouvez également entrer la taille des paquets qui seront envoyés par la requête (correspond à l'option -l de la commande PING).

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller les ports TCP/IP

Cette méthode contrôle les connexions TCP/IP (WinSock) aux serveurs, à différents intervalles de temps définis dans fréquence de détection. ServiceKeeper vérifie qu'une session TCP est correctement ouverte sur le "socket" défini.

Propriétés de la règle 'Surveiller les services TCP/IP'

  • Hôte(s) : entrer le nom ou l'adresse IP du serveur hébergeant le service TCP que vous voulez surveiller (le nom de l'ordinateur surveillé sera mis par défaut). Vous pouvez spécifier plusieurs hôtes en utilisant des virgules comme séparateurs. Exemple : www.site1.com,www.site2.com,123.123.123.123
    Note : vous pouvez spécifier un port TCP particulier en même temps que le nom d'hôte ou l'adresse IP. Exemple: server.site1.com:8080
  • Port : Vous pouvez spécifier n'importe quel port que vous voulez contrôler.
  • Délai : spécifie le délai maximum en millisecondes que doit mettre le serveur à répondre.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les journaux d'évènements
Surveiller les compteurs de performances
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser le code retour de scripts
Utiliser le code retour de programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller le journal d'événements

Utilisez cette méthode pour surveiller le journal d'événements et filtrer les événements spécifiques qui déclencheront une tentative de réparation. Les événements sont enregistrés dans des registres séparés : Application, Security et System logs (Windows XP), auxquels on peut ajouter les registres Directory et File Replication service logs si l'ordinateur est un contrôleur de domaine, et un DNS server log si l'ordinateur est également un serveur DNS.

On peut consulter le Journal d'événements dans l' "Event Viewer". Les 3 types d'événements principaux sont les suivants : Erreur, Avertissement, Informations.

Propriétés de la règle 'Surveiller le journal d'évènements'

  • Journal : Services, applications et pilote reportant des messages dans chacun des journaux.
  • Source : habituellement identique au nom du service. Vous pouvez visualiser le nom de la source d'un service en vous reportant aux différents journaux d'événements de l'Event Viewer (champ Source), et le comparer à la liste fournie par ServiceKeeper.
  • Détecter une panne quand le journal contient :
    • au moins une erreur : le journal sera surveillé pour détecter les erreurs éventuelles. Les événements erreurs sont importants, ce peut être des pertes de données ou de fonctionnalités. Par exemple si un service n'est pas lancé au démarrage, une erreur sera enregistrée.
    • au moins un avertissement : le journal sera surveillé pour détecter les avertissements éventuels. Les avertissements ne sont pas nécessairement importants, mais ils peuvent indiquer un problème futur possible. Par exemple, quand il reste peu d'espace disque, un avertissement sera enregistré.
    • Parmi les événements suivants : vous pouvez faire surveiller le journal pour n'importe quel événement en fournissant son ID (identifiant) qui peut être consulté dans l'Event Viewer (champ Événement). Ceci est pratique lorsque l'on veut détecter un ou plusieurs événements de type erreur, avertissement ou information, pour un service contrôlé.

Voir aussi
Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller les compteurs de performances

Windows propose des compteurs de performance qui permettent de visualiser les données représentant les aspects spécifiques du système. Ces compteurs peuvent être utilisés pour détecter précisément toutes sortes d'erreurs intervenant sur les composants du système ainsi que des situations d'exécution critiques.

On peut consulter les compteurs de performance et les analyser depuis Démarrer/Paramètres/Panneau de configuration/Outils d'Administration/Analyseur de Performance

Propriétés de la règle 'Surveiller des compteurs de performance

Dans l'exemple ci-dessus, le processus de service du spooler sera détecté comme défaillant si plus de 500 handles sont alloués.
  • Sélectionnez un compteur en utilisant le bouton [...] à droite du champ.
  • Indiquez la condition de défaillance (Egal, Plus grand, Différent....etc.).

Sélection d'un compteur

Les compteurs les plus communément utilisés sont listés dans le tableau ci-dessous. Pour une description complète des données fournies par un compteur particulier associé à objet de performance, cliquer sur Expliquer dans la boîte de dialogue Parcourir les compteurs :

  • Sélectionner l'ordinateur sur lequel sont lancés les services que vous voulez surveiller. Pour cela il faut que vous ayez les droits appropriés et la licence ServiceKeeper adéquate. Indiquer le Niveau de détail pour déterminer la définition des compteurs disponibles.
  • Sélectionnez l'Objet de performance. Voir le tableau ci-dessous.
  • Sélectionnez le compteur disponible pour l'objet surveillé. Certains compteurs nécessitent que l'on spécifie les Instances. Voir le tableau ci-dessous.
Objet de Performance | Compteur | Valeurs
Mémoire
Pages/s | Les pages/s sont le nombre de pages lues à partir du disque ou écrites sur le disque afin de résoudre des défauts de page matériels. (Les défauts de page matériels se produisent lorsqu'un processus nécessite du code ou des données qui ne sont ni dans son jeu de pages de travail ni dans la mémoire physique et doivent être récupérés sur le disque.) Ce compteur a été créé pour indiquer le type de fautes qui causent des délais au niveau du système. C'est la somme des pages entrées/s et des pages sorties/s de l'objet Mémoire. Cette somme est le nombre de pages, pour pouvoir être comparée à d'autres comptes de pages, tels que Défauts de page/s sans conversion. Ce compteur inclut le trafic des pages pour le compte du cache système afin d'accéder aux données des fichiers pour les applications. Cette valeur inclut aussi les pages de et vers des fichiers de mémoire mappée non-cachés. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Pages en entrée/sec | Pages en entrée/s est le nombre de pages lues sur le disque pour résoudre des défauts de page matériels. (Les défauts de page matériels se produisent lorsqu'un processus nécessite du code ou des données qui ne sont ni dans son jeu de pages de travail ni dans la mémoire physique et doivent être récupérés sur le disque.) Ce compteur a été créé pour indiquer le type de fautes qui causent des délais au niveau du système. Il inclut les pages récupérées pour satisfaire les défauts dans le cache du système de fichiers (habituellement demandés par les applications) et dans les fichiers de mémoire mappée non-cachés. Ce compteur dénombre les pages et peut être comparé sans conversion à d'autres décomptes de pages, tels que Défauts de page/s de l'objet Mémoire. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Défauts de page/s | Les défauts de page/s sont le taux global de défauts de page traités par le processeur. Il est mesuré en nombre de défauts de page par seconde. Un défaut de page intervient lorsqu'un processus nécessite du code ou des données qui ne se trouve pas dans son jeu de pages de travail en mémoire centrale (espace de la mémoire physique). Ce compteur inclut les défauts matériels (nécessitant un accès au disque) et les défauts logiciels (si le défaut de page est trouvé ailleurs qu'en mémoire physique.) La plupart des processeurs peuvent traiter de grands nombres de défauts logiciels sans conséquence. Cependant, un défaut matériel peut causer des délais significatifs. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Objets
Processus | Le processus est le nombre de processus dans l'ordinateur au moment du sondage. Notez que ceci constitue un décompte instantané et non pas une moyenne sur un intervalle de temps. Chaque processus représente l'exécution d'un programme.
Threads | Les threads sont le nombre de threads dans l'ordinateur au moment du sondage. Notez que ceci constitue un décompte instantané et non pas une moyenne sur un intervalle de temps. Une thread est l'entité exécutable de base pouvant exécuter des instructions sur un processeur.
Disque physique
Lectures disque/s | Les lectures disque/s sont le taux d'opérations de lecture sur le disque.
Ecritures disque/s | Les écritures disque/s sont le taux d'opérations d'écriture sur le disque.
Processus
% Temps processeur | Le % Temps processeur est le pourcentage du temps écoulé passé par le processeur à exécuter les instructions de toutes les threads de ce processus. Une instruction est l'unité d'exécution de base d'un ordinateur, une thread est l'objet qui exécute les instructions, et un processus est l'objet créé lorsqu'un programme s'exécute. Le code exécuté pour gérer des interruptions dues au matériel et gérer des conditions de déroutement est inclus dans ce compte. Sur les ordinateurs multi-processeurs, la valeur maximale de ce compteur est 100 % fois le nombre de processeurs.
ID du processus créateur | La valeur ID du processus créateur est l'ID du processus qui a créé le processus. Remarquez que ce processus créateur peut s'être terminé depuis la création du nouveau processus et donc, cette valeur peut identifier un processus qui n'est plus en cours d'exécution.
N° du processus | Le Nº du processus est l'identificateur unique de ce processus. Notez que les numéros de processus sont réutilisés de façon à ce qu'ils n'identifient qu'un seul processus pendant la durée de vie de celui-ci.
Défaut de page/s | Les défauts de page/s sont le taux de défauts de page générés par les threads s'exécutant dans ce processus. Un défaut de page intervient lorsqu'un processus fait référence à une page de mémoire virtuelle qui ne se trouve pas dans son jeu de pages de travail en mémoire centrale. Un défaut de page ne causera pas sa recherche sur disque si cette page est dans la liste En attente, et donc déjà en mémoire centrale, ou si elle est utilisée par un autre processus avec lequel la page est partagée.
Jeu de travail | Le jeu de travail est le nombre actuel d'octets qu'il y a dans le jeu de travail de ce processus. Le jeu de pages de travail est le jeu de pages mémoire touchées récemment par les threads de ce processus. Si la mémoire disponible de l'ordinateur est au-dessus d'un seuil, les pages sont laissées dans le jeu de pages de travail d'un processus même si elles ne sont pas utilisées. Lorsque la mémoire disponible tombe en dessous d'un seuil, les pages sont retirées du jeu de travail. Si elles s'avèrent nécessaires, elles seront ramenées après un défaut de page logiciel dans le jeu de travail avant qu'elles ne quittent la mémoire centrale.
Processeur
% Temps processeur | Le % Temps processeur est le pourcentage de temps pendant lequel le processeur est occupé à exécuter des threads actives. Il est calculé en mesurant le temps passé à exécuter la thread du processus inactif dans un intervalle de temps et en soustrayant la valeur de 100%. (Chaque processeur a une thread inactive qui consomme des cycles lorsque aucune autre thread n'est prête à s'exécuter.) Il peut être considéré comme le pourcentage de temps sur l'intervalle échantillon passé à faire un travail utile. Ce compteur affiche le pourcentage moyen de temps.
Interruptions/s | Les interruptions/s sont le nombre d'interruptions matérielles reçues et traitées par le processeur à chaque seconde. Ce compteur n'inclut pas les DPC, qui sont dénombrés séparément. Il indique indirectement l'activité des périphériques qui génèrent des interruptions, tels que les horloges système, la souris, les pilotes de disques, les lignes de communication de données, les cartes d'interface réseau et d'autres périphériques. Ces périphériques interrompent normalement le processeur lorsqu'ils ont terminé une tâche ou lorsqu'ils ont besoin d'assistance. L'exécution normale des threads est suspendue pendant les interruptions. La plupart des horloges système interrompent le processeur toutes les 10 millisecondes, créant un fond d'activité d'interruption. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Serveur
Total des octets/s | Le total octets/s est le nombre d'octets envoyés et reçus sur le réseau. Cette valeur fournit une indication générale de l'activité du serveur.
Blocs de contexte en attente/s | Les blocs de contexte en attente/s sont le taux auquel les blocs de contextes de travail ont dû être mis dans la file FSP du serveur en attendant d'être traitées.
Erreurs d'autorisation d'accès | Les erreurs d'autorisation d'accès sont le nombre de fois que des ouvertures pour des clients ont échoué avec le statut STATUS_ACCESS_DENIED. Cela peut indiquer si quelqu'un tente d'accéder à des fichiers au hasard en espérant en trouver un qui n'était pas protégé correctement.
Fichiers ouverts | Les fichiers ouverts sont le nombre de fichiers actuellement ouverts sur le serveur. Cela indique l'activité courante du serveur.
Total des fichiers ouverts | Le total des fichiers ouverts est le nombre de tentatives réussies d'ouverture réalisées par le serveur pour ses clients. Cela est utile pour déterminer le nombre d'E/S fichier, le temps perdu pour des opérations basées sur des chemins et l'efficacité des verrous optionnels.
Total des ouvertures de sessions | Le total des ouvertures de session inclut toutes les sessions interactives, les sessions réseau, les sessions de service, les sessions qui ont réussi, et celles qui ont échoué depuis le dernier redémarrage de l'ordinateur.
Ouvertures de sessions/s | Ouvertures de sessions/s est le taux de toutes les ouvertures de sessions du serveur.
Sessions serveur | Les sessions serveur sont le nombre de sessions actuellement actives dans le serveur. Cela indique l'activité courante du serveur.
Système
Opérations de fichier/s | Les opérations de fichier/s sont le taux combiné des opérations de lecture et d'écriture sur tous les disques logiques de l'ordinateur. C'est l'inverse des Opérations de contrôle de fichier/s de l'objet Système. Ce compteur affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Opérations de lecture de fichier/s | Les opérations de lecture fichier/s sont la combinaison du taux de requêtes de lecture du système de fichiers à tous les périphériques de l'ordinateur, y compris les requêtes de lecture à partir du cache du système de fichiers. Ce compteur est mesuré en nombre de lectures. Il affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Opérations d'écriture de fichier/s | Les opérations d'écriture fichier/s sont la combinaison du taux de requêtes d'écriture du système de fichiers à tous les périphériques de l'ordinateur, y compris les requêtes d'écriture dans le cache du système de fichiers. Ce compteur est mesuré en nombre d'écritures. Il affiche la différence entre les valeurs observées dans les deux derniers intervalles de temps, divisée par la durée de l'intervalle échantillon.
Temps d'activité système | Le temps d'activité du système est le temps écoulé (en secondes) pendant lequel le système a été en marche depuis le dernier démarrage. Ce compteur affiche la différence entre l'heure de démarrage et l'heure actuelle.
Thread
% Temps processeur | Le % Temps processeur est le pourcentage du temps écoulé passé par le processeur à exécuter les instructions de cette thread. Une instruction est l'unité d'exécution de base d'un processus et une thread est l'objet qui exécute les instructions. Le code exécuté pour gérer des interruptions dues au matériel et gérer des conditions de déroutement est inclus dans ce compte.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller l'utilisation mémoire d'un processus

Grâce à cette méthode de détection, vous pourrez facilement traquer les éventuelles fuites mémoire de vos processus.
  • Sélectionnez l'ordinateur sur lequel s'exécute le processus que vous souhaitez contrôler.
  • Spécifiez le processus que vous souhaitez contrôler.
  • Indiquez la condition de défaillance (Egal, Plus grand, Différent....etc.).
  • Spécifiez si ServiceKeeper doit additioner la mémoire utilisée et la taille de la mémoire virtuelle allouée au processus du service (pagefile.sys).
Note : Vous ne pouvez contrôler que les processus s'exécutant sur un ordinateur surveillé par ServiceKeeper

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performances
Surveiller l'utilisation CPU d'un processus
Utiliser le code retour de scripts
Utiliser le code retour de programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller l'utilisation CPU d'un processus

Une utilisation abusive et prolongée de la CPU par un processus peut être synonyme de panne et entraine de forts ralentissements des autres applications lancées sur le serveur. Contrôlez, avec cette méthode, l'utilisation CPU de tous vos processus.
  • Sélectionnez l'ordinateur sur lequel s'exécute le processus que vous souhaitez contrôler.
  • Spécifiez le processus que vous souhaitez contrôler.
Note : Vous ne pouvez contrôler que les processus s'exécutant sur un ordinateur surveillé par ServiceKeeper

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performances
Surveiller l'utilisation mémoire d'un processus
Utiliser le code retour de scripts
Utiliser le code retour de programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Utiliser les valeurs de retour des fonctions script

Cette fonction vous permet d'écrire votre propre code VBScript pour détecter des pannes éventuelles. Vous pouvez par exemple écrire un script qui se connecte à une base de données avec ADO, et qui vérifie s'il y a plus de x enregistrements en attente de traitement. Vous pouvez également utiliser votre script avec des objets WMI qui vous permettent d'accéder aux éléments du système (journal d'événements, base de registre, composants, etc.)

Propriétés de la règle 'Utiliser les valeurs de retour des fonctions script'

Les paramètres suivants sont disponibles :
  • Info.Computer : chaîne de caractères correspondant au nom de l'ordinateur hébergeant la ressource.
  • Info.Name : chaîne de caractères correspondant au nom de la ressource, du service ou processus.
  • Info.DisplayName : chaîne de caractères correspondant au nom long de la ressource, du service ou du processus.
  • Info.FailCount: nombre entier indiquant combien de fois la ressource a été détectée comme défaillante.

La fonction doit retourner False si une panne a été détectée. Vous pouvez également stocker un message d'erreur dans la variable Info.Error

Directives de pré-compilation

Ces directives peuvent être inclues dans le texte au sein des commentaires.
  • '$$typelib:[file_name]pour accéder à des constantes définies dans une Type Library.
    Exemple : des constantes ADO peuvent être utilisées si ce qui suit est inséré au début du script :
    '$$typelib: c:\program files\common files\system\ado\msado15.dll
    or
    '$$typelib: c:\program files\common files\system\ado\msado25.tlb
  • '$$object: (ProgID|CLSID) : name pour ajouter un objet nommé dans le contexte du script :
    Exemple : Si MyRecorset est défini, il peut être utilisé ainsi :
    '$$object:ADODB.Recordset:MyRecordset
  • '$$include:[file_name] pour inclure du code externe. La ligne de texte est remplacée par le contenu du [file_name]
Plus d'information sur le scripting : vous trouverez des ressources expliquant WMI, ADSI, et Windows Scripting sur les sites Microsoft pour les développeurs : Windows Script Technologies et Active Directory Service Interfaces.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser le code de retour d'un programme
Surveiller le système de fichiers
Détecter les défaillances de ressources


Utiliser le code de retour d'un programme

La plupart des exécutables retournent un code permettant de déterminer si une erreur s'est produite. Cette fonctionnalité vous permet d'exécuter un programme afin de vérifier si la ressource surveillée fonctionne correctement.

Propriétés de la règle 'Utiliser le code de retour d'un programme'

  • Programme : spécifier le chemin d'accès de votre exécutable dont vous voulez tester le code de retour.
  • Paramètres : paramètres de ligne de commande de votre programme.
  • Répertoire : spécifie le répertoire par défaut dans lequel le programme est exécuté.
  • Détecter une panne... : spécifie les conditions de défaillance en fonction du code de retour renvoyé.
  • Attendre l'arrêt du processus pendant xxx secondes : ServiceKeeper tuera le processus s'il ne se termine pas dans la période de temps spécifiée et reportera une erreur.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller les journaux d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Surveiller le système de fichiers
Détecter les défaillances de ressources


Surveiller le système de fichiers

Vous pourrez, grâce aux fonctionnalités de cette option, surveiller le système de fichiers. En effet, vous aurez la possibilité d'observer les fluctuations du nombre ou de la taille des fichiers dans un répertoire, de contrôler l'espace disque sur vos différents volumes, de détecter d'éventuelles pannes en examinant les dernières dates d'accès et/ou de modifications de certains fichiers.

Note : Les propriétés suivantes ne sont accessible que dans le mode avancé. Le mode assistant ne permet que de contrôler l'espace disponible restant d'un disque.

Propriétés de la règle 'Surveiller le système de fichiers'

  • Rechercher les fichiers nommés : spécifiez le nom du fichier recherché. Vous pouvez utiliser les jokers * (toute chaîne de caractères) et ? (tout caractère).
  • Rechercher dans : spécifiez le répertoire dans lequel vous souhaitez rechercher les fichiers. Vous pouvez également utiliser les jokers * et ? pour spécifier plusieurs répertoires (Les caractères jokers ne sont admis que dans le dernier sous-répertoire, par exemple : c:\smtp\domaines\domaine*com).
  • Détecter une panne quand : déterminez ici la condition de panne à détecter.
  • Rechercher dans les sous-répertoires : cette option vous permet de determiner si la recherche doit aussi porter sur les sous-répertoires du répertoire spécifié dans la propriété Rechercher dans.
  • Au moins un des fichiers satisfait la condition spécifiée ci-dessus : lorsque cette propriété est cochée, une erreur sera retournée dès qu'un fichier satisfait la condition de détection de panne saisie.
  • Tous les fichiers doivent satisfaire la condition spécifiée ci-dessus : lorsque cette propriété est cochée, tous les fichiers retournés par la recherche devront satisfaire la condition de panne saisie pour qu'une erreur soit retournée.

Voir aussi

Surveiller un site web
Surveiller un site FTP
Surveiller un serveur SMTP
Surveiller un serveur POP3
Surveiller un serveur NNTP
Surveiller des composants réseaux
Surveiller les ports TCP/IP
Surveiller le journal d'évènements
Surveiller les compteurs de performance
Surveiller l'utilisation mémoire d'un processus
Surveiller l'utilisation CPU d'un processus
Utiliser les valeurs de retour des fonctions script
Utiliser le code de retour d'un programme
Détecter les défaillances de services

© 1997-2007 Active+ Software . All trademarks property of their owners. Send us feedback.


Réparer les ressources surveillées

Réparer les ressources défaillantes

ServiceKeeper propose plusieurs méthodes de récupération qui peuvent être combinées pour réparer ou contourner les défaillances des ressources. Vous pouvez définir l'ordre dans lequel les différentes méthodes seront appliquées.

Pour éditer les paramètres de réparation des ressources

1. Lancez la console Service+. Sélectionnez une vue sous le noeud Ressources surveillées de l'arborescence de la console.

2. Double-cliquez sur l'objet représentant la ressource surveillée que vous souhaitez éditer ou sélectionnez cet objet et cliquez sur le bouton Propriétés [image] de la barre d'outils.

3. Cliquez sur l'onglet Surveiller et le choix Réparer pour accéder à la liste des règles de réparation existantes.

Vous pouvez ajouter, modifier, supprimer ou réordonner les règles de réparation. Chaque règle peut être activée ou désactivée individuellement. ServiceKeeper exécutera successivement les règles de réparation actives jusqu'à ce que la ressource soit réparée ou que les tentatives de réparation soient abandonnées.

Voir aussi

Ajouter une règle de réparation
Modifier une règle de réparation
Supprimer une règle de réparation
Surveiller des ressources


Ajouter une action de réparation

Pour ajouter une action de réparation

1. Cliquez sur l'onglet Surveillance et le choix Réparer de la fenêtre des propriétés pour accéder à la liste des actions de réparation existantes.

2. Cliquez sur le bouton [image] pour lancer l'assistant de création des actions de réparations.

3. Sélectionnez l'action de votre choix et cliquez sur Suivant.

4. Entrez une nouvelle description pour votre action de réparation. Cliquez sur Suivant.

5. Editez les paramètres de l'action.

Chaque action possède des paramètres qui lui sont propres. Consultez les pages ci-dessous pour obtenir plus d'information sur les paramètres spécifiques à chaque action.

Types d'action

Ne pas réparer mais notifier Démarrer un service Lancer un exécutable Exécuter un script Réparer le système de fichiers Redémarrer l'ordinateur Arrêter la surveillance d'une ressource

Voir aussi

Réparer les ressources défaillantes


Modifier une action de réparation

Pour modifier une action de réparation

1. Cliquez sur l'onglet Surveillance et le choix Réparer de la fenêtre des propriétés pour accéder à la liste des actions de réparation existantes.

2. Sélectionnez l'action de votre choix.

3. Cliquez sur le bouton Propriétés [image] ou double-cliquez sur l'action choisie. La fenêtre des propriétés des actions de réparation apparait.

Chaque action possède des paramètres qui lui sont propres. Consultez les pages listées ci-dessous pour obtenir plus d'information sur les paramètres spécifiques à chaque action.

Types d'action

Ne pas réparer mais notifier Démarrer un service Lancer un exécutable Exécuter un script Réparer le système de fichiers Redémarrer l'ordinateur Arrêter la surveillance d'une ressource

Voir aussi

Réparer les ressources défaillantes


Supprimer une action de réparation

Pour supprimer une action de réparation

1. Cliquez sur l'onglet Surveillance et le choix Réparer de la fenêtre des propriétés pour accéder à la liste des actions de réparation existantes.

2. Sélectionnez l'action de votre choix et cliquez sur le bouton Supprimer [image] ou appuyez sur la touche Suppr de votre clavier.

Voir aussi

Réparer les ressources défaillantes


Ne pas réparer mais notifier

Seules les actions de notifications seront exécutées lors de la détection d'une panne. L'action "Ne pas réparer mais notifier" n'échouant jamais, elle peut être utilisée comme porte de sortie d'un jeu d'actions, c'est pourquoi l'ordre de la liste des actions est important.

Cette méthode est très pratique pour les administrations à distance, lorsqu'elle est utilisée avec la méthode de notification écrire au journal d'événements HTML. Tant que le service demeure en panne, cette action peut-être exécutée même dans le second jeu d'actions, ainsi de nouvelles entrées seront insérées dans le journal d'événements HTML, qui lui peut être consulté depuis Internet.

Propriétés de l'action 'Ne pas réparer mais notifier'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.

Voir aussi

Démarrer un service
Lancer un exécutable
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'une ressource
Réparer les ressources défaillantes


Démarrer un service

Cette action permet de démarrer un service sur l'ordinateur local ou sur un ordinateur distant.

Propriétés de l'action 'Démarrer un service'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Ordinateur : sélectionnez l'ordinateur hébergeant le service à démarrer.
  • Service : sélectionnez le service à démarrer.
  • Paramètres : fournissez des paramètres de démarrage si nécessaire.
  • Redémarrer le service s'il était déjà démarré : le service est redémarré s'il est déjà démarré.

Voir aussi

Ne pas réparer mais notifier
Lancer un exécutable
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance de la ressource
Réparer les ressources défaillantes


Lancer un exécutable

Utilisez cette méthode pour lancer un programme ou un batch personnalisé qui se chargera d'exécuter les actions de réparation appropriées.

Propriétés de l'action 'Lancer un exécutable'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Programme : chemin d'accès de l'exécutable. Notez que vous ne pouvez pas pointer sur un lecteur réseau mappé (ordinateur distant). Si l'exécutable est sur une autre machine, utilisez le chemin UNC.
  • Paramètres : vous pouvez utiliser les paramètres suivants :
    • %FailCount% : nombre de fois que la ressource est tombée en panne.
    • %FailReason% : cause de la défaillance.
      • 2 Code de retour d'un processus
      • 3 Service TCP/IP
      • 4 Compteurs de performance
      • 5 Journal d'événements
      • 6 Code de retour d'un script
      • 7 Système de fichiers
    • %FailComputer% : ordinateur hébergeant la ressource défaillante.
    • %FailService% Alias du service ou nom de la ressource.
    • %FailServiceDisplayName% Nom long du service ou de la ressource
    Ces mots clés sont également disponibles en tant que variables d'environnement.
  • Répertoire : répertoire courant du processus.
  • Attendre l'arrêt du processus pendant xxx secondes : ServiceKeeper tuera le processus s'il ne se termine pas dans la période de temps spécifiée. Si vous ne voulez pas attendre la fin du processus, entrez 0 comme valeur.

Voir aussi

Ne pas réparer mais notifier
Démarrer un service
Exécuter un script
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'une ressource
Réparer les ressources défaillantes


Exécuter un script

Avec cette option vous avez la possibilité d'écrire un script (VBScript) pour réparer vos ressources défaillantes. Vous pouvez par exemple écrire un script qui nettoierait certains fichiers avant de relancer un processus.

Propriétés de l'action Exécuter un script

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.

Les objets et paramètres suivants sont disponibles pour le script :

  • Info.Computer : chaîne de caractères indiquant le nom de l'ordinateur hébergeant la ressource.
  • Info.Name : chaîne de caractères indiquant le nom de la resource.
  • Info.DisplayName : chaîne de caractères correspondant au nom long de la ressource.
  • Info.FailCount : nombre entier indiquant combien de fois la ressource a été détecté comme défaillante.
  • Info.FailReason : nombre entier indiquant quelle méthode a été déclenchée pour effectuer la réparation. Ce peut être l'une des méthodes suivantes :
    • 2 Code de retour d'un processus
    • 3 Service TCP/IP
    • 4 Compteurs de performance
    • 5 Journal d'événements
    • 6 Code de retour d'un script
    • 7 Système de fichiers
  • Info.DesiredServiceState : nombre entier indiquant l'état désiré pour un service. (1 pour Arrêté, 4 pour Lancé, 7 pour Pause)
Si l'action de réparation échoue, False doit être retourné et Info.Error peut être défini avec un texte décrivant l'erreur.

Directives de Pré-compilation

Ces directives peuvent être inclues dans le texte au sein des commentaires.
  • '$$typelib:[file_name] pour accéder à des constantes définies dans une Type Library.
    Exemple : des constantes ADO peuvent être utilisées si ce qui suit est inséré au début du script :
    '$$typelib: c:\program files\common files\system\ado\msado15.dll
    or
    '$$typelib: c:\program files\common files\system\ado\msado25.tlb
  • '$$object: (ProgID|CLSID) : name pour ajouter un objet nommé dans le contexte du script :
    Exemple : Si MyRecorset est défini, il peut être utilisé ainsi :
    '$$object:ADODB.Recordset:MyRecordset
  • '$$include:[file_name] pour inclure du code externe. La ligne de texte est remplacée par le contenu du [file_name]
Plus d'information sur le scripting : vous trouverez des ressources expliquant WMI, ADSI, et Windows Scripting sur les sites Microsoft pour les développeurs : Windows Script Technologies et Active Directory Service Interfaces.
Voir aussi
Ne pas réparer mais notifier
Démarrer un service
Exécuter un programme
Réparer le système de fichiers
Redémarrer l'ordinateur
Arrêter la surveillance d'une ressource
Réparer les ressources défaillantes


Réparer le système de fichiers

Avec cette fonctionnalité, vous pourrez entreprendre diverses actions sur le système de fichiers comme copier, déplacer ou supprimer un ensemble de fichiers.

Propriétés de l'action 'Réparer le système de fichiers

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Les fichiers nommés : spécifiez le(s) fichier(s) que vous souhaitez copier, déplacer ou supprimer. Vous pouvez utiliser les jokers * (toute chaîne de caractères) et ? (tout caractère).
  • De : spécifiez le répertoire source à partir duquel vous voulez copier, déplacer ou supprimer les fichiers.
  • Vers : spécifiez le répertoire destination vers lequel vous souhaitez copier ou déplacer les fichiers.
  • Envoyer le(s) fichier(s) dans la corbeille : si vous sélectionnez l'action Supprimer le(s) fichier(s), vous avez la possibilité de déplacer le(s) fichier(s) vers la corbeille.
    Note : Chaque utilisateur possédant sa propre corbeille, les fichiers seront déplacés dans la corbeille du compte utilisateur utilisé par ServiceKeeper pour se lancer.
    Attention : Si vous sélectionnez un répertoire source qui n'est pas situé sur un disque local, les fichiers ne pourront pas être déplacés vers la corbeille et seront détruits.
  • Rechercher dans les sous-répertoires : grâce à cette option, vous pourrez copier, déplacer ou supprimer les fichiers présents dans les sous-répertoires du répertoire spécifié dans la propriété De.
  • Ignorer les erreurs : lorsque cette option est activée, ServiceKeeper ignore les fichiers qu'il ne peut pas traiter (copier, déplacer ou supprimer). Par contre, si cette option n'est pas cochée, ServiceKeeper stoppe le traitement et retourne une erreur dès qu'il rencontre le moindre problème avec un des fichiers traité.

Voir aussi

Ne pas réparer mais notifier
Lancer un exécutable
Démarrer un service
Exécuter un script
Redémarrer l'ordinateur
Arrêter la surveillance d'un service
Réparer les services défaillants

© 1997-2007 Active+ Software . All trademarks property of their owners. Send us feedback.


Redémarrer l'ordinateur

Vous pouvez utiliser cette option en dernier ressort, si toutes les autres actions de récupération ont échoué. Tous les processus, y compris les applications client-serveur, seront interrompus brutalement.

Propriétés de l'action 'Redémarrer l'ordinateur'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.
  • Stopper le processus de réparation si cette action réussit : cette option indique à ServiceKeeper de stopper les tentatives de réparation dés que l'une d'elles a réussi.
  • Terminer les applications de force : ceci fermera les applications même si elles attendent une action utilisateur comme par exemple "Voulez-vous enregistrer vos modifications ?"

Voir aussi
Ne pas réparer mais notifier
Démarrer un autre service
Exécuter un programme
Exécuter un script
Réparer le système de fichiers
Arrêter la surveillance d'une ressource
Réparer les ressources défaillantes


Arrêter la surveillance d'une ressource

Cette option indique à ServiceKeeper qu'il doit arrêter de surveiller la ressource. L'état courant de la ressource est ignoré tant que les paramètres de surveillance de la ressource ne sont pas modifiés ou que le service ServiceKeeper n'est pas redémarré.

Propriétés de l'action 'Arrêter la surveillance d'une ressource'

  • Description : vous pouvez fournir une description pour votre règle.
  • Exécuter cette action de réparation quand le nombre de détection de panne atteint... jusqu'à... : les deux valeurs renseignées ici déterminent quand cette action aura lieu. Chaque fois qu'une défaillance est détectée, le compteur de détection de défaillance est incrémenté et sa valeur est comparée avec ces deux valeurs pour déterminer si cette action de réparation doit être exécutée ou non.
    Le compteur de détection de défaillance est automatiquement remis à zéro si aucune défaillance n'a été détectée pendant un temps donné. Ce temps est spécifié au travers de l'onglet Avancé.

Voir aussi

Ne pas réparer mais notifier
Démarrer un autre service
Exécuter un script
Exécuter un programme
Réparer le système de fichiers
Redémarrer l'ordinateur
Réparer les ressources défaillantes


Paramétrer les notifications

ServiceKeeper vous permet de choisir entre différentes méthodes de notification d'erreur que vous pouvez combiner afin d'être sûr d'être notifié des incidents survenus sur votre serveur quel que soit l'endroit où vous vous trouvez.

Pour configurer les notifications

1. Sélectionnez une vue de l'arborescence de la Console Service+ puis sélectionnez une vue.

2. Cliquez avec le bouton droit de la souris sur la ressource et sélectionnez Propriétés ou double-cliquez sur la ressource surveillée.

3. Cliquez sur l'onglet Surveiller et le choix Notification pour accéder à la liste des méthodes de notification.

  • Utiliser les méthodes de notification de ServiceKeeper : cette option vous permet d'utiliser les paramètres par défaut de ServiceKeeper.

4. Pour configurer une méthode de notification, sélectionnez la méthode de notification choisie et cliquez sur le bouton Propriétés [image] ou double-cliquez la méthode de notification.

Chaque méthode de notification possède ses propres paramètres de configuration. Consultez les pages listées ci-dessous pour plus d'information sur chacune d'entre elles.

Méthodes de notification

Envoi d'un email (SMTP) Envoi d'une alerte administrative Lancer un exécutable Envoi d'un trap SNMP Exécuter un script Ecrire dans un journal d'évènements HTML Ecrire dans un fil RSS Notification vocale (Expérimentation)

Voir aussi

A propos des ressources surveillées


Envoi d'un email

A chaque détection d'erreur un email sera envoyé, après que les actions de réparation ait été entreprises. L'information, contenue dans le corps du message comme dans un fichier journal, contient les erreurs détectées ainsi que le actions de réparation entreprises et le nom de la ressource surveillée.

Pour éditer les propriétés de la notification 'Envoi d'un email'

1. Depuis la liste des notifications, sélectionnez Envoi d'un email (SMTP) et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • De : adresse e-mail de l'émetteur du message.
  • A : adresse du destinataire qui recevra la notification d'erreur. Vous pouvez entrer plusieurs adresses en séparant les adresses par des virgules.
  • Sujet : sujet du message.
  • Charset (Table de caractères) : encodage MIME. Si "Pas d'encodage" est sélectionné, le message ne sera pas encodé. Cette option est utile lorsque l'on envoie un message à des clients mail non compatibles avec du contenu MIME (Pager, SMS, etc.).
  • Format : sélectionnez le format dans lequel le message sera envoyé (Note : "envoyer uniquement le sujet" ajoutera le message de notification dans le sujet).
  • Serveur SMTP : nom de l'hôte du serveur SMTP pour les mails sortants. Vous pouvez également entrer l'adresse IP de votre serveur.
  • Authentification : sélectionnez la méthode d'authentification et entrez les informations d'ouverture de session. Consultez votre administrateur réseau pour plus d'information.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle la ressource a commencé à être surveillée
    • %UpTime% : la durée pendant laquelle la ressource surveillée a été en marche
    • %DownTime% : la durée pendant laquelle la ressource surveillée a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) de la ressource surveillée
    • %LastKnownRunningState% : la date à laquelle la ressource surveillée a été détectée en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur la ressource surveillée
    • %FailureCountSinceRestart% : le nombre de panne détectées sur la ressource surveillée depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si la ressource surveillée est en marche au moment de la notification (0 si elle est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Envoi d'une alerte administrative

Cette méthode de notification affichera une alerte avec les services Messenger et Alerter. Les 2 services doivent être démarrés sur l'ordinateur de réception si les alertes administratives sont envoyées sur une autre machine.

Pour éditer une notification 'Envoi d'une alerte administrative'

1. Depuis la liste des notifications, sélectionnez Envoi d'une alerte administrative et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

2. Entrez le nom du compte utilisateur ou le nom de l'ordinateur qui doit recevoir le message. Vous pouvez spécifier plusieurs comptes utilisateur ou ordinateurs en utilisant des virgules (ex : Admin, Vincent, Daniel).

3. Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :

  • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
  • %Date% : la date à laquelle la notification a été lancée
  • %Time% : l'heure à laquelle la notification a été lancée
  • %StartMonitoringDate% : la date à partir de laquelle la ressource a commencé à être surveillée
  • %UpTime% : la durée pendant laquelle la ressource surveillée a été en marche
  • %DownTime% : la durée pendant laquelle la ressource surveillée a été en panne
  • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) de la ressource surveillée
  • %LastKnownRunningState% : la date à laquelle la ressource surveillée a été détectée en marche pour la dernière fois
  • %LastFailureDate% : la date à laquelle est survenue la dernière panne
  • %FailureCount% : le nombre de panne détectées sur la ressource surveillée
  • %FailureCountSinceRestart% : le nombre de panne détectées sur la ressource surveillée depuis le redémmarrage de ServiceKeeper
  • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
  • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
  • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
  • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
  • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
  • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
  • %Running% : 1 si la ressource surveillée est en marche au moment de la notification (0 si elle est en panne)
  • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
  • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
  • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'un email (SMTP)
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Lancer un exécutable

Cette méthode de notification peut être utilisée pour lancer un programme qui a une interface en ligne de commande.

Pour éditer une notification 'Lancer un exécutable'

1. Depuis la liste des notifications, sélectionnez Lancer un exécutable et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Programme : indique le chemin complet d'accès à l'exécutable. Notez que vous ne pouvez pas pointer sur un disque mappé (ordinateur à distance). Si l'exécutable est sur une autre machine, utilisez le chemin UNC.
  • Paramètres : vous pouvez transmettre les paramètres suivants à votre exécutable :
    • %MessageFile% sera remplacé par le nom d'un fichier qui contient le message d'erreur.
    • %Message% sera remplacé par le message d'erreur exact. Les retours chariot sont remplacés par des espaces.
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle la ressource a commencé à être surveillée
    • %UpTime% : la durée pendant laquelle la ressource surveillée a été en marche
    • %DownTime% : la durée pendant laquelle la ressource surveillée a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) de la ressource surveillée
    • %LastKnownRunningState% : la date à laquelle la ressource surveillée a été détectée en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur la ressource surveillée
    • %FailureCountSinceRestart% : le nombre de panne détectées sur la ressource surveillée depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si la ressource surveillée est en marche au moment de la notification (0 si elle est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)
  • Répertoire : répertoire dans lequel s'exécutera le programme.
  • Attendre l'arrêt du processus pendant xxx secondes : ServiceKeeper tuera le processus s'il ne se termine pas dans la période de temps spécifiée. Si vous ne voulez pas attendre la fin du processus, entrez 0 comme valeur.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle la resource surveillée a commencé à être surveillée
    • %UpTime% : la durée pendant laquelle la resource surveillée a été en marche
    • %DownTime% : la durée pendant laquelle la resource surveillée a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) de la ressource surveillée
    • %LastKnownRunningState% : la date à laquelle la resource surveillée a été détectée en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur la resource surveillée
    • %FailureCountSinceRestart% : le nombre de panne détectées sur la resource surveillée depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si la resource surveillée est en marche au moment de la notification (0 si elle est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi
Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Exécuter un script

Avec cette fonctionnalité, vous pouvez écrire un script (VBScript) pour envoyer les notifications d'erreurs.

Pour éditer une notification 'Exécuter un script'

1. Depuis la liste des notifications sélectionnez Exécuter un script et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle ou la ressource a commencé à être surveillée
    • %UpTime% : la durée pendant laquelle ou la ressource surveillée a été en marche
    • %DownTime% : la durée pendant laquelle ou la ressource surveillée a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) de la ressource surveillée
    • %LastKnownRunningState% : la date à laquelle ou la ressource surveillée a été détectée en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur ou la ressource surveillée
    • %FailureCountSinceRestart% : le nombre de panne détectées sur ou la ressource surveillée depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si ou la ressource surveillée est en marche au moment de la notification (0 si elle est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

L'objet suivant est accessible depuis le script :

  • Info.Message : chaîne qui contient le message d'erreur, et qui peut inclure CR LF.

Si la notification échoue, la fonction doit retourner False et Info.Error peut être défini avec un texte décrivant l'erreur.

Directives de Pré-compilation :

Les directives de pré-compilation suivantes peuvent être inclues dans le code source au sein de commentaires.
  • '$$typelib:[file_name] pour accéder à des constantes définies dans une Type Library.
    Exemple : des constantes ADO peuvent être utilisées si ce qui suit est inséré au début du script :
    '$$typelib: c:\program files\common files\system\ado\msado15.dll
    ou
    '$$typelib: c:\program files\common files\system\ado\msado25.tlb
  • '$$object: (ProgID|CLSID) : name pour ajouter un objet nommé dans le contexte du script :
    Exemple : Si MyRecorset est défini, il peut être utilisé ainsi :
    '$$object:ADODB.Recordset:MyRecordset
  • '$$include:[file_name] pour inclure du code externe. La ligne de texte est remplacée par le contenu du [file_name]
Plus d'information sur le scripting : vous trouverez des ressources expliquant WMI, ADSI, et Windows Scripting sur les sites Microsoft pour les développeurs : Windows Script Technologies et Active Directory Service Interfaces

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Ecrire dans un journal d'évènements HTML
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Ecrire dans un journal d'événement HTML

Cette méthode de notification permet à un administrateur de consulter le journal d'événements de ServiceKeeper à partir de n'importe quel navigateur web.

Pour éditer une notification 'Ecrire dans un journal d'événement HTML'

1. Depuis la liste des notifications sélectionnez Ecrire dans un journal d'événement HTML et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Fichier HTML : chemin d'accès au fichier HTML qui contient le journal. Pour pouvoir consulter le journal depuis l'extérieur, le fichier doit être placé dans un répertoire accessible depuis un site web. On peut utiliser un chemin UNC pour stocker le fichier sur un serveur distant. Si le fichier n'existe pas, il sera créé automatiquement; s'il existe, les événements seront ajoutés à la fin du fichier.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle la ressource a commencé à être surveillée
    • %UpTime% : la durée pendant laquelle la ressource surveillée a été en marche
    • %DownTime% : la durée pendant laquelle la ressource surveillée a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) de la ressource surveillée
    • %LastKnownRunningState% : la date à laquelle la ressource surveillée a été détectée en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur la ressource surveillée
    • %FailureCountSinceRestart% : le nombre de panne détectées sur la ressource surveillée depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si la ressource surveillée est en marche au moment de la notification (0 si elle est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un fil RSS
Notification vocale (Expérimentation)
Paramétrer les notifications


Paramètres avancés

Les paramètres avancés vous donnent accès à un paramétrage fin des surveillances.

Pour modifier les paramètres avancés

1. Sélectionnez une vue de l'arborescence de la Console Service+ puis sélectionnez une ressource.

2. Cliquez avec le bouton droit de la souris sur la ressource surveilléeet sélectionnez Propriétés ou double-cliquez sur la ressource.

3. Cliquez sur l'onglet Surveiller et le choix Avancé.

  • Délai entre chaque tentative de réparation : après une tentative de réparation, ServiceKeeper attendra le temps spécifié avant de relancer le processus de détection de panne sur la ressource.
  • RAZ du compteur de panne au bout de : Après que la ressource est fonctionné correctement pendant le temps spécifié, le compteur de détection de panne est remis à zéro. Le compteur de détection de panne est utilisé pour déterminer quel jeu d'action de réparation doit être exécuté à un moment donné. Si la défaillance n'est pas corrigée, elle est détectée continuellement de façon récursive. Le compteur de défaillance est incrémenté. De ce fait sa valeur augmente et peut déterminer l'exécution de nouvelles actions.

Voir aussi

Réparer les services défaillants


Comprendre les services

Un service est une application d'un type particulier : en général, une telle application n'a aucune interaction avec l'utilisateur de l'ordinateur (il ne possède pas d'interface graphique et ne nécessite pas de session utilisateur pour s'exécuter). De plus, il s'exécute en arrière plan et interagit avec le système, du démarrage à l'arrêt de l'ordinateur.

Les services sont considérés comme des extensions du système d'exploitation. Ayant été introduits avec Windows NT, ils sont maintenant connus sous le nom de "Services Win32" sur les plates-formes contemporaines (Windows 2000, XP, .Net) puisque s'appuyant sur les APIs Win32.

Un service typique auquel vous pouvez penser immédiatement est le service "Alerteur", qui est un programme capable de notifier les utilisateurs d'alertes administratives. Ce programme doit fonctionner tant que l'ordinateur est démarré et ne nécessite aucune interface utilisateur pour délivrer ses alertes.

Vous pouvez également imaginer une application Client-Serveur, que vous voulez démarrer automatiquement au démarrage du système, et qui ne dépendrait d'aucune session utilisateur. Cette application pourrait cependant offrir la possibilité aux utilisateurs connectés d'exécuter certaines tâches spécifiques au travers d'une interface graphique. De tels besoins devraient vous encourager à exécuter cette application en arrière plan, en tant que service, plutôt qu'en avant plan comme la plupart des applications.

Les services se connectent au système d'exploitation de la même manière que les utilisateurs. Lorsqu'il se lance, le service s'authentifie au système en utilisant un compte utilisateur ou le compte système. Le compte système (LocalSystem) possède des droits d'administrateur local. Si votre service doit accéder à des ressources réseau qui nécessitent une authentification NT, vous devez lancer le service avec un compte utilisateur possédant les droits nécessaires pour accéder à la ressource réseau.

Certains services ont besoin, pour s'exécuter, qu'un ou plusieurs autres services soient au préalablement lancés. Un paramètre particulier des services appelé "Dépendances du service" (DependOnService) liste tous les services qui doivent être démarrés pour que le service courant puisse s'exécuter correctement. Un service peut s'exécuter dans son propre processus comme un hôte, ou partager avec d'autres services un même processus.

Le contexte du Service :

Pour s'exécuter, les services nécessitent un Service Control Manager (SCM) ; d'autre part un Service Control Program (SCP) est nécessaire pour les contrôler. De plus, pour être exécutée en tant que service, une application doit être conçue ou modifiée pour interagir avec le système dans le contexte d'un service plutôt que dans un contexte utilisateur au travers d'une interface graphique. Veuillez vous référer aux fichiers d'aide de ServiceMill pour vous documentez sur la manière de transformer des applications standards en service.
Un SCP permet aux utilisateurs de contrôler et de configurer les services. Windows fournit un SCP pour la gestion des services standard : le composant de panneau de configuration "Services" (sous Windows NT4) et le composant enfichable MMC "Services" (sous Windows 2000, XP, .Net). Service+ est un SCP amélioré qui remplace le SCP standard fourni par Windows. Les SCP sont des outils permettant de contrôler (démarrer, arrêter, mettre en pause/continuer, tuer, etc.) et de configurer (ajouter des dépendances, etc.) les services Windows.

Service+ CL est un SCP en ligne de commandes permettant un contrôle avancé des services au travers de tout un domaine. Le SCM est supporté par Windows dans le processus services.exe. C'est lui qui joue le rôle d'interface de communication entre les services et le SCP. Le SCM transfère les commandes et les modifications de configuration initiées par le SCP aux services, les services, quant à eux, reportent leur état au SCM qui le transmet aux SCP. Le SCM possède également d'autres fonctionalités comme la possibilité de bloquer ou de débloquer la base de données des services.

Notez que certaines applications s'exécutant en tant que service nécessitent une configuration particulière et peuvent donc inclure leur propre SCP. C'est le cas de ServiceKeeper, qui permet de contrôler, de planifier et de réparer l'exécution des services et qui intègre, pour réaliser cela, son propre SCP.

Interaction avec les utilisateurs :

Nous avons vu qu'un service était controlé au travers d'un SCP et du SCM. Bien que la plupart des services n'interagissent jamais avec l'utilisateur, certaines applications exécutées en tant que service peuvent parfois avoir besoin de l'interaction avec l'utilisateur. Les services nécessitant cela, incluent un drapeau dans l'en-tête de leur fichier exécutable, indiquant s'ils sont de type console ou de type graphique. La plupart des services se disent de type console et donc n'interagissent pas avec l'écran. Il existe des limitations, dans Windows, sur les circonstances dans lesquelles un service peut interagir avec l'écran, notamment lorsque il s'exécute en utilisant un compte utilisateur. Veuillez vous référer aux fichiers d'aide de ServiceMill pour vous documentez sur la manière de transformer des applications standard en service tout en conservant l'interaction avec l'écran.

Voir aussi

Références
Paramétrage des Services
Les Processus de Services
Les Comptes de Services
Le SCM
Le SCP
Le Cycle d'Exécution

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Propriétés des Services

Les propriétés des services décrivent des caractéristiques comme le type, le chemin d'accès à l'exécutable, le mode de démarrage (manuel ou automatique), le comportement du système en cas d'erreur de démarrage et l'appartenance aux groupes (comment et quand le service démarre t'il par rapport aux autres). Le tableau suivant provient d'un article du gourou de NT Mark Russinovich de Sysinternals. Nous ne recommanderons jamais assez leurs publications très compréhensibles et couvrant tous les aspects du très varié système d'exploitation qu'est Windows.

Propriété | Valeur | Description de la propriété
DependOnGroup | Nom du groupe | Les pilotes ou les services ne démarreront pas tant qu'un service ou un pilote du groupe n'aura pas démarré.
DependOnService | Nom du service | Les services ne démarreront que lorsque le service spécifié aura démarré. Cette propriété n'est pas applicable aux pilotes.
Description | Description du service | Jusqu'à 1024 octets pour décrire le service. Nouveau dans Windows 2000.
DisplayName | Nom du service | C'est le nom du service affiché dans l'application "Services" Si aucun nom n'est spécifié, alors l'Alias du service (le nom du service dans la base de registres) est utilisé.
ErrorControl | IGNORE (0) | Le gestionnaire d'entrées/sorties ignore les erreurs retournées par le driver. Aucun avertissement n'est affiché ou inscrit dans le journal d'événements.
 | NORMAL (1) | Si le pilote retourne une erreur, un avertissement est affiché.
 | SEVERE (2) | Si le pilote retourne une erreur et que l'utilisateur n'utilise pas la dernière configuration de boot valide, le système redémarre sur la dernière configuration de boot valide. Sinon, le système ne redémarre pas.
 | CRITICAL (3) | Si le pilote retourne une erreur et que l'utilisateur n'utilise pas la dernière configuration de boot valide, le système redémarre sur la dernière configuration de boot valide. Sinon, le système est arrété avec un écran bleu de crash.
FailureActions | Description des actions entreprises par le SCM lorsque le service se termine de manière anormale | Les actions pouvant être entreprises sont le redémarrage du service, du système et l'exécution d'un programme spécifique. Cette nouvelle propriété de Windows 2000 n'est pas applicable aux pilotes.
FailureCommand | Ligne de commande | Le SCM lit cette propriété seulement si "FailureActions" spécifie qu'un programme doit être exécuté à la suite d'une défaillance du service. Cette nouvelle propriété de Windows 2000 n'est pas applicable aux pilotes.
Group | Nom du groupe | Le driver ou le service s'initialisera lorsque son groupe s'initialisera.
ImagePath | Chemin d'accès au fichier exécutable du service ou du pilote | Si ImagePath n'est pas spécifié, le gestionnaire d'entrées/sorties recherchera le driver dans \winnt\system32\drivers, et le SCM cherchera le service dans \winnt\system32.
ObjectName | Généralement LocalSystem, mais peut être un compte utilisateur comme le compte Administrateur | Spécifie le compte avec lequel le service va s'exécuter. Si Object-Name n'est pas défini, LocalSystem est utilisé. Cette propriété n'est pas applicable aux pilotes.
Start | SERVICE_BOOT_START (0) | NT Loader (NTLDR) ou OSLOADER précharge le pilote qui se trouve donc en mémoire durant le démarrage. Les pilotes SERVICE_BOOT_START s'initialisent juste avant les pilotes SERVICE_SYSTEM_START.
 | SERVICE_SYSTEM_START (1) | Les pilotes SERVICE_SYSTEM_START sont chargés et initialisés juste après que se soient initialisés les pilotes SERVICE_BOOT_START.
 | SERVICE_AUTO_START (2) | Le SCM démarre le pilote ou le service.
 | SERVICE_DEMAND_START (3) | Le SCM doit démarrer le pilote ou le service à la demande.
 | SERVICE_DISABLED (4) | Le pilote ou le service n'est ni chargé ni initialisé.
Tag | Tag Number | L'ordre d'initialisation d'un pilote dans son groupe. Cette propriété n'est pas applicable aux services.
Type | SERVICE_KERNEL_DRIVER (1) | Gestionnaire de périphérique.
 | SERVICE_FILE_SYSTEM_DRIVER (2) | Pilote de gestion de fichier Kernel.
 | SERVICE_RECOGNIZER_DRIVER (8) | Pilote de reconnaissance du système de fichier.
 | SERVICE_WIN32_OWN_PROCESS (16) | Un service qui s'exécute seul dans son propre processus.
 | SERVICE_WIN32_SHARE_PROCESS (32) | Un service qui partage son processus d'exécution avec d'autres services.
 | SERVICE_INTERACTIVE_PROCESS (256) | Un service qui peut afficher des fenêtres et accepter des entrées utilisateur.
La plupart des propriétés citées ci-dessus peuvent être configurées à partir du SCP (composant de panneau de configuration). Veuillez vous référer au chapitre Configuration des propriétés générales de Service+ pour voir quelles sont les propriétés qui peuvent être modifiées.

Entrée de base de registres du service:

Les propriétés d'un service sont stockées dans une clef de la base de registres correspondant au service, qui est une représentation non volatile de la base de données des services du SCM (ServiceActive database). Vous pouvez donc voir les propriétés des services en utilisant un éditeur de base de registres (Menu Démarrer, Exécuter et tapez regedit). Vous trouverez les propriétés des services de votre ordinateur dans la branche de la base de registres des services : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services folder. La capture écran suivante représente les propriétés du service ServiceKeeper :

Les entrées de base de registres d'un service sont généralement créées pendant l'installation des applications qui incluent ce service. Le programme d'installation de l'application appelle l'API CreateService (contenue dans la DLL Advanced API winnt\system32\advapi32.dll) pour enregistrer le service auprès du système et pour spécifier les propriétés nécessaires au bon fonctionnement de l'application utilisant le service.

Voir aussi

Références
Les Services
Les Processus de Services
Les Comptes de Services
Le SCM
Le SCP
Le Cycle d'Exécution

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Les Processus de Services

Lancer le service :

Au démarrage, un service appelle l'API StartServiceCtrlDispatcher. Cette API construit une liste des noms des services (points d'entrée) qui s'exécute dans un processus partagé. Le SCM envoie ensuite la commande "Start" (Démarrer) à tous les services du processus. Pour chaque commande reçue, StartServiceCtrlDispatcher crée un thread qui implémente la boucle de réception de commandes du service, et ne rend le contrôle au processus que lorsque tous les threads se sont terminés. Lorsque'un service s'exécute dans un processus propre, StartServiceCtrlDispatcher n'utilise que la fonction ServiceMain.

Afin de recevoir les commandes du SCM telles que Stop, Pause/Continuer, Interroger, Fermer, vous devez appeler, durant le démarrage, l'API RegisterServiceCtrlHandler qui permet d'enregistrer la table des fonctions qui traitent les différentes commande reçues. Le thread principal du processus du service reçoit la commande adressée à un service s'exécutant dans le processus, et utilise cette table pour déterminer et invoquer la fonction correspondant à la commande.

Durant le démarrage, l'état du service est périodiquement reporté au SCM.

Processus Propre / Processus Partagé :

Les services, parfois, partagent le même processus d'exécution pour préserver les ressources système. Par exemple, le SCM partage le même processus avec plusieurs services (EventLog, LanmanServer, Alerter, DHCP, etc. under Windows 2000). Service+ montre, dans les propriétés des services, ceux qui partagent un processus d'exécution.

Avec Windows 2000 est arrivé "Service Host", une application permettant d'organiser efficacement les processus partagés de services. Les services qui s'exécutent dans un processus "Service Host" sont implémentés dans des DLLs. Le chemin d'accès à l'exécutable du service est le chemin d'accès de "svchost.exe" et possède un paramètre représentant une clef de la base de registre que le processus SvcHost utilise pour retrouver le chemin d'accès et charger la DLL.

Plusieurs instances de "Service Host" peuvent être lancées, cependant tous les services s'exécutant dans un même processus doivent avoir le même paramètre de démarrage et sont donc enregistrés sous la même entrée dans la base de données du SCM et présentés au SCM comme des services hébergés dans un même processus "SvcHost". Les paramètres de démarrage des services sont stockés dans la clef de registre : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost.
Pour plus d'informations sur le sujet, visitez Inside Win32 Services un article de Marc Russinovich.

Voir aussi

Présentation
Les Services
Paramétrage des Services
Les Comptes de Services
Le SCM
Le SCP
Le Cycle d'Exécution

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Les Comptes d'exécution des Services

Compte Système :

Généralement, les services s'exécutent en LocalSystem, c'est à dire dans le contexte de sécurité du compte système, qui offre le niveau le plus haut de privilèges mais qui entraîne quelques problèmes en matière d'accès et de sécurité. Les services s'exécutant sous le compte système ne peuvent pas accéder aux profils des autres comptes, et ne peuvent accéder aux ressources réseaux que si le compte système de l'ordinateur sur lequel il s'exécute s'est vu concéder les droits d'accès nécessaires (Windows 2000, XP).

La limitation la plus notable se situe au niveau de l'interaction des services avec l'écran. Tous les processus Win32, et donc les services, sont associés à une "WindowStation" qui contient le bureau et une seule station peut recevoir les entrées utilisateur (WinSta0). La règle générale, est que le SCM associe au processus du service une station invisible pour empêcher l'interaction de l'utilisateur.

Toutefois, pour permettre à certains services d'interagir avec l'écran, une mesure a été entreprise pour définir un nouveau type de service : SERVICE_INTERACTIVE_PROCESS. Le SCP permet de faire cela en cochant la propriété "Interagir avec l'écran" à partir des propriétés générales d'un service. Dans ce cas, le SCM connecte le service sur la station WinSta0. Cependant, cette option ne peut être utilisée que si le service s'exécute dans le contexte de sécurité du compte système (Local System); ce qui implique qu'un service interagissant avec l'écran ne pourra accéder aux ressources réseaux.

Compte Utilisateur :

Les services s'exécutant sous un compte utilisateur peut accéder à toutes les ressources réseaux auxquelles l'utilisateur a accès. Le SCM démarre le service en le connectant avec le compte utilisateur et le mot de passe saisis dans le SCP ou par le programme d'installation du service. Le service est associé à une station de fenêtres invisible, interdisant toute interaction.

Cette limitation majeure peut être contournée en utilisant ServiceMill qui permet aux services utilisant un compte utilisateur d'interagir avec l'écran. En fait, n'importe quelle application (graphique ou console) peut être exécutée en service en utilisant ServiceMill, tout en maintenant les interactions nécessaires à une application d'avant-plan et l'accès aux ressources réseau (en fonction des droits d'accès du compte utilisateur utilisé).

Il y a de nombreux avantages à exécuter une application en tant que service tout en conservant l'interaction avec l'écran. Il peut être pertinent qu'une application nécessitant un flux continu d'informations, traite ces données externes reçues en arrière plan même lorsque vous n'êtes plus connecté. De plus, pour des raisons de sécurité, il serait judicieux de cacher l'exécution de cette application, en vous déconnectant de l'ordinateur. Enfin, si cette application effectue un travail critique, vous pouvez la surveiller, la réparer et la contrôler à distance en utilisant des outils de surveillance de services efficaces comme ServiceKeeper et Service+.

Voir aussi

Références
Les Services
Paramétrage des Services
Les Processus de Services
Le SCM
Le SCP
Le Cycle d'Exécution

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Le SCM

Pour tous les systèmes Windows NT, le fichier exécutable contenant le SCM est services.exe, situé dans le répertoire system32 et s'exécutant comme une application console Win32. WinLogon démarre le SCM très tôt pendant le démarrage de l'ordinateur. Les services configurés pour être démarrés automatiquement sont lancés par la fonction SvcCtrlMain du SCM avant que la boîte de dialogue de connexion au système ne soit affichée. Pour qu'un SCP et le SCM puisse communiquer, il faut que l'événement de synchronisation, crée par la fonction SvcCtrlMain soit signalé.
Le SCM repose sur une base de données de services qui spécifie, entre autre, les dépendances entre les services et les groupes.
Pour plus d'informations sur ce sujet, reportez vous à l'article Inside Win32 Services de Marc Russinovich.

Voir aussi

Références
Les Services
Paramétrage des Services
Les Processus de Services
Le SCP
Le Cycle d'Exécution

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Le SCP

Le Service Control Programs (SCP) communique avec le Service Control Manager (SCM) en utilisant un ensemble d'APIs : CreateService, OpenService, StartService, ControlService, QueryServiceStatus et DeleteService. Le SCP utilise l'API OpenSCManager pour ouvrir un canal de communication avec le SCM et pour accéder aux APIs citées ci dessus.

Le SCM crée un objet représentant la base de données des services et le présente au SCP à la suite d'un appel à OpenSCManager. Cet objet est protégé par un descripteur de sécurité qui détermine quels accès sont accordés à quels comptes : tous les comptes peuvent énumérer les services pour les afficher mais seuls les comptes administrateurs ont les droits nécessaires à la création ou la destruction d'entrées dans la base de données des services du SCM.

Un autre descripteur de sécurité est spécifié par le SCP à l'appel de l'API CreateService. Ce descripteur est associé à l'entrée du service dans la base de données. Il est également stocké dans la base de registres, ce qui lui permet de survivre à un redémarrage de la machine. C'est lui qui détermine quelles commandes le SCP pourra ordonner au service (Démarrer, Arrêter, Mettre en Pause/Continuer, etc.).

Les services fournissant un SCP intégré peuvent dicter la ligne de conduite d'un service au SCM. Par exemple ServiceKeeper permet de définir un "Délai d'attente maximum sur un état en instance". Si ce délai est dépassé, le service est considéré comme défaillant et le processus du service est terminé. Le SCM n'impose aucun délai maximum à un service pour s'arrêter, se mettre en pause, ... Ce délai a été imposé par ServiceKeeper.
Pour plus d'information sur ce sujet, veuillez vous référer à l'article Inside Win32 Services de Marc Russinovich.

Voir aussi

Références
Les Services
Paramétrage des Services
Les Processus de Services
Le SCM
Le Cycle d'Exécution

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Le Cycle d'Exécution

Ordre de démarrage des services :

Le SCM utilise la fonction ScAutoStartServices pour démarrer en groupe et dans le bon ordre tous les services configurés en démarrage automatique. L'ordre est défini par la clef de base de registres "ServiceGroupOrder" qui se trouve dans HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ et par la propriété des services "DependOnGroup". Avant de démarrer un service, ScAutoStartServices vérifie que les groupes contenus dans "DependOnGroup" se sont correctement initialisés et qu'au moins un des services de ce groupe est démarré.

Ensuite, ScAutoStartServices vérifie, en utilisant la clef de base de registres "DependOnService", si le service est dépendant d'autres services du même groupe, et si, le cas échéant, tous ces services sont déjà démarrés. Si ce n'est pas le cas, le service est ignoré.

ScAutoStartServices boucle sur tous les groupes jusqu'à ce que tous les services des groupes soient démarrés ou aient généré une erreur de dépendance. C'est cette boucle qui permet au SCM de définir l'ordre de démarrage des services au sein d'un groupe, en concordance avec la propriété "DependOnService". Le SCM commence par démarrer les services dont dépendent les autres, laissant ces derniers pour les prochains tours de boucle.

Après avoir terminer de démarrer les groupes de "ServiceGroupOrder", le SCM démarre les services appartenant aux groupes n'étant pas lister dans "ServiceGroupOrder" puis il démarre les services n'appartenant à aucun groupe.

Démarrage d'un service :

Quand il démarre un service, le SCM appelle la méthode ScStartService. Cette méthode récupère, dans la clef de base de registres du service, la propriété "ImagePath", qui permet de déterminer le chemin d'accès de l'exécutable du service. Ensuite, il détermine, toujours à partir de la base de registres, si le service s'exécute dans un processus propre ou dans un processus partagé. Enfin, la propriété "ObjectName" est utilisée pour déterminer le compte (LocalSystem ou compte utilisateur) utilisé par le service. Tout au long de l'exécution du service, le SCM conserve dans sa base de données la propriété "ImagePath" et le compte utilisateur utilisé par le service.

Le SCM démarre le processus dans un état suspendu avec la fonction ScLogonAndStartImage. Il crée un tuyau de communication nommé (\Pipe\Net\NetControlPipe(x) ou x est incrémenté à chaque ouverture d'un nouveau tuyau de communication) avec le processus. Ensuite, le SCM attend que le service appelle StartServiceCtrlDispatcher et qu'il se connecte au tuyau de communication. Si au bout du délai "ServicesPipe" ou si un délai de 30 secondes est dépassé et qu'aucune connexion n'a été établie, le SCM termine le processus. Quand le service s'est connecté au SCM au travers du tuyau de communication, le SCM envoie au service la commande Start. Si le service ne démarre pas, le système reporte l'erreur dans le journal d'événements système.

Erreurs de démarrage:

La propriété ErrorControl détermine comment le SCM doit réagir lorsqu'un service retourne une erreur au démarrage. Si ErrorControl est à SERVICE_ERROR_IGNORE ou s'il n'est pas défini, l'erreur est ignorée. Si ErrorControl est à SERVICE_ERROR_NORMAL, le SCM écrit un message, incluant une description textuelle de l'erreur Win32 qui s'est produite, dans le journal d'événements. L'utilitaire d'administration Service+ vous permet de spécifier la valeur de la propriété ErrorControl à la création d'un service.

Lorsque ErrorControl est à SERVICE_ERROR_SEVERE ou à SERVICE_ERROR_CRITICAL, si le service retourne une erreur au démarrage, un redémarrage de la machine est initié par le SCM. Le SCM commence par écrire un message dans le journal d'événement puis il appelle la méthode ScRevertToLastKnownGood qui rétabli la dernière configuration stable de base de registres. Puis le système est redémarré grâce au service NtShutdownSystem. C'est le SCM qui est responsable de la sauvegarde de la dernière configuration stable, c'est à dire la dernière configuration qui a permis de démarrer tous les services configurés en démarrage automatique et de connecter un utilisateur.

Défaillance de services:

Sous Windows NT 4.0, il n'existe aucune manière de prévenir les utilisateurs qu'un service est défaillant, ainsi, les administrateurs doivent obligatoirement utiliser des utilitaires comme ServiceKeeper pour surveiller l'exécution des services. Sous Windows 2000, le SCM expose quelques méthodes de détection de panne et de réparation : vous pouvez configurer les services, grâce aux propriétés FailureAction et FailureCommand pour que le SCM entreprenne des actions de réparation (Redémarrage du service, du système, Lancement d'un programme externe).

D'autres méthodes de détection de panne, de réparation mais aussi de notification sont implémentées par ServiceKeeper. Les propriétés de ces méthodes sont stockées dans la base de registres dans la clef : HKEY_LOCAL_MACHINE\SOFTWARE\Active+\ServiceKeeper\Services. Toutes ces méthodes sont configurables au travers de Service+ et du composant enfichable MMC "Services" de gestion des services.

Arrêt du système d'exploitation :

Lors de l'arrêt de l'ordinateur, le système utilise la routine CSRSS pour notifier à tous les processus actifs qu'un arrêt est en cours. CSRSS laisse à chaque processus un délai maximum "WaitToKill" pour lui permettre de s'arrêter correctement. Quand le SCM est notifié de l'arrêt de l'ordinateur, il le communique aux services nécessitant une notification de l'arrêt de l'ordinateur pour nettoyer les ressources et utilise un délai spécifique pour permettre au service de s'arrêter correctement. Le SCM enregistre le "Wait Hint", la valeur qu'il utilise pour décréter qu'un service ne répond plus, et laisse le "Wait Hint" maximum au service pour s'arrêter.

Si le délai de "Wait Hint" est dépassé sans que le processus ne se soit arrêté, le SCM vérifie si un autre service a reporté l'information de l'arrêt en cours. Ensuite, le SCM attend de nouveau le délai maximum spécifié par les "Wait Hint", et répète ainsi le scénario jusqu'a l'arrêt des processus ou jusqu'à ce que le CSRSS atteigne le délai de "WaitToKill". Dans ce cas, l'arrêt continue sans le SCM et sans que les processus de service ne se soient arrêtés. L'administrateur peux augmenter le délai "WaitToKillServicesTimeout" dans HKEY_USERS\.DEFAULT\ControlPanel\Desktop\WaitToKillApp pour être sûr que les services s'arrêtent proprement.

Pour plus d'informations sur ce sujet, veuillez vous reporter à l'article Inside Win32 Services de Marc Russinovich.

Voir aussi

Overview
Les Services
Paramétrage des Services
Les Processus de Services
Le SCM
Le Cycle d'Exécution

© ©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Installer votre licence

Installer votre nouvelle licence

Lorsque vous téléchargez et installez un logiciel Active+ Software, vous bénéficiez d'une licence gratuite de 30 jours vous permettant d'évaluer chaque produit à votre guise. Lorsque vous décider d'acheter le produit Active+ software vous fournit un nouvel identifiant et une nouvelle clef. Il vous faut enregistrer ces informations dans le logiciel.

Pour installer votre nouvelle clef

  • Pour installer votre nouvelle clef, ouvrez la Console Service+ depuis le menu Outils d'administration ou le raccourci Service+ présent sur le bureau.
  • Sélectionnez le noeud Service+ dans l'arborescence.
  • Cliquez avec le bouton droit de la souris et choisissez Toutes les tâches/Enregister une nouvelle clef.


Mises à jours des Logiciels

Mises à jour des Logiciels

Connexion au site d'Active+ Software pour consulter les dernières versions de nos logiciels...

©1997-2007 Active+ Software . Toutes les marques citées sont la propriété de leurs ayants droit. Envoyez vos remarques.


Ecrire dans un fil RSS

Cette méthode de notification permet à un administrateur d'être notifier au travers de son lecteur de fils RSS des évènements qui sont intervenus sur son système surveillé par ServiceKeeper.

Pour éditer une notification 'Ecrire dans un fil RSS'

1. Depuis la liste des notifications sélectionnez Ecrire dans un fil RSS et cliquez sur le bouton Propriétés [image] ou double-cliquez sur la notification.

  • Fichier du fil RSS : chemin d'accès au fichier RSS (XML) qui contient le fil. Pour pouvoir consulter le journal depuis l'extérieur, le fichier doit être placé dans un répertoire accessible depuis un site web. On peut utiliser un chemin UNC pour stocker le fichier sur un serveur distant. Si le fichier n'existe pas, il sera créé automatiquement; s'il existe, les événements seront ajoutés à la fin du fichier.
  • Message : vous pouvez entrer un message personnalisé qui sera envoyé lors de la notification. Certains mots-clef, reconnus par ServiceKeeper peuvent être insérés dans votre message. Ces mots-clef seront remplacés par ServiceKeeper avant d'envoyer le message. La liste des mots-clef disponibles est la suivante :
    • %ErrorMessage% : le message généré automatiquement par ServiceKeeper
    • %Date% : la date à laquelle la notification a été lancée
    • %Time% : l'heure à laquelle la notification a été lancée
    • %StartMonitoringDate% : la date à partir de laquelle la ressource a commencé à être surveillée
    • %UpTime% : la durée pendant laquelle la ressource surveillée a été en marche
    • %DownTime% : la durée pendant laquelle la ressource surveillée a été en panne
    • %Availability% : le pourcentage de disponibilité (100 * UpTime) / (UpTime + DownTime) de la ressource surveillée
    • %LastKnownRunningState% : la date à laquelle la ressource surveillée a été détectée en marche pour la dernière fois
    • %LastFailureDate% : la date à laquelle est survenue la dernière panne
    • %FailureCount% : le nombre de panne détectées sur la ressource surveillée
    • %FailureCountSinceRestart% : le nombre de panne détectées sur la ressource surveillée depuis le redémmarrage de ServiceKeeper
    • %LastSucceededRecoveryDate% : la date de la dernière tentative de réparation réussie
    • %LastFailedRecoveryDate% : la date de la dernière tentative de réparation qui a échouée
    • %FailedRecoveryCount% : le nombre de tentatives de réparation qui ont échouées
    • %FailedRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont échouées depuis le redémmarrage de ServiceKeeper
    • %SucceededRecoveryCount% : le nombre de tentatives de réparation qui ont réussies
    • %SucceededRecoveryCountSinceRestart% : le nombre de tentatives de réparation qui ont réussies depuis le redémmarrage de ServiceKeeper
    • %Running% : 1 si la ressource surveillée est en marche au moment de la notification (0 si elle est en panne)
    • %Failure% : 1 si une panne a été détectée au moment de la notification (0 si pas de panne)
    • %RecoverySucceeded% : 1 si la tentative de réparation a réussi (0 si la tentative de réparation a échouée ou si aucune réparation n'a été tentée)
    • %RecoveryFailed% : 1 si la tentative de réparation a échoué (0 si la tentative de réparation a réussi ou si aucune réparation n'a été tentée)

Voir aussi

Envoi d'un email (SMTP)
Envoi d'une alerte administrative
Lancer un exécutable
Envoi d'un trap SNMP
Exécuter un script
Ecrire dans un journal d'évènements HTML
Notification vocale (Expérimentation)
Paramétrer les notifications