Fichier d'Aide eMill

Bienvenue sur l'aide d'eMill®

Merci d'avoir choisi eMill pour la gestion de vos projets d'emailing.

Pour utiliser l'aide d'eMill, ils vous suffit de naviguer à travers l'arborescence à gauche ou de cliquer sur les onglets "Recherche" ou "Index". Si vous souhaitez voir apparaître des compléments d'information dans l'aide d'eMill, n'hésitez pas à nous faire part de vos commentaires par email.

Pour nous contacter :

Service Commercial : ventes@activeplus.com

Assistance Technique : support@activeplus.com

Rubriques principales du fichier d'aide :

Présentation d'eMill
Création d'un Nouveau Projet de Publipostage
Éditer le contenu du message
Éditer les listes de destinataires
Expédition du Projet
Suivi des messages
Fax
Guide des Scripts Serveur
Modèles de Scripts Serveur
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configuration et Installation

1. Configuration requise

L'utilisation d'eMill requiert différents composants du système Windows et plusieurs modules inclus avec Internet Explorer 6.0 ou ses versions supérieures.

En installant eMill votre système d'exploitation sera contrôlé et les ressources manquantes seront indiquées ou installées.

Les composants et modules utilisés sont :

  • Systèmes d'exploitation: Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows 2008, Windows 2008 R2, versions 32-bit & 64-bit.
    Note : Seul eMill Professionnel peut être installé sur Windows XP Home. Le module eMill Fax et le client web eMill ne peuvent pas être installés sur des systèmes d'exploitation 64 bits.
  • Internet explorer 6.0 ou ultérieur : visualisateur et éditeur html (composants du système).
  • Windows Scripting Host (WSH) : moteur de script VBScript
  • Microsoft Data Access Component (MDAC) : inclus ActiveX Data Object (ADO) et les fournisseurs OLE DB de plusieurs bases de données (SQL Server, Oracle, etc.). Jet 4.0 est nécessaire mais n'est plus inclus avec MDAC version 2.6 et supérieures (sera installé).
  • Programmeurs : si vous avez l'intention d'utiliser les fonctions script d'eMill de façon intensive, vous devez installer soit Visual InterDev soit Microsoft's Script Debugger pour déboguer vos scripts (optionnel).
  • Applications incorporées : les fichiers en format standard envoyés en attachement (ex : fichiers Word ou Excel) peuvent être édités à partir de la Fenêtre Conception d'eMill
  • Format PDF : Acrobat Reader® 5.0 ou supérieur doit être installé pour afficher le contenu du message créé en PDF. La dernière version est disponible sur le site Adobe.
  • eMill Fax : Le service de télécopie Microsoft est nécessaire pour utiliser eMill Fax. Si ce composant n'est pas détecté, il sera installé par eMill.
  • Microsoft .NET Framework v2.0: nécessaire à l'utilisation du Client Web d'eMill (téléchargé et installé lors de l'installation d'eMill).
  • Services Internet (IIS) 5.0 ou versions ultérieures: nécessaire à l'installation du Redirecteur eMill (suivi des messages), à l'affichage des statistiques de suivi des messages et à l'utilisation du Client Web d'eMill. IIS sera automatiquement installé par le programme d'installation d'eMill.

2. Installation d'eMill

Le programme d'installation d'eMill va installer selon l'édition dont vous disposez et vos préférences : le serveur eMill, le client Windows eMill, le client Web eMill ainsi que les modules eMill Fax et eMill SMS.

  • Lancez le programme d'installation :
    - Si vous avez téléchargé le fichier 'Self-extractible', faites un double clic sur eMillEnterpriseSetup.exe ou eMillProfessionnalSetup.exe.
    - Si vous avez téléchargé le fichier 'Zip', dézippez le dossier eMillEnt.zip ou eMillPro.zip et faites un double clic sur setup.exe.
  • Fenêtre de bienvenue : Démarrez l'installation en cliquant sur 'Suivant'.
  • Accord de licence : Consultez le contrat de licence, sélectionnez 'J'accepte les termes de ce contrat de licence' et cliquez sur 'Suivant'.
    Si vous souhaitez un complément d'informations sur le contrat de licence, n'hésitez pas à nous contacter.
  • Clé d'enregistrement : Entrez le code client et la clé qui vous ont été envoyés lors de l'achat d'eMill.
  • Répertoire d'installation : Par défaut, eMill est installé dans le répertoire C:\Program Files\Active+\eMill.
  • Type d'installation : Le logiciel eMill se compose d'un serveur qui génère, envoie et reçoit les messages ainsi que d'un client eMill qui permet de créer et de gérer les campagnes.
    Si vous installez eMill pour la première fois, sélectionnez 'Serveur eMill et ses composants' pour lancer une installation complète. Si vous souhaitez installer uniquement le client eMill et vous connecter à un serveur eMill déjà installé (accessible depuis le réseau local ou distant), sélectionnez 'Client Windows eMill' et entrez le nom du serveur eMill auquel vous souhaitez vous connecter.
  • Composants Serveur eMill : Sélectionnez les composants que vous souhaitez installer:
    - Serveur eMill : Génère, envoie et reçoit les messages. Il est nécessaire au fonctionnement d'eMill.
    - Client Windows eMill : Permet de créer et de gérer ses campagnes. Il est nécessaire au fonctionnement d'eMill.
    - Client Web eMill : Permet de créer et de gérer ses campagnes à distance à partir d'un simple navigateur internet. Son installation nécessite IIS (Services Internet). Ce composant sera automatiquement installé par le programme d'installation d'eMill mais n'est pas disponible dans les éditions familiales des systèmes d'exploitation Windows.
    - Option Fax eMill : Permet de diffuser et de gérer des campagnes de mailing fax. Son installation nécessite le Service de Télécopie. Il sera automatiquement installé par le programme d'installation d'eMill.
    - Option SMS eMill : Permet de gérer des campagnes de mailing SMS et de se connecter à des prestataires externes pour les diffuser.

La connectivité est également importante, si vous utilisez eMill en interaction avec d'autres systèmes au travers de réseaux locaux ou distants, assurez-vous d'avoir un accès Internet adéquat et/ou les droits utilisateurs sur des bases de données spécifiques situées sur d'autres machines en réseau. Contactez votre administrateur réseau si l'accès vous est refusé.

Connexion à un serveur eMill distant : Si vous souhaitez qu'un client Windows puisse se connecter à un serveur eMill distant, vous devez ouvrir le port TCP 2156 sur la machine sur laquelle le serveur eMill est installé. Sous Windows XP SP2 et Windows 2003 (Pare-feu Windows), une exception nommée 'eMill' est automatiquement ajoutée au pare-feu par le programme d'installation d'eMill.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Présentation d'eMill

Les 3 étapes clés de création d'un projet d'emailing

La conception | La publication | L'envoi
  • Création du contenu de votre message
  • Édition des listes de destinataires
  • Édition des listes noires
  • Personnalisation de votre projet d'emailing
 Une fois la conception de votre projet achevée, l'étape de publication consiste à envoyer votre projet d'emailing du client eMill vers le serveur eMill Cette partie finale est accessible à partir de la fenêtre files d'attente. Elle permet de générer les messages pour chaque destinataire, de les envoyer et de recevoir les réponses ou les courriers non délivrés.
Client eMill | Serveur eMill

1. La Conception

- Éditer le contenu du message : eMill possède un éditeur intégré qui vous permet de créer le corps du message dans les 2 formats supportés par les clients mail Internet : HTML et Texte. L'éditeur génère toutes les balises HTML courantes nécessaires à la finalisation du contenu. Les contenus HTML peuvent être édités et modifiés en utilisant votre application favorite.

- Éditer les listes de destinataires : Vous pouvez vous connecter aux bases de données de la plupart des formats existants. Vous pouvez également créer une nouvelle base spécifique à votre projet, importer des adresses du presse-papiers ou de fichiers non formatés. L'éditeur vous permet d'ajouter, de modifier ou de supprimer chaque enregistrement individuellement.

- Personnalisation : La personnalisation de votre projet d'emailing peut se faire de 3 façons :

  • Insertion de champs de votre source de données
  • Activation des contenus selon vos conditions

  • Insertion de script via l'interface script

- Éditeur de script : eMill utilise des scripts pour accéder aux sources de données. Ces scripts sont générés par les assistants de projet et modifiés selon les instructions données par des boîtes de dialogue. Les utilisateurs familiers avec VBScript peuvent éditer directement le script du projet afin de personnaliser davantage les contenus. Des événements script, qui seront appelés pendant le traitement du mailing, peuvent également être ajoutés. Des exemples de scripts sont disponibles pour les utilisateurs non familiers avec le scripting.

2. La Publication

A la conception du projet, eMill génère une arborescence et sauvegarde les fichiers dans des formats courants (txt, html, vbs, mdb,...). Un travail en collaboration requérant des applications externes est possible au stade de la conception.

Une fois la conception terminée, une nouvelle arborescence est publiée, affichant tous les fichiers qui seront utilisés pour l'envoi, et les files d'attente (dossiers de messages) sont générées. Quand le projet est publié, il est en instance d'expédition et ne peut plus être édité. Les modifications doivent être faites à partir des fichiers de pré-publication (étape de conception) et le projet doit être publié à nouveau.

3. L'envoi

Cette étape est gérée par 2 composants principaux :

- Le générateur : Il crée les messages pour chaque destinataire et les stocke dans la boîte d'envoi d'eMill. Pour cela, il fusionne tous les fichiers, prépare les en-têtes, encode le contenu en format MIME, intègre les attachements, convertit les contenus en PDF (optionnel), et génère les fichiers email (EML).

- L'expéditeur : Il livre les messages générés et affiche leur départ en temps réel dans la file d'attente. Vous pouvez intervenir durant la transmission : mettre en attente, abandonner, relancer, planifier, puis, une fois tous les envois exécutés, consulter les statistiques. Les messages sont soit livrés directement sur le serveur mail de chaque destinataire soit relayés vers des serveurs SMTP externes ou d'entreprise. Lors de l'expédition, il est possible d'équilibrer les charges sur plusieurs serveurs.

Les composants d'eMill

  • Serveur eMill : Le serveur eMill génère, envoie et reçoit les emails. Il s'exécute en tâche de fond en tant que service Windows (emillsrv.exe). Il démarre automatiquement en utilisant le compte système et joue le rôle de serveur. Ainsi, il permet à d'autres utilisateurs du réseau de publier leurs projets sur cette machine, en fonction des permissions accordées. L'administration du Serveur eMill se fait via le composant Services du panneau de configuration (Démarrer/Paramètres/Panneau de configuration/Services).
  • Redirecteur eMill : Il vous permet d'enregistrer les informations concernant le suivi des messages comme les taux d'ouverture et de clics. Ces informations sont ensuite collectées par le serveur eMill qui vous affiche les statistiques de suivi des messages. Le redirecteur eMill s'intégre au serveur Web Microsoft Internet Information Server (IIS) sous la forme d'une DLL ISAPI. La configuration du redirecteur eMill se fait via le composant logiciel enfichable d'IIS (Démarrer/Programmes/Outils d'administration/Gestionnaire des Services Internet).
  • Fax : Le module fax d'eMill vous permet d'intégrer l'envoi et la réception de télécopies au coeur de vos projets et de combiner efficacement emailing et mailing fax. Vous profitez aussi de la flexibilité d'eMill pour la réception de fax par email en format Adobe Acrobat PDF ou TIFF (format image).

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Création d'un Projet de Publipostage

Création d'un nouveau projet de publipostage

Pour créer un nouveau projet d'emailing, vous pouvez :

  • Lancer l'assistant Nouveau Projet de Publipostage, une série de boîtes de dialogue qui vous guide pour les configurations de base. Tous les paramètres et les fichiers créés par l'assistant demeurent accessibles et peuvent être modifiés à tout moment. Si vous désirez démarrer un projet à partir d'un fichier email reçu par Internet, l'assistant Nouveau Projet de Publipostage vous permet d'utiliser le modèle de message optionnel.
  • Dupliquer un projet existant à partir du menu Fichier en sélectionnant Dupliquer le projet sous.
  • Créer un nouveau projet mailing vide.

Après la création de votre nouveau projet, ajoutez un nouveau contenu en utilisant les éditeurs intégrés d'eMill ou votre application favorite. Si vous désirez importer des fichiers existants, utilisez l'option nouveau contenu à partir d'un fichier.

Vous avez également la possibilité d'utiliser uniquement eMill en tant qu'éditeur en créant un nouveau fichier HTML ou Texte ou un nouveau fichier script. Vous pourrez ensuite inclure ces fichiers à un projet en utilisant l'option nouveau contenu à partir d'un fichier.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Créer un nouveau projet

Il est recommandé de démarrer en utilisant cette option. En effet, créer un nouveau projet va générer un fichier interne qui comporte l'emplacement et le nom de toutes les ressources liées au projet.

A partir du menu Fichier/Nouveau, sélectionnez l'option Projet Mailing, puis OK.

Les 3 boîtes de dialogue suivantes vont créer l'arborescence des contenus du projet (fichiers éditables), et établir la connexion entre votre projet et la source de données fournissant les enregistrements (liste de destinataires).

  • Nommez votre projet, validez le chemin par défaut ou choisissez-en un nouveau, cliquez sur Suivant.

  • Complétez le champ De : nom de l'expéditeur du mailing et adresse email, visibles par les destinataires.
  • Entrez le sujet de votre message, puis cliquez sur Suivant :

  • Sélection de la source de données :
    L'assistant vous demande de sélectionner la source de données qui vous permettra d'établir la liste des destinataires. Vous avez le choix entre plusieurs options : créer une base de données si vous n'en avez pas, se connecter à une base de données (Excel, Access, Carnet d'adresses ou Contacts Outlook), se connecter à une base de données par ADO Avancées (Oracle, SQL Server,..), se connecter à une source de données XML (format XML ADO), se connecter à une base MySQL ou importer les adresses à partir de fichiers ou du presse-papiers. Si vous utilisez eMill pour la première fois, vous pouvez sélectionner la dernière option Je n'ai pas de base de données, en créer une, ceci terminera le travail de l'assistant.
  • Sélection des tables/requêtes et association des champs : voir Éditer les listes de destinataires

Projet mailing vide :

Cette option n'utilise pas l'assistant et vous permet de générer directement le dossier du projet et les fichiers par défaut milset.vbs et .mil. Vous pouvez spécifier ensuite le contenu des fichiers et les sources de données que vous désirez utiliser.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Créer un nouveau fichier contenu

Créer un nouveau fichier HTML ou texte

Vous avez la possibilité d'utiliser eMill comme un éditeur traditionnel texte ou HTML en créant un nouveau fichier à partir de l'assistant Nouveau Document.

  • A partir du menu Fichier/Nouveau, sélectionnez l'option Fichier HTML ou Fichier texte, puis OK

Un nouveau fichier apparaît dans l'éditeur de contenus d'eMill. Tant que le fichier n'est pas encore relié à un projet, certaines fonctions de l'éditeur ne sont pas disponibles.

Attacher le fichier à un projet : pour avoir accès à toutes les fonctionnalités et afficher le fichier dans la fenêtre conception, il faut sauvegarder le fichier sur votre disque et l'inclure dans un projet en utilisant l'option nouveau contenu à partir d'un fichier.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Créer un nouveau fichier script

eMill est pourvu de fonctionnalités de script serveur que vous pouvez utiliser optionnellement pour une personnalisation encore plus importante des contenus ou pour intégrer votre solution de publipostage à un autre logiciel d'entreprise. Les scripts ne sont pas envoyés avec les messages mais exécutés par le serveur qui s'en sert pour générer une partie du contenu. Vous pouvez inclure des scripts au contenu des messages au moment de la création ou les insérer plus tard. Le fait de créer les scripts indépendamment du contenu peut être utile si la mise en page, les graphiques et le corps du texte proviennent d'une source externe.

  • A partir du menu Fichier/Nouveau, sélectionnez l'option Fichier VBScript, puis OK. Un nouveau fichier script apparaît dans la fenêtre de l'éditeur texte. Vous pouvez commencer la rédaction du script.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Utiliser un modèle

Vous pouvez créer un nouveau projet à partir d'un fichier email existant : en définissant ce fichier en tant que modèle, eMill extraira des parties MIME, les contenus éditables du message et les sauvegardera dans le dossier du projet, prêts à être édités. Cette fonctionnalité est utile si vous désirez travailler à partir d'emails précédemment reçus ou envoyés, incluant des contenus avec des mises en page complexes.

  • A partir du menu Fichier/Nouveau, sélectionnez l'option Projet Mailing, puis OK. Nommez le projet et indiquez dans le navigateur l'emplacement de l'email à décoder, en utilisant l'option Plus de fichiers ou en sélectionnant un modèle dans la liste.
Note : Vous pouvez créer vos propres modèles de message avec n'importe quel logiciel capable de générer des fichiers MIME (fichier .eml pour Outlook Express ou Thunderbird par exemple). Placez ensuite ces modèles de message dans le dossier "\Program Files\Active+\eMill\Templates"
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Définir les options de la messagerie

Définir les Options d'eMill

La configuration des options d'eMill correspondent aux configurations générales qui seront valables pour l'ensemble de vos projets d'emailing. Les options d'eMill incluent :

- Options générales : Elles vous permettront d'adapter eMill à vos besoins et à votre utilisation.

- Paramètres par défaut : Ils correspondent à l'en-tête par défaut pour l'ensemble de vos projets. Vous pourrez ensuite spécifier l'en-tête pour chaque projet dans les propriétés de l'en-tête. Il est important de préciser, qu'avec eMill, les informations concernant l'adresse de l'expéditeur ou les informations sur le serveur ne sont pas cachées. Tous les emails envoyés avec eMill sont "traçables", il est donc INUTILE d'utiliser eMill pour des envois abusifs ou illégaux.

- Files d'attente sortantes : Elles vous permettent de spécifier quel(s) serveur(s) SMTP vous souhaitez utiliser pour envoyer les messages.

- Files d'attente entrantes : Elles vous permettent de spécifier quel(s) compte(s) mail vous souhaitez utiliser pour recevoir les réponses ou les courriers non délivrés. Vous pourrez ensuite associer pour chaque projet publié une ou plusieurs files d'attente entrante et décider du traitement de ces messages.

- Options avancées : Elles spécifient le(s) serveur(s) DNS utilisé(s) et le domaine SMTP de l'expéditeur.

- Comptes utilisateurs : L'accès au serveur eMill est déterminé par les comptes eMill. Les comptes eMill contiennent des projets publiés et possèdent une liste d'utilisateurs avec des droits associés.

- Suivi des messages : Spécifie les adresses URL utilisées par le module de suivi des messages.

- S/MIME : Spécifie les certificats utilisés pour l'envoi de messages sécurisés (signature électronique et cryptage)

- SMS : Spécifie les configurations générales pour l'utilisation du module SMS d'eMill.

- Fax : Spécifie les configurations générales pour l'utilisation du module fax d'eMill.

- Stockage : Spécifie dans quelles bases de données les messages et les statisques seront stockés.

- Clés DKIM : Permet de configurer les clés de signature DKIM.

ATTENTION : il existe une législation spécifique à la protection de la vie privée dans certains pays, relative à l'utilisation commerciale des emails. Faites attention aux nombreux règlements existants dans certains pays concernant :
  • Les emails non sollicités
  • Les informations au sujet du nom de l'expéditeur et du routeur
  • Les informations trompeuses de l'en-tête d'un email
  • L'origine des messages et le chemin utilisé pour la transmission
  • Le nom légal et l'adresse physique de l'expéditeur
  • La date et l'heure affichées sur le message
  • Les restrictions de contenu (ex : contenu à caractère sexuel)
  • L'utilisation et le stockage de l'information concernant les individus

Il est possible que les conditions légales d'envoi puissent outrepasser votre législation locale. Si vous êtes dans l'incapacité de déterminer précisément la destination des messages envoyés, il est conseillé de vous conformer aux lois les plus restrictives.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configuration des options générales

  • A partir du menu Outils/Options, cliquez sur l'onglet Général.
  • Sélectionnez vos options de Démarrage d'eMill.
  • Cochez l'option Rechargement automatique des fichiers... pour recharger l'éditeur avec les fichiers sauvegardés les plus récents : eMill ne ferme pas les fichiers qui ont été ouverts dans son éditeur afin de permettre un travail en collaboration.
  • Cochez l'option Ajouter la date et l'heure au journal d'évènements du projet afin que chaque évènement du journal du projet publié soit précédé de la date et de l'heure de l'évènement.
  • Double-clique : détermine l'action effectuée lors d'un double-clic sur un enregistrement de la liste des destinataires. Vous pouvez éditer l'enregistrement ou obtenir un aperçu du message.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configuration des options par défaut

Configuration des paramètres par défaut

Si les informations suivantes sont manquantes ou incorrectes, les filtres anti-spam peuvent compromettre la livraison de vos messages. L'adresse de l'expéditeur doit obligatoirement être précisée.

  • A partir du menu Outils/Options, cliquez sur l'onglet Paramètres par défaut.

  • Entrez l'adresse De : adresse email de l'expéditeur des messages.
  • Entrez l'adresse Répondre à : adresse email à laquelle reviennent les réponses. Vous n'avez pas besoin de spécifier cette adresse si elle est identique à celle du champ "De".
  • Entrez le nom de votre Société ou votre nom tel qu'il apparaîtra dans l'en-tête.
  • Sélectionnez le Jeu de Caractères du contenu du message. eMill est capable de la reconnaître à partir des paramètres de votre système. Si votre message contient plusieurs langages, sélectionnez Unicode UTF-8 dans le menu déroulant.
Format des adresses email : utilisez la syntaxe suivante pour entrer les adresses :
"Prénom Nom" <xyz@rien.com>
ou cliquez sur le bouton à droite du champ texte et utiliser le "composeur d'adresse email"

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configuration des files d'attente sortantes

Pour envoyer vos messages, vous devez disposer d'un serveur SMTP qui assure le transport du courrier sur Internet. La configuration des files d'attente sortantes permet de décider quel serveur SMTP vous souhaitez utiliser.

  • A partir du menu Outils/Options, cliquez sur Files d'attente sortantes.

    La liste affiche l'ensemble des serveurs SMTP relai et des serveurs SMTP intégrés utilisables pour envoyer les messages. Le nombre de serveurs que vous pouvez ajouter dépend de la license d'eMill.

  • Cochez/décochez la case Simulation pour tester le processus de l'expédition : la session SMTP sera lancée et la commande RSET envoyée pour abandonner la transmission. Les messages apparaîtront comme envoyés dans les files d'attente, mais les destinataires ne recevront rien.

Ajouter un serveur :

  • Cliquez sur le bouton Ajouter. La boîte de dialogue Ajouter une file d'attente sortante apparaît.

  • Cochez/décochez la case Activé pour autoriser ou non eMill à utiliser ce serveur pour envoyer des messages. Si plusieurs serveurs sont activés pour une même expédition, l'équilibrage des charges sera déterminé automatiquement par leur capacité de traitement et leur disponibilité.
  • Entrez un nom unique désignant la file d'attente. Ce nom peut ensuite être utilisé pour restreindre l'usage de cette file d'attente à certains projet ou à tous les projets d'un compte.
  • Entrez le Nombre de connexions. Ce paramètre détermine le nombre maximum de messages qui peuvent être envoyés simultanement. Afin d'en déterminer le nombre optimal, commencez par 8 puis augmentez la valeur au fur et à mesure que la limite du serveur ou de la bande passante est atteinte. 14 doit correspondre à des performances correctes lors de l'utilisation d'un serveur relai, une valeur de 50 ou plus devrait donner de bons résultats en mode livraison directe. Veuillez noter totefois qu'une valeur trop élevée pourrait diminuer l'efficacité.
  • Choisir le Mode d'envoi de la file d'attente sortante. En mode Livraison directe, eMill se connectera directement aux serveurs SMTP des destinataires via son serveur SMTP intégré pour délivrer le message. Ce mode de fonctionnement nécessite cependant certains paramètrages assez avancés, veuillez consulter la section Questions/Réponses du site Internet afin connaître les limitations qui peuvent s'appliquer à l'utilisation du serveur SMTP intégré. En mode Envoi via un serveur SMTP relai, eMill enverra les messages à un serveur SMTP de votre choix qui se chargera de la livraison finale du message.
  • Entrez le nom de l'adresse du Serveur relai (ex. : smtp.domaine.fr) ou l'adresse IP du serveur. Si vous souhaitez utiliser le serveur de votre fournisseur d'accès Internet (FAI), le nom du serveur est indiqué dans le courrier reçu lors de votre inscription.
  • Entrez un Port de connexion au serveur relai. Le port standard pour les serveurs SMTP est 25. Cependant, le port 587 est de plus en plus utilisé pour les connexions sécurisés (par exemple, pour utiliser les serveurs SMTP de Free, Orange ou Télé2 vous devez utiliser le port 587).
  • Sélectionnez la méthode d'Authentification et entrez les informations nécessaires à l'ouverture de session.
    • Non : Système le plus utilisé. Cela signifie que vous n'avez pas besoin d'un nom d'utilisateur et d'un mot de passe pour vous connecter au serveur SMTP. Ce dernier vous authentifie en détectant votre adresse IP ou le nom de domaine de l'expéditeur du message.
    • Compte (texte en clair) : Système de plus en plus utilisé. Cette méthode s'applique dans le cas où le serveur SMTP utilisé nécessite un nom d'utilisateur et un mot de passe envoyé sans cryptage. Par exemple, pour utiliser le serveur SMTP de Free, Orange ou Télé2, il vous faut sélectionner cette option et indiquer votre identifiant de messagerie et votre mot de passe de messagerie qui vous ont été communiqués lors de votre inscription.
    • Compte POP3 : Système peu utilisé. Cette méthode s'applique dans le cas où le serveur SMTP vous authentifie en vérifiant si vous pouvez ouvrir une session POP avant une session SMTP.
    • Sécurité Windows (compte du processus) : Système peu utilisé. Utilise le compte avec lequel le serveur eMil est lancé (par défaut, le compte système) pour vous s'authentifier au près du serveur SMTP.
    • Sécurité Windows (compte spécifique) : Utilise un compte Windows spécifique pour vous authentifier. Sélectionnez cette méthode si vous utilisez Exchange Server pour envoyer les messages. Indiquez ensuite un nom et un mot de passe d'un compte utilisateur connu d'Exchange.
    Si vous ne savez pas quelle méthode d'authentification utiliser, veuillez contacter votre administrateur système.

Paramètres avancés :

  • Cliquez sur l'onglet Avancés de la boîte d'ajout ou de modification de file d'attente sortante :

  • Le Nom d'hôte est le nom présenté par eMill lors de la connexion au serveur SMTP distant. Si ce paramêtre est absent, le nom complet (FQDN) de la machine sera utilisé à la place. Dans le cas de l'utilisation du serveur SMTP intégré, il est important que ce nom corresponde au nom fournis pas une résolution DNS inverse de l'addresse d'émission.
  • La liste Liaison IP permet de spécifier l'addresse IP qui sera utilisée pour envoyer les messages. Par défaut, l'addresse est choisie automatiquement. Dans le cas d'un serveur avec plusieurs interfaces réseau ou plusieurs addresses IP, il peut être intéressant ou nécessaire de spécifier la ou les addresses d'émission.
  • La limitation Nombre maximum de messages par minute permet de limiter le débit de cette file d'attente. Certain founisseur d'accès Internet imposent ce genre de limitation.
  • Lorsque la limitation Nombre maximum de messages par session est activée, la file d'attente coupera la connexion au serveur SMTP relai et la réouvrira à chaque fois que le nombre de message sélectionné sera envoyé. Cette option n'a aucun effet sur le serveur SMTP intégré.

Modifier un serveur :

  • Sélectionnez un serveur dans la liste et cliquez sur Modifier.
  • Modifiez les informations dans la boîte de dialogue Modifier une file d'attente sortante (voir la procédure ci-dessus).

Supprimer un serveur :

  • Sélectionnez un serveur dans la liste et cliquez sur Supprimer.
Sécurité : certains serveurs mail proposent diverses stratégies pour limiter les risques d'utilisation incorrecte (ex : réussir à ouvrir une session POP avant une session SMTP). Vérifiez avec votre administrateur réseau si vous rencontrez des problèmes avec vos serveurs mail sortants.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configuration des files d'attente entrantes

eMill vous permet de collecter les réponses à vos emailings, de les stocker dans la boîte d'arrivée et de traiter ces messages. Pour cela vous devez suivre 3 étapes :

- Configuration des files d'attente entrantes : Pour recevoir les réponses ou les messages non délivrés (NPAI/DSN/Bounces) et les stocker dans le dossier Boîte d'arrivée d'eMill, vous devez spécifier sur quel compte mail eMill doit collecter ces emails. La configuration des files d'attente entrantes permet au serveur eMill d'aller récupérer des emails reçus sur un compte POP3 (client mail) ou dans un dossier. La configuration des files d'attente entrantes se fait au niveau du serveur eMill, elles sont donc communes à tous les utilisateurs d'eMill et à tous les projets.

Exemple : Si vous attendez des réponses de votre campagne sur l'adresse ventes@entreprises.fr alors vous donnez à eMill les détails concernant le compte où arrive ces emails (compte POP3).

- Associez votre projet publié aux files d'attente correspondantes : Après publication de votre projet, vous devez spécifier quelle file d'attente entrante (compte POP3 ou dossier) doit être utilisée pour collecter les réponses. Il est possible d'associer un projet à plusieurs files d'attente entrantes si vous devez collecter des réponses sur plusieurs comptes mails ou sur plusieurs dossiers.

- Traitement des messages entrants : Une fois les emails collectés par eMill, vous pourrez décider des règles de traitement de ces messages à travers la fenêtre Règles de Message (réexpédier, mise à jour des bases de données, gestion des inscriptions/désinscriptions,...).

  • A partir du menu Outils/Options, cliquez sur l'onglet Files d'attente entrantes :

Liste des files d'attente entrantes :

La liste affiche toutes les files d'attente entrantes en cours, avec leur état et leur configuration.

Ajouter une nouvelle file d'attente entrante :

  • Cliquez sur Ajouter. La boîte de dialogue File d'attente des messages entrants apparaît :
  • Entrez le Nom de la file d'attente et l'Intervalle de scrutation des emails (fréquence de récupération des emails). Le nom vous aidera à identifier la source quand vous inscrirez votre projet aux files entrantes.
  • Sélectionnez une méthode : accès POP3 ou chemin d'accès aux fichiers (voir note en bas de page).

Réception de fax : Au lancement du serveur eMill, une file d'attente entrante fax est automatiquement créée. Celle-ci permet de spécifier à eMill que les fax reçus sont stockés dans un dossier (par défaut Program Files\Active+\eMill\Fax\Inbox).

Modifier une file d'attente entrante :

  • Sélectionnez une des files d'attente de la liste et cliquez sur Modifier.
  • Modifiez les informations dans la boîte de dialogue File d'attente des messages entrants (voir la procédure ci-dessus).

Supprimer une file d'attente entrante :

  • Sélectionnez une des files et cliquez sur Supprimer.

Méthodes POP3 ou Chemin d'accès : si vous disposez d'un serveur de mail externe pour recevoir les messages, utilisez la connexion POP3 avec les mêmes paramètres qui seraient utilisés par un client mail pour télécharger les messages. Si le serveur de mail est sur un réseau local, il est plus efficace de fournir directement le chemin d'accès aux fichiers mail. Vérifiez avec votre administrateur réseau.
Notifications locales : Cette file d'attente entrante permet de recevoir des notifications locales lorsque vous utilisez le serveur SMTP intégré d'eMill et lorsque l'envoi d'un message est abandonné par eMill. Notez que pour créer ces notifications, vous devez cocher l'option "Générer des notifications de livraison localement" dans les propriétés des notifications.
Note : eMill laissera les messages sur le serveur. Les messages seront détruits après avoir été récupérés via l'événement OnAcceptMail de l'objet Mailing. Voir la section script global.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configurations des options avancées

Configuration des options avancées

  • A partir du menu Outils/Options, cliquez sur l'onglet Avancées :
  • Serveur(s) DNS : Le serveur DNS permet à eMill de connaître les adresses IP associées aux noms de domaine des destinataires lors de l'utilisation du Serveur SMTP intégré (mode direct) ou de connaître les adresses IP associées aux serveurs externes (mode relais).
    - Serveur DNS par défaut : eMill utilisera le ou les serveurs DNS configurés dans les options réseau de votre ordinateur. Cette option est généralement recommandée.
    - Utiliser un DNS spécifique : vous permet d'entrer directement l'adresse IP d'un serveur DNS spécifique.
    - Utiliser le service Web DNS d'Active+ Software : sélectionnez cette option si vous ne pouvez utiliser ni le(s) serveur(s) DNS par défaut ni un serveur DNS spécifique. Le service Web DNS étant plus lent, il est conseillé de ne l'utiliser qu'à des fins de dépannage.
  • Nom de l'IP inversée : Il est important de remplir correctement ce paramètre car il peut être utilisé par les serveurs de réception pour détecter les serveurs émetteurs de spams. Il correspond au nom qui est retourné lorsque vous lancez une requête d'IP inversée (voir note de bas de page) sur l'IP publique de la machine sur laquelle le serveur eMill est installé. Notez que si vous utilisez un serveur SMTP relais présent sur votre réseau local, vous n'avez pas besoin de renseigner cette information.
  • Simuler un serveur SMTP en réception : Cette option ne s'applique que dans le cas de l'utilisation du serveur SMTP intégré (mode direct). Si le serveur de réception vérifie l'existence du serveur d'envoi pour détecter les serveurs émetteurs de Spam, il va envoyer une demande à eMill (commande HELO). En cochant cette option, eMill répondra à cette demande.
Nom de l'IP inversée : Pour connaître le nom de l'IP inversée, vous pouvez contacter votre administrateur réseau ou suivre les étapes suivantes:
- Sous Windows, cliquez sur Démarrer > Exécuter
- Entrez 'cmd' et cliquez sur OK
- Ecrivez 'nslookup 192.168.100.1' (192.168.100.1 est à remplacer par l'adresse ip publique d'eMill)
- Le nom de l'ip inversée est celui inscrit en face de 'Nom :' (3ème ligne).
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configuration des comptes utilisateurs

Les versions Entreprise et Service Provider permettent de donner accès aux fonctionnalités d'eMill à des utilisateurs à travers le réseau local ou Internet. L'accès au serveur eMill est déterminé par les comptes eMill et se fait à travers une interface Windows ou Web. Les comptes eMill contiennent des projets publiés et possèdent une liste d'utilisateurs avec des droits associés.

Afin de pouvoir créer ou publier un projet, générer ou envoyer des messages, consulter les statistiques de suivi des messages, un utilisateur ou un groupe d'utilisateurs doit posséder les autorisations nécessaires sur le compte approprié.

  • A partir du menu Outils/Options, cliquez sur l'onglet Comptes :

Liste des comptes :

Cette liste affiche tous les comptes disponibles sur le serveur eMill installé sur la machine locale. Notez qu'il est nécessaire d'être administrateur sur la machine pour pouvoir administrer eMill.

En installant eMill, un compte Utilisateurs est créé par défaut et accorde tous les droits aux utilisateurs authentifiés sur cet ordinateur.

Pour limiter l'utilisation d'un serveur eMill, vous devrez supprimer ou modifier ce compte.

Ajouter un nouveau compte :

  • Cliquez sur Ajouter. La boîte de dialogue Ajouter un compte apparaît :
  • Entrez le Nom du nouveau compte et sa description.
  • Complétez les informations concernant le gestionnaire du compte. Ces informations ne sont pas obligatoires mais seront stockées dans la base de données des comptes. Par conséquent, il vous sera possible d'y accéder par script et de les utiliser pour produire des rapports sur l'activité des utilisateurs pour chaque gestionnaire de compte.

Attribution des autorisations aux utilisateurs :

  • Cliquez sur l'onglet Sécurité. L'utilisateur en cours (Session Windows) est affiché par défaut avec toutes les autorisations accordées.

  • Cliquez sur Ajouter pour ajouter un utilisateur ou un groupe d'utilisateurs au compte eMill :

La liste complète des utilisateurs de tous les domaines est affichée. Pour ajouter un utilisateur ou un groupe, sélectionnez-le dans la liste, cliquez sur Ajouter, puis sur OK.

  • Définissez les autorisations en cochant les cases correspondantes :
    • Création et suppression de projets : L'utilisateur peut visualiser l'ensemble des modules et enregistrer toutes ses modifications.
    • Visualiser les projets : L'utilisateur peut visualiser tous les modules excepté les files d'attente et les statistiques de suivi des messages. Les modifications effectuées dans le projet ne peuvent pas être sauvegardées.
    • Modifier les projets : L'utilisateur peut visualiser tous les modules excepté les files d'attente et les statistiques de suivi des messages. Les modifications effectuées dans le projet peuvent être sauvegardées.
    • Visualiser des messages : L'utilisateur peut uniquement afficher les messages contenues dans les files d'attente.
    • Générer et supprimer des messages : L'utilisateur peut afficher les messages contenus dans les files d'attente, générer les messages et supprimer les messages.
    • Démarrer et arrêter l'expéditeur : L'utilisateur peut afficher les messages contenus dans les files d'attente, démarrer et arrêter l'expéditeur.
    • Visualiser les statistiques de suivi des messages : L'utilisateur peut visualiser les statistiques de suivi des messages mais ne peut pas les réinitialiser.
    • Réinitialiser les statistiques de suivi des messages : L'utilisateur peut visualiser et réinitialiser les statistiques de suivi des messages.
    • Créer et supprimer des listes partagées : L'utilisateur peut créer et supprimer des listes partagées pour ce compte.
    • Modifier les enregistrements des listes partagées : L'utilisateur peut modifier les enregistrements des listes partagées disponibles pour ce compte.
  • Utiliser ce compte pour les tâches en arrière plan : eMill utilise un compte afin de s'authentifier pour accomplir certaines tâches comme le traitement des messages entrants ou la génération des messages. Afin de sécuriser le déroulement de ces tâches, il est conseillé de cocher cette case et de spécifier un compte ayant des droits limités. Si vous ne cochez pas cette option, le compte utilisé par défaut est celui du serveur eMill (compte système par défaut).

Définition de restrictions pour les utilisateurs :

Cliquez sur l'onglet Restrictions.
  • Fonctionnalités autorisées : Sélectionnez les fonctionnalités qui seront mises à disposition des utilisateurs du compte.
    • Envoi d'emails : L'utilisateur peut envoyer ses projets par e-mail.
    • Suivi des messages : L'utilisateur peut activer le suivi des messages sur les e-mails envoyés. Les autorisations pour visualiser et/ou réinitialiser les statistiques de suivi des messages doivent être définies dans l'onglet Sécurité.
    • Envoi de fax : L'utilisateur peut envoyer ses projets par Fax.
    • Envoi de SMS : L'utilisateur peut envoyer ses projets par SMS.
  • Files d'attente entrantes : L'utilisateur aura la possibilité de s'abonner aux files d'attente définies ici. Notez que les files d'attente entrantes doivent être préalablement configurées à partir du menu Outils/Options/Files d'attente entrantes.
    • Autoriser l'accès à toutes les files d'attente : L'utilisateur pourra s'abonner à toutes les files d'attente entrantes configurées dans le menu Outils/Options/Files d'attente entrantes.
    • Autoriser l'accès aux files d'attente suivantes : Cochez la ou les cases correspondantes aux files d'attente entrantes qui seront mises à disposition de l'utilisateur.

Spécifier des limitations par utilisateur (disponible avec l'édition eMill Service Provider) :

Cliquez sur l'onglet Limitations. Pour activer une limitation, cochez la case correspondante et définissez le paramètre en entrant une valeur dans la zone de texte adéquate.
  • Nombre maximum de projets par compte : Permet de limiter le nombre de projets par compte. Par exemple, si vous entrez "1", les utilisateurs du compte ne pourront créer qu'un seul projet.
  • Nombre maximum de messages par génération : Permet de limiter le nombre de messages par génération. Cette limitation a pour objectif de définir un nombre maximum de messages par campagne. La génération des messages sera interrompue lorsque le nombre maximum est atteint.
  • Taille maximale des messages : Permet de limiter la taille des messages envoyés. Si un utilisateur essaye d'envoyer un message qui excède la taille maximum, la génération du message sera interrompue et une note sera ajoutée au journal du projet avec le nom du destinataire, la taille du message et la taille maximale autorisée.
  • Nombre maximum de messages émis par minute : Permet de limiter le nombre de messages envoyés chaque minute afin d'éviter une surcharge du serveur SMTP.

Configurer le module de comptabilité (disponible avec l'édition eMill Service Provider) :

Cliquez sur l'onglet Comptabilité.

Le module de comptabilité a pour objectif de mettre à disposition un outil de contrôle de l'activité de l'utilisateur permettant également de faciliter la facturation.
Sur ce dernier point, il est possible d'associer les différentes valeurs présentées (messages envoyés, messages générés, trafic sortant, etc.) à un nombre de crédits. A vous de définir ensuite la valeur d'un crédit afin d'établir votre politique tarifaire.

Afin de configurer le module de comptabilité, vous devez suivre 2 étapes :

  1. Valeurs créditables : Définissez quelle est la valeur en crédit de chaque élément. Par exemple, "compter 5 crédits pour chaque email envoyé". Pour établir une valeur, sélectionnez-la dans le tableau et cliquez sur Éditer.
    • Emails envoyés : Pour chaque email envoyé, définissez le nombre de crédits comptabilisés. Vous avez également la possibilité de comptabiliser des crédits additionnels si la taille des messages excède une certaine limite.
      Exemple : Vous souhaitez compter 5 crédits pour chaque email envoyé et des crédits additionnels si la taille d'un message excède 500 Ko et ceci pour chaque tranche de 500 Ko supplémentaire. Si l'utilisateur envoie 10 messages de 400 Ko chacun dont 2 messages de 600 Ko, le nombre de crédits comptabilisés sera de :
      - Emails envoyés : 10 messages x 5 crédits = 50 crédits
      - la taille de 2 des emails envoyés est de 600 Ko et excède donc de 100 Ko la taille limite de 500 Ko. Pour chacun de ces messages, 5 crédits additionnels (l'équivalent d'un e-mail envoyé) seront compatibilisés soit 2 messages x 5 crédits x 1 tranche = 10 crédits.
      - Le nombre total de crédits comptabilisés sera de 50 + 10 = 60 crédits.

    • Fax envoyés : Pour chaque fax envoyé, définissez le nombre de crédits comptabilisés.
      Exemple : Vous souhaitez compter 5 crédits pour chaque fax envoyé. Si l'utilisateur envoie 10 fax, le nombre de crédits comptabilisés sera de 10 fax x 5 crédits = 50 crédits.
    • SMS envoyés : Pour chaque SMS envoyé, définissez le nombre de crédits comptabilisés.
      Exemple : Vous souhaitez compter 5 crédits pour chaque SMS envoyé. Si l'utilisateur envoie 10 SMS, le nombre de crédits comptabilisés sera de 10 SMS x 5 crédits = 50 crédits.
    • Messages générés : Pour chaque message généré (email, fax et/ou SMS), définissez le nombre de crédits comptabilisés. Vous avez également la possibilité de comptabiliser des crédits additionnels si la taille totale des messages générés excède une certaine limite.
      Exemple : Vous souhaitez compter 5 crédits pour chaque message généré et des crédits additionnels si la taille d'un message excède 500 Ko et ceci pour chaque tranche de 500 Ko supplémentaire. Si l'utilisateur génère 10 messages de 400 Ko chacun dont 2 messages de 600 Ko, le nombre de crédits comptabilisés sera de :
      - Messages générés : 10 messages x 5 crédits = 50 crédits
      - la taille de 2 des messages générés est de 600 Ko et excède donc de 100 Ko la taille limite de 500 Ko. Pour chacun de ces messages, 5 crédits additionnels (l'équivalent d'un message généré) seront comptabilisés soit 2 messages x 5 crédits x 1 tranche = 10 crédits.
      - Le nombre total de crédits comptabilisés sera de 50 + 10 = 60 crédits.
    • Trafic sortant : Définissez le nombre de crédits comptabilisés selon la taille totale des messages envoyés.
      Exemple : Vous souhaitez compter 5 crédits pour chaque tranche de 100 Ko. Si l'utilisateur envoie 500 Ko (10 messages de 50 Ko chacun), il y aura 5 tranches de 100 Ko et le nombre de crédits comptabilisés sera de 5 tranches x 5 crédits = 25 crédits.
  2. Valeurs comptabilisées : Ce tableau présente l'état des différentes valeurs à un moment donné et permet d'obtenir le nombre total de crédits comptabilisés selon la configuration définie dans le tableau des "Valeurs créditables".
    • Emails envoyés : Donne le nombre d'emails envoyés depuis la dernière réinitialisation.
    • Fax envoyés : Donne le nombre de fax envoyés depuis la dernière réinitialisation.
    • SMS envoyés : Donne le nombre de SMS envoyés depuis la dernière réinitialisation.
    • Messages reçus : Donne le nombre total de messages reçus sur tous les projets du compte depuis la dernière réinitialisation.
    • Messages générés : Donne le nombre total de messages générés sur tous les projets du compte depuis la dernière réinitialisation.
    • Trafic sortant : Donne la taille totale des messages envoyés sur tous les projets du compte depuis la dernière réinitialisation.
    • Trafic entrant : Donne la taille totale des messages reçus sur tous les projets du compte depuis la dernière réinitialisation.
    • Crédits : Donne le nombre total de crédits comptabilisés depuis la dernière réinitialisation selon les paramètres définis dans le tableau des "Valeurs créditables".
    • Rafraîchir : Cliquez ici pour mettre à jour le tableau des valeurs comptabilisées.
    • Réinitialiser : Cliquez ici pour remettre à zéro l'ensemble des valeurs comptabilisées. Attention, cette action ne peut pas être annulée.
    • Rapport : Cliquez ici pour générer un rapport en tant que fichier Excel ou CSV. Le rapport est composé d'un tableau présentant l'état des différentes valeurs ci-dessus par jour. Il peut être utile pour surveiller l'activité quotidienne du compte et pour générer les factures de vos clients puisque vous disposez du nombre de crédits comptabilisés chaque jour.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit..


Configuration du suivi des messages

Le suivi des messages se fait par l'intermédiaire d'un or plusieurs redirecteurs eMill installés sur un serveur Web. Les messages suivis envoient des informations aux redirecteurs eMill, que le serveur eMill téléchargera pour générer les statistiques de suivi des messages (pour plus de détails, voir Suivi des messages).

  • A partir du menu Outils/Options, cliquez sur l'onglet Suivi :

Liste des redirecteurs:

La liste des redirecteur affiche tous les redirecteurs configurés ainsi que leur mode de fonctionnement.

Ajouter un nouveau redirecteur :

  • Cliquez sur Ajouer. La boîte Propriétés du redirecteur apparaît :
  • Sélectionnez un mode de Fonctionnement. Cela peut être Redirection et collecte si le redirecteur est actif et doit être utilisé pour suivre les messages, Collecte uniquement si le redirecteur ne doit plus être utilisé pour suivre les messages, mais l'a été et continue à receuillir des données de suivi, ou Désactivé.
  • Spécifiez le Type de redirecteur. Les nouveaux redirecteurs ASPX et PHP sont en version 2. Les URLs suivis pour les redirecteurs en version 2 sont compressées et encodées. Pour permettre une compatibilité avec les versions d'eMill plus anciennes, les redirecteurs version 2 sont capables de fonctionner comme des redirecteurs version 1 sous Linux.
  • Entrez l'URL deredirection. C'est l'URL du site web ou du dossier virtuel où le redirecteur est installé, accessible depuis l'Internet.
  • Entrez l'URL de collecte. C'est l'URL du site web ou du dossier virtuel où le redirecteur est installé, accessible depuis la machine eMill. Dans la plupart des cas, cette URL est identique à l'URL de redirection.
  • Entrez le Domaine, le Nom d'utilisateur et le Mot de passe du compte utilisateur de collecte utilisé pour sécurisé la connexion. Le champ Domaine n'est requis que pour les redirecteurs version 1 sous Windows. Ce champ peut-être rempli avec un point ou avec le nom de la machine Windows où est installé le redirecteur si le compte utilisateur de collecte ne fait pas parti d'un domaine NT.
  • Si plusieurs redirecteurs fonctionnent dans le mode Redirection et collecte, vous pouvez spécifier une liste d'affinités par domaine. Cette liste est composée de motifs (chaîne pouvant contenir les caractères jocker ? et *) séparés par des virgules. Lorsque un message est rendu, si le domaine de l'expéditeur correspond à un de ces motifs, ce redirecteur spécifique sera utilisé pour suivre ce message.

Modifier un redirecteur :

  • Sélectionnez le redirecteur et cliquez sur Modifier. La boîte de dialogue Propriétés du redirecteur apparaît.
  • Modifiez les informations depuis la boîte de propriétés (voir procédure ci-dessus).

Configurer un redirecteur par défaut :

  • Sélectionnez un redirecteur fonctionnant en mode Redirection et collecte, puis cliquez sur Défaut. Ce redirecteur sera utilisé pour suivre les messages lorsque aucune affinité par domaine ne sera trouvée.

Supprimer un redirecteur :

  • Sélectionner un redirecteur et cliquez sur Supprimer.
Note : si aucun redirecteur ne fonctionne en mode Redirection et collecte, le suivi des messages est considéré comme désactivé. Toute tentative de génération d'un projet ayant le suivi des messages activé échouera avec l'erreur Suivi des messages non configuré.
© eMill 2001-2015 . Toutes les marques citées sont la propriété de leurs ayants droit


Configuration de S/MIME

L'option S/MIME vous permet d'envoyer des messages sécurisés à votre liste de destinataires. Grâce à la signature électronique, vos destinataires sont assurés de la provenance et de l'intégrité du message reçu. Le cryptage vous permettra d'envoyer des données sensibles (message confidentiel, relevé de compte, de consommation, etc.).

Sous Windows, les certificats sont stockés dans des magasins. Pour visualiser la liste des magasins et des certificats installés sur votre ordinateur, ouvrez une nouvelle console MMC et ajoutez le composant logiciel enfichable Certificats.

Note : Chaque certificat contient deux clés : une clé privée et une clé publique. La signature électronique nécessite l'utilisation de la clé privée de l'expéditeur. Le cryptage, quant à lui, nécessite l'utilisation de la clé publique du destinataire. eMill se base sur l'adresse email de l'expéditeur du message pour déterminer quel certificat utiliser pour signer les messages. De la même manière, eMill se base sur l'adresse email du destinataire pour déterminer quel certificat utiliser pour crypter les messages.

Par défaut, un certificat interdit l'accès direct à sa clé privée. Pour qu'eMill puisse utiliser un certificat pour signer les messages, vous devez autoriser l'accès à la clé privée du certificat. Pour cela, vous devez exporter votre certificat en désactivant la protection renforcée de la clé privée et l'importer à nouveau dans le magasin de votre choix.

Le serveur eMill étant un service Windows, il ne peut pas accéder aux magasins de certificats stockés sur le compte de l'ordinateur.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Set the SMS options

Options SMS

Afin d'effectuer l'envoi de SMS, eMill utilise des SMSCs (Short Message Service Center) qui prennent en charge le routage des SMS jusqu'au téléphone portable du destinataire. Avant d'envoyer des SMS avec eMill, vous devez donc vous inscrire et acheter des crédits auprès d'une SMSC. Ensuite, les options SMS vous permettent de sélectionner le système que eMill va utiliser parmi les SMSCs disponibles.

  • A partir du menu Outils/Options, cliquez sur l'onglet SMS :

Le tableau présentant les SMSCs disponibles est divisé en 2 colonnes, le nom de la SMSC et son type. Deux types de SMSCs sont actuellement supportés:

  • Passerelle email - SMS: eMill est déjà configuré pour l'utilisation de la passerelle TM4B. Afin d'utiliser ce service, vous devez suivre les étapes suivantes:
    1. Créer un compte: rendez-vous sur le site http://www.tm4b.com et créez un compte en cliquant sur 'Register Online'.
    2. Accorder le droit d'envoyer des SMS à l'adresse e-mail de l'expéditeur: l'adresse e-mail de l'expéditeur qui sera utilisée pour envoyer les SMS (Projet > Propriétés > En-têtes) doit être associée à votre compte TM4B. Pour cela, connectez-vous à votre compte en ligne TM4B, et rendez vous dans Settings > SMS API. Enfin, sous SMTP Access, entrez l'adresse e-mail de l'expéditeur et un mot de passe de votre choix.
    3. Configurer TM4B dans eMill: Sélectionnez TM4B dans le tableau des SMSCs disponibles, cliquez sur Activer puis sur Propriétés. Entrez le nom d'utilisateur de votre compte TM4B et le mot de passe que vous avez associé à l'adresse e-mail de l'expéditeur (voir étape 2). Notez que le champ 'Expéditeur' peut être modifié si vous utilisez un Short Code TM4B qui vous permet de recevoir des SMS.
    Merci de nous contacter si vous souhaitez utiliser une autre passerelle email - SMS.
  • SMPP: Deux serveurs SMPP sont listés dans le tableau des SMSCs disponibles, "World-Text" et "Other SMPP Server" qui vous permet de configurer le serveur SMPP de votre choix. Afin d'utiliser "World-Text", vous devez suivre les étapes suivantes:
    1. Créer un compte: Rendez-vous sur le site http://www.world-text.com et créez un compte en cliquant sur My Account > Register.
    2. Configurer TM4B dans eMill: Sélectionnez World-Text dans le tableau des SMSCs disponibles, cliquez sur Activer puis sur Propriétés. Entrez le nom d'utilisateur et le mot de passe de votre compte World-Text. Tous les autres paramètres sont automatiquement complétés. Si vous rencontrez des problèmes autour de ces paramètres, vous pouvez nous contacter ou consulter le document de configuration en vous connectant à votre compte World-Text et en cliquant sur 'SMPP Integration Documentation'. Notez que le champ 'Expéditeur' peut être modifié si vous utilisez un Short Code World-Text qui vous permet de recevoir des SMS.

Notez que le choix entre les 2 types de SMSCs (passerelle ou SMPP) dépendra principalement du prix des crédits et de la façon dont vous souhaitez utiliser le canal SMS (volume d'envoi, réception de SMS,...). Renseignez vous auprès des ces SMSCs pour plus de détails.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Configuration du Fax

Options Fax

Les options Fax vous permettent de déterminer les paramètres par défaut utilisés par le module fax d'eMill. Ces options ne sont accessibles qu'à partir du poste où le serveur eMill est installé. Vous pourrez aussi spécifier pour chacun des périphériques fax utilisés les propriétés de réception.

  • A partir du menu Outils/Options, cliquez sur l'onglet Fax :

  • Postmaster : Cette adresse email correspond à l'adresse de la passerelle fax. Quand vous recevez des notifications de livraison des messages (DSN), cette adresse apparaîtra en tant qu'expéditeur. Laissez l'adresse par défaut postmaster@[Fax] ou spécifiez une adresse vous permettant de reconnaître facilement ces messages.
  • Page de garde par défaut : eMill vous offre la possibilité d'indiquer une page de garde qui sera utilisée par défaut pour vos envois de fax. Cliquez sur Éditer pour modifier la page de garde en utilisant Microsoft® Éditeur de Page de Garde Télécopie. Il n'est pas obligatoire de spécifier une page de garde par défaut car vous pouvez créer une page de garde directement en tant que contenu de votre projet d'emailing.

    Si vous choisissez d'utiliser une page de garde par défaut, les champs seront complétés automatiquement de la manière suivante :

    1. Les champs de la page de garde concernant l'expéditeur (société, adresse, numéro de télécopie, etc.) seront complétés grâce aux informations indiquées dans la console de télécopie Microsoft (Outils > Informations sur l'expéditeur).

    2. Les champs suivants de la page de garde seront complétés dynamiquement par eMill :

    - Nom du destinataire : complété dynamiquement pour chaque destinataire si vous avez spécifié les champs Prénom et/ou Nom dans les propriétés des listes de destinataires. Dans le cas contraire, eMill complètera ce champ avec le numéro de télécopie.

    - Numéro de télécopie du destinataire : complété dynamiquement pour chaque destinataire.

    - Date et Heure : complété dynamiquement à l'envoi.

    - Nombre de pages envoyées : complété dynamiquement à l'envoi.

    - Objet : complété avec le sujet spécifié dans les propriétés de l'en-tête ou dans la fonction script Mail_OnStart().

    - Remarque : Afin de remplir ce champ vous devez créer un fichier texte et le positionner en tête de la liste des contenus (voir Positionnement des contenus). Si vous avez un contenu HTML et un contenu texte alternatif, le champ sera complété en utilisant le contenu texte et le contenu HTML sera ignoré lors de la création du fax.

  • Qualité d'image : Vous pouvez ici spécifier la qualité du fax envoyé. Le choix entre les 2 formats proposés se fera selon que vous souhaitiez privilégier la qualité graphique du fax ou limiter le temps d'émission. En effet, ce dernier sera plus long pour une qualité "normale" (200 x 200 pixels) que pour une qualité "brouillon" (200 x 100 pixels).
    Il est important de noter que, si vous utilisez Adobe Acrobat 4/5, il est fortement déconseillé d'utiliser une qualité "brouillon".
  • Périphériques Fax : Liste des modems utilisés par eMill pour la réception des fax. Sélectionnez un des modems de la liste puis cliquez sur Propriétés pour éditer les propriétés de réception du périphérique Fax (voir aussi réception des fax)
  • Règles de numérotation

- Pour accéder à une ligne extérieure : Précisez ici si un indicatif doit être ajouté aux numéros numérotables pour accéder à une ligne extérieure.

- Règles : Les règles de numérotation pour l'ensemble des programmes de téléphonie sont gérées directement par votre système d'exploitation Windows. En cliquant sur Règles, vous accédez directement aux Options de modems et téléphonie de Windows (ces options sont aussi accessibles depuis le panneau de configuration). Si vous spécifiez un numéro à tester, vous pourrez voir en temps réel l'effet des réglages de ces options sur le numéro. Ce numéro à tester doit être représenté sous une forme canonique (ex : +1 (254) 1234567) ou sous une forme pseudo canonique (ex : +33 468123456, en incluant bien un espace après l'indicatif du pays).

Propriétés de réception du périphérique Fax

Cette fenêtre vous permet de décider des propriétés de réception du périphérique fax que vous avez sélectionné.

  • Transférer dans la file entrante "fax" d'eMill : En cochant cette option, eMill Fax transfèrera les fax reçus vers la file entrante "fax" associée au projet.
  • Transférer directement par SMTP : En cochant cette option, eMill Fax transfèrera les fax reçus vers l'adresse email de votre choix. Si vous cochez cette option, les notifications de livraison des messages (DSN) seront tout de même reçues dans la boîte d'arrivée d'eMill.
  • De : Cette adresse email correspond à l'adresse du périphérique fax qui va gérer la réception des fax. Elle vous permettra de reconnaître quels fax sont émis par quels modems et de traiter les fax différemment selon le modem.
  • A : Adresse où les fax seront transférés si vous sélectionné l'option "Transférer directement par SMTP". Si vous sélectionnez uniquement "Recevoir dans la file entrante Fax" il faut obligatoirement préciser cette adresse car un message ne peut pas être créé sans cette indication. Elle pourra être utile pour traiter les messages différemment selon le destinataire.
  • Format : Sélectionnez le format dans lequel vous souhaitez recevoir les fax : PDF (Adobe Acrobat) ou TIFF (format image).
  • Inclure les images réduites des 4 premières pages : Cette option vous permet d'avoir un aperçu des 4 premières pages du fax reçu directement dans le corps du message.
  • Ne recevoir que la pièce jointe fax : Cette option avancée vous permet de recevoir les fax directement en pièces jointes sans aucune indication dans le corps du message. Ceci peut éviter d'avoir trop d'indications dans le corps du message en cas d'automatisation du routage des fax.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Options de Stockage

eMill enregistre par défaut les informations sur les messages générés et les statistiques de message dans des bases de données au format SQLite. Cependant, eMill vous permet aussi de stocker ces données dans des bases externes de type MySQL ou SQL Server.

  • A partir du menu Outils/Options, cliquez sur l'onglet Stockage :
  • Cochez Stocker les messages et les statistiques dans une base de données externe afin de spécifier à eMill d'utiliser une base de données externe. Veuillez noter que seul les nouveaux projets utiliseront la ou les bases de votre choix.
  • L'option Type de base de données vous permet de choisir un serveur de base de données de type MySQL ou SQL Server.
  • La champ Serveur de base de données doit contenir le nom réseau du serveur MySQL ou SQL Server. Cela peut être un nom de domaine, un nom NetBIOS, une addresse IP ou un nom de server SQL Server tel que NOMDUSERVER\SQL2005.
  • Entrez un Nom d'utilisateur pouvant se connecter au serveur de base de données. Vous devez activer le type de transport TCP/IP pour vous connecter à un serveur SQL Server et utiliser un compte utilisateur propre à SQL Server.
  • Entrez le Mot de passe de l'utilisateur.
  • Cochez Utiliser une seule base de données si vous souhaitez que tous les projets de tous les comptes utilisent la même base.
  • Cochez Créer une base de données par compte si vous souhaitez que une base soit créer pour chaque compte eMill. L'utilisateur sélectionné pour se connecteur au serveur de base de données doit avoir le droit de créer des nouvelles base. Ce choix permet une meilleure isolation des comptes eMill et peut aussi augmenter les performances dans certains cas.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Clés DKIM

eMill peut signer les messages sortant en utilisant la technologie DKIM. Différentes clés peuvent être utilisées poour signer les messages en fonction de l'adresse ou du domaine de l'expéditeur.

  • A partir du menu Outils/Options, menu, cliquez sur l'onglet Clés DKIM :

Cliquez sur le bouton Ajouter pour créer une nouvelle clé DKIM, sur le bouton Modifier pour modifier une clé DKIM existante, ou sur le bouton Supprimer pour supprimer une clé DKIM existante.

Boîte de dialogue de clé DKIM

Cette boîte de dialogue vous permet de configurer une nouvelle clé DKIM ou de modifier les proprietés d'une clé existante.

  • Activé : spécifie si cette clé est utilisable.
  • Sélecteur : spécifie le nom du sélecteur associé avec cette clé DKIM. Le sélecteur détermine avec le domaine le nom de l'enregistrement DNS contenant la clé publique. Ce champ est obligatoire.
  • Domaine : spécifie le nom du domaine signant avec cette clé DKIM. Le domaine détermine avec le selecteur le nom de l'enregistrement DNS contenant la clé publique. Ce champ est obligatoire.
  • Identité : spécifie l'adresse email de l'identité signant les messages avec cette clé. L'identité doit appartenir au Domaine signant. Ce champ est optionnel.
  • Clé privée : spécifie la clé RSA privée à utiliser pour signer les messages.
  • Générer : crée une clé privée RSA 1024 bits. Ce bouton ne devrait être utilisé que pour créer de nouvelles clés.
  • Restrictions : détermine si cette clé doit être utilisée pour signer les messages en fonction de l'adresse ou du domaine de l'expéditeur. Pour signer les messages, eMill cherche d'abord une clé dont la restriction correspond à l'adresse de l'expéditeur, puis une clé dont la restriction correspond au domaine de l'expéditeur, enfin eMill utilise une clé non restreinte si elle existe. Il est déconseillé d'avoir plusieurs clés avec la même restriction.
  • Nom de l'enregistrement DNS associé : champ automatiquement généré contenant le nom de l'enregistrement DNS devant contenir la clé privée associée à cette clé DKIM. Ce nom dépend du Domaine et du Sélecteur.
  • Donnée de l'enregistrement DNS associé : example de donnée que doit contenir l'enregistrement DNS associé à cette clé DKIM. Cette donnée contient la clé publique.
  • Vérifier le DNS : lance une procédure de vérification de l'enregistrement DNS associé à la clé DKIM. Un message de diagnostic sera affiché indiquant si une erreur est survenue, si la clé publiqué ne correspond pas, ou si la vérification a réussi.
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Editer les listes partagées

eMill vous permet de créer des listes préconfigurées qui pourrons ensuite être utilisées dans vos projets comme liste de destinataires ou listes noires via l'assistant d'ajout de liste. Les listes partagées sont disponible pour toutes les version Entreprise d'eMill.

Vous devez être administrateur du serveur eMill ou avoir le droit Créer et supprimer des listes partagées sur au moins un compte eMill pour pouvoir gérer des listes partagées.

  • Cliquez sur le menu Outils/Liste partagées :

Seules les listes modifiables par l'utilisateur en cours sont affichées. Si l'utilisateur en cours est administrateur du serveur eMill, toutes les listes seront affichées.

Ajouter une liste partagée :

Cliquez sur le bouton Ajouer pour ajouter une nouvelle liste partagée. Si eMill est situé sur la même machine que le serveur eMill, un assistant similaire à l'assistant d'ajout de liste des projets sera lancé. L'assistant permet de choisir la source de données parmis Access, MySQL, SQL Server et Connection ADO avancée.

Modifier une liste partagée :

Sélectionnez une liste partagée et cliquez sur le bouton Modifier pour ouvrir la feuille de proriétés de la liste partagé.

  • Activé : spécifie si la liste est utilisable et visible.
  • Nom : nom de la liste partagée qui identifie cette dernière de façon unique.
  • Chaîne de connection ADO : paramètre avancé établissant le lien entre une base de données et la liste partagée. Cliquez sur le bouton Propriétés pour générer une chaîne de connexion ADO via la fenêtre des Propriétés des liaisons de données. Cliquez sur le bouton Modifier la source de données pour générer la chaîne de connexion à partir de l'assistant.
  • Requête SQL retournant les enregistrement: requête SQL qui retourne les enregistrements de la liste via la connexion ADO à la source de données.

  • Autoriser l'accès à la liste pour tous les comptes : autorise l'utilisation de cette liste à tous les utilisateurs d'eMill. Seul les administrateurs peuvent choisir cette option. De même une liste disponible pour tous les utilisateurs d'eMill ne pourra être supprimée et modifiée que par les administrateurs.
  • Autoriser l'accès à la liste pour les comptes suivents : autorise l'accès à la liste partagée pour les utilisateurs eMill des comptes cochés. Seul les comptes où l'utilisateur courant à le droit Créer et supprimer des listes partagées sont listés, ou tous les comptes si l'utilisateur courant est un administrateur.

Supprimer une liste partagée :

Sélectionnez une liste partagée et cliquez sur le bouton Supprimer pour la supprimer.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Conception de votre Projet

Utilisation d'eMill

Avec eMill vous pouvez concevoir toutes sortes de projets, des plus simples aux plus complexes.

La conception des projets simples est facilitée par l'utilisation des outils et des éditeurs intégrés d'eMill. Il n'est pas nécessaire d'avoir des compétences particulières. Pour des projets plus complexes, il peut être nécessaire d'avoir quelques connaissances en scripting, bases de données et html.

Vous pouvez soit acquérir les compétences nécessaires à l'exécution de toutes ces tâches, soit agir en tant que chef de projet en utilisant eMill pour organiser et centraliser le travail d'une équipe. Ce dernier cas implique un travail en collaboration, les fichiers générés par des applications externes devront se conformer à la structure du projet, qu'il s'agisse de leur nom ou de leur emplacement.

Éditer le contenu du message :

Si vous utilisez l'assistant pour créer un nouveau projet de publipostage, eMill ajoutera automatiquement 2 contenus : un contenu HTML et un contenu texte alternatif. Ce dernier est créé afin que votre message soit lisible par les clients mail qui n'accepte pas le format HTML.

Vous pouvez aussi créer un nouveau contenu HTML ou texte à tout moment en utilisant l'assistant ajout de contenu. Pour éditer ces contenus à vous de choisir si vous souhaitez utiliser les éditeurs intégrés d'eMill ou une application externe de votre choix. Une fois le contenu créé, vous devrez aussi définir ses propriétés et son positionnement.

Afin de vous permettre de transmettre à chacun de vos destinataires, un message unique et attractif, eMill met à votre disposition des outils performants de personnalisation : insertion de champs de la source de données, insertion de scripts et activation des contenus selon vos conditions.

Éditer les listes de destinataires

Avec eMill, vous avez la possibilité d'utiliser l'ensemble de vos sources de données quelques soient leurs formats. Il vous suffit de sélectionner la source de données que vous souhaitez utiliser quand vous créez un nouveau projet ou quand vous ajouter une liste de destinataires :

- Si vous n'avez pas de base de données, eMill vous propose d'en créer une.

- Si vous avez une source de données de type Excel, Access ou Outlook.

- Si vous avez une base de données nécessitant une connexion par ADO avancées comme Oracle ou SQL Server.

- Si vous avez une source de données XML.

- Si vous avez une base de données My SQL.

- Si vous avez collecté des adresses email dans un fichier texte non structuré, eMill vous permettra de les récupérer rapidement.

Une fois connecté à votre source de données, vous pourrez éditer les enregistrements directement dans eMill ou dans l'application externe de votre choix. De plus, eMill vous propose un ensemble complet de fonctionnalités vous permettant de maximiser la qualité de votre listes de destinataires :

- En consultant les propriétés des listes de destinataires ou les propriétés des listes noires, vous avez la possibilité d'ajouter un filtre à votre source de données afin de cibler précisément vos messages.

- Vous pouvez importer ou exporter des adresses directement dans votre liste.

- Vous pouvez vérifier la validité des adresses de votre liste (email ou fax).

Aperçu du message final

Un aperçu accessible à tout moment et qui vous permettra de visualiser le message créé pour chaque destinataire. De plus, pour les utilisateurs avancées, eMill affiche l'ensemble des ressources utilisées pour la création du message et pour chaque contenu.

Éditer le script global

eMill utilise des scripts pour accéder aux sources de données. Ces scripts sont générés par les assistants de projet et modifiés selon les instructions données par des boîtes de dialogue. Les utilisateurs familiers avec VBScript peuvent éditer directement le script du projet afin de personnaliser davantage les contenus. Des événements script, qui seront appelés pendant le traitement du mailing, peuvent également être ajoutés. Des exemples de scripts sont disponibles pour les utilisateurs non familiers avec le scripting.

Éditer les propriétés du projet

A travers les propriétés du projet, vous accédez à l'ensemble des paramètres importants du projet : propriétés générales, listes de destinataires, listes noires, en-tête, expéditeur, notifications, S/MIME et fax.

Traitement des messages entrants

Accessible depuis la fenêtre de conception ou la fenêtre des files d'attente, le traitement des messages entrants vous permettra de spécifier si vous souhaitez automatiser le traitement des réponses ou des notifications de livraison. Ainsi, vous avez la possibilité de mettre à jour vos bases, gérer les inscriptions/désinscriptions,...

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Fenêtre de Conception

Cliquez sur l'icône Conception : le projet s'affiche dans la Fenêtre de Conception.

Cliquez sur l'icône Files d'Attente : les files de tous les projets publiés s'affichent dans la fenêtre Files d'Attente.

A l'ouverture ou à la création d'un nouveau projet, la Fenêtre de Conception s'affiche. eMill utilise une fenêtre MDI (Multiple Document Interface) qui vous permet d'ouvrir simultanément plusieurs projets. La fenêtre de conception utilise une arborescence en arbre afin d'accéder facilement aux différentes parties du projet : les contenus du message, la ou les listes des destinataires, la ou les listes noires, le script global et l'aperçu du message final. Il suffit de cliquer sur un des éléments de l'arborescence de gauche pour le visualiser dans la partie droite de la fenêtre de conception.

Vue générale

La vue générale affiche une synthèse du projet.

Édition des Contenus

Les contenus sont les éléments enfants de l'élément Contenus. Sélectionnez un contenu dans l'arborescence pour ouvrir l'éditeur correspondant dans la partie droite de la fenêtre de conception.

Pour ajouter un nouveau contenu au projet, vous pouvez :

  • Cliquer avec le bouton droit sur l'élément Contenus et sélectionner Ajouter un contenu.
  • Cliquer sur le menu Projet/Ajouter un contenu pour lancer l'assistant ajout de contenu.
  • Cliquer sur le bouton Ajouter un contenu de la barre d'outils.

Vue Destinataires

Les listes de destinataires sont les éléments enfants de l'élément Listes de destinataires. Toutes les listes de destinataires actives seront utilisées lors de la génération des messages.

  • Pour modifier votre source de données destinataires, l'activer ou la désactiver, la supprimer ou en ajouter une nouvelle, utilisez l'onglet destinataires des propriétés du projet.
  • Pour ajouter ou supprimer des colonnes de la base de données, utilisez le menu Projet -> Source de Données -> Ajouter/Supprimer colonne ou utilisez le clic-droit sur les titres de la base de données.
  • Pour éditer un enregistrement, sélectionnez-le et utilisez la barre d'outils Enregistrement, les raccourcis clavier, le clic droit ou les commandes du menu.
  • Pour classer les enregistrements, cliquez sur le titre de la colonne.

Vue Liste Noire

Les listes noires sont les éléments enfants de l'élément Listes noires. Tous les destinataires d'un publipostage dont l'adresse ou le numéro de fax figure dans une des listes noires actives ne recevront pas d'email ou de fax.

  • Pour modifier une liste noire, l'activer ou la désactiver, la supprimer ou en ajouter une nouvelle, utilisez l'onglet Listes noires des propriétés du projet.
  • L'édition des enregistrements d'une liste noire est similaire à celle d'une liste de destinataires.

Aperçu final

Sélectionnez l'élément Aperçu pour générer un message en fonction des contenus, des scripts et de l'enregistrement courant de votre projet. La vue Message permet de visualiser le contenu du message, les en-têtes et les attachements comme la plupart des clients mail l'afficheront. La vue MIME affiche une représentation avancée de la hiérarchie et de la source MIME du message.

  • Utilisez la barre d'outils Enregistrement pour changer l'enregistrement courant et générer un nouveau message.
  • Chaque partie MIME du message peut être visualisée indépendamment en cliquant sur l'élément enfant de l'élément Aperçu correspondant.

Éditeur de Script Global

Sélectionnez l'élément Script global pour afficher l'éditeur du script global. Le script global est généré par l'application et sauvegardé dans le fichier Milset.vbs.

Note : un menu contextuel regroupant les commandes les plus utilisées est disponible pour chaque élément de l'arborescence via le clic-droit de la souris.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Barres d'outils/Raccourcis Clavier/Menus

Commandes Standards
Ces commandes permettent d'administrer les fichiers, d'exécuter les opérations de base dans l'application ou de choisir les options et les préférences. La plupart sont disponibles dans la barre d'outils standard.
Commandes du menu | Icône | Raccourcis | Etat | Action
Fichier/Nouveau |  | Ctrl+N | Application lancée | Lance un nouveau projet ou un nouveau document
Projet/Nouveau contenu |  | Ctrl+E | Projet ouvert | Ajoute un nouveau contenu au projet
Fichier/Ouvrir |  | Ctrl+O | Application lancée | Ouvre un projet existant ou des fichiers éditables
Fichier/Fermer |  | Ctrl+W | Projet ouvert | Ferme le projet
Fichier/Enregistrer |  | Ctrl+S | Projet ouvert | Sauvegarde le projet et tous les fichiers non sauvés
Fichier/Enregistrer Tout |  | Ctrl+Shift+S | Projet ouvert | Sauvegarde tous les projets ouverts
Affichage/Rafraîchir |  | F5 | Application lancée | Rafraîchit la vue courante
Fichier/Publier |  |  | Projet ouvert | Publie les fichiers sur le serveur et peut éventuellement générer et/ou envoyer les messages (voir la structure d'un projet)
 |  |  | Projet ouvert | Ouvre le document actif dans l'application externe associée
Projet/Envoyer un message test |  |  | A partir de l'aperçu | Permet d'envoyer un message de test avant la publication
Fichier/Quitter |  | Ctrl+Q | Application lancée | Quitte l'application
Fichier/Files d'attente |  |  | Fenêtre de Conception | Affiche les Files d'Attente
Projet/Propriétés |  | Alt+Entrée | Projet ouvert | Permet de définir et de modifier les propriétés du projet
Edition/Annuler |  | Ctrl+Z | Projet ouvert | Annule la dernière commande
Edition/Rétablir |  | Ctrl+Y | Projet ouvert | Répète la dernière commande
Edition/Couper |  | Ctrl+X | Contenu fichier ouvert | Coupe la sélection du document et la colle dans le presse-papiers
Edition/Copier |  | Ctrl+C | Contenu fichier ouvert | Copie la sélection du document et la colle dans le presse-papiers
Edition/Coller |  | Ctrl+V | Contenu fichier ouvert | Insère le contenu du presse-papier dans le document
Edition/Supprimer |  |  | Contenu fichier ouvert | Supprime la sélection
Edition/Sélectionner Tout |  | Ctrl+A | Contenu fichier ouvert | Sélectionne tout le document
Edition/Rechercher |  | Ctrl+F | Contenu fichier ouvert | Cherche des caractères dans le document
Edition/Rechercher Suivant |  | F3 | Contenu fichier ouvert | Poursuit la recherche de caractères dans le document
Edition/Remplacer |  |  | Contenu fichier ouvert | Cherche et remplace des caractères dans un document
Outils/Options |  |  | Projet ouvert | Permet de modifier les options de la messagerie
Outils/Importer des adresses |  |  | Projet ouvert | Permet de créer rapidement une liste des destinataires
Fenêtre/Cascade |  |  | Projets ou contenu ouverts | Affiche plusieurs fenêtres à l'écran
Fenêtre/Mosaïque |  |  | Projets ou contenu ouverts | Affiche plusieurs fenêtres à l'écran
Fenêtre/Réorganiser les Icônes |  |  | Projets ou contenu ouverts | Réorganise les fenêtres réduites
Aide/Général |  |  | Application lancée | Lien sur le Fichier d'Aide

Commandes de l'éditeur HTML
Ces commandes permettent de créer le contenu HTML du message. Note : les scripts intégrés sont insérés avec la commande Insérer/Champ Données APRES avoir lié le fichier HTML au projet.
Commandes du menu | Icône | Raccourcis | Etat | Action
Insertion/Image |  |  | Fichier HTML dans l'éditeur de contenus | Insère une image à un point d'insertion, incorporée dans le fichier email
Insertion/Signet |  |  | Fichier HTML dans l'éditeur de contenus | Crée un point d'ancrage au point d'insertion
Insertion/Liens |  | Ctrl+K | Image ou texte sélectionné | Affiche la fenêtre de création de lien
Insertion/Champ Source de Données |  |  | Fichier HTML dans l'éditeur de contenus | Génère les scripts pour l'insertion des variables de contenu
Insertion/Script |  |  | Fichier HTML dans l'éditeur de contenus | Insère les scripts client ou serveur dans le document
Format/Style |  |  | Fichier HTML dans l'éditeur de contenus | Permet de sélectionner les styles de texte standard html
Outils/options de l'éditeur HTML |  |  | Projet ouvert | Permet d'indiquer vos préférences d'Editeur

Commandes de l'éditeur d'enregistrements
Ces commandes permettent d'éditer les enregistrements de la vue destinataires. Note : les modifications faites seront également effectuées dans la base de données source.
Commandes du menu | Icône | Raccourcis | Etat | Action
 |  |  | Depuis la vue aperçu | Change la liste de destinataires courante
Projet/Enregistrements/Editer |  | Clic Droit | Enregistrements sélectionnés dans la vue destinataires | Editere les enregistrements sélectionnés
Projet/Enregistrements/Ajouter nouveau |  | Clic Droit | Depuis la vue destinataires | Ajoute un nouvel enregistrement à la liste
Projet/Enregistrements/Aller au premier |  | Ctrl+Echap | Enregistrements sélectionnés dans la vue destinataires | Sélectionne le premier enregistrement de la liste
Projet/Enregistrements/Aller au précédent |  | Ctrl+Gauche | Enregistrements sélectionnés dans la vue destinataires | Sélectionne l'enregistrement précédent
Projet/Enregistrements/Aller à |  | Ctrl+Gauche | Depuis la vue destinataires | Sélectionne l'enregistrement numéroté
Projet/Enregistrements/Aller au suivant |  | Ctrl+Droit | Enregistrements sélectionnés dans la vue destinataires | Sélectionne l'enregistrement suivant
Projet/Enregistrements/Aller au dernier |  | Ctrl+Fin | Enregistrements sélectionnés dans la vue destinataires | Sélectionne le dernier enregistrement de la liste

Commandes de l'éditeur de script
Ces commandes permettent d'éditer le script global milset.vbs. Elles sont disponibles depuis l'éditeur de script.
Commandes du menu | Icône | Raccourcis | Etat | Action
Edition/Débogueur de script/Ouvrir |  |  | éditeur de script | Attache le débogeur : Microsoft InterDev ou Microsoft Script Developer
Edition/Débogueur de Script /S'arrêter à la prochaine commande |  |  | éditeur de script | Exécute le script partiellement
Edition/Inverser un point d'arrêt |  | F9 | éditeur de script | Ajoute/retire les points d'interruption, l'exécution du script est arrêtée aux points d'interruption
Edition/rEffacer les point d'arrêt |  |  | éditeur de script | Retire tous les points d'interruption
Edition/Commenter |  |  | éditeur de script | Change la sélection en commentaire
Edition/Décommenter |  |  | éditeur de script | Change le commentaire en ligne de code
Edition/Signet/ Inverser Signet |  | F2 | éditeur de script | Ajoute/supprime les Signets
Edition/Signet/ Signet suivant |  |  | éditeur de script | Envoit le curseur au Signet suivant
Edition/Signet/ Signet précédent |  |  | éditeur de script | Envoit le curseur au Signet précédent
Edition/Signet/ Effacer les Signets |  |  | éditeur de script | Supprime tous les Signets
Outils/Options de l'Editeur de Script |  |  |  | Permet de configurer vos préférences d'Editeur

Commandes des Files d'attente
Ces commandes permettent de publier, générer et envoyer le projet. Elles sont disponibles dans la fenêtre files d'attente.
Commandes du menu | Icône | Raccourcis | Etat | Action
File d'attente/Mailing/Générateur/Démarrer |  | Clic Droit | File d'attente sélectionnée | Lance la génération des fichiers email (encodage MIME)
File d'attente/Mailing/Générateur/Pause |  | Clic Droit | Générateur lancé | Interrompt la génération, peut reprendre à l'endroit où elle s'est arrêtée
File d'attente/Mailing/Générateur/Arrêter |  | Clic Droit | Générateur lancé ou en pause | Annule la génération, propose de nettoyer le dossier boîte d'envoi
File d'attente/Mailing/Expéditeur/Démarrer |  | Clic Droit | Messages d ans la boîte d'envoi | Lance la transmission, déplace les messages de la boîte d'envoi au dossier 'envoyés'
File d'attente/Mailing/Expéditeur/Arrêter |  | Clic Droit | Transmission Lancée | Arrête la transmission, les messages non envoyés restent dans la boîte d'envoi
File d'attente/Mailing/Statistiques |  | Clic Droit | File d'attente sélectionnée | Présente un résumé des résultats du mailing
File d'attente/Mailing/Planification |  | Clic Droit | File d'attente sélectionnée | Planifie le mailing
File d'attente/Mailing/Propriétés |  | Clic Droit | File d'attente sélectionnée | Affiche la boîte de dialogue des propriétés du projet
File d'attente/Message/Ouvrir |  | Clic Droit | Message(s) sélectionné(s) | Ouvre le fichier des messages dans le client mail
File d'attente/Message/Edition |  | Clic Droit | Message(s) sélectionné(s) | Ouvre le fichier des messages dans notepad (format EML)
File d'attente/Message/Détruire |  | Clic Droit | Message(s) sélectionné(s) | Détruit les fichiers messages
File d'attente/Message/Propriétés |  | Clic Droit | Message(s) sélectionné(s) | Edite les propriétés des fichier messages
File d'attente/Dossier/Tout détruire |  | Clic Droit | Dossier message sélectionné | Détruit tous les messages d'un dossier
File d'attente/Dossier/Tout abandonner |  | Clic Droit | Dossier boîte d'envoi sélectionné | Abandonne les messages de la boîte d'envoi, les envoit dans le dossier ' abandonnés'
File d'attente/Dossier/Tout Sélectionner |  | Ctrl+A | File d'attente / Dossier sélectionné | Sélectionne tous les dossiers ou les messages
File d'attente/Dossier/Rafraîchir |  | F5 | Expéditeur ou File d'attente sélectionnés | Rafraîchit la vue

© 2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer le contenu du message

Éditer le Contenu du Message

eMill met à votre disposition tous les outils nécessaires pour concevoir des contenus attractifs et personnalisés. eMill offre aussi une flexibilité totale dans la gestion et l'édition du message. En effet, vous pouvez ajouter un nouveau contenu vierge et le concevoir grâce aux éditeurs intégrés d'eMill ou importer un contenu à partir d'un fichier existant. De plus, la personnalisation du contenu étant un élément clé dans la création d'un projet d'emailing, eMill vous donne l'opportunité de personnaliser vos contenus de façon illimitée.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer le contenu du message

Créer un nouveau contenu

eMill vous permet de disposer de plusieurs contenus pour un même projet et d'éditer des contenus de différents formats :

- Contenus HTML : Ils peuvent être créés en utilisant l'éditeur HTML d'eMill ou à partir d'un fichier existant local ou distant. Si vous souhaitez utiliser une application externe pour modifier un fichier HTML, il vous suffit de cliquer sur l'icône Ouvrir avec ( [image]) dans la barre d'outils. Une fois votre fichier modifié, enregistrez-le et les modifications seront automatiquement prises en compte dans eMill.

- Contenus texte : Ils peuvent être créés en utilisant l'éditeur texte d'eMill ou à partir d'un fichier existant.

- Autres formats de contenus : Tous les autres types de fichiers peuvent être utilisés en tant que pièce jointe. Pour spécifier qu'un contenu doit être envoyé en tant que pièce jointe, vous pouvez ajouter un pièce jointe ou modifier les propriétés du contenu.

Note : Si vous avez utilisé l'assistant Nouveau Projet de Publipostage pour créer un nouveau projet, 2 contenus sont créés par défaut : un contenu HTML (CorpsHTML) et un contenu texte alternatif (CorpsTexte). Ce dernier est créé afin que votre message soit affiché en format texte si le client mail de votre destinataire n'accepte pas le contenu HTML.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Créer un nouveau contenu

Ajouter un contenu

Lors de la création d'un nouveau projet, eMill crée par défaut un nouveau contenu html et un nouveau contenu texte. Ce dernier est créé afin que votre message soit affiché en format texte si le client mail de votre destinataire n'accepte pas le contenu HTML.

Vous pouvez ajouter à tout moment des nouveaux contenus à votre projet ou des contenus provenant de fichiers ou de pages web existants. Depuis la fenêtre de conception, cliquez sur le menu Projet/Ajouter un contenu pour lancer l'Assistant ajout de contenu :

Nom et description du contenu :

Le nom du contenu doit être unique. Si le contenu est une pièce jointe, le nom du fichier attaché sera construit à partir de ce nom.

Le champ description est optionnel, il correspond à l'en-tête MIME Content-Description.

Ajouter un nouveau contenu vide :

Sélectionnez l'option Contenu HTML vierge, Contenu texte vierge ou Contenu VBS vierge pour ajouter un nouveau contenu HTML, texte ou script vierge.

Ajouter un nouveau contenu à partir d'une page web :

Sélectionnez l'option Contenu importé d'une page web pour importer le contenu d'une page web existante.
Cliquez sur Suivant et entrez l'URL de votre page web (par exemple, http://www.emill.net/newsletter.html). Cochez l'option Importer les images et les feuilles de style pour importer l'ensemble de ces éléments dans le dossier du projet.

Ajouter un nouveau contenu à partir d'un fichier existant :

Sélectionnez l'option Contenu à partir d'un fichier existant pour utiliser un fichier existant comme contenu.
Cliquez sur Suivant et sélectionnez le fichier que vous souhaitez utiliser. Si le fichier ne se trouve pas dans le dossier du projet eMill, il est fortement recommandé de laisser cochée la case Copier le fichier dans le dossier du projet. Dans le cas contraire, si vous publiez votre projet sur un serveur eMill distant, il est possible que ce contenu ne soit pas trouvé et que la génération s'arrête en retournant l'erreur Le fichier spécifié est introuvable ou Accès refusé.

Ajouter un nouveau contenu web lié :

Cette option permet de configurer l'affichage d'une page web selon des données provenant de votre liste de destinataires. Elle vous offre également la possibilité de générer le contenu de l'email à partir d'une application web dynamique existante telle qu'un intranet, un extranet ou des services web.

Pour plus de détails, consultez l'aide sur les Paramètres HTTP.

Sélectionnez l'option Contenu lié à une page web. Cliquez sur Suivant et entrez l'URL à laquelle vous souhaitez être liée. Si l'accès à la page web nécessite une authentification, entrez le nom d'utilisateur et le mot de passe du compte.

Ajouter une pièce jointe personnalisée pour chaque destinataire :

Cette option permet d'envoyer des pièces jointes spécifiques à chaque destinataire.

Par exemple, si vous souhaitez envoyer à des commerciaux un rapport d'activité, il sera différent pour chaque contact. Vous allez donc indiquer à eMill dans quel dossier se trouve ces rapports et quel critère sera utilisé pour savoir quel rapport correspond à quel destinataire (nom du rapport dans une colonne de la liste de destinataires, nom du rapport basé sur le nom du destinataire, etc.)

Sélectionnez Pièce jointe personnalisée par destinataire et cliquez sur Suivant.
Cliquez sur Dossier afin de sélectionner le dossier dans lequel se trouve les pièces jointes à envoyer.
Faites un clic droit dans la zone de texte à l'endroit où vous souhaitez insérer une information provenant de la source de données. Par exemple, si le nom du fichier à joindre est indiqué dans une colonne de la liste, faites un clic droit à la fin du chemin menant au dossier et sélectionnez la colonne de la liste contenant les noms de fichiers.

Fin de l'assistant :

Cochez la case Ouvrir les propriétés du contenu à la fin de l'assistant pour ouvrir la boîte des propriétés du contenu lorsque vous cliquez sur Terminer.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Créer un nouveau contenu

Ajouter une pièce jointe

Vous pouvez ajouter à tout moment une pièce jointe de 2 façons (tous les formats de fichiers sont acceptés en tant que pièce jointe) :

- Ajouter une pièce jointe unique pour tous les destinataires : Depuis la fenêtre de conception, cliquez sur le menu Projet/Ajouter une pièce jointe pour ouvrir une fenêtre vous permettant de sélectionner le fichier que vous souhaitez ajouter. Une fois la pièce jointe ajoutée, elle sera affichée à la suite des contenus dans la fenêtre de conception.

- Ajouter une pièce jointe personnalisée pour chaque destinataire : Depuis la fenêtre de conception, cliquez sur le menu Projet/Ajouter un contenu et sélectionnez l'option Pièce jointe personnalisée par destinataire. Rendez vous dans la section de l'aide Ajouter un contenu pour plus de détails.

- Transformer un contenu de votre projet en pièce jointe en modifiant les propriétés du contenu.

Vous pouvez décider de l'ordre d'affichage de vos pièces jointes à travers la fenêtre de positionnement des contenus.

Il est important de noter que les possibilités de personnalisation des contenus sont les mêmes pour le corps du message que pour les pièces jointes.

De plus, eMill vous offre la possibilité d'éditer un contenu HTML ou texte et de le convertir dynamiquement au format Adobe Acrobat PDF lors de la génération des messages (uniquement disponible avec l'option PDF d'eMill).

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés du contenu

Les propriétés du contenu vont vous permettre de spécifier les propriétés générales de votre contenu et ses conditions d'activation.

Depuis la fenêtre de conception, sélectionnez un contenu, puis cliquez sur le menu Affichage/Propriétés. La boîte de dialogue Propriétés du contenu s'affiche :

Général :

  • Nom du contenu: nom du contenu dans le projet.
  • Nom du fichier : chemin d'accès complet au fichier.
  • URL: Lorsque le contenu est une page web liée, l'URL de cette dernière est indiquée ici. Notez qu'il est possible d'insérer des informations provenant de la source de données dans l'URL en faisant un clic droit dans la zone de texte URL et en sélectionnant "Insérer champ" puis le champ adéquat.
  • Disposition : sélectionnez Corps du message si vous désirez que le contenu soit affiché dans le corps du message, Pièce jointes si vous voulez que le fichier soit envoyé en tant que pièce jointe et En ligne si vous souhaitez que le contenu soit affiché dans le message à la suite du corps du message.
  • Encodage : détermine l'encodage MIME dans lequel le contenu doit être généré. Un message comportant plusieurs contenus de fichiers peut utiliser différentes techniques d'encodage pour chaque partie. Sélectionnez Auto pour obtenir la valeur optimisée d'eMill par défaut. Sinon, utilisez Quoted-Printable pour le texte et l'html, et Base64 pour les autres formats.
  • Langage : spécifie le langage utilisé par les scripts du contenu. Si vous avez insérer un script permettant d'afficher la date du jour dans le contenu du message, cette propriété permettra d'adapter au pays du destinataire le format de la date : 26/11/04 en France et 11/26/04 aux Etats-Unis.
    Si ce contenu est lié à une page web et que cette dernière n'est pas disponible dans le langage indiqué ici, le contenu sera affiché conformément aux paramètres par défaut de la page web.
  • Jeu de Caractères : Sélectionnez le jeu de caractères correspondant au langage utilisé dans ce contenu. Le jeu de caractères par défaut est défini dans les propriétés générales du projet. Si votre contenu comprend plusieurs langages différents, sélectionnez Unicode UTF-8 dans la liste de jeu de caractères.
    Si ce contenu est lié à une page web et que cette dernière n'est pas disponible avec le jeu de caractères indiqué ici, le contenu sera affiché conformément aux paramètres par défaut de la page web.
  • Content-Type : spécifie le type du contenu MIME. Cette valeur est automatiquement remplie par eMill lors de la création du contenu.
  • Content-Description : sert de rappel si vous avez plusieurs contenus de fichiers dans votre message. La description des attachements est également insérée dans la source MIME et peut être affichée par le client mail.
  • Exécuter les scripts inclus : à cocher si des scripts serveurs sont incorporés au contenu.
  • Convertir en PDF : permet d'envoyer des documents au format PDF. eMill ne peut convertir que les fichiers texte ou html en PDF (pendant la génération des messages). Pour tous les autres formats, les sources des fichiers sont nécessaires pour pouvoir convertir en PDF avant l'importation dans un projet. Consultez le site Adobe pour plus d'informations sur le format PDF.
  • Compresser au format ZIP : permet d'envoyer des attachements au format ZIP pour gagner de l'espace. Si un fichier HTML est compressé, les images et les liens relatifs seront ajoutés à l'archive ZIP.
  • Incorporer les images externes : valide uniquement pour les contenus html. Lorsque cette option est activée, eMill téléchargera les images du contenu html situées sur le web et les incorporera au message final.
  • Générer une partie texte alternative : Pour les contenus HTML, cette option permet de générer et d'ajouter automatiquement un contenu texte alternatif lors de la génération du message.

Conditions :

Détermine si le contenu doit être inclus dans le message. Vous avez ainsi la possibilité d'activer le contenu selon vos conditions. Par exemple, il est possible d'envoyer le contenu en français uniquement aux destinataires qui vivent en France ou envoyer une lettre d'informations sur les livres uniquement aux contacts étant intéressés par les livres, etc. La limite de personnalisation de votre contenu dépendra de la précision de votre source de données.

  • Sélectionnez Activer ce contenu pour que le contenu soit toujours inclus au message.
  • Sélectionnez Désactiver ce contenu pour que le contenu ne soit jamais inclus au message.
  • Sélectionnez Tester les conditions suivantes pour que le contenu soit activé en fonction du résultat des conditions. Celles-ci permettent de tester la valeur des champs de la source de données. Cliquez sur les boutons Ajouter, Éditer et Supprimer pour respectivement ajouter une condition, modifier une condition existante ou supprimer une condition.

Spécifications du contenu et du client mail : les clients mail affichent habituellement une partie du contenu dans une fenêtre "corps du message" et montre une liste d'attachements qui peuvent être ouverts dans le client ou dans une application externe. Il n'y a pas de règles universelles. Les utilisateurs peuvent configurer leur client mail afin qu'il n'affiche pas le html par exemple, dans ce cas le contenu html apparaîtra en tant qu'attachement avec un fichier texte alterné à la place. La configuration du client mail peut aussi avoir une incidence sur la façon dont le message apparaîtra (scripts clients désactivés ou plug-in manquants).
Avec eMill vous avez la possibilité de choisir les instructions d'encodage des parties MIME : chaque fichier contenu est généré pour former un fichier MIME unique avec des délimiteurs. Dans la plupart des cas, la première partie du fichier MIME est affichée d'abord dans la fenêtre "corps du message" pendant que les suivantes sont affichées soit selon l'ordre dans lequel elles sont reçues, soit comme attachements.

Paramètres HTTP :

Cet onglet apparaît lorsque un contenu est créé à partir d'un lien vers une page web. Les options ci-dessous vont vous permettre d'envoyer vers votre page web des données de différents types : champ de la liste de destinataires, variable serveur, valeur constante ou élément de session.

  • Encodage
    • Jeu de caractères : Permet de spécifier le jeu de caractères à utiliser pour les données à envoyer.
    • Type d'encodage : Permet de configurer le type d'encodage des données à envoyer. Utilisez le type d'encodage "multipart/form-data" si vous souhaitez envoyer des données au format binaire.

Pour ajouter des données à envoyer, cliquez sur Ajouter ; pour modifier une donnée à envoyer, sélectionnez l'élément dans la liste et cliquez sur Editer ; pour supprimer une donnée à envoyer, sélectionnez l'élément dans la liste et cliquez sur Supprimer.

  • Méthode
    • URL : Sélectionnez cette méthode pour envoyer les données en tant que paramètres de l'URL de votre page web.
    • POST : Sélectionnez cette méthode pour envoyer les données en tant que paramètres du formulaire de votre page web (simulation d'un clic sur un bouton 'Soumettre').
  • Envoyer un seul champ : Cochez cette option pour spécifier une donnée à envoyer.
    • Nom : Définissez un nom pour la donnée à envoyer.
    • Champ de l'enregistrement : Permet d'envoyer des données provenant de la liste de destinataires. Ex. : Entrez 'email' dans le champ nom, puis, sélectionnez 'Champ de l'enregistrement' et le champ 'Email' de votre liste. Avec la méthode URL, vous envoyez, ainsi, l'adresse email du destinataire en tant que paramètre de l'url : http://www.pageweb.com/?email=destinataires@destinataires.com
    • Elément de Session : Permet d'envoyer la valeur d'un élément de l'objet Session du Script Global. Ex. : Entrez 'Test' dans le champ nom, puis, sélectionnez 'Élément de session' et entrez le nom de l'élément de session. Avec la méthode URL, vous envoyez, ainsi, la donnée sous la forme suivante : http://www.pageweb.com/?Test=ValeurDeLElementDeSession.
    • Variable Serveur : Permet d'envoyer une valeur de la collection ServerVariables de l'objet script Request (PROJECT_PATH, CONTENT_NAME, etc.). Voir Script Server Guide.
    • Valeur constante : Permet d'envoyer tout type de valeur constante. Ex. : Entrez 'Note' dans le champ nom, puis, sélectionnez 'Valeur Constante' et entrez 'Avril2006'. Avec la méthode URL, vous envoyez, ainsi, la donnée sous la forme suivante : http://www.pageweb.com/?Note=Avril2006

  • Envoyer un ensemble de champs : Cochez cette option pour spécifier un ensemble de données à envoyer.
    • Préfixe : Ce champ n'est pas obligatoire mais permet de préfixer l'ensemble des valeurs envoyées.
    • Champs de l'enregistrement: Permet d'envoyer l'ensemble des champs provenant de la liste de destinataires. Par exemple, pour une liste avec les colonnes 'Nom' 'Prenom' 'Email' et 'Telephone' et avec la méthode URL, vous enverrez les données sous la forme suivante : http://www.pageweb.com/?nom=NomDuContact&Prenom=PrenomDuContact&Email=email@email.com&telephone=TelDuContact.
    • Eléments de Session: Permet d'envoyer les différentes valeurs de l'objet Session du Script Global.
    • Variables Serveur: Permet d'envoyer les valeurs contenues dans la collection ServerVariables de l'objet Request. Voir Script Server Guide.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Positionnement des contenus

La fenêtre de positionnement affiche tous les contenus qui sont utilisés pour générer le message.

Depuis la fenêtre de conception, sélectionnez le noeud Contenus, puis cliquez sur le menu Affichage/Propriétés.

Sélectionnez un contenu et cliquez sur les flèches haut et bas pour modifier l'ordre. Vous pouvez aussi sélectionner un contenu et le glisser à la position désirée avec la souris. Les contenus qui ne sont pas marqués comme corps du message (pièces jointes) seront affichés chez les destinataires dans l'ordre défini dans cette boîte de propriétés.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer le contenu du message

Personnalisation des contenus

Un des facteurs clés de réussite d'un projet d'emailing est la personnalisation de votre message. Grâce aux outils d'eMill, vous pouvez rendre votre message attractif et adapté au profil de chacun de vos destinataires (pays, centres d'intérêt, etc.).

La personnalisation des contenus (corps du message ou fichiers joints) peut se faire de 3 façons :

  • Insertion de champs de votre source de données
  • Activation des contenus selon vos conditions
  • Insertion de script via l'interface script
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Insérer un champ de source de données

Insérer un champ de la source de données

Les messages peuvent être facilement personnalisés en insérant des champs de sources de données (variables de contenu) dans le contenu des fichiers Texte ou HTML. Ces variables sont fournies par la source de données des listes de destinataires liées au projet.

  • A partir de l'éditeur de contenus, en mode normal, cliquez dans le document à l'endroit où vous voulez insérer une variable.
  • Sélectionnez Champs de la source de données à partir du menu Insertion.

Tous les champs des sources de données liées à votre projet sont affichés entre {}. On peut attribuer une valeur par défaut pour remplacer les champs vides.

7 champs complémentaires sont affichés automatiquement si ils ont été associés à un champ de votre source de données (voir Propriétés de la liste) :

- FullName : Il est constitué de FirstName et LastName si ils ont été associés à un champ de votre source de données (voir Propriétés de la liste). Les premières lettres sont en capitales, les autres en minuscules.
- FirstName : disponible si "Prénom" a été associé à un champ de votre source de données (voir Propriétés de la liste). La première lettre est en capitale, les autres en minuscules.
- LastName : disponible si "Nom" a été associé à un champ de votre source de données (voir Propriétés de la liste). La première lettre est en capitale, les autres en minuscules.
- EmailAddress : Il est constitué de FirstName, LastName et Email afin de former la syntaxe suivante: "[FirstName] [LastName]" <xyz@abc.tld>.
- Email : l'association de "Email" avec la source de données est obligatoire si vous souhaitez envoyer vos messages par email (voir Propriétés de la liste). Les mauvaises adresses sont contrôlées par le filtreur d'adresses.

- Fax : l'association de "Fax" avec la source de données est obligatoire si vous souhaitez envoyer vos messages par fax (voir Propriétés de la liste). Les numéros de fax dont le format ne permet pas de les exploiter directement peuvent être transformés grâce à l'outil de transformation des numéros.

- SMS : l'association de "SMS" avec la source de données est obligatoire si vous souhaitez envoyer vos messages par SMS (voir Propriétés de la liste). Les numéros de téléphone dont le format ne permet pas de les exploiter directement peuvent être transformés grâce à l'outil de transformation des numéros.
  • Sélectionnez un Champ et cliquez sur OK. Le script est automatiquement généré et inséré dans le fichier.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Insérer des scripts

La fonction "insertion de scripts" incorpore n'importe quel script serveur ou client dans un fichier.

Un script client est un script exécuté par le logiciel qui reçoit l'email (ex : Microsoft Outlook, Netscape Messenger, Eudora, Lotus Mail, Groupwise, etc.).

Un script serveur est exécuté par le serveur eMill afin de générer le message, il utilise les fonctionnalités de scripting d'eMill et est indépendant du client.

  • Sélectionnez le contenu incluant les sciprts.
  • Sélectionnez le menu Affichage/Propriétés et cochez l'option Exécuter les scripts inclus dans les propriétés du contenu
  • A partir de l'éditeur de contenus, en mode normal, cliquez dans le document à l'endroit où vous voulez insérer du script et sélectionnez le menu Insertion/Script... La boîte d'insertion de script s'affiche :

Scripts client :

Sélectionnez JavaScript ou VB Script selon le langage de scripting choisi. Collez ou tapez le script dans la fenêtre Script. Le script ne sera pas exécuté par le préprocesseur d'eMill, mais sera envoyé avec le document.

Scripts serveur :

Cochez l'option Script Serveur et collez ou tapez votre code VB Script dans la fenêtre Script. Ceci signalera à eMill qu'il doit exécuter le script au niveau du serveur.

Insertion du script dans le document : l'emplacement du script dans le document est important. Par exemple, si vous insérez des variables de contenu, eMill générera les délimiteurs du script serveur au point d'insertion. Vous pouvez insérer autant de scripts que vous voulez (client ou serveur) dans un document, il suffit de répéter l'action décrite ci-dessus. Le mode source, dans lequel vous pourrez ensuite éditer, vous indiquera tous les scripts insérés dans le document.

Note : Des exemples de scripts sont disponibles dans le Guide des Scripts Serveur et dans les exemples d'eMill (sélectionner le menu Fichier/Ouvrir exemple)

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer le contenu du message

Les éditeurs intégrés d'eMill

Le logiciel eMill inclut des éditeurs HTML et Texte qui s'adapteront au niveau de connaissance de l'utilisateur. Ils permettent à chacun de créer rapidement et facilement des contenus attractifs.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Utilisation de l'éditeur de Texte

L'éditeur de texte d'eMill vous permet d'écrire des messages en format Texte et des contenus script (à inclure ensuite). Les options de l'éditeur vous permettent de personnaliser la présentation. Elles sont appliquées au texte uniquement quand il est affiché dans l'éditeur. L'éditeur ne génère que du texte brut dépourvu d'information de style, de fonte ou de mise en page.

  • Créez un nouveau contenu à partir de l'éditeur de contenus. Sélectionnez Fichier texte ou Fichier VBScript .
  • Indiquez les propriétés du contenu.
Le fichier est affiché dans l'éditeur de texte. Vous pouvez éditer le message en utilisant les commandes standards.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Utilisation de l'éditeur HTML

L'éditeur HTML propose 2 modes d'édition : le mode normal qui restitue les éléments tels qu'ils apparaîtront dans le client mail, et le mode source qui permet d'éditer directement la source HTML. Utilisez le menu Affichage/Source HTML ou le raccourci CTRL+H pour passer d'un mode à l'autre. Notez que l'éditeur d'eMill, même s'il traite tous les tags nécessaires à la réalisation d'une mise en page améliorée, est destiné à produire du contenu d'emails.

Si vous avez l'intention de réaliser des mises en page recherchées à partir d'un environnement interface graphique, nous vous conseillons d'utiliser un éditeur web professionnel puis d'importer le fichier dans votre projet ou de copier/coller le contenu.

Pour les instructions concernant l'édition, voir la description des commandes standards et éditeur html

Avant de commencer, sélectionnez le contenu HTML que vous souhaitez éditer.

Propriétés de la page :

Pour accéder aux propriétés de votre document HTML, sélectionnez le menu Format/Propriétés de la page :
  • Titre de la Page : (Optionnel) - Le texte inséré entre les balises <TITLE></TITLE> est affiché en tant que nom du document quand il est vu à partir d'un navigateur web.
  • Marges : (Optionnel) - Spécifie les attributs TOPMARGIN et LEFTMARGIN du tag BODY. Détermine l'espace entre les limites extérieures de la fenêtre client et le contenu affiché.
Sélectionnez l'onglet Arrière-plan pour accéder aux propriétés complémentaires :
  • Image en arrière-plan : choisir le fichier JPEG ou GIF que vous voulez afficher en arrière-plan.
  • Couleur du texte par défaut : génère et affecte une valeur à l'attribut TEXT du tag BODY.
  • Couleur de l'arrière-plan : spécifie la couleur de remplissage de l'arrière-plan dans la fenêtre du client mail. Génère et affecte une valeur à l'attribut du tag BODY.

Copier/Coller un contenu HTML depuis une application externe :

Si vous créez votre contenu HTML en utilisant une application externe vous pouvez soit importer le fichier dans votre projet soit copier le contenu pour le coller dans l'éditeur d'eMill.

Si vous utilisez des applications qui ne sont pas des éditeurs HTML professionnels (Microsoft Word, Microsoft Publisher...), il est fortement conseillé de ne pas importer le fichier tel quel mais de copier le contenu et le coller dans l'éditeur HTML d'eMill en utilisant la fonctionnalité Collage Spécial. Celle-ci permet de 'nettoyer' le code créé par ces applications et vous évitera d'être bloqué par les filtres anti-spam de certains clients mail.

Pour utiliser le Collage Spécial, copiez le contenu de votre email, ouvrez l'éditeur HTML d'eMill dans la vue Design et rendez vous dans le menu Edition > Collage Spécial.

Cochez les cases correspondant aux éléments que vous souhaitez supprimer. Par exemple, si vous collez un contenu en provenance de Word, il est conseillé de cocher la case Styles. En cochant la première case Tous les tags et attributs, vous ne garderez que le texte du document.

Fonctionnalités d'édition du texte :

L'éditeur propose les polices disponibles sur votre système. Puisque le client mail s'appuie sur les polices du système, il est conseillé dans un souci d'uniformité de ne pas utiliser de polices trop "exotiques".
  • Police : liste des polices disponibles sur votre système. Génère et affecte une valeur au tag FONT.
  • Style : applique au texte sélectionné les tags STRONG (gras) et EM (italique).
  • Taille : génère et affecte une valeur à l'attribut SIZE du tag FONT
  • Effets : applique au texte sélectionné le tag U (souligné). Le paramétrage des couleurs génère et affecte une valeur à l'attribut COLOR du tag FONT autour du texte sélectionné.
  • Séparateurs : "Insérer une Ligne Horizontale" génère un tag HR au point d'insertion. "Insérer une Coupure de Ligne" génère un tag BR au point d'insertion. "Retour Charriot" (Entrée) génère un tag P au point d'insertion.

Insertion d'images :

eMill insère les images par défaut dans le fichier email. Si vous avez besoin de conserver des images sur le serveur, tapez l'URL complète du fichier image en mode source (ex : "http://www.masociete.fr/graphics/map.gif")
  • Source de l'Image : chemin et nom du fichier de l'image. Utilisez le bouton de droite pour rechercher le fichier ou tapez une chaîne URL commençant par http:// pour des images stockées sur un serveur web. Génère et affecte la valeur à l'attribut SRC (source) du tag IMG (image).
  • Équivalent texte : fournit du texte en remplacement de l'image pour les clients qui ne téléchargent pas les graphiques. Génère et affecte une valeur à l'attribut ALT du tag IMG.
  • Mise en page : génère et affecte des valeurs aux attributs ALIGN et BORDER du tag IMG.
  • Espacement : génère et affecte des valeurs aux attributs HSPACE et VSPACE du tag IMG.

Liens :

Vous permet de créer un lien depuis une sélection texte ou image.
  • URL : entrez l'adresse http sur laquelle pointe le lien.
  • Signet : ajoute une ancre optionnelle à l'adresse du dessus.
  • Autoriser le suivi du lien : Détermine si le clic sur ce lien doit être enregistré si le suivi des messages est activé.
  • Nom: définissez un nom pour le lien afin de le différencier lors de l'analyse des statistiques de suivi des messages.

Lien de désabonnement : A partir du menu Insertion, sélectionnez 'Lien de désabonnement'. Ceci ajoute un lien à votre message avec le texte 'Cliquez ici pour se désabonner'. Lorsqu'un destinataire clique sur ce lien, un nouveau message est ouvert avec les éléments suivants pré remplis :
- A : Le message est envoyé à l'adresse email de l'expéditeur de la campagne (voir Propriétés de l'en-tête).
- Sujet : Il est composé du terme 'UNSUBSCRIBE', de l'adresse email du destinataire et du numéro d'identification de votre projet eMill.
Notez que vous pouvez traiter automatiquement les demandes de désabonnements avec eMill grâce aux Règles de Message.

Tableaux :

Les tableaux aident à contrôler les mises en page HTML, ils permettent de positionner du texte ou des images dans une grille dont les dimensions peuvent être déterminées précisément.

Les tags et les attributs générés pour les tableaux :
  • TABLE : ce tag indique l'endroit où commence <TITLE> et finit </TITLE> un tableau.
  • TR : ce tag indique l'endroit où commence <TR> et finit </TR> une ligne.
  • TD : ce tag indique l'endroit où commence <TD> et finit </TD> une cellule dans une ligne.

Quelques astuces de base à connaître si vous créez vos tableaux en mode source :

Le texte et les images sont insérés entre <TD></TD>, qui délimitent une cellule.

Les cellules sont inclues entre <TR></TR>, qui marquent les limites d'une ligne.

les lignes sont inclues entre <TABLE></TABLE>, qui définissent un tableau.

Le nombre de fois où <TR></TR> apparaît indique le nombre de lignes du tableau. Le nombre de fois où <TD></TD> apparaît entre chaque <TR></TR> indique le nombre de cellules. Il doit être identique pour chaque ligne si aucune cellule contiguë n'est fusionnée. Les cellules contiguës dans une ligne peuvent être fusionnées, dans ce cas un attribut COLSPAN est généré après le tag <TD> (ex : <TD COLSPAN=2> indique que 2 cellules de la ligne sont fusionnées). Notez que eMill ne génère pas les attributs ROWSPAN en aperçu normal (fusionner des cellules contiguës dans deux lignes différentes).

Les attributs WIDTH et HEIGHT peuvent être ajoutés aux tags TABLE, TR et TD. La valeur sera en pixels ou en pourcentage (dimension du tableau ou de la fenêtre). Ces attributs sont utilisés pour une mise en page HTML précise.

Attributs des tableaux :
  • Nombre de Colonnes : détermine le nombre de cellules par ligne (tags TD).
  • Nombre de Lignes : détermine le nombre de lignes (tags TR, incluant les tags ci-dessus).
  • Taille : applique un attribut WIDTH et/ou HEIGHT au tag TABLE (choisir en pixels ou en pourcentage).
  • Bordure : détermine l'attribut BORDER au tag TABLE (épaisseur des bords du tableau).
  • Espacement des Cellules : indique l'attribut CELLSPACING au tag TABLE (espace entre les cellules).
  • Bordure des Cellules : indique l'attribut CELLPADDING au tag TABLE (espace entre les objets dans la cellule et les limites externes de la cellule).
  • Couleur Tableau : indique l'attribut BGCOLOR au tag TABLE.
  • Couleur Cellules : programme un attribut BGCOLOR à tous les tags TD du tableau.
Les attributs optionnels à partir de l'option Propriétés du Tableau (clic droit dans le tableau) :
  • Arrière-plan : détermine un fichier image JPEG ou GIF à l'arrière-plan du tableau (attribut BACKGROUND).
  • Alignement : génère les tags DIV et détermine l'attribut ALIGN avant le tag TABLE.
Attributs des Cellules : faites un clic droit dans la cellule ou sélectionnez un groupe de cellules sur une même ligne. Note : les cellules vides ne peuvent pas être sélectionnées en aperçu normal. Les cellules sont créées avec un espace pour permettre la sélection. Créez-en un si ce dernier à été supprimé.
  • Taille : applique un attribut WIDTH et/ou HEIGHT au tag TD (choisir en pixels ou en pourcentage).
  • Couleur Cellule : indique un attribut BGCOLOR au tag TD.
  • Arrière-plan : détermine un fichier image JPEG ou GIF à l'arrière-plan de la cellule (attribut BACKGROUND).
  • Alignement Horizontal : détermine l'attribut ALIGN au tag TD.
  • Alignement Vertical : détermine l'attribut VALIGN au tag TD.
Couleurs : l'éditeur fournit une palette de couleurs. Les couleurs s'appliquent au texte, aux tableaux, aux cellules et à l'arrière-plan du document. Vous pouvez spécifier des couleurs personnalisées et les ajouter à la palette couleur du projet.

A partir des propriétés d'une page, d'un tableau, d'une cellule ou d'une police, sélectionnez la couleur que vous désirez. Pour ajouter une couleur avec la palette, sélectionnez Personnaliser les couleurs, choisissez une couleur dans l'échantillonneur et cliquez sur Ajouter aux couleurs personnalisées.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Options des éditeurs

eMill dispose d'un éditeur HTML et d'un éditeur Texte/Scripts. L'éditeur est sélectionné en fonction du type de contenu, et le fichier à éditer est affiché dans l'éditeur de contenus.

Éditeur HTML :

Pour afficher les options HTML, éditer un fichier HTML, puis sélectionner le menu Outils/Options de l'éditeur HTML
  • Cochez Tous les marqueurs pour afficher certains tags de mise en forme tels que les paragraphes, les sauts de lignes, etc.
  • Cochez Afficher les bordures d'épaisseur nulle pour visualiser les bordures invisibles en mode édition.
  • Cochez Ouvrir en mode source HTML par défaut pour ouvrir l'éditeur HTML en mode source HTML par défaut.
  • Cochez Encoder les caractères 8 bit en tant qu'entités HTML pour transformer tous les caractères 8 bit en entité HTML lorsque une entité correspondante existe (ex.: au caractère © correspond l'entité HTML &copy).

Éditeur texte :

Pour afficher les options de l'éditeur texte, éditez un fichier texte ou script et sélectionnez le menu Outils/Options de l'éditeur de script

Les configurations de l'éditeur de script vous permettent d'afficher le code de façon détaillée. Vous pouvez affecter des couleurs aux différents éléments du script, indenter, ou mettre les mots-clés en lettres capitales.

Toutes les options doivent être décochées lorsque vous utilisez l'éditeur pour écrire du contenu texte.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer les enregistrements

Éditer les listes de destinataires

La création et la gestion des listes de destinataires et des listes noires sont des moments clés de la conception d'un projet d'emailing. Grâce à la flexibilité et à la puissance d'eMill, vous disposez d'un ensemble complet de fonctionnalités pour créer des listes de qualité et très ciblées.

En effet, eMill vous permet de créer une liste de destinataires depuis n'importe quel type de sources de données. Vous pourrez ensuite sélectionner les tables/requêtes et les champs que vous souhaitez utiliser afin de disposer d'une liste très précise.

Une fois la liste créée, vous pouvez :

- Modifier les enregistrements directement dans eMill.

- Importer ou Exporter des adresses.

- Vérifier les adresses.

- Éditer les propriétés des listes de destinataires ou les propriétés des listes noires. Ces outils vous permettront, par exemple, d'ajouter des filtres à votre source de données afin d'affiner la sélection de vos destinataires.

Un peu de vocabulaire...

- Enregistrement : Un "enregistrement" correspond à une ligne de votre base de données.

- Champs : Un "champ" correspond à une colonne de votre base de données.

- Tables : Une "table" correspond à un tableau à deux dimensions comprenant des enregistrements et des champs. Une base de données peut intégrer plusieurs tables.

- Requêtes : Une "requête" est une demande adressée à une base de données qui permet de l'interroger et d'en extraire des informations précises. eMill utilise des requêtes SQL pour extraire les informations demandées par l'utilisateur.

- Chaîne de connexion ADO : Une "chaîne de connexion ADO" permet à eMill de créer et de gérer une connexion avec votre base de données.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer les enregistrements

Ajouter une liste de destinataires

Au lancement de l'assistant Nouveau Projet de Publipostage, vous pouvez sélectionner le type de source de données que vous souhaitez utiliser pour établir votre liste de destinataires. Une fois le projet créé, vous pouvez ajouter une liste de destinataires ou une liste noire à tout moment en sélectionnant Projet/Ajouter une liste de destinataires ou Projet/Ajouter une liste noire.

La flexibilité d'eMill vous permet d'utiliser vos données quelques soient le format de votre source de données :

  • Si vous souhaitez utiliser une liste partagée, eMill ouvrira un assistant spécifique permettant de sélectionner la liste à utiliser.
  • Si vous n'avez pas de bases de données, eMill vous permet de créer votre liste de destinataires directement dans eMill. eMill créera un fichier base de données spécifique (database.mdb) dans l'arborescence du projet et l'associera automatiquement au projet. Vous pourrez éditer ensuite les champs et les enregistrements de cette base depuis la vue destinataires d'eMill.
  • Si vous souhaitez vous connecter à une base de données (Excel, Access, Carnet d'adresses Windows, Contacts Outlook), eMill ne créera pas une base de données spécifique à votre projet. Il générera automatiquement une chaîne de connexion avec le fichier sélectionné et les champs choisis. Il vous sera possible de sélectionner les champs dans des tables ou des requêtes.
  • Si vous sélectionnez d'autres formats de bases de données (Oracle, ...), eMill ouvrira une boîte de paramétrage de connexion aux bases de données qui vous aidera à établir la connexion entre eMill et votre source de données. Quand la connexion est établie avec succès, il vous sera possible de sélectionner les champs dans des tables ou des requêtes.
  • Si vous sélectionnez Source de Données XML, eMill vous permettra de vous connecter à des fichiers XML dont le format est celui utilisé par le recordset d'ADO. Cette option a pour principal utilité de récupérer des adresses email depuis des applications eCommerce telles que osCommerce ou Oxid.
  • Si vous souhaitez utiliser une base de données MySQL, eMill ouvrira un assistant spécifique.
  • Si vous souhaitez utiliser une base de données SQL Server, eMill ouvrira un assistant spécifique.
  • Si vous avez collecté des adresses email dans un fichier texte non structuré, eMill vous permettra de les récupérer rapidement.
  • Si vous souhaitez utiliser une liste d'un compte eMill OptIn Service (service gratuit de gestion de listes d'abonnés), vous pouvez construire une connexion directe entre eMill OptIn Service et votre projet.
  • Si vous souhaitez utiliser le système pixi* (système de gestion de back office de sites e-commerce), vous pouvez construire une connexion directe entre pixi* et votre projet.

Tous les champs sélectionnés sont disponibles dans eMill et sont affichés dans la vue destinataires. Les champs contenant les adresses email ou les numéros de fax et de téléphone sont nécessaires selon le canal d'émission que vous souhaitez utiliser. Les autres champs serviront aux variables de contenu (nom, préférences, montant d'une facture, etc.) et peuvent être insérés dans le message grâce à l'option Insérer/Champ de données.

Une fois la liste créée, il est possible de filtrer les enregistrements, de modifier les associations de champs et d'éditer la source de données soit à partir des propriétés du projet soit en sélectionnant la liste et en cliquant sur Affichage/Propriétés.

Bases de données et Aperçus : n'oubliez pas que les enregistrements affichés dans la vue Destinataires ne sont qu'une IMAGE de la base construite à partir des requêtes. Si vous avez l'autorisation de modifier des enregistrements dans la vue Destinataires et que vous le faites, vous modifierez en fait les entrées de la base à laquelle vous êtes lié. Noter que certaines bases de données ne vous permettront pas de modifier ou de détruire des enregistrements à partir de la vue Destinataires d'eMill.
Liaison avec des applications de Gestion de Relation Client : certaines applications GRC ne s'appuient pas sur une base de données unique pouvant être accessibles par une chaîne de connexion ADO et des requêtes SQL. La source de données est plutôt divisée en fichiers de divers formats. eMill implémente un fournisseur spécifique pour lier un projet à ACT! par exemple, permettant d'utiliser n'importe quel enregistrement de cette application. eMill détectera si ACT! est installé sur la même machine et proposera de s'y lier avec l'assistant Nouveau Projet de Publipostage. D'autres fournisseurs de données spécifiques seront ajoutés prochainement.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Listes partagées

eMill vous permet d'utiliser des listes partagées en tant que liste de destinataire ou liste noire.
  • Quand vous démarrez un nouveau projet ou quand vous ajoutez une nouvelle source de données à un projet existant, sélectionnez la source de données "Liste partagée eMill".

  • Emplacement : Serveur eMill où est située la liste. Habituellement un unique serveur est disponible. Veuillez noter que le projet doit être publié sur le même serveur eMill que la liste, ou cette dernière ne sera pas disponible.
  • Nom : Nom de la liste partagée à utiliser. Seules les listes accessibles à l'utilisateur en cours sont affichées.

Puis cliquez sur <Suivant> pour sélectionner vos Tables/Requetes.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Créer une nouvelle base de données

Vous n'avez pas de base de données

Vous pouvez créer une nouvelle base de données si vous n'avez pas de base à laquelle vous connecter. eMill générera une base de données compatible Microsoft Access dans le dossier de votre projet avec des champs définis au préalable. Vous pouvez modifier ces champs ou en ajouter en éditant la base avec l'option Source de Données/Ajouter ou Supprimer Colonne, ou en utilisant Microsoft Access.

  • Dans l'assistant, sélectionnez Je n'ai pas de base de données, en créer une dans la boîte de sélection de la source de données.

Une fois la base créée, vous pouvez ajouter/éditer des enregistrements dans la vue destinataires en utilisant le menu Projet/Enregistrement ou la boîte d'outils des enregistrements. Pour plus de détails, voir modifier un enregistrement.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Importer d'un fichier

Importer d'un fichier texte non structuré

eMill vous permet d'importer des adresses email depuis de nombreux formats de fichiers (txt, csv, html, doc, xls, etc) ou depuis le presse-papiers. Cette fonctionnalité est pratique pour envoyer un message à une liste de destinataires non sauvegardée dans une base de données. Vous n'avez pas besoin d'ouvrir le fichier ou d'installer l'application : eMill parcourt et reconnaît les adresses dans la multitude d'informations.

  • Dans l'assistant, sélectionnez Importer d'un fichier texte non structuré, dans la boîte de sélection des sources de données

Importer depuis un fichier

  • Sélectionnez Importer les adresses de n'importe quel fichier :
  • Tapez le chemin ou cliquez sur le bouton à droite du champ pour rechercher votre fichier. Le chemin du fichier source et la base par défaut sont affichés (database.mdb).

Importer depuis le presse-papiers

Si eMill n'est pas capable d'importer des adresses d'un fichier (les données ne sont pas reconnues parmi les informations), vous pouvez ouvrir le fichier dans son application native et copier le contenu dans le presse-papiers. eMill extraira alors les adresses à partir du presse-papiers.

  • Ouvrez le fichier dans son application et copiez le contenu dans le presse-papiers.
  • Sélectionnez Importer les adresses du Presse-papiers :

Le nombre total d'adresses email importées dans la nouvelle base du projet est affiché. Les enregistrements importés sont sauvegardés dans un fichier database.mdb, à l'intérieur du dossier projet, qui pourra être édité plus tard dans la vue destinataires ou en utilisant Microsoft Access.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Connexion à une base de données

Se connecter à une base de données

eMill s'intègre avec les fichiers Microsoft Access, Excel, Carnet d'adresses Windows, contacts Outlook, ACT! 2000, et génère automatiquement la chaîne de connexion et les requêtes SQL pour récupérer les champs d'une base.

  • Dans l'assistant, sélectionnez l'une des options suivantes :
    - Tableau Excel (.xls)
    - Base de données Access (.mdb)
    - Carnet d'adresses Windows (.wab)
    - Outlook
    - Fichiers texte
  • Si nécessaire, tapez le chemin d'accès à votre fichier dans la boîte de sélection des sources de données, ou cliquez sur le bouton à droite pour rechercher votre fichier.

eMill récupérera toutes les tables et les requêtes de la base (procédure de stockage) et les affichera dans la fenêtre Tables/Requêtes.

  • Sélectionnez une des Tables/Requêtes de la base pour visualiser les Champs disponibles. Sélectionnez les champs dont vous avez besoin pour votre projet : cliquez sur les champs en maintenant la touche CTRL enfoncée pour en sélectionner plusieurs. L'* vous permet de sélectionner l'ensemble des champs de la Table/Requête sélectionnée. Notez que, selon le canal d'émission que vous souhaitez utiliser, vous devez avoir un champ contenant les adresses email, les numéros de fax ou de téléphone.
  • Si nécessaire, faire les associations de champs qui serviront pour les informations utilisées dans les en-têtes de message. Cliquez sur le menu déroulant, vous devez voir la liste de tous les champs récupérés. Selon le canal d'émission que vous souhaitez utilisé, vous devez associer un champ email, fax ou SMS.

Le générateur de requêtes SQL : sélectionner les tables/requêtes de la base et les champs disponibles génère une requête SQL qui remontera les informations. Vous pouvez cependant éditer et entrer n'importe quelle requête SQL sans utiliser le générateur d'eMill.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Générer une chaîne de connexion

Connexion à une base de données par ADO avancées

eMill se connecte aux bases de données en utilisant des chaînes de connexion ADO (ActiveX Data Objects) : il suffit d'indiquer le fournisseur de base de données (pilote) et le chemin d'accès. eMill utilise les drivers installés avec le système d'exploitation incluant la plupart des fournisseurs de formats de bases de données. Les boîtes de dialogue suivantes font partie de votre système Windows 2000 et de la documentation de l'aide Windows.

  • Quand vous créez un nouveau projet, cochez ADO Avancées (SQL Server, Oracle, etc.) dans la boîte de sélection des sources de données.
  • Entrez la chaîne de connexion si vous la connaissez ou cliquez sur le bouton à droite pour appeler la fenêtre Propriétés des liaisons de données.
  • Sélectionnez le fournisseur qui supporte votre base et entrez le chemin d'accès à votre base à partir de l'onglet Connexion. Pour savoir quel fournisseur sélectionner, consultez le vendeur de votre base de données ou la documentation Microsoft. Vous pouvez également essayer quelques fournisseurs de la liste et Tester la connexion (recommandé)

Quand la connexion est correctement établie, retournez dans la boîte de sélection source de données en cliquant sur OK. La chaîne de connexion est affichée :

eMill récupérera toutes les tables et les requêtes de la base (procédure de stockage) et les affichera dans la fenêtre Tables/Requêtes :

  • Sélectionnez une des Tables/Requêtes de la base pour visualiser les Champs disponibles. Sélectionnez les champs dont vous avez besoin pour votre projet : cliquez sur les champs en maintenant la touche CTRL enfoncée pour en sélectionner plusieurs. L'* vous permet de sélectionner l'ensemble des champs de la Table/Requête sélectionnée. Notez que, selon le canal d'émission que vous souhaitez utiliser, vous devez avoir un champ contenant les adresses email, les numéros de fax ou de téléphone.
  • Si nécessaire, faire les associations de champs qui serviront pour les informations utilisées dans les en-têtes de message. Cliquez sur le menu déroulant, vous devez voir la liste de tous les champs récupérés. Selon le canal d'émission que vous souhaitez utilisé, vous devez associer un champ email, fax ou SMS.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Source de données XML

Le connecteur XML a pour principal objectif de vous donner la possibilité de récupérer les adresses email depuis des solutions de e-commerce telles que osCommerce ou Oxid. En effet, en utilisant cet assistant, vous pouvez uniquement vous connecter aux fichiers XML dont le format est celui utilisé par le recordset d'ADO ou d'ADO.NET. Si vous souhaitez en savoir plus sur ces formats, visitez la page de la Bibliothèque Microsoft consacré au recordset ADO ou au recordset ADO.NET(en anglais).

Lorsque vous sélectionnez Source de données XML, l'assistant vous permet d'entrer l'URL où se situe le fichier XML. L'URL peut être de type 'http' ou 'https' et l'accès au fichier peut être sécurisé par un mot de passe.

Cliquez ici pour afficher un exemple de format de fichier XML pouvant être utilisé avec cet assistant.

Notez que si vous souhaitez récupérer des données d'un fichier XML ayant un format différent, vous avez la possibilité d'utiliser l'Objet Datasource du Script Global (vous trouverez plus de détails en ouvrant l'exemple Source de données XML à partir de Fichier -> Ouvrir Exemple).

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Se connecter à une base de données MySQL

eMill s'intègre parfaitement à MySQL et génère automatiquement la chaîne de connexion ADO et la requête SQL pour récupérer les champs destinataires.
  • Quand vous démarrez un nouveau projet ou quand vous ajoutez une nouvelle source de données à un projet existant, sélectionnez la source de données "Base de données MySQL".

  • Serveur MySQL : Entrez le nom ou l'adresse IP de votre serveur MySQL.
  • Port : Entrez le port TCP/IP. Le port par défaut de MySQL est 3306.
  • Nom d'utilisateur/Mot de passe : Entrez votre nom d'utilisateur MySQL et votre mot de passe.
  • Base de données: Sélectionnez la base de données qui contient votre liste de destinataires.

Puis cliquez sur <Suivant> pour sélectionner vos Tables/Requetes

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Se connecter à une base de données SQL Server

eMill s'intègre parfaitement à SQL Server et génère automatiquement la chaîne de connexion ADO et la requête SQL pour récupérer les champs destinataires.
  • Quand vous démarrez un nouveau projet ou quand vous ajoutez une nouvelle source de données à un projet existant, sélectionnez la source de données "Base de données SQL Server".

  • Hôte SQL Server : Entrez le nom ou l'adresse IP de votre serveur SQL Server ou choisissez en un dans la liste déroulante.
  • Nom d'utilisateur : Entrez votre nom d'utilisateur SQL Server. Si aucun nom n'est fournis, l'authentification Windows interactive sera utilisée.
  • Mot de passe : Mot de passe associé au nom d'utilisateur.
  • Base de données : Sélectionnez la base de données qui contient votre liste de destinataires.
  • Mémorise les paramètres : Cochez cette case pour mémoriser les paramètres saisis pour une prochaine utilisation. Si cette case est décochée, les paramètres précédemment mémorisés seront effacés.

Puis cliquez sur <Suivant> pour sélectionner vos Tables/Requetes.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Connexion à un compte eMill OptIn Service

eMill OptIn Service est un service en ligne gratuit pour automatiser l'ensemble du processus de gestion d'une liste de diffusion :

  • Création d'un formulaire d'abonnement personnalisé
  • Gestion automatique des abonnements et des désabonnements
  • Support du procédé de double opt-in
  • Nombre illimité de listes et d'abonnés
  • Statistiques d'abonnement

Se connecter à un compte eMill OptIn Service

Si vous disposez d'un compte eMill OptIn Service, vous avez la possibilité de diffuser des campagnes d'e-mailing en utilisant vos listes eMill OptIn Service.

Pour connecter un projet d'emailing à votre compte eMill OptIn Service, voici les étapes à suivre :

  • Lancez l'assistant d'ajout d'une nouvelle liste
  • Sélectionnez l'option 'Liste d'abonnés eMill OptIn Service'
  • Entrez l'adresse email et le mot de passe de votre compte eMill OptIn Service
  • Sélectionnez la liste eMill OptIn Service que vous souhaitez utiliser
  • Sélectionnez les colonnes de la liste que vous souhaitez afficher dans votre projet

Vous avez maintenant construit une connexion directe entre eMill et votre compte eMill OptIn Service. Cela signifie qu'à chaque fois qu'un abonné sera ajouté ou supprimé d'une liste eMill OptIn Service, les changements seront immédiatement répercutés dans votre projet d'e-mailing.

Notez que vous ne pouvez pas éditer une liste eMill OptIn Service à partir d'eMill. Si vous devez modifier un enregistrement, supprimer un contact ou changer la structure de la liste, vous devez vous connecter en ligne à votre compte eMill OptIn Service.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Connexion à un système pixi*

pixi* est un système de contrôle et de gestion des produits et des stocks pour les sites Internet marchands. Il permet de traiter, d'organiser et de superviser un magasin en ligne 24/7 partout dans le monde.

Grâce au partenariat mis en place avec l'éditeur de pixi*, MadGeniuses, eMill donne la possibilité de connecter directement un projet d'emailing à un système pixi*. Ainsi, vous élaborez des processus de communication réactifs, ciblés et efficaces.

Se connecter à un système pixi*

Avant de se connecter à pixi*, vous devez commander auprès de MadGeniuses le module 'API pixi*'. Vous recevrez avec ce module, l'URL, le nom d'utilisateur et le mot de passe à entrer pour vous connecter à votre système pixi*.

Ensuite, vous pouvez définir des filtres afin de récupérer uniquement les données nécessaires à votre campagne. Pour activer un ou plusieurs filtres, cochez simplement la case appropriée dans les différentes pages de filtrage.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer les enregistrements

Éditer les enregistrements

eMill fournit un ensemble complet d'outils pour optimiser la gestion et la qualité de vos listes de destinataires :

- Modifier les enregistrements directement dans eMill.

- Importer des adresses dans une liste ou exporter les adresses d'une liste.

- Vérifier les adresses (email and fax) : syntaxe, informations DNS et simulation de l'envoi.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Modification d'un enregistrement

Modifier un enregistrement

Pour éditer un enregistrement, utilisez le menu Projet/Enregistrement, la boîte d'outils des enregistrements ou double-cliquez sur la ligne d'un enregistrement (à condition d'avoir configuré l'option dans les options générales)

  • Depuis la vue destinataires ou liste noire, sélectionnez un enregistrement pour l'éditer :

Les champs proviennent soit d'une base externe à laquelle vous vous êtes liés, soit de la base du projet si vous en avez créé une. En modifiant un enregistrement dans l'éditeur d'enregistrements, la donnée dans la base sera modifiée.

Vous pouvez également ajouter ou supprimer des enregistrements dans la vue destinataires en utilisant l'option Projet/Enregistrement/Ajouter nouveau ou Supprimer. Notez que les restrictions s'appliquent en fonction de l'option de la source de données (voir note en bas de page).

Ajouter/Supprimer des colonnes :

Les colonnes de la vue destinataires reproduisent les champs récupérés dans la base. Pour ajouter ou supprimer des champs, utilisez l'option Projet/Source de Données/Ajouter une colonne ou supprimer une colonne. Notez que des restrictions s'appliquent en fonction de l'option de la source de données et de vos autorisations utilisateurs.

Les sources de données qui ne vous permettent pas d'éditer les enregistrements :

Changer des enregistrements dans la vue destinataires modifiera les entrées de la base de données à laquelle le projet est lié. Cependant vous ne pourrez pas éditer, ajouter ou supprimer d'enregistrements dans les cas suivants :
  • Base de données en lecture uniquement : le compte de la base ne vous permet pas de modifier des enregistrements.
  • Champs récupérés dans des tables distinctes : la requête SQL remonte des données de plusieurs tables.
  • Formats spécifiques : carnet d'adresses Windows, contacts Outlook ou Act!

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Importer/Exporter des adresses

Importer des adresses

Avec eMill, vous pouvez importer et ajouter des enregistrements depuis n'importe quelle source de données. Par exemple, si votre projet est connecté à une base Access, vous pouvez importer des enregistrements supplémentaires d'une base Oracle et les ajouter à votre base Access.

Il est important de noter que pour importer des adresses dans une base de données, vous devez disposer des droits d'accès et d'édition (contactez votre administrateur réseau si ce n'est pas le cas).

Tous les enregistrements seront consultables dans la vue destinataires.

  • Depuis la vue destinataires, sélectionnez l'option Fichier/Importer des Adresses. L'assistant s'affiche :
  • Sélectionnez le type de source de données que vous voulez utiliser pour importer les enregistrements. L'assistant vous demandera de sélectionner les tables qui comportent les champs à importer. Selon le canal d'émission sélectionné, vous devez avoir un champ contenant les adresses email, les numéros de fax ou de téléphone. La requête SQL est générée automatiquement.
  • L'assistant affiche les champs de votre liste de destinataires (Source de données) ainsi que les champs nouvellement récupérés (Champs importés). Sélectionnez les champs dans la liste Champs Importés et leur correspondance dans la Source de Données, puis cliquez sur Lier pour construire les associations.

Cliquez sur Suivant. Le nombre d'enregistrements importés est affiché. Les enregistrements sont, à présent, incorporés à la source de données Destinataires.

Fusionner différentes bases de données :

Si votre projet est lié à une base d'entreprise et que vous ne voulez pas ou ne pouvez pas y ajouter les adresses importées, vous devez :

- Exporter les enregistrements de votre base d'entreprise dans une base temporaire (voir ci-dessous).

- Ajouter cette nouvelle base en utilisant l'assistant Ajout d'une liste de destinataires.

- Importer et fusionner les adresses (voir ci-dessus).

Exporter des enregistrement d'une base de données :

A partir de la vue destinataires, utilisez l'option Fichier/Exporter Adresses pour exporter tous les enregistrements de la vue destinataires dans une base temporaire. Cette option est utile lorsque vous ne voulez pas ou ne pouvez pas effectuer des modifications dans la base utilisée par votre projet.

Les propriétés des listes de destinataires ou les propriétés des listes noires vous propose également l'option d'exporter la liste lors de la publication du projet. Lorsque cette option est activée, il n'est plus nécessaire de disposer d'une connexion permanente à la source de données lors de la génération des emails.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Vérification des adresses email

Vérifier les adresses

eMill propose une option qui permet de vérifier toutes les adresses (email ou téléphone pour le fax et le SMS) avant de publier le projet. Vous pouvez spécifier les options de vérification ainsi que les options de correction. Les modifications effectuées selon ces mesures seront reproduites dans la base de données.

  • Dans le menu Outils, sélectionnez Vérifier les adresses :

Options de vérification :

  • Vérifier la syntaxe des adresses :
    - Adresse eMail : les critères sont au moins un caractère entre deux '.', au moins un caractère avant le '@', au moins un caractère entre le '@' et le dernier '.' et au moins un caractère après le dernier '.' (aucun caractère interdit).
    - Numéros de fax ou de téléphone : Pour être validés, les numéros de fax ou de téléphone doivent répondre aux exigences d'un des 3 formats suivants : numérotable, canonique ou international.
  • Vérifier les informations DNS : contrôle si le nom de domaine est reconnu en tant que serveur mail (uniquement disponible pour les adresses email).
  • Se connecter au mail serveur et simuler l'envoi : contrôle si la boîte mail est reconnue par le serveur de réception (uniquement disponible pour les adresses email).
  • Ignorer les adresses vides : le générateur ignorera l'enregistrement (l'entrée restera dans la base de données).

Mesures correctives :

  • Détruire l'enregistrement : si un problème relatif aux options ci-dessus est détecté, l'enregistrement sera supprimé de la liste et de la base.
  • Écrire le champ : cette option vous permet d'entrer des commentaires tels que "contrôler cette adresse", permettant de classer les adresses invalides et de les corriger ultérieurement.
  • Éditer l'enregistrement manuellement : cette option permet d'éditer un enregistrement erroné quand il est détecté.
  • Appeler l'événement : lie la détection d'erreur à un événement script dans le script global.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Gestion de l'Opt-In

Cet assistant vous permet d'automatiser la gestion des abonnements à votre liste d'envoi. Il génère un formulaire à copier/coller sur votre site Internet, crée un message de confirmation (double opt-in) et ajoute des règles de traitement des messages pour la gestion des demandes d'inscription ou de désinscription.
  • Sélectionnez dans l'arborescence la liste que vous souhaitez utilisez et rendez vous dans le menu Outils > Configuration de l'Opt-In.
  • Formulaire Web : Vous allez maintenant créer un formulaire qui sera intégré à votre site Internet et permettra aux visiteurs de s'abonner à votre liste d'envoi.
    1. Sélectionnez les champs : Le tableau liste les champs disponibles dans votre liste d'envoi. La première étape consiste à sélectionner les champs que vous souhaitez faire remplir par les nouveaux abonnés à votre liste d'envoi. Pour chacun de ces champs, vous pouvez choisir si il est :

      - Obligatoire : Le champ apparaîtra dans le formulaire d'abonnement. Si le nouvel abonné ne fournit pas cette information, un message lui précisera que cette information est obligatoire.
      - Optionnel : Le champ apparaîtra dans le formulaire d'abonnement mais le nouvel abonné ne sera pas obligé de fournir cette information.
      - Ne pas demander : Si vous souhaitez qu'un champ n'apparaisse pas dans le formulaire, décochez le(s) case(s) correspondante(s).

    2. URL de redirection : Une fois que le nouvel abonné envoie le formulaire, il sera redirigé vers l'URL indiquée ici.
      Si vous souhaitez rediriger le nouvel abonné vers une page de bienvenue, voici les étapes à suivre :
      - Créez une nouvelle page sur votre site Internet appelée, par exemple, "bienvenue.html".
      - Éditez le texte de votre page de bienvenue. Il est conseillé d'utiliser cette page pour informer le nouvel abonné qu'il va recevoir un message lui permettant de confirmer son inscription. Notez que vous avez la possibilité de personnaliser cette page en utilisant les informations fournies par le nouvel abonné lors de son inscription. En effet, tous les paramètres disponibles sont ajoutés à l'URL de redirection.
      - Ajoutez le lien à votre page de bienvenue en tant qu'URL de redirection (ex.: http://www.monentreprise.com/bienvenue.html).
    3. Adresse e-mail : Afin de gérer automatiquement les inscriptions et les désinscriptions, eMill va créer des règles de traitement des messages qui vont mettre à jour votre liste. eMill recevra les informations sur les inscriptions et les désinscriptions par l'intermédiaire d'un e-mail envoyé à l'adresse indiquée ici.
  • Message de confirmation :

    Le message de confirmation est automatiquement envoyé au nouvel abonné lors de son inscription. Il lui permet de confirmer son abonnement à votre liste d'envoi en cliquant sur un lien. Ce procédé appelé 'double opt-in' permet d'éviter qu'une personne soit abonnée à son insu et de disposer d'une liste d'envoi propre à 100%.

    • eMill vous permet de modifier le message de confirmation (sujet et corps du message) envoyé au format HTML. Vous pouvez soit insérer du texte brut entre les tags <body> et </body>, soit écrire du code HTML directement dans la zone de texte, soit copier/coller le code depuis un éditeur HTML externe.

    Vous pouvez aussi personnaliser le message en utilisant les informations fournies par le nouvel abonné lors de son inscription. Pour cela utilisez la syntaxe suivante : %NomDuChamp%. Ceci va vous permettre, par exemple, de commencer votre message en utilisant le prénom du nouvel abonné : "Bonjour %Prénom%".

    Notez que le message de confirmation contient un lien qui ne doit pas être effacé : <a href="%SubscribeLink%">ici</a>. En effet, il contient les informations permettant à eMill d'identifier l'abonné et de confirmer son inscription.

  • Étape finale :
    1. Code du formulaire web : Afin d'afficher le formulaire d'inscription sur votre site Internet, vous devez copier l'ensemble du code contenu dans la zone de texte et le coller dans le code HTML de votre site (il doit être collé entre les tags <body> et </body>).
    2. Configuration des files d'attente : Afin de permettre à eMill de recevoir les messages contenant les informations sur les nouveaux abonnés, vous devez associer votre projet avec la file d'attente entrante correspondant à l'adresse email indiquée pendant l'étape de création du formulaire. Notez que les files d'attente entrantes sont à configurer à partir du menu Outils/Options/Files d'attente Entrantes et permettent à eMill de récupérer des messages à partir de votre serveur mail (POP3 ou fichier).
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Aperçu du Message Final

L'aperçu du message vous permet de visualiser et de tester le contenu du message tel qu'il sera envoyé.

Ainsi, l'ensemble des critères de personnalisation seront exécutés : champs de la source de données, scripts (contenus et globaux) et conditions d'activation des contenus.

Bien que l'aperçu ne génère et n'affiche qu'un seul message à la fois (fichier EML), vous pouvez utiliser les commandes édition de l'enregistrement pour générer et afficher les messages envoyés à chaque destinataire.

Le mode d'aperçu du message permet également de lancer une analyse anti-spam afin d'évaluer les risques que votre message soit déclaré comme spam lors de son envoi.

Vue Message ::

Affiche le message tel qu'il sera représenté dans la plupart des clients mail. La partie supérieure de la vue contient les principaux en-têtes ainsi que la liste des attachements. Lorsque le message possède un corps texte et html, seul le corps html sera affiché dans la vue message. Cependant, chaque contenu est visualisable indépendamment dans l'aperçu contenu.

Vue MIME :

Affiche la hiérarchie des parties MIME du message ainsi que la source du message. Cliquez sur une des parties de la hiérarchie pour accéder à la source de cette partie, cliquez ensuite sur la flèche à droite de la première ligne de la partie MIME.

Note : vous pouvez tester le message, éditer sa source ou l'enregistrer sur le disque à l'aide des commandes du menu contextuel du nœud aperçu.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Aperçu du contenu

Aperçu contenu

Lors de l'aperçu du message final, un nœud est créé dans l'arborescence du projet pour chaque contenu du message. Cliquez sur le nœud aperçu puis sur le signe + situé à sa droite pour afficher la liste des contenus du message.

Pour chaque contenu, un ensemble de vues est disponible en fonction de son type :

  • Contenu : le contenu est affiché si son format est compatible avec eMill, sinon, une description de ce contenu est affichée.
  • Source : affiche la source html décodée des contenus de type text/html.
  • Binaire : affiche une représentation hexadécimale du contenu. Cette vue est disponible pour les contenus qui ne sont pas de type texte.
  • MIME : similaire à la vue MIME de l'aperçu du message final, excepté que la source du contenu est affichée en gras, permettant ainsi de mieux distinguer la source du contenu dans la source complète du message.
Note : vous pouvez ouvrir le contenu avec l'application qui lui est associée ou l'enregistrer sur le disque à l'aide des commandes du menu contextuel du nœud du contenu.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Aperçu du contenu

Propriétés du message

La boîte des Propriétés du Message vous permet de consulter les informations concernant le fichier email (EML) et ses parties MIME. Les propriétés du message sont accessibles à partir de la fenêtre de conception lors d'un aperçu (sélectionnez le nœud aperçu puis cliquez sur le menu Affichage/Propriétés) et à partir des files d'attente (sélectionnez un message, puis cliquez sur le menu Affichage/Propriétés).

Général :

  • Taille : taille totale du message.
  • Date : date de création ou d'expédition du message.
  • Destinataire SMTP : affiche la liste des adresses destinataires du message. Lors de l'envoi, le message sera expédié à chacune de ces adresses
  • Expéditeur SMTP : adresse email de l'expéditeur.
  • État : affiche un résumé des transmissions SMTP pour chaque destinataire.

Source :

La vue source permet d'afficher l'en-tête du message ou la source MIME complète. L'en-tête contient un ensemble de champs normalisés et propriétaires. Voici une description de quelques champs :

  • X-Sender : champ privé correspondant à l'expéditeur SMTP. Non visible par le destinataire.
  • X-Receiver : liste privée des destinataires SMTP. Non visible par le destinataire.
  • From : information sur l'expéditeur précisée dans les propriétés des en-têtes. Visible par le destinataire.
  • To : adresse email du destinataire fournie par la source de données. Visible par le destinataire.
  • Date : affichage de la date à laquelle le message a été généré. Visible par le destinataire.
  • X-Receiver-Status : indique l'état de transmission d'un destinataire spécifique. Champ privé, non visible par le destinataire.
  • X-Priority : niveau de priorité, supporté par la plupart des clients mail.
  • Subject : "Sujet" précisé dans les propriétés des en-têtes.
  • Mime-Version : version d'encodage.
  • Content-Type : spécifie le type de contenu de chaque partie MIME.

Parties MIME :

La hiérarchie des parties MIME est affichée dans le cadre supérieur de la fenêtre. Sélectionnez une partie dans le cadre supérieur de la fenêtre pour afficher son en-tête dans le cadre inférieur

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Analyse anti-spam

Cliquez sur le bouton 'Analyse Anti-Spam' au bas de la fenêtre d'aperçu pour analyser votre message à l'aide du système anti-spam SpamAssassin.

L'analyse anti-spam récupère votre message, l'analyse et affiche le score de l'analyse. Plus votre score est élevé, plus vous avez de chances que votre message soit marqué comme étant un spam.

Il y a trois niveaux de score :

  • Le vert signifie que votre email ne risque pas d'être filtré ou bloqué.
  • Le jaune signifie que votre email risque d'être filtré ou bloqué.
  • Le rouge signifie que votre email a de grandes chances d'être filtré ou bloqué.
Note :

L'analyse anti-spam est exécutée par le projet Apache SpamAssassin, un des sytèmes anti-spam les plus performants et les plus utilisés.

Cependant, vous devez considérer le résultat de l'analyse comme étant un conseil heuristique plutôt qu'une réalité.

En effet, il est possible que votre message soit déclaré comme spam dans la boîte de réception de votre destinataire même si le résultat de l'analyse anti-spam était vert. Cela peut arriver lorsque :

  • Le serveur que vous utilisez pour envoyer des emails est blacklisté.
  • Le serveur que vous utilisez pour envoyer des emails n'est pas configuré correctement.
  • Les paramètres du programme qui lit les messages de votre destinataire sont plus sensibles que les paramètres par défaut de SpamAssassin.

Cliquez ici pour obtenir plus d'informations sur les différents mécanismes anti-spam.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer le Script Global

Éditer le Script Global

Le script global est un fichier script Visual Basic généré par eMill, qui stocke les instructions. Chaque projet comprend un fichier script Milset.vbs sauvegardé dans l'arborescence du projet.

L'éditeur de script vous permet d'éditer les scripts en utilisant les événements AMS pour programmer les fonctions, ou pour mieux personnaliser l'accès aux données. Vous pouvez éditer le script global pour :

  • Accéder aux enregistrements à partir d'une base XML ou de bases non compatibles ADO
  • Traiter automatiquement le retours des emails
  • Délivrer des contenus avec conditions en fonction des enregistrements
  • Personnaliser les en-têtes des emails en fonction des enregistrements

Le script global est présenté dans l'éditeur avec plusieurs options d'affichage. Vous pouvez afficher des parties de Milset.vbs en utilisant les boutons Vue Événement, Objet ou Module Complet et en sélectionnant l'Objet ou l'Événement dans le menu déroulant. Les fonctionnalités de l'éditeur : signets, point d'interruption, chercher/remplacer sont similaires aux autres éditeurs, que vous pouvez également utiliser à la place d'eMill.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Utiliser les événements de source de données

L'objet DataSource présente des méthodes similaires aux événements quand ils sont utilisés dans le script global. Le but principal de cet objet est de permettre d'accéder à des bases de données non compatibles ADO.

Quand vous utilisez cet objet, vous devez cocher l'option Utiliser le script global pour accéder à la source de données dans la boîte de dialogue Propriétés du Projet

La méthode recommandée pour personnaliser le code des bases non compatibles ADO est de créer votre projet en cochant l'option Je n'ai pas de base de données, en créer une dans l'assistant de projet, et d'éditer le script global dans l'éditeur de script global en utilisant les événements suivants :

Objet | Evénement | Description
DataSource | AddNew | Appelé lors de la création d'un nouvel enregistrement dans eMill
DataSource | BOF | État de début de fichier. Vrai si la position de l'enregistrement en cours est avant la position du premier enregistrement.
DataSource | CancelUpdate | Appelé lorsque la modification d'un enregistrement est annulée.
DataSource | CanDelete | État de suppression de l'enregistrement. Vrai si l'enregistrement peut être détruit.
DataSource | CanMovePrevious | État de l'ordre. Vrai si l'enregistrement peut être ramené en arrière.
DataSource | CanUpdate | État de la mise à jour de l'enregistrement. Vrai si l'enregistrement peut être mis à jour.
DataSource | Close | Ferme la connexion à la source de données.
DataSource | CopyAdoRecordsetToEmillRecordset | Copie dans l'objet Record d'eMill les valeurs de l'enregistrement ADO en cours.
DataSource | Delete | Détruit l'enregistrement en cours.
DataSource | EOF | État de Fin de Fichier. Vrai si la position de l'enregistrement en cours est après le dernier enregistrement.
DataSource | GetRowCount | Retourne le nombre total d'enregistrements.
DataSource | Move | Déplace la position courante en avant ou en arrière.
DataSource | MoveFirst | Déplace la position courante au premier enregistrement.
DataSource | Open | Ouvre la connexion à la base de données.
DataSource | Update | Sauve les modifications de l'enregistrement.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Utiliser les événements mail

L'objet Mail fournit 2 événements, appelés au début et à la fin de la génération de chaque email. Ce qui signifie que les événements sont appelés une fois pour chaque destinataire.

Consultez le Guide des Scripts Serveur pour voir comment utiliser ces événements.

Object | Event | Description
Mail | OnEndRender | Appelé quand la génération pour le destinataire en cours va commencer.
Mail | OnStartRender | Appelé quand la génération pour le destinataire en cours est terminée.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Utiliser les événements de la messagerie

L'objet Mailing fournit 5 événements, appelés au début et à la fin du traitement du mailing, au moment de la génération. Les autres événements sont appelés durant la livraison ou la réception des réponses.

Consultez le Guide des Scripts Serveur pour voir comment utiliser ces événements.

Objet | Evénement | Description
Mailing | OnAcceptMail | Appelé quand un email va être réceptionné.
Mailing | OnEndRender | Appelé quand la génération est terminée.
Mailing | OnMailStatus | Appelé quand un fichier email est transféré de la Boîte d'Envoi à Envoyé ou Abandonné.
Mailing | OnReceiveMail | Appelé après qu'un email entrant ait été accepté.
Mailing | OnStartRender | Appelé quand la génération d'un projet est commencée.
Mailing | OnUrlClicked | Appelé lorsque un message suivi est ouvert ou lorsque un lien suivi est cliqué.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Editer les Propriétés du Projet

Éditer les propriétés du projet

La boîte de propriétés du projet centralise les paramètres importants du projet (également accessibles à partir de l'assistant projet), ainsi que les paramètres spécifiques au planificateur et à l'inscription de la boîte d'arrivée du projet (dans les files d'attente uniquement).

Toutes les valeurs sont sauvegardées dans le fichier MonProjet.mil (à l'exception des inscriptions aux boîtes d'arrivée). Ce fichier est au format XML et peut être édité avec n'importe quel éditeur texte.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés générales

  • Dans le menu Projet/Propriétés, cliquez sur l'onglet Général :
  • Sélectionnez un Jeu de caractères : cette valeur est également fixée dans la boîte de dialogue Paramètres par défaut.
  • Sélectionnez le Langage par défaut des contenus. Le langage est utilisé en script pour formater les nombres, les dates, les devises, etc.
  • Sélectionnez la Date de l'email : cette valeur détermine la date et l'heure de l'en-tête MIME
  • Cochez Générer un message par destinataire... si votre source de données a un champ email comprenant plusieurs adresses. Chaque adresse recevra un email distinct (cette option ne fonctionne pas avec les numéros de fax)
  • Cochez Ne pas générer de doublons afin de ne générer qu'un email ou qu'un fax par destinataire ayant plusieurs fois la même adresse. Cette option est une alternative à l'outil Retirer les doublons.
  • Spécifiez un ratio d'erreur à partir duquel la génération doit être abandonnée. Lorsque cette valeur est égale à zéro, la génération sera abandonnée à la première erreur.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés des listes de destinataires

  • Dans le menu Projet/Propriétés, cliquez sur l'onglet Destinataires :
  • Cochez la case située à gauche d'une liste pour l'activer, ou décochez la case pour la désactiver. Une liste activée sera utilisée lors de la génération des messages.
  • Cliquez sur le bouton Ajouter pour ajouter une nouvelle liste de destinataires.
  • Sélectionnez une liste et cliquez sur le bouton Éditer pour ouvrir les propriétés de la liste de destinataires.
  • Cliquez sur le bouton Dupliquer pour créer une nouvelle liste à partir de celle sélectionnée.
  • Cliquez sur le bouton Renommer pour éditer le nom de la liste directement.
  • Cliquez sur le bouton Supprimer pour supprimer la liste sélectionnée. Un projet peut ne pas avoir de listes de destinataires, si celui-ci est destiné uniquement à automatiser le traitement des messages entrants par exemple.
  • Cliquez sur les boutons Monter ou Descendre pour modifier l'ordre des listes de destinataires. Les listes actives seront successivement parcourues dans cet ordre lors de la génération des messages.

Propriétés de la liste de destinataires :

  • Activé : spécifie si la liste doit être utilisée lors de la génération des messages.
  • Nom de la liste : nom servant à identifier une liste de destinataires. Chaque liste doit posséder un nom unique.
  • Filtrage : permet de sélectionner plus précisément les enregistrements de la liste en fonction d'un ou plusieurs filtres. Les enregistrements correspondant aux critères de sélection des filtres seront conservés. Les boutons Ajouter, Éditer et Supprimer vous permettent respectivement d'ajouter un nouveau filtre, de modifier un filtre existant et de supprimer un filtre.

- Sélectionnez "Toutes les conditions sont vérifiées" si vous souhaitez conserver les enregistrements répondant à tous les critères.

- Sélectionnez "Au moins une condition est vérifiée" si vous souhaitez conserver les enregistrements répondant à un des critères.

  • Modifier la source de données : appelle l'assistant de connexion aux base de données qui vous permet de choisir facilement la source de données de la liste de destinataires.

  • Association des champs : eMill permet d'associer les valeurs Email, Fax, SMS, Prénom et Nom à n'importe quel champ de la source de données. Ces champs seront utilisés lors de la génération des messages pour déterminer le nom et l'adresse email (ou le numéro de fax/téléphone) du destinataire du message.
  • Canaux : permet d'activer ou de désactiver chaque canal d'émission et de décider de leur priorité. Si plusieurs canaux sont sélectionnés, les messages seront envoyés via le premier canal de la liste, si le champ correspondant est vide ils seront envoyés via le second canal. Si un seul canal est sélectionné, il sera utilisé seul pour envoyer les messages.
    Il est important de noter que les champs Fax et SMS ainsi que la liste des canaux ne sont disponibles que si les modules Fax et SMS d'eMill ont été activés et installés.

    Exemple lorsque les canaux Email et Fax sont activés :

    - Si le champ Email est présent et que le champ Fax est vide, le message sera envoyé en tant qu'email.

    - Si le champ Email est vide et que le champ Fax est présent, le message sera envoyé en tant que Fax.

    - Si les champs Email et Fax sont présents le message sera envoyé en tant qu'email si le canal Email est en première position dans la liste des canaux, en tant que Fax autrement.

  • Chaîne de connexion ADO : paramètre avancé établissant le lien entre une base de données et la liste des destinataires. Cliquez sur le bouton Propriétés pour générer une chaîne de connexion ADO via la fenêtre des Propriétés des liaisons de données. Ce paramètre est automatiquement rempli par l'assistant de connexion aux bases de données.
  • Requête SQL qui retourne les enregistrements : sélectionne les enregistrements de la source de données formant la liste de destinataires. Vous pouvez modifier la requête SQL manuellement ou choisir une des requêtes prédéfinies retournant les enregistrements de chaque table de la base de données. Ce paramètre est automatiquement rempli par l'assistant de connexion aux bases de données.
  • Exporter la liste des destinataires lors de la publication : lorsque vous publiez sur un serveur eMill distant, la source de données peut ne pas être accessible ou disponible, ou la base locale peut être trop grande ou trop complexe pour être utilisée depuis un serveur distant. En cochant cette option, la source de données sera exportée dans une base temporaire qui ne contiendra que la liste des destinataires nécessaires à la génération.
  • Utiliser le script global pour accéder à la source de données : à cocher si vous utilisez une base de données non compatible ADO. Les propriétés de l'objet DataSource et les méthodes du script global serviront à accéder aux données. Consultez le Guide des Scripts Serveur pour davantage d'informations sur les scripts.

L'onglet Liste partagée est présent à la place de l'onglet Source de données si la liste est connectée à une liste partagée eMill.
  • Emplacement : Serveur eMill où est située la liste. Habituellement un unique serveur est disponible. Veuillez noter que le projet doit être publié sur le même serveur eMill que la liste, ou cette dernière ne sera pas disponible.
  • Nom : Nom de la liste partagée à utiliser. Seules les listes accessibles à l'utilisateur en cours sont affichées.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés des listes noires

Une liste noire est un ensemble d'adresses email et/ou de numéros de fax que vous désirez exclure du publipostage. Lors de la génération, si l'adresse email ou le numéro de fax du destinataire d'un message est trouvé dans une des listes noires actives, le message ne sera pas généré.

  • Dans le menu Projet/Propriétés, cliquez sur l'onglet Listes noires :
  • Cochez la case située à gauche d'une liste pour l'activer, ou décochez la case pour la désactiver.
  • Cliquez sur le bouton Ajouter pour ajouter une nouvelle liste de destinataires.
  • Sélectionnez une liste et cliquez sur le bouton Éditer pour ouvrir les propriétés de la liste noire.
  • Cliquez sur le bouton Dupliquer pour créer une nouvelle liste à partir de celle sélectionnée.
  • Cliquez sur le bouton Renommer pour éditer le nom de la liste directement.
  • Cliquez sur le bouton Supprimer pour supprimer la liste sélectionnée. Les listes noires sont optionnelles.
  • Cliquez sur Monter ou Descendre pour modifier l'ordre des listes noires.

Éditer les propriétés de la liste noire :

  • Activé : spécifie si les adresses Email et les numéros de fax contenus dans la liste noire doivent être exclus lors de la génération des messages.
  • Nom de la liste : nom servant à identifier une liste de destinataires. Chaque liste doit posséder un nom unique.
  • Filtrage : permet de sélectionner plus précisément les enregistrements de la liste en fonction d'un ou plusieurs filtres. Les enregistrements correspondant aux critères de sélection des filtres seront conservés. Les boutons Ajouter, Editer et Supprimer vous permettent respectivement d'ajouter un nouveau filtre, de modifier un filtre existant et de supprimer un filtre.

    - Sélectionnez "Toutes les conditions sont vérifiées" si vous souhaitez conserver les enregistrements répondant à tous les critères.

    - Sélectionnez "Au moins une condition est vérifiée" si vous souhaitez conserver les enregistrements répondant à un des critères.

  • Modifier la source de données : appelle l'assistant de connexion aux base de données qui vous permet de choisir facilement la source de données de la liste noire.

  • Association des champs : associez la valeur Email/Fax/SMS au champ de la source données contenant les adresses email et/ou les numéros de Fax/SMS. Les destinataires dont l'adresse email ou le numéro de fax est contenu dans une des listes noires actives seront exclus lors de la génération des messages.
    Il est important de noter que les champ Fax et SMS ne sont disponibles que si vous avez installé les options Fax et SMS d'eMill.

  • Chaîne de connexion ADO : paramètre avancé établissant le lien entre une base de données et la liste des destinataires. Cliquez sur le bouton Propriétés pour générer une chaîne de connexion ADO via la fenêtre des Propriétés des liaisons de données. Ce paramètre est automatiquement rempli par l'assistant de connexion aux bases de données.
  • Requête SQL qui retourne les enregistrements : sélectionne les enregistrements de la source de données formant la liste de destinataires. Vous pouvez modifier la requête SQL manuellement ou choisir une des requêtes prédéfinies retournant les enregistrements de chaque table de la base de données. Ce paramètre est automatiquement rempli par l'assistant de connexion aux bases de données.
  • Exporter la liste des destinataires lors de la publication : lorsque vous publiez sur un serveur eMill distant, la source de données peut ne pas être accessible ou disponible, ou la base locale peut être trop grande ou trop complexe pour être utilisée depuis un serveur distant. En cochant cette option, la source de données sera exportée dans une base temporaire qui ne contiendra que la liste des destinataires nécessaires à la génération.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés de l'en-tête

Propriétés des en-têtes

Les filtres anti-spam peuvent compromettre la livraison de vos messages, si les informations suivantes manquent ou sont incorrectes. L'adresse de l'expéditeur "De" est obligatoire et peut dans certains cas correspondre à l'adresse "Répondre à".

  • A partir du menu Projet/Propriétés, cliquez sur l'onglet En-têtes :

  • Entrez l'adresse SMTP de l'expéditeur : adresse de l'expéditeur de l'email (voir note en bas de page).
  • Entrez l'adresse De : adresse de l'expéditeur de l'email (identique à au-dessus ou voir note en bas de page).
  • Entrez l'adresse Répondre à : adresse email à laquelle doivent revenir les réponses.
  • Entrez le nom de votre Société ou votre nom tel qu'il apparaîtra dans l'en-tête.
  • Entrez le Sujet de l'email (voir ci-dessous pour personnaliser le sujet).
  • Sélectionnez un niveau de Priorité : optionnel, géré par la plupart des clients mail.
  • Cliquez sur OK ou sur un autre onglet d'option pour des paramétrages plus avancés.

Personnalisation des en-têtes: eMill vous donne la possibilité de personnaliser chacune des en-têtes en insérant des informations provenant de votre source de données. Pour cela, faites un clic droit dans la zone de texte de l'en-tête, allez sur 'Insérer champ' et sélectionnez le champ que vous souhaitez utiliser pour personnaliser l'en-tête. Vous noterez que la liste des champs se compose des champs de votre source de données ainsi que de champs spéciaux. Rendez vous dans l'aide concernant la personnalisation des contenus pour plus de détails sur ces derniers.
"Expéditeur SMTP" et "De" : eMill différencie "l'Expéditeur SMTP" du champ "De" qui figure dans les en-têtes du message. L'adresse Expéditeur SMTP est utilisée lors de la transmission du message via SMTP. Si le message ne peut être transmis au destinataire final, une notification de livraison (DSN) sera retournée à cette adresse et non à l'adresse du champ "De". Cependant, afin de limiter les risques de blocage par les filtres anti-spam, il est conseillé de mettre la même adresse pour ces deux champs.
Format des adresses email : Utiliser la syntaxe suivante pour entrer les adresses :
"Nom" <xyz@rien.com>
ou cliquer sur le bouton à droite du champ texte et utiliser le "composeur d'adresse email"
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés de l'expéditeur

  • A partir du menu Projet/Propriétés, cliquez sur l'onglet Expéditeur :
  • Sélectionnez une option dans Sauver les messages envoyés : non, uniquement les en-têtes, oui. Si vous sélectionnez Non, la reprise des générations abandonnées ne sera pas possible.
  • Sélectionnez une option dans Sauver les messages abandonnés : non, uniquement les en-têtes, oui. Si vous sélectionnez Non, tous les messages sortants abandonnés seront détruits. Sinon le message entier ou juste les en-têtes seront transférés dans le dossier "abandonnés". Notez que les messages dont les adresses sont incorrectes seront également transférés.
  • Sélectionnez une valeur pour le Régulateur : détermine la quantité maximum de messages envoyés par minute, indépendamment du nombre de files d'attente sortantes et de la configuration de leur compteur de thread respectif.
  • Tentatives : détermine l'intervalle entre les tentatives de connexion au serveur mail réceptionnaire.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés des notifications

  • Dans le menu Projet/Propriétés, cliquez sur l'onglet Notifications :
Cette boîte de dialogue détermine les paramètres utilisés par l'extension SMTP RFC1891, laquelle permet à un client SMTP de spécifier (a) que les notifications doivent être générées sous certaines conditions, (b) si ces notifications doivent retourner le contenu des messages.

La plupart des serveurs SMTP supportent l'extension RFC1891. 60% des serveurs d'après nos tests (Juillet 2002).

  • Cochez Jamais si vous ne voulez pas que le serveur SMTP envoie des notifications.
  • Cochez Succès si vous désirez recevoir les notifications d'expéditions réussies.
  • Cochez Échec si vous désirez recevoir les notifications d'expéditions échouées.
  • Cochez Délais si vous désirez recevoir les notifications de délais d'expédition.
  • Sélectionnez En-têtes uniquement si vous ne voulez pas que le message entier revienne (recommandé).
  • Cochez Générer des notifications de livraison localement si vous désirez recevoir des notifications lorsque l'envoi d'un message est abandonné. De plus, cette option vous permet de recevoir des notifications lorsque vous utilisez le serveur SMTP d'eMill pour envoyer les messages.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés S/MIME

  • Dans le menu Projet/Propriétés, cliquez sur l'onglet S/MIME :

  • Signer numériquement : Vous pouvez envoyer les messages signés en mode transparent ou en mode opaque. En mode clair, la signature électronique est ajoutée à la fin du message; en mode opaque, le message est codé. Si vous envoyez vos messages signés en mode opaque, les utilisateurs des programmes de courrier électronique ne prenant pas en charge le protocole S/MIME ne pourront pas lire les messages signés.
  • Crypter le contenu et les attachements : Si vous cochez cette option, les messages seront cryptés en utilisant l'algorithme spécifié. Pour crypter un message vous devez posséder la partie publique du certificat du destinataire (clef publique).
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


SMS Properties

Propriétés SMS

Les propriétés SMS vous permettent de définir quelle partie de votre message constituera le contenu du SMS. Notez que le contenu d'un SMS ne peut pas excéder 160 caractères.

  • Dans le menu Projet/Propriétés, cliquez sur l'onglet SMS :
  • Le contenu SMS est dans le sujet du message : Le contenu du SMS sera constitué du sujet du message. Le sujet doit être défini dans les propriétés de l'en-tête du projet.
  • Le contenu SMS est dans le corps texte du message : Notez que le contenu du SMS ne peut pas être créé à partir d'un document HTML. Si vous disposez de plusieurs contenus texte dans votre projet, eMill utilisera le premier contenu texte activé. Afin de modifier l'ordre des contenus, consultez les propriétés des contenus.
  • Le contenu SMS est le sujet et le corps texte : Le contenu du SMS sera constitué du sujet et du corps texte. Vous avez la possibilité de séparer le sujet et le texte soit par un espace, soit par un saut de ligne (le saut de ligne n'est pas disponible si vous utilisez la passerelle email - SMS TM4B, voir Configuration du SMS).
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Propriétés des règles de transformation de la numérotation

Propriétés de la numérotation

Si les numéros de fax ou de téléphone inclus dans vos sources de données sont dans un format qui n'est pas exploitable directement, eMill vous propose un outil exclusif de transformation automatique de la numérotation.

Les seuls formats de numéros exploitables pour envoyer des fax ou des SMS sont les suivants :

- Les formes numérotables : représente un numéro directement composable et qui n'est valable qu'à partir d'un lieu précis. Par exemple, le numéro 0468123456 est composable directement mais ne sera valable qu'à partir de la France.

- Les formes internationales : représente un numéro qui est valable à partir de n'importe quel lieu. Par exemple +33468123456.

- Les formes canoniques : représente un numéro de forme internationale dont la présentation permet de visualiser rapidement le code pays, le code région et le numéro de fax. Par exemple, +33 468123456 ou +1(254)1234567.

Les règles de transformation d'appel vont donc vous aider à transformer les numéros de fax et de téléphone de votre source de données en numéros de formes numérotables, internationales ou canoniques.

Étapes de conception d'une règle de transformation :

1. Numéro Test : Inscrire en bas de la fenêtre de propriétés de la numérotation un numéro ayant la même forme que les numéros que vous souhaitez transformer. Ce numéro sera utilisé pour les tests de validation de votre nouvelle règle de transformation.

2. Cliquez sur Ajouter pour ajouter une nouvelle règle de transformation.

3. Le modèle source : Au cours de la génération des fax ou des SMS, eMill compare les numéros de votre source de données aux modèles source. Quand les 2 formes correspondent, eMill applique la règle de transformation correspondante. Le modèle source doit donc représenter précisément la forme des numéros à transformer. Ainsi, pour concevoir le modèle source, il vous faut représenter chaque caractère/chiffre du numéro à transformer dans le modèle source :

- Dès que vous rencontrez dans votre numéro à transformer les caractères suivants : + ( ) vous devez les représenter dans le modèle source en utilisant les mêmes caractères. Si vous rencontrez d'autres caractères vous ne devez pas les représenter dans le modèle source.

- Dès que vous rencontrez dans votre numéro à transformer un chiffre qui ne devra pas figurer dans le numéro transformé, représentez-le par ?.

- Dès que vous rencontrez dans votre numéro à transformer un chiffre qui doit figurer dans le numéro transformé, représentez-le par #.

- Si vous souhaitez représenter une suite de chiffres à la fin de votre numéro à transformer, inscrivez *.

4. Définir le nombre cible : Une fois qu'eMill a trouvé un modèle source correspondant à un numéro de votre source de données, il transforme ce dernier dans la forme définie par le nombre cible. Le nombre cible doit respecter les formes numérotables, internationales ou canoniques.

5. Validez votre règle de transformation en cliquant sur OK.

6. Cliquez sur Tester afin de vérifier que la règle de transformation fonctionne avec le numéro test.

Exemple

 | Exemple 1 | Exemple 2 | Exemple 3
Numéro à transformer | 04-68-12-34-56 | 1-254-123-4567 | 1-254-123-4567
Modèle source | ?######### | ####* | 1###*
Numéro cible | +33 ######### | +#(###)* | +1(###)*
Numéro transformé | +33 468123456 | +1(254)1234567 | +1(254)1234567

Exemple 3 : Si vous souhaitez restreindre l'application de la transformation des numéros de ce format à ceux commençant par le chiffre 1, alors vous devez inscrire dans le modèle source le chiffre 1.

Modifier une règle de transformation :

  • Sélectionnez la règle de transformation que vous souhaitez modifier.
  • Cliquez sur Modifier.
  • Suivez les étapes de conception d'une règle de transformation décrites ci-dessus.

Priorité des règles de transformation :

Lors de la génération des messages, eMill compare les numéros de fax et de téléphone de votre source de données aux modèles source que vous avez configurés. eMill commencera donc sa comparaison par le premier modèle source de la liste puis, par le 2ème jusqu'a ce qu'il trouve un modèle correspondant. Il vous est donc possible de décider de la priorité des règles de transformation les unes par rapport aux autres en utilisant les boutons Monter et Descendre situés sur la droite de la liste des règles.

Dupliquer une règle de transformation pour un autre projet :

Afin d'utiliser les mêmes règles de transformation de la numérotation d'un projet à un autre, vous avez la possibilité de les dupliquer en suivant ces étapes :

  • Sélectionnez dans la liste les règles que vous souhaitez dupliquer (vous pouvez sélectionner plusieurs règles en maintenant la touche Ctrl appuyée).

  • Faites un clic droit sur votre souris et sélectionnez copier dans le menu déroulant.

  • Rendez vous sur la fenêtre de propriétés de numérotation du projet pour lequel vous souhaitez ajouter ces règles.

  • Faites un clic droit à l'endroit de la liste où vous souhaitez ajouter les règles copiées et sélectionnez coller dans le menu déroulant.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Statistiques

  • Dans le menu Projet/Propriétés, cliquez sur l'onglet Statistiques :
  • Cochez la cache Enregistrer les statistiques de message afin qu'eMill enregistre les statisques de message tel que la nombre total de messages envoyés, le nombre de messages échoués, et le nombre de retours. Lorque cette option est cochée, un noeud Statistiques apparaîtra dans les files d'attente lorsque le projet sera publié.
  • La liste Champs de la liste de destinataires à attaque aux message permet d'associer aux messages des champs de la source de données. Ces champs pourront être utilisés comme critères de filtrage ou de tri dans les statistiques.
  • L'option Mode de suivi permet d'activer l'enregistrement des ouvertures et/ou des clics sur les liens des messages envoyés dans les statistiques.
  • Cochez l'option Suivi anonyme afin de ne plus disposer des détails des clics et des ouvertures par message. Cette option est obligatoire dans certains pays pour des raisons de protection de vie privée.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Traitement des messages entrants

Lorsqu'un nouveau message est disponible dans une file d'attente entrante ou lorsque ce message est téléchargé dans la boîte d'arrivée du projet, divers traitements peuvent alors être effectués. Par exemple, répondre automatiquement à une demande de documentation, gérer les abonnements, désabonnements ou courriers non délivrés, etc. La configuration de ces traitements s'effectue depuis la boîte de propriétés Messages entrants du projet.

Configuration générale :

A partir du menu Projet/Messages entrants, cliquez sur l'onglet Général :

Deux traitements différents peuvent être exécutés lors du téléchargement d'un message dans la boîte d'arrivée du projet :

  • Appeler l'évènement script Mailing_OnReceiveMail() :
    L'évènement Mailing_OnReceiveMail() du Script Global est appelé par eMill. Entrez votre propre code VBScript dans cette procédure. Voir le Guide des Scripts Serveur pour plus d'informations.
  • Appliquer les règles suivantes :
    Une règle de message est un ensemble d'actions qui seront exécutées si une ou plusieurs conditions sont vérifiées. Par exemple, supprimer l'expéditeur du message de la liste des destinataires si le sujet du message contient le mot "REMOVE".

Téléchargement des messages :

A partir du menu Projet/Messages entrants, cliquez sur l'onglet Téléchargement :

Les options de téléchargement permettent d'accepter ou de refuser les nouveaux messages disponibles dans les files d'attente entrantes. Si un message est refusé, celui-ci ne sera pas téléchargé dans la boîte d'arrivée du projet. Si au moins un projet télécharge le message, celui-ci sera supprimé de la file d'attente entrante.
Les différentes options de téléchargement sont :

  • Le télécharger :
    Le message sera toujours téléchargé dans la boîte d'arrivée du projet.
  • Appeler l'évènement script Mailing_OnAcceptMail() :
    L'évènement Mailing_OnAcceptMail() du Script Global est appelé par eMill. Entrez votre propre code VBScript dans cette procédure. Voir le Guide des Script Serveur pour plus d'informations.
  • Tester les conditions :
    Le message sera téléchargé si une ou toutes les conditions présentes dans la liste sont vérifiées. Si aucune condition n'est présente, le message sera téléchargé par défaut.

Files d'Attente Entrantes

Avant d'abonner la "boîte d'arrivée" du projet à une ou plusieurs files d'attente entrantes, vous devez configurer les files d'attente entrantes dans la boîte de dialogue options. Les files d'attente entrantes disponibles sont ensuite affichées dans la liste.

  • A partir du menu Projet/Messages entrants, cliquez sur l'onglet Files d'attente entrantes :

  • Cochez ou décochez les cases afin d'abonner ou de désabonner le projet à une ou plusieurs file(s) d'attente entrante(s).

Réception de fax : Au lancement du serveur eMill, une file d'attente entrante fax est automatiquement créée. Celle-ci permet de spécifier à eMill que les fax reçus sont stockés dans un dossier (par défaut C:\Program Files\Active+\eMill\Fax\Inbox).

Tester le traitement des messages entrants :

Afin de tester les règles ou les scripts de traitement des messages entrants, vous pouvez simuler l'arrivée de nouveaux messages. Cliquez sur le menu Outils/Simuler des messages entrants et sélectionnez un ou plusieurs messages à tester (fichier .eml).

Étant donné que le projet n'est pas publié lors de la simulation des messages entrants, certaines fonctionnalités diffèrent du traitement réel :

  • La suppression ou le déplacement d'un message n'a aucun effet car les files d'attentes et la boîte d'arrivée du projet ne sont disponibles que si le projet est publié.
  • Les messages redirigés et les réponses sont envoyés directement au lieu d'être placés dans la boîte d'envoi du projet.
Remarque : l'onglet Files d'attente entrantes n'est disponible que pour les projets publiés.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Règle de message

Une règle de message est un ensemble d'actions et de conditions dépendantes d'un message. Lors de l'application de la règle à un message, si les conditions sont vérifiées, les actions seront exécutées. Depuis la page Général de la boîte de propriétés des Messages entrants, cliquez sur les boutons Ajouter ou Éditer pour créer une nouvelle règle ou en éditer une existante :

Conditions :

Vous pouvez ajouter autant de conditions à vérifier que nécessaire. Si aucune condition n'est ajoutée, la ou les actions de la règle seront toujours exécutées par défaut.
Les conditions vérifiables lors de la réception d'un nouveau message sont :

  • Rechercher des valeurs dans le corps du message :
    Recherche une ou plusieurs valeurs texte dans le corps du message. La condition est vérifiée en fonction de critères de recherche. Si le message possède une partie texte et une partie html, la recherche sera effectuée sur la partie html uniquement.
  • Rechercher des valeurs dans le sujet :
    Recherche une ou plusieurs valeurs texte dans le sujet du message. La condition est vérifiée en fonction de critères de recherche. Le même résultat peut être obtenu en recherchant dans l'en-tête Subject du message.
  • Rechercher des valeurs dans un en-tête :
    Recherche une ou plusieurs valeurs texte dans un en-tête du message de votre choix. La condition est vérifiée en fonction de critères de recherche. Pour plus d'informations, consultez la section Base de Connaissances - Exemples d'en-têtes.
  • Rechercher des valeurs dans un champ du corps :
    Recherche une ou plusieurs valeurs texte dans un champ du corps du message. Un champ dans le corps d'un message est détecté lorsqu'il correspond au format suivant : "nom du champ : valeur du champ". Si la valeur du champ s'écrit sur plusieurs lignes, elle doit être inscrite entre guillemets (pour plus de détails, ouvrez l'exemple Formulaires Web à partir de la page d'accueil).
  • Rechercher des valeurs dans le champs A, CC ou De :
    Recherche une ou plusieurs valeurs texte dans le champ A, CC ou De du message. La condition est vérifiée en fonction de critères de recherche. Le même résultat peut être obtenu en recherchant dans l'en-tête To, CC ou From du message.
  • Comparer la date du message :
    Compare la date du message à un intervalle de temps.
  • Comparer la taille du message :
    Compare la taille du message à une taille maximale ou minimale.
  • Comparer l'importance du message :
    Compare la priorité du message à une valeur de votre choix. Si la priorité n'est pas spécifiée dans le message, elle est considéré comme Normale.
  • Notification de livraison :
    Vérifie si le message est ou non une notification de livraison (Delivery Status Notification). Si le message doit être une notification de livraison, il est possible de spécifier le type de notification souhaitée (Succès, Échec, Relayé, Déployé ou Retardé).
  • Planifier la date et l'heure de réception :
    Permet de spécifier les jours et heures de réception du message pour lesquels la condition est vérifiée. La planification est hebdomadaire par intervalle d'une demi-heure.
  • L'enregistrement existe dans la source de données :
    La condition est vérifiée si un ou plusieurs enregistrements sont trouvés dans une source de données. La source de données peut-être soit une liste des destinataires ou une liste noire du projet, soit une source de données externe (compatible ADO). La recherche dans la source de données est effectuée en comparant un ou plusieurs champs de la source de données avec des valeurs provenant du messages ou des valeurs constantes. Par exemple, vous pouvez vérifier si au moins un enregistrement existe où le champ Email de la source de données contient l'adresse email de l'expéditeur du message.
  • L'enregistrement n'existe pas dans la source de données :
    La condition est vérifiée si aucun enregistrement n'est trouvé dans une source de données. Le type de source de données ainsi que la recherche des enregistrements est identique à la condition précédente.
  • Le message est signé numériquement et crypté :
    Vérifie si le message est signé numériquement et/ou crypté (voir S/MIME).
  • Le message est une demande de désabonnement :
    Vérifie si le message est une demande de désabonnement envoyé par un destinataire d'une campagne à partir du lien de désinscription inclus dans l'email envoyé (voir Utilisation de l'éditeur HTML).

Actions :

Une règle de message doit comporter au moins une action à exécuter si la vérification des conditions a réussi.
Les actions exécutables lors de la réception d'un nouveau message sont :

  • Rediriger le message :
    Crée une copie du message reçu et modifie la liste des destinataires par les adresses email de votre choix. Le nouveau message est ensuite placé dans la boîte d'envoi.
  • Déplacer le message dans un dossier :
    Déplace le message de la boîte d'arrivée à un sous-dossier de votre choix.
  • Répondre au message :
    Crée un nouveau message en réponse au message reçu et le place dans la boîte d'envoi. La réponse peut-être soit le message reçu auquel est ajouté le texte de la réponse, soit un modèle de message (fichier .eml).
  • Ajouter un texte au journal du projet :
    Permet d'ajouter une ligne de texte au journal du projet.
  • Ajouter un enregistrement à une source de données :
    Ajoute un enregistrement à la liste des destinataires, à la liste noire ou à une source de données externe (compatible ADO). La valeur des champs du nouvel enregistrement pourra soit être affectée à une valeur extraite du message reçu, soit être affectée à une valeur constante, soit être nulle.
  • Modifier un enregistrement d'une source de données :
    Modifie la valeur des champs d'un ou plusieurs enregistrements d'une liste des destinataires, d'une liste noire ou d'une source de données externe (compatible ADO). La recherche des enregistrements à modifier est identique à la condition L'enregistrement existe dans la source de données. La valeur des champs pourra soit être affectée à une valeur extraite du message reçu, soit être affectée à une valeur constante, soit incrémentée ou décrémentée (pour les valeurs numériques), soit effacée (si la source de données le supporte).
  • Supprimer un enregistrement d'une source de données :
    Supprime un ou plusieurs enregistrements d'une liste des destinataires, d'une liste noire ou d'une source de données externe (compatible ADO). La recherche des enregistrements à supprimer est identique à la condition L'enregistrement existe dans la source de données.
  • Supprimer le message :
    Supprime le message reçu.
  • Sauver le certificat de l'expéditeur dans le magasin de certificat des destinataires :
    Si vous souhaitez envoyer des messages cryptés par le protocole S/MIME, la clé publique du destinataire est nécessaire. Cette action permet d'enregistrer cette clé publique dans votre magasin de certificats afin de pouvoir envoyer des messages cryptés à ce destinataire pour des futures campagnes.
  • Appeler une page web :
    Permet de déclencher des actions sur une application web externe. Si l'accès à la page web nécessite une authentification, entrez le nom d'utilisateur et le mot de passe du compte.
  • Arrêter de traiter les règles :
    Arrête l'exécution des règles suivantes. L'exécution des actions de la règle en cours n'est pas stoppée.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Publication de votre Projet

Le composant d'eMill qui génère et envoie les messages est le serveur eMill. Afin d'envoyer les messages de votre projet, il est nécessaire de copier ce projet sur un serveur eMill. Cette opération est appelé publication.

  • Ouvrez votre projet et sélectionnez Fichier/Publier et envoyer :

  • Sélectionnez le Serveur eMill sur lequel publier le projet. La liste déroulante contient l'ensemble des serveurs connectés dans les files d'attente.
  • Sélectionnez le Compte à utiliser : les comptes du serveur eMill auxquels vous appartenez seront affichés. En fonction de vos droits sur ce compte, la publication peut-être refusée.
  • Cochez Générer les messages afin de lancer la génération des messages après la publication.
  • Cochez Supprimer les messages précédemment générés afin de supprimer les messages de la boîte d'envoi créés lors de générations précédentes.
  • Cochez Commencer à envoyer les messages pour démarrer l'expéditeur. Les nouveaux messages générés seront envoyés immédiatement.
  • Si vous cochez Ouvrir le projet dans les files d'attente, la fenêtre des files d'attente sera ouverte à la fin de la publication et le projet publié sera sélectionné.
  • Abonnement aux files d'attente entrantes: Afin de permettre à eMill de recevoir des messages, vous devez associer votre projet à une ou plusieurs files d'attente entrantes. Notez que les files d'attente entrantes doivent être créées à partir du menu Outils/Options/Files d'attente entrantes et permettent à eMill de récupérer vos e-mails depuis un ou plusieurs serveurs mail (POP3 ou fichier).
Notifications locales : Abonnez-vous à cette file d'attente entrante pour recevoir des notifications locales lorsque vous utilisez le serveur SMTP intégré d'eMill et lorsque l'envoi d'un message est abandonné par eMill. Notez que pour créer ces notifications, vous devez cocher l'option "Générer des notifications de livraison localement" dans les propriétés des notifications.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Fenêtre des Files d'Attente

Cliquez sur l'icône Files d'Attente : les files d'attente de tous les projets publiés s'affichent dans la Fenêtre Files d'Attente.

Cliquez sur l'icône Conception : le projet s'affiche dans la Fenêtre de Conception.

La Fenêtre des Files d'Attente vous présente un aperçu de tous les projets publiés pour chaque Serveur eMill. Les dossiers sont à l'intérieur de chaque file (Boîte d'arrivée, Boîte d'envoi, Envoyés, Abandonnés).

Vous pouvez cliquer sur n'importe lequel d'entre eux pour afficher la liste des dossiers et des fichiers. Le clic droit proposera plusieurs options (Tout Détruire, Tout Abandonner, Rafraîchir, Tout Sélectionner...), ces options sont également disponibles dans le menu "files d'attente". Voir les commandes files d'attente disponibles.

  • File d'attente : le projet publié apparaît en tant que dossier dans la fenêtre de gauche sous le serveur eMill.
  • Boîte d'arrivée : dossier du message généré dans la file d'attente. Il reçoit tous les retours de l'expédition conformément à la façon dont vous l'avez inscrit dans les files d'attente entrantes.
  • Boîte d'envoi : dossier du message généré dans la file d'attente. Il reçoit tous les fichiers email exécutés (EML) et prêts à être expédiés.
  • Envoyés : dossier du message généré dans la file d'attente. Il sauvegarde tous les messages envoyés selon les configurations des propriétés générales.
  • Abandonnés : dossier du message généré dans la file d'attente. Il reçoit les messages en sélectionnant l'option Tout Abandonner du dossier boîte d'envoi.
  • Suivi : statistiques de suivi des messages.
  • Journal : liste les évènements relatifs au projet, tels que les erreurs lors de la génération des messages, les erreurs de script, etc.

Se connecter à un autre serveur eMill :

Le serveur local eMill est affiché par défaut dans la fenêtre des Files d'Attente, avec tous les projets qui y sont publiés. Vous pouvez également vous connecter à d'autres Serveurs eMill à travers le réseau local ou distant (eMill édition Entreprise), et les afficher dans votre fenêtre Files d'Attente.

Pour ajouter un nouveau serveur eMill, cliquez sur Fichier > Ajouter un serveur eMill... Entrez le nom du serveur eMill (le nom de la machine sur le réseau local ou son adresse sur un réseau distant) puis une description (nom optionnel avec lequel le serveur apparaîtra dans les files d'attente). Pour vous connecter à un serveur eMill sur un réseau distant, vous pouvez aussi spécifier une connexion à distance ou VPN qu'eMill lancera automatiquement pour se connecter au serveur.

Vos droits sur le serveur eMill distant sont configurés depuis les options du compte utilisateur de cette machine.

Connexion à un serveur eMill distant : Si vous souhaitez qu'un client Windows puisse se connecter à un serveur eMill distant, vous devez ouvrir le port TCP 2156 sur la machine sur laquelle le serveur eMill est installé.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Génération des Messages

Le générateur va préparer les en-têtes du message, encoder le corps du message en MIME et transférer les fichiers email (EML) avec les attachements dans le dossier boîte d'envoi. Les options d'encodage comprennent Quoted Printable ou Text (8bit) pour les documents à base de texte, Base64 pour les attachements. eMill mettra automatiquement les valeurs correctes selon le type de contenu.

  • Sélectionnez une file d'attente (uniquement si le projet est publié) dans la fenêtre Files d'Attente.
  • Sélectionnez l'option Démarrer dans le menu File d'Attente/Mailing/Générateur

Vous pouvez mettre en pause/redémarrer ou abandonner la génération des messages en utilisant les commandes files d'attente. Si vous mettez la génération en pause elle reprendra au point où elle s'est arrêtée. Si la dernière génération des messages a été abandonnée, eMill vous proposera de reprendre la génération si l'option Sauver les messages envoyés des propriétés de l'Expéditeur n'est pas Non.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Lancer l'Expéditeur

L'expéditeur a deux états - Lancé ou Arrêté - qui sont indépendants de l'état du générateur de messages (Démarré / En Pause / Abandonné). L'expéditeur concerne les messages du dossier "boîte d'envoi", qu'elle soit vide, en cours de remplissage ou pleine. Notez que les messages doivent avoir été générés (présents dans le dossier "Boîte d'envoi") avant de pouvoir être envoyés.

  • Depuis la fenêtre Files d'Attente, sélectionnez la file (le projet doit être publié) pour laquelle vous voulez lancer l'expéditeur et basculez entre Lancé/Arrêté depuis le menu Files d'attente/Mailing/Expéditeur.
En lançant l'expéditeur, tous les fichiers générés dans le dossier "boîte d'envoi" sont transférés dans le dossier "envoyés" conformément aux options de l'expéditeur qui ont été sélectionnées. La livraison des messages peut être contrôlée en temps réel depuis la fenêtre files d'attente.

Liste de contrôle :

Vérifiez les points suivants avant de commencer la livraison de vos messages :
  1. Files d'attente sortantes : vérifiez que les files d'attente sortantes utilisées par l'expéditeur sont autorisées et que la simulation est désactivée.
  2. Les serveurs : vérifiez que les informations concernant le serveur DNS et le Domaine SMTP sont renseignées et exactes.
  3. En-têtes : vérifiez l'exactitude des informations concernant l'en-tête et sa cohérence avec l'information ci-dessus pour s'assurer d'un bon niveau de livraison.
  4. Retours : inscrivez la boîte d'arrivée du projet dans une file d'attente entrante.
  5. Succession des tâches : le projet doit être publié avant d'être généré, et généré avant d'être expédié.
  6. Messages doubles : lorsque vous utilisez le planificateur, veillez à ne pas générer le message 2 fois, en les générant au moment de la publication et en spécifiant au planificateur de lancer une génération lui aussi.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Planificateur

Le Planificateur

Pour avoir accès aux fonctions de planification, votre projet doit être publié.

  • Dans la fenêtre Files d'Attente, sélectionnez le dossier du projet publié que vous voulez planifier.
  • Depuis le menu Projet, sélectionnez Planification.

Le planificateur est actif si la case Activé est cochée. Dans le menu déroulant, sélectionnez l'action que vous désirez planifier :
- 'Générer seulement' : Exécute le processus de génération des messages.
- 'Envoyer seulement' : Fonctionne uniquement pour les projets dont les messages sont déjà générés.
- 'Générer et envoyer' : L'envoi se fait directement après la génération.

Compte d'exécution :

Entrez le nom d'utilisateur et le mot de passe du compte utilisé pour ouvrir votre session Windows.

Configurations des paramètres du planificateur :

Vous avez ici accès à un ensemble complet d'options permettant d'adapter la périodicité d'exécution de l'action à vos besoins.

  • La liste déroulante affiche les déclencheurs configurés. Un déclencheur permet de définir à quel(s) moment(s) est exécutée l'action définie ci-dessus. Notez que vous pouvez configurer un nombre illimité de déclencheurs.
    - Pour ajouter un déclencheur, cliquez sur le bouton 'Ajouter'.
    - Pour supprimer un déclencheur existant, sélectionnez-le dans la liste déroulante et cliquez sur le bouton 'Supprimer'.
    - Pour éditer un déclencheur existant, sélectionnez-le dans la liste déroulante et modifiez ses paramètres.
    Note : Une fois que vous avez édité, créé ou supprimé un déclencheur, n'oubliez pas de cliquer sur le bouton 'Appliquer' afin de valider ces modifications.
  • Heure de début : Indiquez l'heure à laquelle vous souhaitez exécuter l'action définie. Ce paramètre s'applique à toutes les options définies ci-dessous.
  • Répéter l'action : Ce paramètre optionnel permet de répéter l'action configurée (générer seulement, envoyer seulement ou générer et envoyer). Il donne la possibilité, par exemple, de répéter la génération toutes les 5 heures pendant 5 semaines. Afin de le configurer, il vous suffit de cocher l'option, de définir la périodicité des répétitions (toutes les X heures ou minutes) et d'indiquer la durée de la répétition de l'action (pendant X heures ou minutes).
  • Choisissez ensuite parmi les options suivantes, la périodicité d'exécution de l'action :
    - Exécuter l'action une seule fois : Cette option permet de planifier une action unique. Indiquez ensuite la date d'exécution.
    - Exécuter l'action tous les X jours : Cette option permet de planifier une action régulière tous les X jours. Indiquez ensuite le nombre de jour séparant chaque action.
    - Exécuter l'action chaque X semaines : Cette option permet de planifier une action régulière chaque semaine. Indiquez ensuite le nombre de semaines séparant chaque action ainsi que les jours d'exécution de l'action.

État de Planification :

Le fait d'appliquer une tâche planifiée à un projet publié affiche l'état de planification dans la fenêtre Files d'Attente :

Générer uniquement : pour éviter de générer des messages en double, assurez vous que l'option Publier uniquement est sélectionnée quand vous publiez votre projet. Tous les fichiers email restés dans le dossier boîte d'envoi sont en attente.

Envoyer uniquement : vous devez sélectionner l'option Publier et Générer les emails quand vous publiez votre projet.

Générer et envoyer : pour éviter d'envoyer des messages en double, assurez vous que l'option Publier uniquement est sélectionnée quand vous publiez votre projet. Contrôler tous les point de la liste de contrôle.

Inactivé : la case Activé est décochée.
Non : aucune tâche n'est définie OU la case Activé est cochée et l'option Ne rien faire est sélectionnée

Note: il n'est pas nécessaire que eMill soit lancé pour qu'un mailing planifié soit envoyé. Quitter l'application n'empêchera pas la tâche planifiée de s'exécuter correctement.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Statistiques

Les statistiques sont accessibles pendant ou après la transmission.

  • Sélectionnez le dossier du projet dans la fenêtre Files d'Attente et sélectionnez l'option Files d'attente/Mailing/Statistiques :
  • Données SMTP : pour évaluer la performance de la session. La capacité de traitement dépend de la bande passante disponible de votre serveur SMTP et du serveur réceptionnaire.
  • Messages : fournit l'état des messages envoyés et abandonnés. Les messages indélivrables à cause d'une adresse incorrecte seront transférés dans le dossier des messages abandonnés, conformément aux configurations des propriétés du projet.
  • DNS : vous indique la performance de votre serveur DNS à résoudre les adresses.
  • Générateur : permet d'évaluer les performances de génération des messages.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Suivi des messages

eMill offre la possibilité d'analyser les retombées d'une campagne de publipostage grâce aux fonctionnalités de suivi des messages. En effet, ce module permet de générer des statistiques détaillées sur les messages ouverts et les liens cliqués.

L'enregistrement des informations de suivi des messages est réalisé par un composant autonome installé sur un serveur Web public : le Redirecteur eMill (pour utiliser le suivi des messages eMill sur un serveur web Linux, merci de nous contacter). Les liens contenus dans les messages envoyés par eMill sont modifiés automatiquement afin de pointer vers une url de redirection. Cette url correspond à l'adresse du site ou du dossier virtuel sur lequel le suivi des messages a été activé. Le redirecteur enregistre chaque clic sur les liens des messages, et redirige automatiquement le navigateur du client vers l'url d'origine. L'ouverture des messages est quant à elle détectée grâce à une image invisible ajoutée aux contenus HTML.

Les informations recueillies par le redirecteur sont ensuite collectées par le serveur eMill depuis l'url de collecte. La collecte est sécurisée par le nom et le mot de passe du compte utilisateur de collecte, qui doit être configuré dans les options de suivi du serveur eMill.

Afin d'utiliser le module de suivi des messages d'eMill, vous devez suivre les 2 grandes étapes suivantes :

1. Installer et activer le redirecteur eMill sur un serveur web public

2. Configurer les options de suivi du serveur eMill

Fig. 1 - Fonctionnement du suivi des messages eMill

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Installation du Redirecteur eMill

Lors de l'installation d'une version Entreprise d'eMill, un raccourci vers le dossier contenant les differentes versions du redirecteur est ajouté sur le bureau. Chaque version est spécifique à un type de serveur web particulier. Les redirecteurs version 2 ont un mode de fonctionnement compatible avec les redirecteurs version 1.

Redirecteur version 1 :

Le redirecteur version 1 est conçu pour fonctionner avec IIS 5 et IIS 6. Il doit être installé sur des serveurs tournant sous Windows 2000, Windows XP ou Windows 2003. Son fichier d'installation est eMillTrkSetup.exe.

Redirecteur version 2 pour Windows :

Le redirecteur version 2 pour Windows est conçu pour fonctionner avec IIS 7. Il doit être installé sur des serveurs tournant sous Windows Vista, Windows 2008 ou Windowz 7. Il est livré en tant qu'application ASP.NET contenue dans l'archive AspxRedirector.zip.

Redirecteur version 2 pour Linux :

Le redirecteur version 2 pour Linux est conçu pour fonctionner avec Apache 2. Le serveur Apache doit avoir le support du PHP et le module Rewrite installés. Il est livré en tant qu'ensemble de fichiers contenus dan l'archive phpredir.zip./p>

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Installation du Redirecteur eMill version 1

Le Redirecteur version 1 est un module autonome sous la forme d'une extension ISAPI qui doit être installé sur un serveur public Microsoft Internet Information Service (IIS) 5 ou 6. Lors de l'installation du programme, la DLL ISAPI ainsi que le composant enfichable de configuration du redirecteur pour MMC seront copiés sur le serveur.

Installation :

  • Étape 1. Avant de lancer le programme d'installation, il est important de créer un compte utilisateur dédié au suivi des messages avec des droits limités. Ceci permettra de sécuriser la communication entre le serveur eMill et le serveur Web où sont collectés les ouvertures et les clics. Vous pouvez créer un compte utilisateur en cliquant sur Démarrez/Programmes/Outils d'administration/Gestion de l'ordinateur.
  • Étape 2. Lancez eMillTrkSetup.exe et suivez les instructions qui apparaissent à l'écran.
  • Étape 3. Créez un répertoire virtuel dédié au suivi des messages. Par défaut, eMill crée un répertoire virtuel appelé "trk" sous votre Site Web par défaut. Sélectionnez "Configurer le suivi des messages eMill plus tard" pour terminer l'installation et configurer le redirecteur plus tard manuellement.
  • Étape 4. Entrez le nom de domaine et le compte utilisateur dédié au suivi des messages (voir Étape 1). Si le compte utilisateur ne fait pas partie d'un domaine, entrez le nom d'ordinateur auquel il appartient à la place du domaine.
  • Étape 5. Cliquez sur Suivant pour lancer l'installation.
  • Étape 6. Le redirecteur eMill est maintenant installé. La dernière page du programme d'installation fournit les différentes données qui vont vous permettre de configurer le serveur eMill à partir du menu Outils -> Options -> Suivi des messages. Pour plus de détails, rendez vous dans la page de l'aide consacrée aux Options eMill de Suivi des Messages.

Activer le suivi des messages eMill sur un répertoire virtuel :

  • Ouvrez le composant d'extension enfichable d'IIS à partir du menu Démarrer/Programmes/Outils d'administration/Services Internet (IIS)
  • Ouvrez le noeud Sites Web.
  • Faites un clic droit sur un de vos sites web et sélectionnez Nouveau/Répertoire Virtuel. Une fois l'assistant lancé, entrez le nom de votre choix (ex. : 'trk'), sélectionnez un répertoire vide dédié au suivi des messages et laissez les autorisations d'accès établies par défaut.
  • Cliquez avec le bouton droit sur le répertoire virtuel sur lequel vous souhaitez activer le suivi des messages eMill. Sélectionnez Toutes les tâches/Activer le suivi des messages eMill.
  • Dans la page Compte utilisateur de collecte, entrez le compte utilisateur que le serveur eMill utilisera pour s'authentifier lors de la collecte des informations de suivi.
  • Cliquez sur suivant puis terminer pour activer le suivi des messages.
  • L'url publique du site ou du dossier virtuel sélectionné doit être utilisée comme url de redirection dans les options de suivi d'eMill.

Modifier les paramètres de suivi des messages :

  • Cliquez avec le bouton droit sur un site ou un dossier virtuel où le suivi est activé, puis sur Propriétés.
  • Cliquez sur l'onglet suivi des messages eMill.

Désactiver le suivi des messages :

  • Cliquez à droite sur un site ou un dossier virtuel où le suivi des messages est activé, puis sur Toutes les tâches/Désactiver le suivi des messages eMill.

Remarque : Le site ou le dossier virtuel utilisé pour le suivi des messages peut être entièrement vide.
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Installation du Redirecteur eMill version 2 pour Windows

Le Redirecteur version 2 pour Windows est un module autonome sous la forme d'une application ASP.NET qui doit être installé sur un serveur Microsoft Internet Information Service (IIS) 7. Afin de rendre l'installation la moins intrusive possible, l'installation doit désormais se faire manuellement.

Installation :

  • Étape 1. Extrayez le contenu de l'archive AspxRedirector.zip dans un nouveau dossier, habituellement un sous-dossier de inetpub.
  • Étape 2. Ajoutez la permission en écriture pour l'utilisateur IIS au fichier emilltrk.log extrait de l'archive. Pour ce faire, faites un clic droit sur ce fichier, sélectionnez Propriétés, allez à l'onglet Sécurité, cliquez sur Editer et ajouter les droits Modifier et Ecriture au groupe local IIS_IUSRS ou Utilisateurs.
  • Étape 3. Lancez la console de gestion d'IIS (inetmgr), et ajoutez une application dont le chemin physique est le dossier contenant les fichiers précédemment extraits. Dans notre exemple, nous créons une application nommée trk à la racine du site web www.mydomain.com. L'URL de redirection et de collecte seront http://www.mydomain.com/trk dans ce cas.
  • Étape 4. Changez le nom d'utilisateur et le mot de passe du compte utilisateur de collected dans les Paramètres de l'application web. Ces valeurs sont nommées CollectUsername et CollectPassword..
  • Étape 5. Vous pouvez ajouter une valeur optionelle DefaultRedirectionUrl. Si cette valeur est précisée, toute requête invalide au redirecteur sera redirigée vers la valeur spécifiée.
  • Étape 6. Le Redirecteur version 2 est maintenant installé.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Installation du Redirecteur eMill version 2 pour Linux

Le Redirecteur version 2 pour Linux est un module autonome sous la forme de fichiers PHP qui doivent être installés sur un serveur Apache 2 ayant le support de PHP et du module Rewrite.

Installation :

  • Étape 1. Extrayez le contenu de l'archive phpredir.zip dans un dossier d'un site web.
  • Étape 2. Ajoutez le droit en écriture à l'utilisateur apache2 pour le fichier emilltrk.log extrait de l'archive.
  • Étape 3. Assurez-vous que le module Rewrite is activé. Pour cela, en tant qu'utilisateur root, entrez la commande :
    a2enmod rewrite
  • Étape 4. Assurez-vous que le module Rewrite soit autorisé pour ce dossier. Cela nécessite que l'option FileInfo soit redéfinissable. Par exemple, dans le fichier de configuration du site web d'installation :
    <Directory /var/www/monsite/trk>
        AllowOverride FileInfo
    </Directory>
  • Étape 5. Configurez le nom d'utilisateur et le mot de passe du compte utilisateur de collecte dans le fichier conf.inc.php. Pour cela, vous devez modifier les valeurs des variables $collect_username et $collect_password.
  • Étape 6. Le Redirecteur version 2 est maintenant installé.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Statistiques de message

Les statistiques de message sont générées pour chaque projet où les statistiques sont activées. Elles sont accessibles depuis les files d'attente, icône Statistiques sous la forme de pages Web dynamiques, appelée Client Web eMill.

L'aide des statistiques de message est directement accessible depuis le Client Web. Cliquez sur les icones en forme de point d'interrogation [image] pour ouvrir une nouvelle fenêtre d'aide.

Attention : Le serveur Web Microsoft Internet Information Service (IIS) version 5.0 ou supérieure doit être installé sur le serveur où se trouve les statistiques. Il est livré avec les systèmes d'exploitation Microsoft Windows 2000 Professionnel ou Server et les versions ultérieures. Pour ajouter IIS, allez dans le composant Ajout/Suppression de programmes du Panneau de configuration, puis cliquez sur le bouton Windows.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


eMill Fax

Le mailing fax offre de nombreux avantages qui viennent non en contradiction mais en complément de l’email. Il s’agit donc d’utiliser simplement le média adéquat selon vos besoins, vos sources ou votre cible. Le logiciel eMill vous permet de combiner efficacement le mailing fax et l'emailing et de profiter de sa puissance et de sa flexibilité pour l'envoi et la réception de fax.

Envoi de fax

eMill vous offre la possibilité d'envoyer par fax les formats suivants : PDF (Adobe Acrobat), TIFF (format image), HTML et TXT. Pour pouvoir envoyer des fax à travers le module fax d'eMill vous devez :

1. Configurez la console de télécopie Windows. En effet, l'envoi des télécopies étant géré directement par votre système d'exploitation Windows, vous devez configurer au moins un modem en émission.

2. Configurez les options générales du fax.

3. Spécifiez les priorités entre les canaux de communication (email, SMS ou fax) pour chacune des listes de destinataires dans les propriétés des listes de destinataires.

Si les numéros de fax inclus dans vos sources de données sont dans un format qui n'est pas exploitable directement, eMill vous propose un outil de transformation de la numérotation.

Réception de fax

Pour pouvoir recevoir des fax en utilisant la puissance d'eMill, vous devez :

1. Créez une file d'attente entrante fax dans les propriétés des files d'attente entrantes : Au lancement du serveur eMill, une file d'attente entrante fax est automatiquement créée. Celle-ci permet de spécifier à eMill que les fax reçus sont stockés dans un dossier (par défaut C:\Program Files\Active+\eMill\Fax\Inbox). Si vous souhaitez qu'eMill collecte les fax reçus dans un autre emplacement (client mail ou dossier), vous pouvez ajouter des nouvelles files d'attente entrante en vous rendant dans les propriétés des files d'attente entrantes.

2. Spécifiez les propriétés de réception des fax. En effet, eMill vous propose de recevoir les fax directement dans la boîte d'arrivée d'eMill ou de les transférer vers le destinataire de votre choix. De plus, vous avez la possibilité de choisir le format de réception afin de faciliter la gestion des fax reçus.

3. Une fois votre projet publié, vous devez l'associer à la file d'attente "fax" et décider du traitement des fax qui seront reçus dans la boîte d'arrivée d'eMill.

Comment envoyer des télécopies en heures creuses ? Vous devez, dans un premier temps, définir les heures creuses dans la console de télécopie Windows. Puis, dans un deuxième temps, configurer la priorité de votre message comme "plus basse" dans les propriétés de l'en-tête. Il ne vous reste plus qu'à lancer l'envoi des messages, ils seront automatiquement mis en attente jusqu'au début des heures creuses.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Guide des Scripts Serveur

Base de connaissances

Afin de vous aider à profiter pleinement des performances et de la flexibilité d'eMill, vous pouvez consulter la base de connaissances. Celle-ci est mise à jour par nos ingénieurs et grâce à vos questions et à vos commentaires. Alors n'hésitez pas à nous contacter par email si vous avez des suggestions.

Vous pouvez aussi consulter la section FAQ de notre site Internet pour obtenir des informations complémentaires.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Fichier d'Aide eMill

Les différentes versions d'eMill et leurs fonctionnalités

Consultez le tableau afin de voir quelles sont les fonctions implémentées par votre version d'eMill. Pour connaître la version de votre logiciel, ouvrez la boîte de dialogue Aide/A propos d'eMill...

eMill édition : | Professionnelle | Entreprise | Commentaires
Origine de la source de données |  |  |
Base de données spécifique au projet | OUI | OUI | Compatible avec Access, l'édition est possible avec eMill
Lien avec des bases de données externes | OUI | OUI | Excel, Access, Carnet d'adresses, Outlook, ACT!
Fusionner des enregistrements à partir d'une base de données | OUI | OUI | Associations de champs, formats hétérogènes
Exporter des enregistrements dans une base de données | OUI | OUI | Compatible avec Access, l'édition est possible avec eMill
Extraire et importer des adresses | OUI | OUI | A partir de fichiers texte non structurés, à partir du presse-papiers
Connexion ADO avancée | Optionnel | OUI | Oracle, Informix, Bases de données SQL Server
Connexion à des bases non ADO | NON | OUI | Object script DataSource
Options de publication |  |  |
Connexion avec d'autres serveurs eMill | OUI | OUI | Affiche tous les serveurs eMill connectés
Comptes d'utilisateur eMill | NON | OUI | Gère plusieurs utilisateurs eMill sur un serveur
Sécurité et Quotas | NON | OUI | Définit les permissions utilisateurs et les quotas sur un serveur eMill
Options du générateur |  |  |
Pilote PDF incorporé | Optionnel | OUI | Convertit le contenu de l'email en PDF avant l'expédition.
Suivi des messages |  |  |
Statistiques de suivi des messages | Optionnel | OUI | Affiche les statistiques de suivi des messages, telles que les taux d'ouverture, les clics, ...
Redirecteur eMill | NON | OUI | Composant chargé d'enregistrer les ouvertures de messages et les clics.
S/MIME |  |  |
Prise en charge de Secure MIME | Optionnel | OUI (versions Gold et Platinium) | Permet de signer et de crypter les messages.
Fax |  |  |
Envoi de mailing fax | Optionnel | OUI | Permet d'accéder aux fonctionnalités permettant d'envoyer et de recevoir des fax.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Structure d'un Projet

Vous trouverez ci-dessous la liste des fichiers qui peuvent être sauvegardés sous des noms et des dossiers différents de ceux définis par défaut.

Arborescence à la conception : Mes Documents\Projets eMill\MonProjet\

En mode conception tous les projets sont sauvegardés par défaut dans le dossier Projets eMill sous Mes Documents. Le nom de dossier MonProjet est celui du projet de publipostage. Vous pouvez renommer les dossiers et changer leur emplacement, mais tous les fichiers du projet doivent rester dans leur dossier respectif.

  • MonProjet.mil est le fichier natif d'eMill dans lequel sont enregistrés tous les paramètres du projet et les autres fichiers du projet.
  • Milset.vbs est le script global généré par eMill, contenant les informations d'accès aux enregistrements de la base de données. Il peut être édité à partir de l'éditeur de script ou d'éditeurs externes.
  • CorpsHtml.htm et CorpsTexte.txt sont les contenus html et texte créés par défaut. Vous pouvez ajouter, supprimer et renommer un nombre illimité de fichiers par envoi, ces fichiers sont sauvegardés dans le dossier du projet et importés dans le projet (voir Ajouter un contenu). Les fichiers html et texte peuvent être convertis en PDF au moment de la génération. Il est possible d'utiliser des éditeurs externes.
  • DataBase.mdb est généré lorsque vous importez des adresses d'un autre fichier (text, html, csv...), du presse-papiers ou lors de la création d'une base de données spécifique au projet. Les enregistrements servent à concevoir la liste des destinataires et à créer les variables de contenu. On peut l'éditer à partir de la vue destinataires ou de Microsoft® Access. Database.mdb ne figure pas dans l'arborescence lorsque le projet est lié à des enregistrements d'une base de données externe.
  • Les autres fichiers sont utilisés pour la conception du message : attachements, images incorporées, etc.
Nom du fichier | Format | Commentaire
MonProjet.Mil | Projet eMill | Fichier XML contenant les paramètres du projet
Milset.vbs | Texte | Fichier contenant le script global
DataBase.mdb | Base de données Access | Liste des destinataires, contenu par défaut dans la base de données
CorpsHtml.htm | Html | Contenu html par défaut des messages
CorpsTexte.txt | Texte | Contenu texte alterné par défaut des messages
Liste des fichiers pouvant se trouver dans le dossier MonCompte@MonProjet\MonProjet.

Arborescence à la publication : Pub\MonCompte@MonProjet\Projet\

En publiant le projet, tous les fichiers du projet apparaîtront dans le dossier MonCompte@MonProjet\Projet, relatif au dossier Pub d'eMill (lui-même situé dans le dossier d'installation d'eMill, généralement "C:\Program Files\Active+\eMill"). "MonCompte" représente le compte eMill sur lequel a été publié le projet (Utilisateurs pour la version professionnelle). Il est recommandé de ne pas renommer, déplacer ou éditer des fichiers et des dossiers contenus dans le dossier Pub. Un Projet doit être modifié à partir des fichiers originaux dans le dossier Mes Documents\Projets eMill, puis publié à nouveau afin de mettre à jour le contenu dans le dossier Pub.

Dossier Message : Pub\MonCompte@MonProjet\Messages\

Quand le projet est publié, un dossier Messages est créé dans le dossier MonCompte@MonProjet. La base de données Messages.mdb stocke des informations sur les fichiers email créés par le générateur, telles que la boîte à laquelle appartient chaque e-mail. Les messages générés sont affichés dans la Boîte d'Envoi dans la fenêtre files d'attente, les emails envoyés avec succès sont transférés dans la boîte Envoyés.

Notez que le fait de stopper l'expéditeur n'interrompra pas la génération qui peut être mise en pause et redémarrée. Quand vous abandonnez la génération vous avez l'option de laisser les messages déjà générés dans la Boîte d'Envoi ou de les détruire. L'option "Tout Abandonner" dans la Boîte d'Envoi transférera les messages dans la boîte Abandonnés, conformément aux configurations des propriétés du projet (en-têtes seulement, message complet). Les réponses des destinataires peuvent être stockées dans la Boîte de Réception si le projet a été précédemment inscrit à une file d'attente entrante.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Exemple d'en-têtes

eMill utilise un ensemble d'en-têtes standards et spécifiques pour créer, envoyer et recevoir des messages. En connaissant ces en-têtes, vous pourrez affiner le traitement des messages entrants en affectant une action pour un type d'en-tête. Voici une description de quelques-uns de ces en-têtes :

  • X-Sender : champ privé correspondant à l'expéditeur SMTP.
  • X-Receiver : liste privée des destinataires SMTP.
  • From : information sur l'expéditeur du message.
  • To : adresse du destinataire.
  • Cc : ce champ est utilisé pour envoyer un message à plusieurs destinataires.
  • Reply-To : si un de vos destinataires répond directement à votre email, la réponse sera envoyée en priorité à l'adresse indiquée dans le champ "reply-to". Si cette information n'est pas disponible, la réponse sera envoyée à l'adresse indiquée dans le champ "From". L'adresse "reply-to" peut être spécifiée dans les propriétés de l'en-tête.
  • Organization : société de l'expéditeur si elle a été précisée.
  • Subject : sujet du message.
  • Date : affichage de la date à laquelle le message a été généré pour les messages sortants et de la date d'envoi pour les messages entrants.
  • X-Priority : ce champ indique la priorité du message. Elle peut aller de 1 (priorité la plus basse) à 5 (priorité la plus haute). Si cette information n'est pas disponible, la priorité par défaut est de 3 (priorité normale).
  • Message-ID : le message-ID est créé par eMill et est unique pour chaque message.

Pour les utilisateurs avancées, retrouvez ici plus d'exemples d'en-têtes.

En-têtes spécifiques pour les fax reçus.

  • X-eMillFax-CallerId : Numéro de fax de l'expéditeur. Cette information peut être cachée par l'expéditeur.
  • X-eMillFax-Tsid : Le Transmitting Station ID (TSID) représente l'identité du télécopieur de l'expéditeur. Cette donnée se compose, en général, du numéro de fax et du nom de la société. Cette information n'est pas toujours disponible.
  • X-eMillFax-Csid : Le Calling Subscriber ID (CSID) représente l'identité du télécopieur du destinataire. Lorsqu'un fax entrant est détecté, le télécopieur du destinataire transmet le CSID au fax de l'expéditeur. Le CSID se compose, en général, du numéro de fax et du nom de la société. Cette information n'est pas toujours disponible.
  • X-eMillFax-DeviceName : Nom du périphérique fax utilisé pour la réception du fax. Cette information est toujours disponible.
  • X-eMillFax-PageCount : Nombre de pages du fax. Cette information est toujours disponible.
  • X-eMillFax-StartTime : Heure de début d'envoi du fax. Cette information est toujours disponible (Sous Windows 2000, ce champ est vide)
  • X-eMillFax-EndTime : Heure de fin d'envoi du fax. Cette information est toujours disponible.
  • X-eMillFax-ExtendedStatus : Permet de savoir si le fax a été reçu entièrement ou de façon partielle. Cette information n'est disponible que sous Windows XP/2003. Chaque nombre représente un statut différent :

16 = réception partielle

18 = appel terminé

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Gestion des Bounces, NPAI ou DSN

La mise en place d'une gestion des bounces est une étape clé dans la construction de vos projets d'e-mailing. L'objectif de cette article est de vous donner les clés pour traiter les bounces facilement et efficacement.

Sommaire:

Introduction

Définitions

Scénarios

La gestion des bounces dans le script global (utilisateurs avancés)

Dans un premier temps, il est important de rappeler certains points importants :

  • Cette article vous aidera à récupérer des informations à partir des bounces afin de les gérer efficacement. Cependant, il est important de savoir que, selon de récentes études, seulement 60% des serveurs SMTP envoient des bounces dans un format standard. Par conséquent, les scénarios décrits ci-dessous qui séparent la gestion des soft bounces et hard bounces ne s'appliqueront en moyenne qu'à 60% des bounces que vous recevrez. Pour une gestion complète des bounces, il est donc conseillé de créer des actions par défaut qui seront appliquées aux bounces reçus dans des formats non standards.

  • Les différents scénarios décrits ci-dessous vous guident dans la configuration d'eMill pour automatiser le traitement des bounces à partir du moment où ils sont dans la boîte de réception de votre projet eMill. Par conséquent, nous assumons que vous avez déjà configuré :

    1. Les files d'attente entrantes : Les bounces sont envoyés à l'adresse e-mail inscrite dans le champ "Expéditeur SMTP" de l'en-tête de votre projet. Il est donc nécessaire d'associer votre projet avec la file d'attente entrante correspondant au serveur mail de cette adresse e-mail.
    2. Les conditions de téléchargement : Ces conditions vous permettent de spécifier quels messages sont téléchargés dans la boîte de réception de votre projet eMill. Veillez donc à ce que les conditions que vous avez configurées ne vous empêchent pas de télécharger les bounces.

  • Les scénarios décrits dans cette article sont les suivants :

    1. Scénario 1 : Lorsque je reçois un bounce m'indiquant que mon envoi a échoué (DSN de type 'Echec'), je souhaite incrémenter de 1 le champ 'DSN' de ma source de données et je veux ajouter dans le champ 'DSN Commentaires' un texte expliquant les raisons de l'échec de l'envoi.
    2. Scénario 2 : Lorsque je reçois un bounce m'indiquant un échec permanent de l'envoi (=hard bounce), je souhaite effacer l'enregistrement de ma source de données.
    3. Scénario 3 : Lorsque je reçois un bounce, je souhaite incrémenter de 1 le champ 'DSN' de ma source de données et supprimer l'enregistrement lorsque ce compteur atteint le chiffre 5.

Définitions: Un DSN, appelé aussi Bounce ou NPAI, est un message créé par le serveur mail du destinataire. Il fournit des informations sur le statut du message que vous avez envoyé. Chaque DSN apporte les les informations suivantes :

Type du DSN: Vous pouvez préciser dans les propriétés des notifications de votre projet, quel(s) type(s) de DSN vous souhaitez recevoir. Par défaut, vous ne recevez que les DSNs de type 'Echec'. Un DSN peut avoir 5 différents types :

  • Succès : Indique que le message a bien été délivré.

  • Relayé : Si vous avez indiqué dans les propriétés des notifications que vous souhaitiez recevoir des DSN de type 'Succès', le DSN 'Relayé' vous prévient que le serveur mail du destinataire ne gère pas les DSN 'Succès'.

  • Déployé : Indique que le message a bien été délivré mais a été directement transféré vers d'autres destinataires. Par conséquent, il est possible que vous receviez de nouveaux DSN à propos du même message.

  • Échec : Indique que l'envoi du message a échoué. Les raisons de cet échec peuvent être nombreuses. Les scénarios de cet article vous permettent de traiter différemment les DSNs de type 'Echec' selon les circonstances.

  • Délais : Indique que l'envoi du message a échoué mais que le serveur mail du destinataire essaye toujours de le délivrer.

Destinataire original de la notification : Cette information vous permet de savoir à quel destinataire le message avait été envoyé à l'origine.

Statut du DSN : Le statut du DSN est fournit grâce à un code de 3 chiffres et permet d'affiner l'analyse du DSN.

Dans un DSN de type 'Echec', le premier chiffre peut être '4' ou '5'. Le chiffre 5 représente un échec permanent de l'envoi (= hard bounce) ce qui signifie que le message ne peut pas être délivré de manière définitive (le domaine n'existe pas, l'utilisateur n'existe pas,...). Le chiffre 4 représente un échec temporaire de l'envoi (= soft bounce) ce qui signifie que le message ne peut pas être délivré pour le moment (boîte mail remplie, serveur de réception occupé,...). Le 2ème chiffre du code indique la source probable de l'échec et le 3ème donne une raison précise de l'échec si celle ci est connue. Cliquez ici pour consulter la liste complète des différents codes définissant le statut du DSN.

Diagnostic de la notification: Le code de diagnostic est une phrase courte qui définit le statut du DSN.

Scénario 1: Lorsque je reçois un bounce m'indiquant que mon envoi a échoué (DSN de type 'Echec'), je souhaite incrémenter de 1 le champ 'DSN' de ma source de données et je veux ajouter dans le champ 'DSN Commentaires' un texte expliquant les raisons de l'échec de l'envoi.
  • Rendez vous dans Projet > Règles de message > Onglet Général, sélectionnez 'Appliquer les règles suivantes' et cliquez sur 'Ajouter'.
  • Entrez un nom pour cette nouvelle règle.
  • Conditions d'exécution des actions :

    1. Cliquez sur 'Ajouter'.
    2. Sélectionnez "Notification de livraison (DSN)" dans la liste des conditions et cliquez sur 'Suivant'.
    3. Sélectionnez le bouton radio 'Le message est une notification de livraison' et cochez uniquement la case 'Echoué'. Cliquez sur 'Terminer'.

  • Actions :

    1. Cliquez sur 'Ajouter'.
    2. Sélectionnez 'Modifier un enregistrement d'une source de données'. Cliquez sur 'Suivant'.
    3. Sélectionnez la liste où les champs 'DSN' et 'DSN Commentaires' sont situés. Cliquez sur 'Suivant'.
    4. Un tableau vous présente la liste des champs de votre source de données et vous permet de configurer les actions à exécuter.

      -> Afin d'ajouter la raison de l'échec de l'envoi dans le champ 'DSN Commentaires', sélectionnez ce champ dans la liste et cliquez sur 'Editer'. Une nouvelle fenêtre s'ouvre dans laquelle vous devez sélectionner 'Diagnostic de la notification' dans la liste des nouvelles valeurs. Cliquez sur OK.

      -> Afin d'incrémenter de 1 le champ 'DSN'1, sélectionnez ce champ dans la liste et cliquez sur 'Editer'. Une nouvelle fenêtre s'ouvre dans laquelle vous devez cocher le bouton 'Modifier la valeur', sélectionner 'Incrémenter de' et entrer '1' dans la zone de texte. Cliquez sur OK.

      -> Cliquez sur Suivant.
    5. Maintenant, vous devez préciser à eMill sur quel enregistrement les actions précédentes seront appliquées. Par exemple, lorsque je reçois un DSN à propos du message envoyé à steve@emilltest.com, je veux que le champ 'DSN' soit incrémenter de 1 pour ce contact et non un autre. Dans cette nouvelle fenêtre, vous allez donc cliquer sur 'Ajouter', sélectionner le champ qui contient les adresses email des destinataires ; dans la liste des opérateurs, choisissez 'est égal à' puis 'Destinataire original de la notification'. Cliquez sur OK. Notez que, par défaut, cette condition est déjà configurée.

Scénario 2 : Lorsque je reçois un bounce m'indiquant un échec permanent de l'envoi (=hard bounce), je souhaite effacer l'enregistrement de ma source de données.
  • A partir de l'onglet Général des règles de message, cliquez sur 'Ajouter'.
  • Entrez un nom pour cette nouvelle règle.
  • Conditions d'exécution des actions :

    1. Cliquez sur 'Ajouter'.
    2. Sélectionnez "Notification de livraison (DSN)" dans la liste des conditions et cliquez sur 'Suivant'.
    3. Sélectionnez le bouton radio 'Le message est une notification de livraison'. Cochez la case 'Echoué'. Cochez la case 'Le statut doit correspondre à' et sélectionnez '5.*.* (Erreur Permanente)' dans la liste déroulante. Cliquez sur 'Terminer'.

  • Actions :

    1. Cliquez sur 'Ajouter'.
    2. Sélectionnez 'Supprimer un enregistrement d'une source de données'. Cliquez sur 'Suivant'.
    3. Sélectionnez votre liste de destinataires. Cliquez sur 'Suivant'.
    4. Maintenant, vous devez préciser à eMill quel enregistrement sera supprimé. Par exemple, lorsque je reçois un DSN à propos du message envoyé à steve@emilltest.com, je veux que ce contact soit supprimé et non un autre. Dans cette nouvelle fenêtre, vous allez donc cliquer sur 'Ajouter', sélectionner le champ qui contient les adresses email des destinataires ; dans la liste des opérateurs, choisissez 'est égal à' puis 'Destinataire original de la notification'. Cliquez sur OK. Notez que, par défaut, cette condition est déjà configurée.

Scénario 3 : Lorsque je reçois un bounce, je souhaite incrémenter de 1 le champ 'DSN' de ma source de données et supprimer l'enregistrement lorsque ce compteur atteint le chiffre 5.
  • A partir de l'onglet Général des règles de message, cliquez sur 'Ajouter'.
  • Entrez un nom pour cette nouvelle règle.
  • Conditions d'exécution des actions :

    1. Cliquez sur 'Ajouter'.
    2. Sélectionnez "Notification de livraison (DSN)" dans la liste des conditions et cliquez sur 'Suivant'.
    3. Sélectionnez le bouton radio 'Le message est une notification de livraison'. Cochez la case 'Echoué'. Cliquez sur 'Terminer'.

  • Actions : Vous devez configurer 2 actions.

    Action 1 : Incrémenter le champ 'DSN' de 11

    1. Cliquez sur 'Ajouter'.
    2. Sélectionnez 'Modifier un enregistrement d'une source de données'. Cliquez sur 'Suivant'.
    3. Sélectionnez la liste où le champ 'DSN' est situé. Cliquez sur 'Suivant'.
    4. Un tableau vous présente la liste des champs de votre source de données et vous permet de configurer les actions à exécuter.

      -> Afin d'incrémenter de 1 le champ 'DSN'1, sélectionnez ce champ dans la liste et cliquez sur 'Editer'. Une nouvelle fenêtre s'ouvre dans laquelle vous devez cocher le bouton 'Modifier la valeur', sélectionner 'Incrémenter de' et entrer '1' dans la zone de texte. Cliquez sur OK.

      -> Cliquez sur Suivant.
    5. Maintenant, vous devez préciser à eMill sur quel enregistrement cette action sera appliquée. Par exemple, lorsque je reçois un DSN à propos du message envoyé à steve@emilltest.com, je veux que le champ 'DSN' soit incrémenter de 1 pour ce contact et non un autre. Dans cette nouvelle fenêtre, vous allez donc cliquer sur 'Ajouter', sélectionner le champ qui contient les adresses email des destinataires ; dans la liste des opérateurs, choisissez 'est égal à' puis 'Destinataire original de la notification'. Cliquez sur OK. Notez que, par défaut, cette condition est déjà configurée.

    Action 2 : Supprimer l'enregistrement lorsque le champ 'DSN' atteint le chiffre 5

    1. Cliquez sur 'Ajouter'.
    2. Sélectionnez 'Supprimer un enregistrement d'une source de données'. Cliquez sur 'Suivant'.
    3. Sélectionnez la liste où le champ 'DSN' est situé. Cliquez sur 'Suivant'.
    4. Maintenant, vous devez préciser sous quelles conditions l'enregistrement sera supprimé :
      - Indiquez quel enregistrement est concerné. Par exemple, lorsque je reçois un DSN à propos du message envoyé à steve@emilltest.com, je veux que ce contact soit supprimé et non un autre. Dans cette nouvelle fenêtre, cliquez sur 'Ajouter', sélectionnez le champ qui contient les adresses email des destinataires ; dans la liste des opérateurs, choisissez 'est égal à' puis 'Destinataire original de la notification'. Cliquez sur OK. Notez que, par défaut, cette condition est déjà configurée.
      - Indiquez le fait que l'enregistrement doit être supprimé à condition que le compteur est atteint le chiffre 5. Cliquez sur 'Ajouter', sélectionnez le champ 'DSN' ; dans la liste des opérateurs, choisissez 'est supérieur ou égal à' puis 'Valeur constante' et entrez le chiffre 5. Cliquez sur OK.
FAQ - Je ne parviens pas à configurer une action pour incrémenter de 1 un champ de ma liste car l'option 'Modifier la valeur' est grisée : Pour pouvoir incrémenter un champ de votre liste, celui-ci doit être configurer comme pouvant recevoir ce type de données. Pour créer une colonne avec des champs de ce type, affichez votre liste de destinataires dans votre projet, sélectionnez le menu Projet > Source de données > Ajouter une colonne. Dans la liste déroulante 'Type de données', sélectionnez 'Entier'.

La gestion des bounces dans le script global (utilisateurs avancés):

eMill donne la possibilité aux utilisateurs familiers avec le script de gérer les DSNs à partir du script global. Cliquez ci-dessous sur le nom des collections pour obtenir plus d'informations et accéder aux exemples :

  • La collection Mail DSNHeaders donne accès à la liste des en-têtes des DSN
  • La collection Mail DSNReceivers donne accès à la liste avancée des en-têtes des DSN
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Managing DSNs & bounces - DSN Status Codes

Les codes de statut du DSN (en anglais)

The DSN Status is a code composed of three numerical fields separated by "." that gives the status of the DSN. You will find below a list of definitions for each numerical value.

First Figure:

2.X.X Success
Success specifies that the DSN is reporting a positive delivery action. Detail sub-codes may provide notification of transformations required for delivery.

4.X.X Persistent Transient Failure
A persistent transient failure is one in which the message as sent is valid, but some temporary event prevents the successful sending of the message. Sending in the future may be successful.

5.X.X Permanent Failure
A permanent failure is one which is not likely to be resolved by resending the message in the current form. Some change to the message or the destination must be made for successful delivery.

Second Figure:

X.0.X Other or Undefined Status
There is no additional subject information available.

X.1.X Addressing Status
The address status reports on the originator or destination address. It may include address syntax or validity. These errors can generally be corrected by the sender and retried.

X.2.X Mailbox Status
Mailbox status indicates that something having to do with the mailbox has cause this DSN. Mailbox issues are assumed to be under the general control of the recipient.

X.3.X Mail System Status
Mail system status indicates that something having to do with the destination system has caused this DSN. System issues are assumed to be under the general control of the destination system administrator.

X.4.X Network and Routing Status
The networking or routing codes report status about the delivery system itself. These system components include any necessary infrastructure such as directory and routing services. Network issues are assumed to be under the control of the destination or intermediate system administrator.

X.5.X Mail Delivery Protocol Status
The mail delivery protocol status codes report failures involving the message delivery protocol. These failures include the full range of problems resulting from implementation errors or an unreliable connection. Mail delivery protocol issues may be controlled by many parties including the originating system, destination system, or intermediate system administrators.

X.6.X Message Content or Media Status
The message content or media status codes report failures involving the content of the message. These codes report failures due to translation, transcoding, or otherwise unsupported message media. Message content or media issues are under the control of both the sender and the receiver, both of whom must support a common set of supported content-types.

X.7.X Security or Policy Status
The security or policy status codes report failures involving policies such as per-recipient or per-host filtering and cryptographic operations. Security and policy status issues are assumed to be under the control of either or both the sender and recipient. Both the sender and recipient must permit the exchange of messages and arrange the exchange of necessary keys and certificates for cryptographic operations.

Third Figure:

  • X.1.0 Other address status
  • X.1.1 Bad destination mailbox address
  • X.1.2 Bad destination system address
  • X.1.3 Bad destination mailbox address syntax
  • X.1.4 Destination mailbox address ambiguous
  • X.1.5 Destination mailbox address valid
  • X.1.6 Mailbox has moved
  • X.1.7 Bad sender's mailbox address syntax
  • X.1.8 Bad sender's system address
  • X.2.0 Other or undefined mailbox status
  • X.2.1 Mailbox disabled, not accepting messages
  • X.2.2 Mailbox full
  • X.2.3 Message length exceeds administrative limit.
  • X.2.4 Mailing list expansion problem
  • X.3.0 Other or undefined mail system status
  • X.3.1 Mail system full
  • X.3.2 System not accepting network messages
  • X.3.3 System not capable of selected features
  • X.3.4 Message too big for system
  • X.4.0 Other or undefined network or routing status
  • X.4.1 No answer from host
  • X.4.2 Bad connection
  • X.4.3 Routing server failure
  • X.4.4 Unable to route
  • X.4.5 Network congestion
  • X.4.6 Routing loop detected
  • X.4.7 Delivery time expired
  • X.5.0 Other or undefined protocol status
  • X.5.1 Invalid command
  • X.5.2 Syntax error
  • X.5.3 Too many recipients
  • X.5.4 Invalid command arguments
  • X.5.5 Wrong protocol version
  • X.6.0 Other or undefined media error
  • X.6.1 Media not supported
  • X.6.2 Conversion required and prohibited
  • X.6.3 Conversion required but not supported
  • X.6.4 Conversion with loss performed
  • X.6.5 Conversion failed
  • X.7.0 Other or undefined security status
  • X.7.1 Delivery not authorized, message refused
  • X.7.2 Mailing list expansion prohibited
  • X.7.3 Security conversion required but not possible
  • X.7.4 Security features not supported
  • X.7.5 Cryptographic failure
  • X.7.6 Cryptographic algorithm not supported
  • X.7.7 Message integrity failure
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


La gestion d'une liste d'abonnés avec eMill

La diffusion de newsletter est devenue quasi indispensable pour une entreprise petite, moyenne ou grande souhaitant s’assurer une visibilité maximale sur Internet. eMill inclut dans toutes ses éditions (Professionnel et Entreprise), tous les éléments nécessaires à une gestion automatisée d’une liste d’abonnés : création du formulaire d’abonnement, traitement des abonnements et des désabonnements, mise à jour manuelle…

Au-delà de la création du message en lui-même qui est évoquée dans d’autres ressources en ligne, ce tutoriel a pour objectif de vous démontrer de quelle manière eMill va vous permettre d’automatiser complètement la gestion de votre liste d’abonnés.

Notez que la 1ère section du tutoriel part du fait que vous démarrez la gestion d’une liste et que vous ne disposez d’aucun acquis. Si vous avez déjà un formulaire d’abonnement sur votre site Internet et que vous souhaitez utiliser eMill pour automatiser la mise à jour de votre liste, reportez-vous à la 2ème partie du tutoriel.

1. Démarrez la gestion d’une liste d’abonnés avec eMill

Grâce à son module de gestion de l’opt-in, eMill va vous fournir tous les éléments pour créer un formulaire d’abonnement en ligne personnalisé et pour gérer automatiquement la maintenance de la liste.

1.1 L’email comme outil de communication entre vos abonnés et eMill

Tout au long de ce tutoriel, vous allez vous rendre compte que l’e-mail est utilisé pour transporter les informations concernant un abonnement ou un désabonnement.

Vous devez donc, pour commencer, sélectionner une de vos adresses e-mail qui servira à cette communication, puis, configurer une file d’attente entrante correspondant à cette adresse email à partir du menu Outils > Options, onglet Files d’attente entrantes (compte POP3 ou fichier). Pour plus de détails sur la configuration des files d’attente entrantes, veuillez vous reporter à l’aide correspondante.

Notez que cette adresse e-mail ne doit pas être nécessairement réservée à eMill et que cette étape est indépendante et peut-être également réalisée à la fin de ce tutoriel.

1.2 Créez un nouveau projet de mailing

A partir du menu Fichier > Nouveau, sélectionnez ‘Projet Mailing vierge’ et cliquez sur OK.

Entrez un nom et une description pour votre nouveau projet et cliquez sur ‘Terminer’.

1.3 Créez une nouvelle liste

Cette liste va vous permettre de stocker toutes les informations que vous collectez sur vos abonnés lors de leur inscription à votre newsletter. Par conséquent, il est important qu’à chaque question que vous allez faire apparaître dans votre formulaire corresponde une colonne dans votre liste. Par exemple, si dans mon formulaire d’abonnement, je veux demander au visiteur son nom, son prénom, le nom de son entreprise et son adresse e-mail, je dois retrouver dans ma liste, les colonnes Nom, Prénom, Entreprise, E-mail.

Pour procéder à l’ajout de la liste, rendez vous dans le menu Projet > Ajouter une liste de destinataires. Entrez un nom pour votre nouvelle liste et cliquez sur ‘Suivant’.

Sélectionnez le type de source de données ‘Je n’ai pas de bases de données, en créer une’ et cliquez sur ‘Suivant’ puis ‘Terminer’.

La liste s’affiche maintenant dans l’arborescence de votre projet sous ‘Listes de destinataires’. Lorsque vous la sélectionnez, son contenu s’affiche dans la fenêtre de droite. Vous pouvez constater qu’elle contient un certain nombre de colonnes par défaut. Si vous souhaitez ajouter ou supprimer des colonnes afin qu’elles correspondent aux informations que vous allez recueillir sur vos abonnés, rendez vous dans le menu Projet > Source de données > Ajouter une colonne / Supprimer une colonne.

1.4 Configurer la mise à jour automatique de la liste

Sélectionnez la liste nouvellement créée à partir de l’arborescence du projet et cliquez sur le menu Outils > Configuration de l’Opt-In.

Cliquez sur ‘Suivant’ afin de lancer l’assistant.

La création du formulaire

La première étape consiste à créer le formulaire d’abonnement que les visiteurs de votre site Internet devront remplir afin de s’abonner à votre newsletter. Pour cela, vous devez donc :

  • Définir les questions qui apparaîtront sur le formulaire. Le tableau détaille l’ensemble des colonnes de votre liste. Pour chacune d’entre elles, vous devez décider si la personne souhaitant s’abonner à votre newsletter doit obligatoirement fournir l’information (cochez la case ‘Obligatoire’), si la question apparaît mais reste optionnelle (cochez la case ‘Optionnel’) ou si la question ne doit pas apparaître dans le formulaire (ne cochez aucune case). Dans l’exemple ci-dessous, je vais créer un formulaire où le visiteur devra renseigner son nom (obligatoire), son prénom (optionnel) et son adresse e-mail (obligatoire).
  • L’URL de redirection. Vous devez fournir l’adresse d’une page Internet qui sera affichée lorsque le visiteur de votre site Internet aura soumis le formulaire d’abonnement. Cette adresse peut correspondre à la page d’accueil de votre site ou à une page où vous remerciez le visiteur de s’être abonné.
  • Adresse e-mail. Entrez l’adresse e-mail définie au point 1.1. Lorsqu’un visiteur de votre site Internet soumet le formulaire d’abonnement, l’ensemble des informations qu’il a fournies vous sont envoyées par e-mail à l’adresse indiquée ici.

Le message de confirmation

Cliquez sur ‘Suivant’

Le message de confirmation est automatiquement envoyé au nouvel abonné lors de son inscription. Il lui permet de confirmer son abonnement à votre liste d'envoi en cliquant sur un lien. Ce procédé appelé 'double opt-in' permet d'éviter qu'une personne soit abonnée à son insu et de disposer d'une liste d'envoi propre à 100%.

Le contenu de l’email de confirmation est automatiquement créé par eMill. Cependant, eMill vous permet de modifier le message de confirmation (sujet et corps du message) envoyé au format HTML. Vous pouvez soit insérer du texte brut entre les tags <body> et </body>, soit écrire du code HTML directement dans la zone de texte, soit copier/coller le code depuis un éditeur HTML externe.

Vous pouvez aussi personnaliser le message en utilisant les informations fournies par le nouvel abonné lors de son inscription. Pour cela utilisez la syntaxe suivante : %NomDuChamp%. Ceci va vous permettre, par exemple, de commencer votre message en utilisant le prénom du nouvel abonné : "Bonjour %Prénom%".

Notez que le message de confirmation contient un lien qui ne doit pas être effacé : <a href="%SubscribeLink%">ici</a>. En effet, il contient les informations permettant à eMill d'identifier l'abonné et de confirmer son inscription.

Intégrez le formulaire d’abonnement sur votre site Internet

Cliquez sur ‘Suivant’

Il ne vous reste plus maintenant qu’à intégrer le formulaire d’abonnement que vous venez de créer sur votre site Internet. Pour cela, commencez par copier l’intégralité du code HTML inclus dans la fenêtre.

Ensuite, ouvrez dans un éditeur la page HTML de votre site où vous souhaitez intégrer le formulaire. Si vous utilisez un éditeur HTML WYSIWIG, passez en vue ‘Code’. Collez le code à l’endroit où vous souhaitez qu’il apparaisse.

Publiez votre page Internet afin qu’elle apparaisse en ligne.

Les règles de messages

Cliquez sur ‘Terminer’

Les règles de messages sont créées afin d’automatiser le traitement des abonnements et des désabonnements. Lorsque la fenêtre vous demandant si vous voulez publier le projet s’affiche, répondez ‘Oui’ afin de valider la création de ces règles.

Quand la boîte de dialogue de publication s’affiche, décochez les cases situées sous ‘Une fois le projet publié’, puis, sous ‘Abonnement aux files d’attente entrantes’, cochez la case correspondant à la file d’attente entrante créée au point 1.1.

Afin de vous fournir un peu plus de détails, voici en quoi consistent ces règles :

  • Abonnement : Comme nous vous l’avons expliqué plus haut, lorsqu’un visiteur de votre site soumet le formulaire d’abonnement, un e-mail contenant toutes les informations qu’il a renseignées est envoyé à l’adresse indiquée au point 1.1. La règle de message va permettre à eMill d’automatiquement télécharger cet e-mail et de mettre à jour votre liste avec les informations fournies par ce nouvel abonné.
  • Désabonnement : La gestion d’une liste d’abonnés implique un suivi rigoureux des désabonnements. Dans chaque newsletter que vous diffuserez, vous devrez insérer un lien permettant à l’abonné de se désinscrire. Pour insérer ce lien lors de la création de votre message dans eMill, utilisez simplement le menu Insertion > Lien de désabonnement.

    Lorsqu’un abonné utilisera ce lien pour se désinscrire, un e-mail contenant les informations sur cet abonné vous sera envoyé. La règle de message va permettre à eMill d’automatiquement télécharger cet e-mail et de mettre à jour votre liste en supprimant l’abonné.

Vous avez maintenant terminé la configuration d’eMill. La maintenance de la liste sera maintenant automatisée. Il ne vous reste plus qu’à créer et diffuser vos newsletters.

2. La création de règles de traitement des messages

Si vous disposez d’ores et déjà d’un formulaire d’abonnement ou si vous souhaitez le créer avec un autre outil qu’eMill, vous pouvez tout de même automatiser la gestion de votre liste d’abonnés. Notez tout de même que ce système peut uniquement être mis en place si les informations concernant un nouvel abonné ou un désabonnement sont envoyées par e-mail sur une de vos adresses.

Cette seconde étape du tutoriel va donc détailler la configuration des règles de traitement de messages. Elles vont permettre à eMill d’automatiquement télécharger les e-mails d’abonnement et de désabonnement et de mettre à jour votre liste avec les informations présentes dans l’e-mail.

Pour commencer, suivez les étapes décrites en 1.1 (files d’attente entrantes), 1.2 (nouveau projet) et 1.3 (nouvelle liste). Ensuite, pour démarrer la configuration des règles de message, rendez vous dans le menu Projet > Règles de message.

2.1 La définition des conditions de téléchargement

Si l’adresse e-mail utilisée pour recevoir les informations sur un nouvel abonné n’est pas exclusivement réservée à cet usage, vous devez définir des conditions de téléchargement afin d’éviter que tous les emails reçus à cette adresse soient téléchargés par eMill.

Cliquez sur l’onglet ‘Téléchargement’, cochez l’option ‘Tester les conditions suivantes’ et cliquez sur ‘Ajouter’.

En règle générale, afin de détecter qu’un email concerne un abonnement ou un désabonnement, nous utilisons des mots clés présents dans le sujet du message. Par exemple, un e-mail contenant les détails sur un nouvel abonné aura comme sujet ‘Formulaire d’abonnement’ et celui à propos d’un désabonnement aura comme sujet ‘Désabonnement’.

Dans la première fenêtre, sélectionnez donc l’option ‘Recherche des valeurs dans le sujet’.

Dans le champ ‘Critère’, sélectionnez ‘contient au moins un’ et entrez sous ‘Valeur(s)’ le texte : Abonnement, Désabonnement. Un e-mail sera donc téléchargé depuis votre boîte de réception uniquement si son sujet contient ‘Abonnement’ ou ‘Désabonnement’.

Cliquez sur ‘Terminer’

2.2 Le traitement des demandes d’abonnement

Cette étape consiste à configurer eMill pour qu’il puisse récupérer les informations sur le nouvel abonné contenues dans l’e-mail afin de mettre à jour la liste d’abonnés. Avant de détailler cette opération, il est important de préciser que :

  • Votre liste d’abonnés doit contenir une colonne pour chaque question posée dans le formulaire d’abonnement.
  • Le contenu de l’e-mail reçu doit être structuré de la façon suivante :

    Question du formulaire : Réponse de l’abonné
    (par ex, Nom : Dupont)

    Notez que le caractère ‘ :’ peut être remplacé par le caractère ‘=’. Si la réponse à une question du formulaire est écrite sur plusieurs lignes, elle doit être entourée par les caractères ‘«’ et ‘»’.

Cliquez sur l’onglet ‘Général’, cochez l’option ‘Appliquer les règles suivantes’ et cliquez sur ‘Ajouter’.

Conditions d’exécution de la règle de message

La première étape de création d’une règle de message consiste à définir la façon dont eMill va reconnaître le message à traiter. Comme nous l’avons fait plus haut (2.1), nous allons utiliser le terme ‘Abonnement’ contenu dans le sujet pour reconnaître l’email d’abonnement.

Cliquez sur le premier bouton ‘Ajouter’.

Sélectionnez l’option ‘Rechercher des valeurs dans le sujet’ et cliquez sur ‘Suivant’.

Dans le champ ‘Critère’, sélectionnez ‘contient au moins un’ et entrez sous ‘Valeur(s)’ le texte : Abonnement.

Cliquez sur ‘Terminer’

Règle de message

La deuxième étape consiste à définir l’action qui va être exécutée lorsqu’un message d’abonnement est détecté. Dans ce tutoriel, cette action va consister à utiliser les informations contenues dans l’e-mail reçu pour mettre à jour la liste d’abonnés.

Cliquez sur le deuxième bouton ‘Ajouter’.

Sélectionnez l’option ‘Ajouter un enregistrement à une source de données’ et cliquez sur ‘Suivant’.

Sélectionnez l’option ‘La liste des destinataires du projet’ puis la liste d’abonnés que vous avez créée au début de ce tutoriel.

La fenêtre suivante s’affiche :

A gauche, les colonnes de votre liste d’abonnés sont listées ; à droite, vous allez devoir indiquer à quelles valeurs contenues dans l’email correspondent chaque colonne.

Sélectionnez, par exemple, la colonne ‘E-mail’ et cliquez sur ‘Editer’.

Nous avons vu plus haut que dans le corps de l’e-mail reçu, l’information est présentée sous la forme suivante : Adresse email : Adresse E-mail de l’abonné

La colonne ‘E-mail’ va donc être mise à jour en utilisant le champ ‘Adresse email’ contenu dans le corps du message.

Sélectionnez dans la liste l’option ‘Champ dans le corps du message’ et écrivez à droite : Adresse email.

Cliquez sur ‘OK’ et répétez l’opération pour chaque information contenue dans l’e-mail.

Cliquez sur ‘Terminer’, puis ‘OK’.

2.3 Le traitement des demandes de désabonnements

Cette étape consiste à configurer eMill pour qu’il puisse détecter une demande de désabonnement, récupérer une information sur l’abonné et le supprimer de la liste d’abonnés. Dans cet exemple, nous allons prendre comme base que l’e-mail de désabonnement a comme sujet « Désabonnement AdresseEmailDeL’Abonné ». Ceci correspond au format d’e-mail que vous recevez si vous utilisez le lien de désabonnement créé par eMill.

Cliquez sur le bouton ‘Ajouter’

Conditions d’exécution de la règle de message

La première étape de création d’une règle de message consiste à définir la façon dont eMill va reconnaître le message à traiter. Comme nous l’avons fait plus haut (2.2), nous allons utiliser le terme ‘Désabonnement’ contenu dans le sujet pour reconnaître l’email de désabonnement.

Cliquez sur le premier bouton ‘Ajouter’.

Sélectionnez l’option ‘Rechercher des valeurs dans le sujet’ et cliquez sur ‘Suivant’.

Dans le champ ‘Critère’, sélectionnez ‘contient au moins un’ et entrez sous ‘Valeur(s)’ le texte : Désabonnement.

Cliquez sur ‘Terminer’

Règle de message

La deuxième étape consiste à définir l’action qui va être exécutée lorsqu’un message d’abonnement est détecté. Dans ce tutoriel, cette action va consister à supprimer le contact de la liste d’abonnés.

Cliquez sur le deuxième bouton ‘Ajouter’.

Sélectionnez l’option ‘Supprimer un enregistrement d’une source de données’ et cliquez sur ‘Suivant’.

Sélectionnez l’option ‘La liste des destinataires du projet’ puis la liste d’abonnés que vous avez créée au début de ce tutoriel.

La fenêtre suivante s’affiche :

Cette étape permet de préciser quel contact de la liste sera supprimé. Nous allons donc définir le fait que le contact supprimé est celui dont l’adresse e-mail est située dans le sujet.

Sélectionnez donc la colonne de votre liste d’abonnés contenant les adresses e-mails (ici, Email) et cliquez sur ‘Editer’.

Dans la dernière liste, sélectionnez l’option ‘Adresse email extraite du sujet’.

Cliquez sur ‘OK’, ‘Terminer’ puis ‘OK’

Vos demandes d’abonnement et de désabonnement seront maintenant traitées automatiquement. Veillez cependant à toujours vous abonner à la file d’attente entrante créée en début de tutoriel en cochant la case correspondante lors de la publication d’un projet.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Se connecter à une liste externe

La plateforme d'emailing permet de construire des connexions directes à la plupart des formats de bases de données et à certaines applications tierces. Cela vous permet de faire réellement interagir la solution d'emailing avec votre infrastructure existante dans le but d'optimiser l'efficacité de vos campagnes.

Vous trouverez dans cette section de la base de connaissances plusieurs articles et tutoriels qui vous aideront à vous connecter aux bases de données ou aux applications suivantes :

  • eMill OptIn Service : Service en ligne gratuit pour la gestion de listes d'abonnés.
  • Système pixi* : Application pour gérer le back-office d'un site e-commerce (stock, clients, catalogue de produits...).
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Connexion à un compte eMill OptIn Service

eMill OptIn Service est un service en ligne gratuit pour automatiser l'ensemble du processus de gestion d'une liste de diffusion :

  • Création d'un formulaire d'abonnement personnalisé
  • Gestion automatique des abonnements et des désabonnements
  • Support du procédé de double opt-in
  • Nombre illimité de listes et d'abonnés
  • Statistiques d'abonnement

Se connecter à son compte eMill OptIn Service

Si vous disposez d'un compte eMill OptIn Service, vous avez la possibilité de diffuser des campagnes d'e-mailing en utilisant vos listes eMill OptIn Service.

Pour connecter un projet d'emailing à votre compte eMill OptIn Service, voici les étapes à suivre :

  • Lancez l'assistant d'ajout d'une nouvelle liste
  • Sélectionnez l'option 'Liste d'abonnés eMill OptIn Service'
  • Entrez l'adresse email et le mot de passe de votre compte eMill OptIn Service
  • Sélectionnez la liste eMill OptIn Service que vous souhaitez utiliser
  • Sélectionnez les colonnes de la liste que vous souhaitez afficher dans votre projet

Vous avez maintenant construit une connexion directe entre la plateforme d'emailing et votre compte eMill OptIn Service. Cela signifie qu'à chaque fois qu'un abonné sera ajouté ou supprimé d'une liste eMill OptIn Service, les changements seront immédiatement répercutés dans votre projet d'e-mailing.

Notez que vous ne pouvez pas éditer une liste eMill OptIn Service à partir de la plateforme d'emailing. Si vous devez modifier un enregistrement, supprimer un contact ou changer la structure de la liste, vous devez vous connecter en ligne à votre compte eMill OptIn Service.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Se connecter à un système Pixi*

pixi* est un système de contrôle et de gestion des produits et des stocks pour les sites Internet marchands. Il permet de traiter, d'organiser et de superviser un magasin en ligne 24/7 partout dans le monde.

Grâce au partenariat mis en place avec l'éditeur de pixi*, MadGeniuses, la plateforme donne la possibilité de connecter directement un projet d'emailing à un système pixi*. Ainsi, vous élaborez des processus de communication réactifs, ciblés et efficaces.

Se connecter à un système pixi*

Avant de se connecter à pixi*, vous devez commander auprès de MadGeniuses le module 'API pixi*'. Vous recevrez avec ce module, l'URL, le nom d'utilisateur et le mot de passe à entrer pour vous connecter à votre système pixi*.

Ensuite, vous pouvez définir les filtres suivants afin de récupérer uniquement les données nécessaires à votre campagne. Pour activer un ou plusieurs filtres, cochez simplement la case appropriée :

  • Clients ayant passé commande aujourd'hui, hier, il y a une semaine, il y a un mois ou à une date spécifique.
  • Clients ayant été livrés aujourd'hui, hier, il y a une semaine, il y a un mois ou à une date spécifique.
  • Clients ayant commandé un article spécifique (entrez le numéro ou l'EAN de l'article).
  • Clients qui ont ou n'ont pas de factures impayées.
  • Clients qui ont ou n'ont pas des commandes non expédiées.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


La création d’emails à partir de flux RSS, ATOM ou RDF

Le thème de ce tutoriel peut paraître, au premier abord, un peu saugrenu. En effet, pourquoi envoyer le contenu de mes flux RSS par e-mail alors que des dizaines de services permettent de lire des flux RSS en instantané. N’est ce pas perdre tout l’intérêt des fils RSS que de l’envoyer par e-mail ?

Il est clair que l’utilisation de ces services représente la solution idéale, cependant, dans la réalité, de nombreuses entreprises proposant un abonnement à un fil RSS continuent de proposer également de recevoir des informations par e-mail afin d’informer le plus grand nombre de personnes, les accros du RSS et les autres qui restent encore nombreux.

L’objectif de ce tutoriel est donc de vous expliquer comment eMill va vous permettre de diffuser des e-mails dont le contenu sera dynamiquement créé en utilisant les flux RSS auxquels les destinataires sont abonnés. Notez que tout au long de ce tutoriel nous parlerons de flux RSS mais le principe est exactement le même pour des flux ATOM ou RDF.

1. Ouverture du projet guide

La création de ce type de projet fait appel à l’écriture de code avancé. Afin que cela reste accessible à tout le monde, un exemple de projet a été créé et va vous permettre de simplement copier/coller le code.

Ouvrez cet exemple, à partir du menu Fichier > Page de démarrage et cliquez sur l’exemple nommé ‘Fils RSS’ à la droite de la page de démarrage.

2. Créez un nouveau projet de mailing

A partir du menu Fichier > Nouveau, sélectionnez ‘Projet Mailing vierge’ et cliquez sur ‘OK’.

Entrez un nom et une description pour votre nouveau projet et cliquez sur ‘Terminer’.

3. Créez un contenu HTML

A partir du menu Projet > Ajouter un contenu, entrez un nom et une description pour votre nouveau contenu et cliquez sur ‘Suivant’.

Sélectionnez ‘Ajouter un nouveau contenu vide’, ‘Fichier HTML’ et cliquez sur ‘Suivant’.

Cliquez sur ‘Terminer’

Le nouveau contenu est maintenant affiché dans l’arborescence de votre projet sous ‘Contenus’.

4. Ajoutez votre liste de destinataires

A partir du menu Projet > Ajouter une liste de destinataires, entrez un nom pour votre nouvelle liste et cliquez sur ‘Suivant’.

Sélectionnez le type de source de données. Pour plus de détails sur les options correspondant aux différentes sources de données, veuillez vous reporter à la section d’aide appropriée.

Cliquez sur ‘Suivant’ puis ‘Terminer’

Note : La liste des destinataires doit inclure une colonne appelée ‘Fils’ et contenant l’adresse des flux RSS auxquels chaque destinataire est abonné. Pour ajouter une colonne à votre liste à partir d’eMill, rendez vous dans le menu Projet > Source de données > Ajouter une colonne.

Si un destinataire doit recevoir des informations provenant de plusieurs flux RSS, entrez les adresses à la suite dans cette colonne en les séparant par un point virgule.

5. Créez le contenu du message

Afin que le contenu du message soit conçu dynamiquement à partir des flux RSS indiqués dans la colonne ‘Fils’ de la liste de destinataires, il va vous falloir entrer du code appelé ‘VB Script’. Grâce au projet exemple ‘Fils RSS’, cette étape est simple à réaliser.

Basculer simplement dans le projet ‘Fils RSS’ et cliquez sur le contenu ‘CorpsHTML’ dans l’arborescence.

Passez en vue ‘HTML’ en cliquant sur le bouton ‘HTML’ au bas de l’éditeur.

Sélectionnez l’ensemble du code et rendez vous dans le menu Edition > Copier.

Basculez dans votre projet, cliquez sur le contenu que vous avez créé, passez en vue ‘HTML’ (bouton au bas de l’éditeur) et rendez vous dans le menu Edition > Coller.

Pour les utilisateurs avancés, n’hésitez pas à parcourir ce code afin d’éventuellement l’adapter à votre usage.

La création de ce projet est maintenant terminée. Afin de vérifier votre réalisation, cliquez sur ‘Aperçu’ dans l’arborescence du projet. Vous pouvez visualiser pour chaque destinataire le contenu dynamiquement créé en utilisant les flux RSS auxquels il est abonné.

6. Annexes

Annexe 1 : Modifier l’apparence du message.

Pour changer la façon dont est affiché le contenu du message, vous devez modifier le code CSS situé entre les balises <style> (ligne 461) et </style> (ligne 505).

Pour cela, cliquez sur le contenu à partir de l’arborescence du projet et basculez en vue ‘HTML’ (bouton au bas de l’éditeur).

Voici le détail de chaque élément du CSS :

  • body, table : Définit le type de police, la taille du texte et la couleur du texte utilisé par défaut dans l’e-mail.
  • table.header, table.footer, table.body : Définit le type, l’épaisseur et la couleur de la bordure entourant le titre et les articles du fils RSS.
  • table.header : Définit la couleur du titre du flux RSS.
  • td.headertext, td.footertext : Définit la position du titre du flux RSS et du pied de page s’il existe.
  • td.footertext : Centre le texte du pied de page s’il existe.
  • img : Définit l’absence de bordure autour des images de l’e-mail.
  • hr : Définit le style de la ligne séparant chaque article du flux RSS.
  • a : Définit le style d’un lien hypertexte.
  • a :hover : Définit le style d’un lien hypertexte lorsqu’il est survolé par la souris.
©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Guide des Scripts Serveur

eMill procure un environnement de script serveur qui permet de générer dynamiquement le contenu des emails. Cet environnement associe Windows Scripting Host (moteur de script VBScript) avec un langage de script serveur spécialisé pour les emails : l'Active Messaging Script (AMS).

AMS implémente des objets internes très similaires à ceux utilisés dans un langage de script très populaire pour le web : Microsoft© Active Server Page.

AMS est le langage utilisé pour accéder à la source de données dans le "script global" (fichier milset.vbs) et pour les appels de fonctions lors de la génération des contenus des emails ou des événements de l'expéditeur. Les fichiers HTML incorporant du script AMS peuvent aussi inclure du script client ainsi que des composants COM. AMS peut aussi être inclus dans des fichiers texte. Vous pouvez vérifier les mises à jour sur notre site web afin de bénéficier des dernières extensions et améliorations de ce langage de script innovant.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Introduction

Active Messaging Script (AMS) permet de créer facilement des applications de messagerie puissantes et hautement personnalisées. Puisqu'il a de nombreux points communs avec des langages de script courants, les débutants apprendront AMS de façon similaire. Les développeurs familiers avec l'ASP et Visual Basic maîtriseront immédiatement ce langage.

Pour les professionnels de l'Internet :

Les e-mails personnalisés deviennent un média efficace pour un nombre croissant de secteurs économiques. Facilité de déploiement, coût et diversité sont les facteurs clés pour le choix d'une solution d'e-mailing personnalisé.

En se connectant aux bases de données de l'entreprise, eMill offre un déploiement et un amortissement plus rapide, tout en supprimant les contraintes de duplication de données. Le langage Active Messaging Script associé, similaire aux langages de script les plus répandus, permet d'ajuster la personnalisation des mailings à l'évolution des besoins, facilement, progressivement et à un coût efficace. La communication par e-mails personnalisés peut maintenant être facilement planifiée, créée, envoyée et finement ajustée grâce à une application productive et son langage de script optimisé.

Les ressources de différents services peuvent participer efficacement à un projet de mailing sans nécessiter de nouvelles compétences ou de nouveaux outils. eMill permet d'utiliser des applications externes courantes, les fichiers pouvant être incorporés au projet dès qu'il est validé et publié.

Contrairement aux solutions de messagerie hébergées, eMill vous laisse un contrôle total sur vos données sensibles, s'adaptant à votre organisation et à votre système d'informations plutôt que le contraire. Quelle que soit l'importance de vos mailings, aucun matériel ou logiciel supplémentaire n'est nécessaire autre qu'une station Windows 2000 standard exécutant eMill et ses objets internes AMS.

Pour les services marketing et les relations clients :

Les services marketing savent qu'une utilisation opportune d'informations pertinentes est la condition de campagnes de promotions efficaces. Maintenir des relations avec les clients est une stratégie hautement rentable, mais qui nécessite un service client de qualité. Tout cela s'appuie sur les données de l'entreprise pour pouvoir individualiser la communication.

Avec AMS, chaque information devient un bien de communication. Les cycles de développement réduits vous permettent de créer et tester rapidement, de façon productive.

Les projets de mailing peuvent être entièrement créés avec eMill via tous ses éditeurs et assistants, ou être composés en équipes, les services marketing, les services publicitaires, les développeurs, les graphistes travaillant avec leurs applications habituelles.

Pour les développeurs Web, et les experts en script et base de données :

Si vous développez des applications Web à l'aide des scripts serveur ASP et de bases de données, eMill peut vous aider à mettre en place un service d'emails hautement personnalisés associé à un site Web en quelques heures.

Vous pouvez utiliser eMill pour envoyer des contenu Web personnalisés, incluant des sites Web entiers (documents lié par URL).

Vous pouvez utiliser eMill pour générer des reçus, des factures, des états de comptes ou n'importe quel contenu basé sur un profil utilisateur.

Connecter eMill à une une base de données de site web sur un inter/intra/extranet est fait en seulement quelques clics. AMS est extrêmement similaire à l'ASP, avec toutes les fonctions VBScript disponibles

Les scripts serveur et client peuvent être écrits depuis votre environnement de développement habituel et inclus plus tard aux fichiers de contenu fournis par les services marketing. Vous pouvez déboguer vos scripts AMS avec Visual InterDev ou Microsoft Script Debugger.

Utilisez l'Aperçu pour tester instantanément vos scripts serveur tels quel, et simuler le mailing en entier avant l'envoi.

Références Active Messaging Script :

  • Active Messaging Script: découvrez AMS en 10 étapes faciles.
  • Création d'un fichier avec script AMS: quels types de fichier peuvent inclure AMS et comment.
  • Travailler avec le langage: découvrez les bases du langage AMS.
  • Utiliser les variables et les constantes: introduction aux définitions de variables et de constantes AMS.
  • Utilisation des collections: comment accéder à un élément de collection.
  • Ecriture de procédures: comment écrire des procédure en AMS.
  • Interaction avec d'autres scripts: scripts serveur AMS qui créent et inter-agissent avec des scripts client JavaScript ou VBScript.
  • Envoi de contenus au client: comment le contenu est envoyé au client mail.
  • Accéder à la source de données: comment eMill utilise Microsoft ActiveX Data Objects (ADO) pour obtenir les informations d'une base de données. Façons supplémentaires d'accéder aux enregistrements de base de données sans ADO.
  • Debugging AMS: comment utiliser les débogueurs avec vos scripts.
  • Guide des Objets Script: description complète des objets AMS.

Apprendre AMS à partir d'autres langages : la plupart des commandes et objets AMS sont dérivés de l'ASP, disponible dans le MSDN Library, section Platform SDK Documentation/Web Services/Internet Information Services/Active Server Page Guide. Vous pouvez tout aussi bien utiliser le MSDN comme référence, souvenez-vous juste que AMS n'est pas utilisé dans un contexte web et ne nécessite pas IIS. Les autres différences entre AMS et ASP seront soulignées.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Active Messaging Script

Active Messaging Script (AMS) est un langage de script serveur, simple d'utilisation, qui fonctionne avec Windows Scripting Host (WSH). WSH est inclus dans toutes les configurations standard Windows 2000 (machine ou serveur).

Comment fonctionne l'interaction entre AMS, eMill et la source de données :

AMS a été développé spécialement pour générer facilement des emails dynamiques dans la plupart des configurations de base Win2K/NT (ex : pas besoin de serveur IIS). eMill utilise AMS pour combiner des contenus HTML ou TXT dont les script sont activés, avec des enregistrements de bases de données externes fournis par n'importe quelle base à laquelle il est connecté. Il vous permet ainsi de générer rapidement des emails de communication extrêmement personnalisés. Vous trouverez ci-dessous un exemple d'AMS qui devrait vous permettre de comprendre comment AMS, eMill, la source de données et les ressources système agissent les uns par rapport aux autres.

Ecrire un message promotionnel avec un contenu personnalisé :

Cet exemple illustre comment le contenu est associé à une base de données en utilisant une chaîne de connexion ADO et des requêtes SQL. La première étape consiste à créer une base de données avec votre application de base de données et à écrire le contenu du message avec l'éditeur d'eMill. Les scripts AMS sont ensuite insérés dans le contenu pour incorporer les enregistrements de la base, puis le script global est édité pour générer le contenu dans différents formats selon les préférences de l'utilisateur.

Étape 1 - La source de données : en utilisant votre base habituelle, créez un nouveau fichier avec une table "Contact" qui inclut les champs Email, Genre, Nom, Format et Montant. Pour plus de facilité nous avons créé un fichier "promotions.mdb" avec Access et nous l'avons sauvé sous "Mes Documents".
Entrez les enregistrements suivants :

eMill est conçu pour se connecter à des bases de données existantes, cependant si vous désirez créer une base spécifique à votre projet l'application créera un fichier par défaut "database.mdb" avec l'assistant projet. Dans ce cas il est recommandé, mais pas obligatoire, que Microsoft Access soit installé sur votre machine. Vous pouvez également utiliser une autre application pour créer votre base de données spécifique et la lier ensuite avec l'assistant projet. Toutes les modifications effectués ultérieurement sur les enregistrements dans la vue destinataires seront répercutées dans la base de données.

Étape 2 - Le Projet de Publipostage : lancez eMill et créez un nouveau projet. Nous l'appellerons "Promotions".
En créant le projet "Promotions", eMill génère un dossier "Promotions" dans le répertoire ..\eMill\Projets\. Des fichiers "Milset.vbs" et 'Promotions.mil' sont créés dans ce dossier.
  • Milset.vbs est le script global généré par eMill, il contrôle, entre autre, la récupération des enregistrements de données. Ce fichier est accessible dans l'éditeur de script global. Nous fournirons plus loin un exemple montrant comment personnaliser le script global..
  • Promotions.mil stocke les propriétés et les configurations du projet. Il peut être édité dans Notepad.
Étape 3 - Lier le projet à une base de données : Sélectionnez le format de base de données utilisé dans l'étape 1. Pour plus de détails, consultez la rubrique Ajouter une liste de destinataires. Dans notre exemple, nous avons sélectionné Microsoft Access puis le fichier "promotions.mdb" sous "Mes Documents".
L'application génère automatiquement la chaîne de connexion ADO pour la base de données "promotions.mdb". Vous pouvez retrouver cette chaîne dans le fichier "promotions.mil" :
Connection=Driver={Microsoft Access Driver (*.mdb)};Dbq=C:\Documents and Settings\dcb.HQ\My Documents
\specials.mdb;DefaultDir=C:\Documents and Settings\dcb.HQ\My Documents;ReadOnly=0;

Étape 4 - Champs associés : sélectionnez la table "Contact" qui contient les champs. Faites correspondre les champs adresses "email" et/ou "fax" (obligatoire), "Nom" (optionnel) et "Prénom" (optionnel) avec ceux de la base de données.
L'application génère automatiquement les requêtes SQL qui récupèrent les données. Vous pouvez retrouver les requêtes dans le fichier "promotions.mil"
ReceiversQuery=Select [Amount],[Email],[Format],[Gender],[Name] From [Contact]
ReceiversCountQuery=Select Count(*) From (Select [Amount],[Email],[Format],[Gender],[Name] From [Contact]) As SourceTable

Étape 5 - Créer le contenu : Deux contenus sont automatiquement créés par l'assistant. CorpsHtml.htm est le contenu Html et CorpsTexte.txt est le contenu texte alternatif. Ce dernier est créé au cas où le client mail d'un destinataire ne supporte pas les contenus Html. Dans l'éditeur de contenu, éditez le message html en utilisant le code qui suit.

Ce qui suit inclut des tags basiques HTML avec de l'AMS incorporé. Collez-le dans "CorpsHtml.htm" en mode source de l'éditeur html.

<HTML>
<HEAD>
<TITLE>Promotions</TITLE>
</HEAD>
<BODY>

<!--La commande script suivante vérifie la valeur du champ Genre provenant de la base, et fournit une expression de
remplacement si la valeur est EMPTY ou NULL-->
<% If CSafeStr(Record.fields("Genre")) = "" Then %>
Cher Client,<BR><BR>
Ce message pour vous informé que
<% Else %>
Cher <%= Record.Fields("Genre") & " " & Record.Fields("Nom") & ",<BR><BR>"%>
En tant que client privilégié,
<% End if %>

<!--Tous les destinataires recoivent cette partie du message-->
vous pouvez bénéficier de nos promotions exclusives <B>Membre du Club</B> sur tous les articles Hikers de la
collection hiver 2001.<BR><BR>
Découvrez les dernières créations de nos stylistes, tout est disponible dans notre
<A HREF="http://www.unlimitedhikers.tld">magasin</A>.<BR><BR>

<!--Une fonction VBScript est utilisée au sein des délimliteurs AMS pour générer la date-->
Dernières promos valables jusqu'au <% Response.Write FormatDateTime(DateAdd("d",30,Now), vbLongDate)%>,
n'attendez pas!<BR><BR>

<!--La commande AMS suivante vérifie dans l'enregistrement si le destinataire bénéficie d'un crédit
et affiche le montant, sinon, une remise de 30% est affichée-->
<% If CSafeStr(Record.Fields("Montant"))= "" Then %>
De plus, vous nous proposons une <B>remise supplémentaire de 30%</B> sur le
<A HREF="http://www.unlimitedhikers.tld/catalog.asp?stuff=old"> matériel de l'année dernière</A>.
<%
Else
        Dim Gift
        Gift = Fix(Record.fields("Montant"))
%>
Vous avez cumulé pour un montant de <% Response.write Gift& " Euros en <B>Points cadeaux</B>.<BR>" %>
<% End If %>

<BR><BR>
Nous espérons recevoir bientôt votre visite,<BR><BR>
Hikers Ltd.
</BODY>
</HTML>
Étape 6 - Voir les messages : sauvez tous les dossiers du projet et cliquez sur le noeud Aperçu. Utilisez les commandes de l'éditeur d'enregistrements pour afficher les messages générés.
L'aperçu affiche le message généré tel qu'il sera reçu par chaque destinataire. Si vous avez entré plusieurs enregistrements dans la base de données, vous pouvez faire défiler chacun des destinataires pour vérifier comment est généré chaque contenu de message.

Cher Monsieur Durant,

En tant que client privilégié, vous pouvez bénéficier de nos promotions exclusives Membre du Club sur tous les articles Hikers de la collection hiver 2001.

Découvrez les dernières créations de nos stylistes, tout est disponible dans notre magasin.

Dernières promos valables jusqu'au jeudi 25 juillet 2002, n'attendez pas!

De plus, vous nous proposons une remise supplémentaire de 30% sur le matériel de l'année dernière.

Nous espérons recevoir bientôt votre visite,

Hikers Ltd.

Cher Monsieur Martin,

En tant que client privilégié, vous pouvez bénéficier de nos promotions exclusives Membre du Club sur tous les articles Hikers de la collection hiver 2001.

Découvrez les dernières créations de nos stylistes, tout est disponible dans notre magasin.

Dernières promos valables jusqu'au jeudi 25 juillet 2002, n'attendez pas!

Vous avez cumulé pour un montant de 39 Euros en Points cadeaux.

Nous espérons recevoir bientôt votre visite,

Hikers Ltd.

Cher Client,

Ce message pour vous informé que vous pouvez bénéficier de nos promotions exclusives Membre du Club sur tous les articles Hikers de la collection hiver 2001.

Découvrez les dernières créations de nos stylistes, tout est disponible dans notre magasin.

Dernières promos valables jusqu'au jeudi 25 juillet 2002, n'attendez pas!

Vous avez cumulé pour un montant de 45 Euros en Points cadeaux.

Nous espérons recevoir bientôt votre visite,

Hikers Ltd.

Étape 7 - Ajout de scripts client : si le contenu du message envoyé est en HTML, il est possible d'ajouter des effets en utilisant des scripts client. Cependant, notez que les scripts client ne sont pas exécutés par le Script Host du serveur, mais sont envoyés en tant que tels et seront exécutés par le client. Par conséquent, il n'est pas recommandé d'utiliser des scripts client car vos messages auront de fortes chances d'être refusés par le client mail du destinataire (risque de virus inclut dans le script client).
Étape 8 - Formats alternés : dans les 2 étapes suivantes, nous allons examiner les valeurs du champ "Format" de la base de données et transmettre le contenu dans le format sélectionné par les destinataires.
Texte alterné : en créant un fichier contenu html avec eMill, un fichier texte équivalent est créé par défaut. La version texte est affichée si "texte uniquement" est activé dans les configurations du client. La version texte est encodée en tant que l'une des parties MIME du fichier email. Cependant certains destinataires peuvent préférer un format différent de celui qu'ils ont définis dans leur client. Il faut donc traiter les préférences de format du serveur avant de distribuer le contenu.

La première tâche consiste à créer les différents formats dans lesquels le contenu est proposé. Ensuite, il faut décider des conditions d'activation de chacun de ces contenus dans les propriétés du contenu.

  • A partir de l'option Projet / Ajouter un contenu, inscrivez Promotions dans le champ "Nom", cliquez sur Suivant et sélectionnez fichier texte sous "Ajouter un contenu vide". Cochez la case vous permettant d'afficher les propriétés du contenu et vérifiez que seule la case "exécuter les scripts inclus" est cochée.

  • Copiez et collez le code ci-dessous dans l'éditeur de texte :

<% If CSafeStr(Record.fields("Genre")) = "" Then %>
Cher Client,<BR><BR>
Ce message pour vous informé que
<% Else %>
Cher <%= Record.Fields("Genre") & " " & Record.Fields("Nom") & ",<BR><BR>"%>
En tant que client privilégié,
<% End if %>

Découvrez les dernières crétations de nos stylistes, tout est disponible dans notre <A HREF="http://www.unlimitedhikers.tld">magasin</A>.<BR><BR>

Dernières promos valables jusqu'au <% Response.Write FormatDateTime(DateAdd("d",30,Now), vbLongDate)%>, n'attendez pas!<BR><BR>

<% If CSafeStr(Record.Fields("Montant"))= "" Then %>
De plus, vous nous proposons une <B>remise supplémentaire de 30%</B> sur le <A HREF="http://www.unlimitedhikers.tld/catalog.asp?stuff=old">
matériel de l'année dernière</A>.
<%
Else
        Dim Gift
        Gift = Fix(Record.fields("Montant"))
%>
Vous avez cumulé pour un montant de <% Response.write Gift& " Euros en <B>Points cadeaux</B>.<BR>" %>
<% End If %>

<BR><BR>
Nous espérons recevoir bientôt votre visite,<BR>
Hikers Ltd.
http://www.unlimitedhikers.tld
  • Pour générer le fichier contenu en format PDF, sélectionnez Projet/Ajouter un contenu, inscrivez CorpsPDF dans le champ "Nom", cliquez sur Suivant et sélectionnez Ajouter un contenu à partir d'un fichier existant. Sélectionnez le fichier CorpsHtml.htm et cochez la case vous permettant d'afficher les propriétés du contenu. Les cases "exécuter les scripts inclus" et "convertir au format PDF" doivent être sélectionnées.

Vous disposez maintenant de 3 contenus : CorpsHTML (avec le corps Texte alternatif), Promotions et CorpsPDF.

Étape 9 - Configurer les conditions : il vous faut maintenant définir pour chacun des contenus dans quelles conditions ils seront activés.
Sélectionnez le premier contenu CorpsHTML dans l'arborescence de gauche et cliquez sur Affichage / Propriétés. Rendez vous dans l'onglet Conditions, cochez la case "Tester les conditions suivantes" et cliquez sur Ajouter. Complétez les 3 champs de la façon suivante :

- La première boîte liste l'ensemble des champs de la source de données. Sélectionnez donc le champ à tester c'est à dire le champ "Format".

- La deuxième boîte vous permet de décider du type de comparaison à appliquer. Sélectionnez "est égal à".

- La troisième boîte vous permet d'inscrire quelle valeur vous souhaitez retrouver dans le champ sélectionné. Inscrivez ici HTML.

Ainsi, le contenu CorpsHTML sera envoyé uniquement aux destinataires dont le champ "Format" est égal à HTML.

Il vous suffit maintenant de répéter cette opération pour :

- le contenu CorpsTexte. Etant donné qu'il est le texte alternatif du contenu HTML, il doit être activé dans les mêmes conditions que CorpsHtml.

- le contenu Promotions en indiquant qu'il doit être envoyé uniquement aux destinataires dont le champ "Format" est égal à TXT.

- le contenu CorpsPDF en indiquant qu'il doit être envoyé uniquement aux destinataires dont le champ "Format" est égal à PDF.

Étape 10 - Simulation : vous pouvez tester votre mailing en visualisant chaque fichier email individuellement comme nous l'avons fait à l'étape 6, ou bien, pour les gros volumes, en cochant l'option simulation de toutes les files d'attente activées.
La simulation est un bon moyen de tester la totalité du publipostage, y compris les adresses email des destinataires. Les fichiers email sont générés individuellement et la transmission est lancée pour chaque message : la session SMTP sera lancée et la commande RSET envoyée pour abandonner la transmission. Les messages apparaîtront comme envoyés dans les files d'attente, mais les destinataires ne recevront rien.
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Création d'un fichier avec script AMS

Un contenu avec script AMS activé est un fichier texte avec l'extension .htm ou .txt qui contient soit :

  • Du texte avec des scripts serveur
  • Du texte avec des tags HTML et des scripts serveur

Les scripts AMS sont entourés des délimiteurs <% et %> pour les différencier du reste du texte, de html ou des autres scripts clients. Si le contenu de l'e-mail ne contient aucun script, le serveur n'effectuera aucun traitement et générera le contenu au format MIME. Si des scripts sont inclus, le serveur exécutera les scripts dynamiquement et générera le texte ou html. L'exemple suivant, que vous pouvez essayer via la commande insérer un champ de la source de données est un script AMS inséré dans un contenu html qui retourne le prénom à partir du champ "Prénom" de la source de données, ou "Client" si la valeur de ce champ est vide ou nulle :

<HTML>
  <BODY>
  Dear <%=DefaultStr(Record.Fields("Prenom"),"Client")%>,
  </BODY>
</HTML>

Dans tous les cas, le client recevra uniquement les parties MIME d'un message qui sont des contenus texte ou html encodés. Les scripts serveur ne sont pas envoyés, mais utilisés dynamiquement par le serveur pour générer une partie ou la totalité du contenu texte ou html.

Insertion de script :

Pour insérer des scripts serveur dans un fichier html, basculez dans le mode source de l'éditeur html et tapez votre script à l'intérieur de la source du document en utilisant la même syntaxe qu'en ASP. Vous pouvez aussi utiliser un éditeur html externe et utiliser la commande créer un nouveau contenu à partir d'un fichier pour lier votre fichier au projet.

Pour insérer des scripts dans un fichiers texte, utilisez l'éditeur texte d'eMill ou n'importe quel autre éditeur texte et différenciez le script du contenu en l'entourant des délimiteurs <% et %>.

Note : les scripts serveur peuvent être écrits séparément du contenu et insérés ensuite dans le contenu au point d'insertion. Les délimiteurs seront alors correctement générés autour du script en fonction du type de script (script serveur ou script client).

Exécuter les scripts inclus : assurez-vous que cette option est bien cochée dans les propriétés du contenu à chaque fois que vous insérez des scripts serveur. Cela signale au serveur qu'il y a des scripts serveur dans le document.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Travailler avec le langage

eMill n'autorise qu'un seul langage de script serveur dans les fichiers contenu : Active Messaging Script (AMS). Il n'y a pas de notion de langage de script primaire ou secondaire, le langage de script par défaut entouré des délimiteurs <% et %> est l'Active Messaging Script. Cependant, vous pouvez spécifier le langage des scripts client que vous insérez (typiquement JavaScript ou VBScript).

Commande de script serveur :

Les commandes entourées des délimiteurs <% et %> doivent être des commandes AMS valides. Toutes les fonctions VBScript sont des commandes valides pour l'Active Messaging Script. Vous trouverez une documentation de ces fonctions dans la section "Platform SDK Documentation/Tools and Scripting" du MSDN. La commande script suivante vous montre comment la fonction now() inclue dans un contenu html retourne la date et l'heure courante, et comment eMill l'utilise pour dater le message. Notez que les délimiteurs utilisés sont ceux d'AMS :

<HTML>
  <BODY>
  Cet e-mail a été généré le <%= Now() %>.
  </BODY>
</HTML>

Mélanger contenu et commandes scripts :

Vous pouvez inclure déclarations, expressions, procédures ou opérateurs entre les délimiteurs <% et %>. Vous pouvez aussi alterner contenus et scripts. L'instruction conditionnelle If...Then...Else... peut être utilisée avec AMS comme dans l'exemple suivant :

<% If CSafeStr(Record.Fields("Genre"))="" Then %>
    Cher(e) Client(e)
<% ElseIf Record.Fields("Genre") = "M." %>
    Cher M. <%= Record.LastName %>
<% Else %>
    Chère <%=Record.Fields("Genre") & " " & Record.LastName %>
<% End If %>

Ce script AMS fonctionne aussi bien dans un fichier html que texte, et retournera "Cher(e) Client(e)" si le champ de source de données "Genre" est vide ou nul. Il retournerait "Cher M. Martin" si le champ "Genre" contenait la valeur "M.", "Chère Mme Roux" ou "Chère Mlle Ferrier" sinon.

CSafeStr : retournera un chaîne vide si la valeur du champ de source de données est vide ou nulle.
Record.Fields : utilisé pour accéder aux valeurs du champ "Genre" de la source de donnée.
Record.LastName : utilisé pour accéder au champ générique "prénom", qui a été associé à un champ de la source de données durant la connexion à la base de données.

Génération du contenu par les scripts serveur :

Plutôt que d'alterner commandes script et contenu, vous pouvez aussi retourner le contenu directement depuis un script en utilisant un objet interne d'AMS : Response.

<%
Dim FirstLine
If CSafeStr(Record.Fields("Prenom"))="" Then
   Response.Write "Cher(e) Client(e)," & vbCrLf
Else
   FirstLine = "Cher(e)" & " " & Record.Fields("Prenom") & " " & Record.Fields("Nom") & "," & vbCrLf
   Response.Write FirstLine
End if
%>

Ce script peut être utilisé pour générer la première ligne (FirstLine) d'un contenu texte ou html (format indifférent). Ce script est très similaire à un script ASP qui serait utilisé dans un contexte web. Nous avons déclaré une variable "FirstLine" qui reçoit les valeurs des champs de la base de données. La chaîne "Cher(e) Client(e)' est substituée à la première ligne personnalisée si un problème apparaît avec le champ "Prénom" de la base de données (valeur vide ou nulle). Notez que si nous étions sûr que le contenu soit au format html, nous aurions pu retourner des tags html avec la commande Response.Write en les insérant entre guillemets (ex.: Response.Write "Cher(e) Client(e),<BR>", au lien d'utiliser la commande vbCrLf).

Caractères blancs dans les scripts :

AMS enlève les caractères blancs des commandes inclues dans les fichiers de contenu. Pour d'autres langages de script client que vous pouvez inclure, les caractères blancs seront préservés. Les langages dépendants des positions et indentations resteront ainsi correctement interprétés. Les caractères blancs incluent les espaces, tabulations, retours chariots. Les commandes AMS suivantes produisent toutes les même résultat :

<% Response.Write "Bonjour" %>

<%Response.Write"Bonjour"%>

<%
Response.Write "Bonjour"
%>

Commentaires AMS :

AMS étant traité sur le serveur, il n'y a pas besoin d'inclure des tags de commentaires pour cacher les scripts aux clients mails ne les supportant pas. Toutes les commandes AMS sont traitées avant que les contenus soient envoyés.

Les commentaires après une apostrophe sont supportés par AMS, même dans une expression de sorti.

<%= Now() 'Tout ce qui suit cette apostrophe est en commentaire %>
Sensibilité à la casse : AMS n'est pas sensible à la casse. Par exemple, vous pouvez utiliser aussi bien Record.Fields que record.fields pour accéder à la collection Fields de l'object record.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Utiliser les variables et les constantes

Une variable est un emplacement de stockage nommé, résidant dans la mémoire de l'ordinateur, qui contient une donnée telle que du texte ou un nombre. La donnée contenue dans la variable est appelée valeur de la variable. Les variables vous permettent de stocker, récupérer et manipuler des valeurs en utilisant des noms qui vous aideront à comprendre ce que fait le script.

Déclaration et nommage des variables :

Même si vous n'êtes pas obligé de déclarer les variable en VBScript avant de les utiliser, c'est toutefois une bonne habitude car cela aide à éviter des erreurs. Déclarer une variable informe le moteur de script qu'une variable avec un nom particulier existe et que vous pouvez donc utiliser des références à cette variable dans le script. Pour déclarer une variable en VBScript, utilisez les instructions Dim, Public, ou Private. Par exemple :

<% Dim RenderDate %>

Vous pouvez utiliser l'instruction VBScript Option Explicit afin de rendre la déclaration des variables obligatoire via les instructions Dim, Private, Public, et ReDim. L'instruction Option Explicit doit apparaître avant tout texte, contenu html ou commande script. Cette instruction affecte seulement les commandes AMS écrites en VBScript.

<% Option Explicit %>
<HTML>
<BODY>
.
.
<%
  Dim RenderDate
  RenderDate = Date ' La date du message à été stockée.
%>
.
.
Rapport d'activité du <%= RenderDate %>
.
</BODY>
</HTML>

Pour plus d'informations sur ces commandes, voyez les références du langage VBScript, que vous pourrez trouver sur le site Microsoft Windows Script Technologies.

Portée des variables :

La portée, ou durée de vie d'une variable détermine quelles commandes script peuvent accéder à cette variable. Les variables en AMS sont déclarées à l'intérieur des fichiers de contenu et peuvent être utilisées par toutes les commandes à l'intérieur du contenu. Il n'y a pas de notion de portée globale, ou de variables ayant une durée de vie dépassant l'exécution du script à l'intérieur du fichier de contenu. Cependant, si vous utilisez des procédures externes (fichiers script appelés depuis le script par la méthode Server.Execute), toutes les déclarations dans ces procédures externes s'appliquent aussi aux scripts du contenu situés après la commande Server.Execute.

Portée d'application et de session :

Nous avons vu ci-dessus que les variables sont accessibles uniquement dans le fichier de contenu. Pour que ces variables soient accessibles au delà du contenu, vous pouvez leur donner une portée d'application ou de session. Les variables avec une portée de session sont accessibles durant la génération de tous les contenus pour un destinataire donné. La session doit ici être comprise comme la période nécessaire au serveur pour générer tous les contenus formant un e-mail. Les variables avec une portée d'application sont accessibles à toutes les sessions du mailing. Les variables d'application peuvent être utilisées pour stocker des informations sur tous les destinataires, telles que des salutations spécifiques ou des valeurs générales utilisées par tout le mailing.

AMS fourni deux objets internes dans lesquels vous pouvez stocker des variables : l'ojet Session et l'ojet Application.

Portée de session :

Pour donner à une variable une portée de session, stockez-la dans l'objet Session en assignant sa valeur à une entrée nommée de l'objet. Par exemple, vous pouvez marquer chaque attachement d'un message multi-part en créant n contenus et en les incluant au projet de mailing :

<HTML>
<BODY>
<-!
Ceci est un des n attachements faisant parti d'un même message
Le numéro de cet attachement est déterminé part son ordre de génération
Cet ordre peut être modifiée dans la fenêtre des propriétés du
contenu d'eMill
-!>
.
.
<%
  Dim i
  i = Session("AttachmentCount")
  Response.Write "Attachement # " & i & " / " & Session("TotalAttachmentCount")
  i = i+1
  Session("AttachmentCount") = i
%>
</BODY>
</HTML>

Le script global du projet peut être personnalisé de la façon suivante :

Sub Mail_OnStartRender()
  Session("TotalAttachmentCount") = Mail.Contents.Count
  Session("AttachmentCount") = 1
End Sub

Nous avons initialisé AttachmentCount au début de la génération de chaque message avec l'événement Mail_OnStartRender. Le nombre total d'attachements a été assigné à TotalAttachmentCount pour chaque destinataire en utilisant la collection Contents de l'objet Mail. A l'intérieur de chaque contenu, nous avons inclus un script utilisant un compteur, qui récupère le compte depuis l'objet Session et qui l'écrit avec la directive Response.Write.

Portée d'application :

Pour donner à une variable une portée d'application, stockez-la dans l'objet Application en assignant sa valeur à une entrée nommée de l'objet. Par exemple, les commandes suivantes stockent la date et le nombre de destinataires dans l'object application au début de la génération du mailing (en utilisant l'événement Mailing_OnStartRender). La variable i a été déclarée en haut du script global. La méthode DataSource_GetRowCount retourne le nombre total de destinataires, étant donnée que l'adresse e-mail est un champ de la source de données obligatoire.

'(Déclarations)
Option Explicit
Dim rst
Dim i
'Fin de (Déclarations)

Sub Mailing_OnStartRender()
  Application("DistributionNumber") = DataSource_GetRowCount()
  i = Date
  Application("NewsletterDate") = i
End Sub

Pour récupérer les information depuis l'objet Application, vous pouvez utiliser la directive de sortie Response.Write dans le script du contenu.

<%
<HTML>
<BODY>
.
.
<%
  Response.Write "Date d'édition " & Application("NewsletterDate") & ", distribution " & Application("DistributionNumber")
%>
</BODY>
</HTML>

Nous aurions pu arriver au même résultat sans utiliser la variable i : Application("NewsletterDate") = Date. Notez que les variables utilisées dans le script global et celles utilisées dans les scripts des contenus doivent chacune être déclarées. Leur durée de vie s'achève à la fin de l'exécution de chaque script.

Utilisation des constantes :

Une constante est un nom qui remplace un nombre ou une chaîne. Certains componsants livrés avec Windows, tel ActiveX Data Objects (ADO), définissent des constantes que vous pouvez utiliser dans vos scripts. Par exemple, le fichier de définition des constantes ADO adovbs.inc stocke les valeurs des types de curseur que vous pouvez utiliser avec un object Recordset. Ce fichier se trouve habituellement dans le dossier Program Files de votre ordinateur.

L'exemple suivant place le nom, la position et l'adresse e-mail de tous les destinataires au début de chaque message. Si vous souhaitez essayer cet exemple, vous devez créer une base de données au projet avec les champs Prénom, Nom, Position et Email dans une table Contact. Le but du script de ce contenu est d'ouvrir une connexion avec la source de données et d'en récupérer les enregistrements. Le type de curseur adOpenDynamic permet tout type de mouvement dans le recorset, tandis que la valeur adLockOptimistic bloque les enregistrements de la source de données quand la méthode update est appelée. Ces deux valeurs sont définies dans le fichier adovbs.inc et sont incluses via la méthode Server.Execute.

<HTML>
<BODY>

<%
  Dim Connect 'la connexion
  Dim rst 'le recordset

  'Inclu la définition des constantes
  Server.Execute "C:\Program Files\Common Files\System\ado\adovbs.inc"

  'Crée et ouvre la connexion
  Set Connect = Server.CreateObject("ADODB.Connection")
  Connect.Open Mailing.connectString

  'Crée et ouvre le recordset
  Set rst = Server.CreateObject("ADODB.Recordset")
  rst.Open "SELECT * FROM Contact", Connect, adOpenDynamic, adLockOptimistic

  Response.Write "Ce rapport d'activité a été envoyé à :<BR>"
  If Not rst.BOF Then
    Do
      Response.Write rst.Fields("Prenom") & " " & rst.Fields("Nom") & ", "
      Response.Write rst.Fields("Position") & ", " & "<A HREF=mailto:" & Chr(34)
      Response.Write rst.Fields("Email")& Chr(34) & ">"& rst.Fields("Email") & "</A>, "
      rst.MoveNext
    Loop While Not rst.EOF
  End If

  'Ferme le recordset et la connexion
  rst.close
  Connect.Close

  'Détruit les objets
  Set rst = nothing
  Set Connect = nothing
%>
</BODY>
</HTML>
Vous ne pouvez pas déclarer de bibliothèque de type, des DLL ni des UUID en utilisant le tag html <METADATA> comme vous le feriez en ASP. Vous devez utiliser la méthode Server.Execute avec le fichier de définition des constantes, comme illustré ci-dessus.
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Utilisation des collections

Plusieurs objets AMS internes exposent des collections : Mail, Record, Application, Request, et Session.

Les collections sont des structures de données que vous pouvez utiliser pour stocker des valeurs telles que du texte ou des nombres. Contrairement aux tableaux qui ont des dimensions fixes, les collections s'agrandissent ou se réduisent automatiquement lorsque des élements sont ajoutés ou retirés. L'accès aux éléments de la collection peut se faire soit par l'index (numéro de la position, à partir de 0), soit en énumérant tous les éléments, soit en spécifiant le nom de la clé identifiant l'élément.

Utilisation d'une collection d'un objet :

Les collections peuvent être utilisées efficacement pour partager des informations au cours d'une session (le processus de génération pour un message individuel), ou au cours d'une génération complète de tous les messages. L'exemple suivant montre un script dans l'événement Mailing_OnStartRender() qui fournit des informations à tous les destinataires grâce à la collection Contents de l'objet Application :

Sub Mailing_OnStartRender()
  Application.Contents("DataStamp") = Now()
End Sub

Utilisé avec les commandes script dans le contenu :

.
.
Les informations ci-dessus ont été rassemblées depuis une base de données à exactement <%=Application.Contents("DataStamp")%>
.
.

Vous n'êtes pas tenu de spécifier le nom de la collection si c'est la collection par défaut de l'objet. La commande ci-dessous fonctionne aussi :

<%= Application("DataStamp") %>

Eliminer le nom de la collection pour accéder aux éléments stockés dans les objets Application ou Session est sûr, car ces objets ne possèdent que la collection par défaut Contents.

Accéder à un élément de collection par clé, par index ou par énumération :

Vous pouvez accéder à un élément d'une collection en le référençant par son nom unique (clé). Par exemple, la collection Fields de l'objet Record garde les valeurs (variants) des champs obtenus via la chaîne de connexion ADO et les requêtes SQL de votre projet.

Supposons que vous avez lié votre projet à une base de données et que le premier et second champ optenus soient Prénom et Nom. Vous pourrez retourner pour chaque message généré (et pour chaque exécution de script) la valeur de ces champs en utilisant les commandes script suivantes :

Prénom : <%= Record.Fields("Prenom")%>
Nom : <%= Record.Fields("Nom")%>

Vous pouvez aussi générer les même valeurs en utilisant une notation par index :

Prénom : <%= Record.Fields(0)%>
Nom : <%= Record.Fields(1)%>

Cependant, l'index associé à un élément peut changer si des éléments sont ajoutés ou retirés de la collection. Les accès indexés ne devraient être utilisés que lors d'énumération de la collection. Voici un exemple utilisant les collections Tos de l'objet Mail.

Ce message a été envoyé à :<BR>
<%
  Dim key

  For Each key In Mail.Tos
    Response.Write(Server.HTMLEncode(Mail.Tos(key))) & "<BR>"
  Next
%>

Les collections AMS supportent la propriété Count, qui retourne leur nombre d'éléments. Vous pouvez utiliser cette propriété pour connaître l'index du dernier élément de la collection.

<%
  Dim i

  For i = 0 to Mail.Tos.Count-1
    Response.Write(Server.HTMLEncode(Mail.Tos(i))) & "<BR>"
  Next
%>

Notez que l'énumération se fait de l'index 0 (première position dans une collection AMS) à Count-1.

Note : pour tous les objet AMS comportant plusieurs collections, vous devez spécifier le nom de la collection. C'est une différence avec ASP qui vous permet d'accéder à un élément d'une collection sans nécessairement spécifier dans quelle collection.
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Ecriture de procédures

Une procédure est un groupe de commandes AMS qui exécute une tâche spécifique et qui peut retourner une valeur. Vous pouvez inclure des procédures dans le contenu ou définir des procédures extérieures dans un fichier que vous pourrez appeler répétitivement en utilisant Server.Execute ou Server.Transfer. Notez que la directive #include utilisée en ASP pour inclure des procédures extérieures n'est pas implémentée dans AMS.

Définir les procédures :

Les procédures à l'intérieur des contenus peuvent uniquement être inclues entre les délimiteurs AMS (<% and %>). Vous ne pouvez pas spécifier d'autre langage de script serveur. Par exemple, l'attribut RUNAT=SERVER à l'intérieur d'un tag <SCRIPT> doit être évité. Ce type de tag ne peut être utilisé que pour des langages client.

Dans l'exemple suivant, nous assignons la valeur d'un champ de la source de données à une variable en utilisant l'objet Record (lorsque les champs sont obtenus via la chaîne de connexon du projet), et en créant un objet RecordSet additionnel (pour les champs de la base de données non optenus par la chaîne de connection du projet).

<%
' assigne la valeur des champs optenus par la chaîne de connection du projet
sName = Record.Fields("FirstName") & " " & Record.Fields("LastName")
lContactID = Record.Fields("ContactID")

' Création d'un nouveau recordet
Set rst = CreateObject("ADODB.Recordset")
rst.Open "SELECT Number, AccountID FROM Account WHERE Account.ContactID=" & lContactID, Mailing.ConnectString

' test des valeurs du recorset
If rst.BOF Then
  Response.Write "No accounting info available for this recipient"
  Response.End
  fRender = False

' Assigne les valeurs des champs obtenus
Else
  sAccountNum = rst.Fields("Number")
  lAccountID = rst.Fields("AccountID")
  rst.Close
  Set rst = Nothing
  Set rst = CreateObject("ADODB.Recordset")
  rst.Open "SELECT * FROM Operation WHERE AccountID=" & lAccountID & " ORDER BY Date", Mailing.ConnectString
  fRender = True
End If
%>

Evitez d'utiliser des commandes script dans les procédures qui ne font pas totalement partie de ces procédures. Ces commandes peuvent causer des résultats imprévisibles. De plus, vous ne pouvez pas utiliser la directive de sortie <%= %> dans une procédure (pour les commandes de script seulement). Utilisez à la place Response.Write pour générer du contenu.

Appeler des procédures externes :

Vous pouvez organiser vos scripts en écrivant un ensemble de procédures qui peuvent soit être inclues dans le fichier de contenu, soit sauvées à part dans un fichier .vbs. Utilisez des procédures extérieures aide beaucoup si vous utlisez des scripts identiques pour plusieurs mailing. Notez que toutes les procédures doivent être écrites en VBScript, incluant optionnellement des objets AMS. Vous ne pouvez pas par exemple appeler de procédures JScript.

L'exemple suivant montre une procédure inclue dans le contenu en utilisant la définition sub. Nous supposerons que le projet est lié à une base de données relatitionnelle client, qui procure les informations sur le constructeur et le modèle des véhicules :

<HTML>
<BODY>
.
.
<%
' assigne des valeurs constantes par modèles
Const WRANGLER = 1
Const CHEROKEE = 2
Const LIBERTY = 4
Const GD CHEROKEE = 8

' connexion  à la base de données client
Sub GetCustomerModel
  Dim rsModel
  Set rsModel = CreateObject("ADODB.Recordset")
  rsModel.Open "SELECT Products.* " &_
    "FROM Products, ContactProducts " &_
    "WHERE ContactProducts.ContactID = " & Record.Fields("ContactID") & " " &_
    "AND Products.ProductID = ContactProducts.ProductID;",_
    Mailing.ConnectString,3,3

  'Récupère le(s) modèle(s) du client
  Session("CustomerModel") = 0
  Session("ModelHave") = ""
  If Not rsModel.BOF Then
    Do
      Select Case rsModel.Fields("Reference")
        Case "W-SE", "W-SPORT", "W-SAHARA"
          Session("CustomerModel") = Session("ModelHave") + WRANGLER
          If Session("CustomerModel") = "" Then
            Session("ModelHave") = "Jeep Wrangler"
          Else
            Session("ModelHave") = Session("ModelHave") + ", Jeep Wrangler"
          End If
        Case "C-SPORT", "C-LIMITED"
          Session("CustomerModel") = Session("ModelHave") + CHEROKEE
          If Session("CustomerModel") = "" Then
            Session("ModelHave") = "Jeep Cherokee"
          Else
            Session("ModelHave") = Session("ModelHave") + ", Jeep Cherokee"
          End If
        Case "L-SPORT", "L-LIMITED"
          Session("CustomerModel") = Session("ModelHave") + LIBERTY
          If Session("CustomerModel") = "" Then
            Session("ModelHave") = "Jeep Liberty"
          Else
            Session("ModelHave") = Session("ModelHave") + ", Jeep Liberty"
          End If
        Case "G-LAREDO", "G-LIMITED", "G-OVERLAND"
          Session("CustomerModel") = Session("ModelHave") + GD CHEROKEE
          If Session("CustomerModel") = "" Then
            Session("ModelHave") = "Jeep Grand Cherokee"
          Else
            Session("ModelHave") = Session("ModelHave") + ", Jeep Grand Cherokee"
          End If
       End Select
       rsModel.MoveNext
       Loop While Not rsModel.EOF
     End If
  rsModel.Close
  Set rsModel = Nothing
End Sub
%>
.
.
<%
  'Crée un contenu personnalisé en appelant une procédure externe
  Server.Execute("specials.vbs?CustomerModel=" & Session("CustomerModel"))
%>
.
.
</BODY>
</HTML>

La procédure externe est de préférence un fichier VBScript avec des objets AMS inclus. Dans cet exemple particulier, nous utiliserons un fichier (specials.vbs, appelé dans le script ci-dessus) qui inclut de l'html et des scripts.

<!-- Ceci est un fragment de code html. Enlevez les tags <HTML> et <BODY> si ce fichier à été crée dans un éditeur html -->
<DIV ALIGN=CENTER>
<TABLE BORDER="0" WIDTH="480" CELLSPACING="1" CELLPADDING="0">
.
.
<%
  'check if customer owns a CHEROKEE, if so, render the following html
  If (Request.QueryString("CustomerModel") And CHEROKEE)=0 Then
%>
<!-- Time to change your rig! Run LIBERTY ad, include URLs to specials on a webserver, etc. -->
<TR>
  <TD>
  .
  .
  </TD>
</TR>
<%
  End If
  'check if customer owns a WRANGLER, if so, render the following html
  If (Request.QueryString("CustomerModel") And WRANGLER)=0 Then
%>
<!-- Recall: Fuel gauge needs fix. Include URLs to MOPAR accessories, etc. -->
<TR>
  <TD>
  .
  .
  </TD>
</TR>
<%
.
.
<% End If %>
.
.
</TABLE>
</DIV>

Passer un tableau aux procédures :

Vous pouvez utiliser des tableaux à l'intérieur de vos scripts comme vous le feriez avec VBScript. Cependant, il est préférable avec AMS d'utiliser des collections. L'exemple qui suit utilise des tableaux.

<%
'retrieve highest and lowest license price from the database
  Function GetPrice(sSize)
    Dim rsPrice
    Set rsPrice = CreateObject("ADODB.Recordset")
    rsPrice.Open "SELECT * FROM Table1 WHERE SIZE = '" & sSize  & "';",_
      Mailing.ConnectString, 3, 3
    If Not rsPrice.BOF Then
      GetPrice = rsPrice.Fields("PRICE")
    Else
      GetPrice = 0
    End If
    rsPrice.Close
  End Function

' make array to store highest and lowest price on article
Dim aDress(2)
aDress(0) = GetPrice("SIZE-S")
aDress(1) = GetPrice("SIZE-XL")
%>
.
.
From $<%=CCur(aDress(0))%> (size S) to $<%=CCur(aDress(1))%> (size XL) only!
.
.
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Interaction avec d'autres scriptss

Interaction avec d'autres scripts

AMS est le langage serveur primaire et ne permet pas à d'autres langages serveur de s'exécuter simultanément sur eMill. Vous pouvez cependant générer et manipuler des scripts client avec AMS si le contenu que vous envoyez est au format html. Faites attention cependant, il n'est pas garantie que ces scripts s'exécuteront correctement sur le client e-mail des destinataires, car tous les clients e-mail ne supportent pas les script clients.

Vous pouvez écrire des scripts serveur qui assemblent des script clients, par exemple en alternant des instructions AMS à l'intérieur de scripts client :

<HTML>
<BODY>
<SCRIPT language=JavaScript>
i = "<%=Record.Fields("Prenom")%>";
document.write("Bonjour ");

if (i == "")
   document.write(" tout le monde !");
else
   document.write(i);

</SCRIPT>
</HTML>
</BODY>

Vous pouvez aussi utiliser Response.Write pour générer le script client :

<HTML>
<BODY>
<SCRIPT language=JavaScript>
document.write("Bonjour <%

If CSafeStr(Record.Fields("Prenom"))="" Then
   Response.Write "tout le monde"
Else
   Response.Write Record.Fields("Prenom")
End If

%> !");

</SCRIPT>
</HTML>
</BODY>
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Envoi de contenus au client

AMS est utilisé pour générer dynamiquement des contenus texte ou html qui sont ensuite transformés dans un format que reconnaissent les client e-mail : le format MIME (Multipurpose Internet Mail Extensions). La différence majeure avec l'ASP est que le résultat final est encodé pour être affiché dans les clients mail. Notez que même si vous envoyez un message avec contenu html, le client mail nécessite que cet html soit encodé au format MIME pour l'afficher correctement.

Fichier email et parties MIME :

Un fichier email (EML) est constitué de plusieurs parties MIME, séparées par des bornes (boundaries). Ces bornes définissent les limites de tous les fichiers et ressources constituant le message. Par exemple, un message html avec des images sera généré avec des bornes séparant la partie html (document maître) des images inclues (parties composantes). Les références aux parties composants depuis le document maître sont faites avec des cid: (identifiant de contenu ou Content-ID). Ce schéma suppose que toutes les parties sont dans le message.

Bornes et identifiants de contenu sont créés lors de la génération du message, et ces valeurs sont supposées uniques.

Vous pouvez voir toutes les parties du fichier email encodé en MIME depuis l'Aperçu, en sélectionnant source.

Les en-têtes du message sont toujours générées en première partie de l'email. Les clients mail utilisent ces différents tags pour afficher l'expéditeur, le sujet du message, la date ainsi que d'autres informations. Voici un exemple d'en-tête classique:

X-Receiver: postmaster@emilltest.com
X-Sender: postmaster@emilltest.com
From: postmaster@emilltest.com
X-Priority: 3
Date: Mon, 17 Dec 01 16:22:39 +0100
Mime-Version: 1.0
To: vince@emilltest.net
Content-Type: multipart/mixed;

Les messages incluent plusieurs fichiers de contenu qui sont encodés dans le même email et assignées à un unique Content-ID. Chaque part apporte des en-têtes supplémentaires qui aident à déterminer l'application nécessaire pour visualiser le contenu, à savoir quel encodage à été utilisé ou comment le contenu doit être présenté au client. Par exemple :

Content-Disposition: inline; filename="CorpsHtml.htm"
Content-Transfer-Encoding: 7bit
Content-Type: text/html; charset=iso-8859-1
X-Content-Name: CorpsHtml

La position de la part MIME détermine l'ordre d'affichage du contenu dans le client mail. La position peut être changée depuis l'application eMill. Le contenu corps du message est toujours affiché en premier. Vous pouvez préciser que le contenu est le corps du message depuis la boîte de dialogue Propriétés du contenu. Le tag Content-Disposition vous laisse le contrôle sur la disposition de chaque contenu dans le message (inline ou attachment), et est modifiable depuis la même boîte de dialogue. Les contenus par défaut CorpsHtml et CorpsTexte ont la propriété "corps du message" activée par défaut. Si vous désactivez cette propriété, vous pourrez changer la disposition ainsi que l'ordre d'affichage.

Type de Contenu et Encodage MIME :

Chaque part MIME peut recevoir une valeur type de contenu (Content-Type) précisant quelles applications peuvent ouvrir le contenu. Le type de contenu est habituellement déterminé automatiquement en fonction de l'extension du fichier et des associations faites dans le système. Par exemple, si Excel est installé sur votre machine, attaché un fichier .xls générera la chaîne du type de contenu application/vnd.ms-excel, indiquant au destinataire quelle application lancer pour ouvrir l'attachement.

Le type de contenu déterminé automatiquement peut être modifié dans la boîte de dialogue Propriétés du contenu.

Il est aussi possible d'utiliser la propriété ContentType de l'objet Response pour spécifier le type du contenu lors de la génération, si l'extension n'est pas communément reconnue par les clients mail. Cela remplace toutes les affectations précédentes.

eMill encode les contenus par défaut (encodage Auto) avec l'encodage MIME (Content-Transfert-Encoding) le plus efficace en terme de taille. eMill peut utiliser les encodages Base64, Quoted-Printable, et Text 8 bit. Le type d'encodage peut aussi être modifié dans la boîte de dialogue Propriétés du contenu ou depuis le script global.

Par exemple, si vous envoyez un fichier postscript (chart1.eps) en attachement, vous pouvez modifier le type du contenu dynamiquement depuis le script global. Les clients qui recevront cet email identifieront ce fichier comme un fichier postscript et chercheront une application pour tenter de l'ouvrir.

Sub Mail_OnStartRender()
  Mail.contents("chart1").headers("Content-Type") = "application/postscript"
  Mail.contents("chart1").Headers("Content-Transfer-Encoding") = "quoted-printable"
End Sub

Ce script global générera les entêtes Content-Type et Content-Transfer-Encoding suivantes :

Content-Disposition: attachment;
filename="chart1.eps"
Content-Transfer-Encoding: quoted-printable
Content-Type: application/postscript
X-Content-Name: chart1

Caractères réservés dans les fichiers de contenu :

Certains caractères que vous aimeriez générer tel < et > peuvent être interprétés comme des tags html et évités, ou alors entraîner des erreurs. Les méthodes URLEncode et HTMLEncode de l'objet Server vous permettent de générer en toute sécurité des chaînes contenant n'importe quels caractères et espaces. Ceci est particulièrement approprié aux chaînes générées depuis un traitement serveur. Par exemple :

<%
Dim key
  For Each key In Mail.Tos
    Response.Write(Server.HTMLEncode(Mail.Tos(key))) & " "
  Next
%>
Mail.Tos(key) retourne une chaîne telle que :
"Prenom Nom" <xyz@rien.com>

Si vous n'aviez pas utilisé la méthode ci-dessus, <xyz@anything.com> aurait été interprété comme un tag inconnu et n'aurait pas été affiché par le client mail.

URLEncode est utile si vous voulez passer une URL en paramètre à un serveur Web. Le serveur devra décoder l'URL reçue.

Images dans les Contenus Html :

Le but des contenus html est de rendre le message graphiquement attrayant. Des images peuvent être incorporées au message, ou téléchargées sur un serveur Web lorsque le client ouvre son email, si la taille des messages est un problème.

Pour laisser les images sur un serveur, utilisez ce type d'URL à l'intérieur du contenu html :

<IMG SRC="http://www.imagedistribution.tld/graphics/logo.gif>

Pour incorporer des images à l'intérieur d'un email, utilisez une URL relative au contenu du fichier, qui n'inclue pas l'adresse d'un serveur Web :

<IMG SRC="pictures/logo.gif>

Le générateur récupèrera le fichier image, l'encodera en Base64 (par défaut), lui assignera un identificateur de contenu (Content-ID), et l'ajoutera entre deux bornes. Le fichier html produit incluant l'image sera :

<IMG SRC=3D"cid:650f2bf7683a4cff6a3ed5aa38afd919">
et l'image sera :
--====a0cf17f5614542a30d9583b0432a7030==
Content-Transfer-Encoding: base64
Content-ID: 650f2bf7683a4cff6a3ed5aa38afd919
Content-Type: image/gif
X-Content-Name: logo.gif
.
.
--====a0cf17f5614542a30d9583b0432a7030==

Note : Avec les images incorporées, le client n'a pas besoin de se reconnecter après avoir télécharger le message. Laisser les images sur le serveur est souvent utiliser pour déterminer quel client ouvre le message.

URL à l'Intérieur des Contenus Html :

Les URL internes aux contenus html peuvent aussi être utilisées pour relier d'autres contenus qui font partie du message. Vous pouvez choisir de garder ces fichiers sur un serveur Web en fournissant uniquement l'adresse de ces fichiers sur le serveur. Ainsi, vous pouvez passer des paramètres, et délivrer un contenu en utilisant les techniques dynamiques classiques du Web. voici un exemple utilisant ASP :

Ce script AMS est inclus dans un contenu html de l'email avant la génération :

.
.
<%Response.Write "http://www.activeplus.com/getkey.asp" & "?id=" & Server.URLEncode(Record.Fields("Email"))%>
.
.

Le client mail reçoit :

.
http://www.activeplus.com/getkey.asp?id=john@emilltest.net
.

En cliquant sur le lien depuis le client mail, le navigateur est lancé sur la page getkey.asp du serveur Web. L'application du serveur peut récupérer l'adresse email, qui identifie l'utilisateur dans la base de données et produire un contenu en conséquence.

<%
  Dim sEmail
  sEmail = Request.QueryString("id")
  'Ceci récupère l'adresse email de celui qui s'est connecté sur le site.
  'Cette adresse était déjà dans la base de données.
  'A partir de là, je peux faire n'importe quel type d'application Web...
  .
  .
%>

Vous pouvez aussi choisir d'envoyer des contenus liés entre eux dans le message. Fournir l'URL d'un fichier qui n'est pas sur un serveur Web va incorporer ce dernier à l'email. Cela revient à envoyer des "sites web" qui peuvent être vus et parcourus dans le client mail (quelques clients ont des limitations). Par exemple, le lien à cebu.htm depuis le fichier CorpsHtml...

.
.
Destinations des croisière :
<UL>
<LI><A HREF="cebu.htm">Cebu</A>
<LI>...
.

... produit le fichier email suivant où cebu.htm est généré et ajouté en tant qu'un autre part MIME du message :

.
Destinations des croisière :
<UL>
<LI><A href=3D"cid:c987cd75d5984f35fa3a1a80276f2ec9">Cebu</A>
.
.
.
--====7e0686b24b5c4c3363e15fa5e78b9901==
Content-Transfer-Encoding: base64
Content-ID: c987cd75d5984f35fa3a1a80276f2ec9
Content-Type: text/html X-Content-Name: cebu.htm
.
.

Notez que vous n'avez pas besoin d'ajouter le fichier cebu.htm au projet (pas d'entrée dans le fichier .mil du projet). Du moment que l'URL pointe sur un fichier qui n'est pas sur un serveur Web, le fichier est ajouté au corps du message. Si cebu.htm avait eu des scripts AMS inclus, il aurait fallu le lier au projet par la boîte de dialogue Créer un nouveau contenu/Créer un nouveau contenu à partir d'un fichier, avec l'option Exécuter les script inclus cochée.

Envoyer conditionnellement des contenus HTML, TXT ou PDF :

Les destinataires peuvent préférer différents formats pour leur email. AMS vous permet de choisir ce format dynamiquement, en fonction des champs de votre base de données. Vous devez générer plusieurs variantes du même contenu. Le contenu créé par défaut lorsque vous commencez un projet est de type html (CorpsHtml), et une version texte alternée est automatiquement générée par la fonction HtmlToText insérée dans le contenu CorpsTexte :

<%
  Response.Write HtmlToText(Mail.Contents("CorpsHtml").Data)
%>

Le contenu CorpsTexte nécessitera quelques retouches si vous utilisez des tableaux ou des URL incorporées à l'intérieur du corps html. Vous pouvez aussi rapidement créer une version PDF du corps html par la boîte de dialogue Créer un nouveau contenu/Créer un nouveau contenu depuis un fichier, en sélectionnant le fichier de votre projet "CorpsHtml.htm", en changeant le nom en "CorpsPdf" et en cochant la case Convertir au format PDF.

Si votre base de données a un champ FormatPrefere, vous pouvez modifier le format en fonction des préférences utilisateur par le script global :

Sub Mail_OnStartRender()
  If Record.Fields("FormatPrefere") = "pdf" Then
    Mail.Contents.Remove("CorpsHtml")
    Mail.Contents.Remove("CorpsTexte")
  ElseIf Record.Fields("FormatPrefere") = "html" Then
    Mail.Contents.Remove("CorpsPdf")
    Mail.Contents.Remove("CorpsText")
  Else
    Mail.Contents.Remove("CorpsPdf")
  End If
End Sub

Notez que si les préférences de l'utilisateur sont txt ou ne sont pas spécifiées, le contenu CorpsText produit par CorpsHtml, n'est pas supprimé. L'enlever nécessiterai que vous n'utilisiez pas la fonction HtmlToText pour créer le contenu texte mais que vous fournissiez le contenu texte entier. La pratique habituelle est, lorsque les contenus texte et html sont envoyés au client, d'indiquer que le texte est la part alternative à la part suivante (html) :

--====2eb127c4f9894f21a94a108132f99e84==
Content-Type: multipart/alternative;
  boundary="====74447ced8fc144f3d487d98de50f78a8=="
--====74447ced8fc144f3d487d98de50f78a8==
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset=iso-8859-1
X-Content-Name: CorpsTexte
.
.
--====74447ced8fc144f3d487d98de50f78a8==
Content-Type: multipart/related;
  boundary="====8ee134697e0848338a5bff8d4d78fc32=="
--====8ee134697e0848338a5bff8d4d78fc32==
Content-ID: 9e4281fca1a14b25761d43b7eb260346
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html; charset=iso-8859-1
X-Content-Name: CorpsHtml
.
.
--====8ee134697e0848338a5bff8d4d78fc32==

Les clients configurés pour lire le texte seulement n'afficheront pas la part relative html.

Une autre façon est d'éviter la création du contenu CorpsPdf en utilisant l'en-tête privée d'AMS X-PDF :

Sub Mail_OnStartRender()
  If Record.Fields("FormatPrefere") = "pdf" Then
    Mail.Contents("CorpsHtml").Headers("X-PDF") = True
    Mail.Contents.Remove("CorpsTexte")
  ElseIf Record.Fields("FormatPrefere") = "txt" Then
    Mail.Contents.Remove("CorpsHtml")
  End If
End Sub

Le tag X-PDF ne sera pas reçu par le client mais est utilisé par le générateur pour convertir la part au format Pdf. Toutes les parties référencées seront aussi converties.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Accéder à la source de données

AMS utilise la technologie Microsoft's ActiveX Data Objects (ADO) pour se lier aux sources de données. Les objets ADO vous laissent un accès facile aux interfaces de programmation OLE DB via le script. En plus des sources de données compatibles OLE DB, ADO vous permet d'accéder aux sources de données compatibles ODBC (Open DataBase Connectivity).

Chaîne de connexion ADO :

eMill possède un assistant pour créer des chaînes de connexion ADO à votre source de données. Une chaîne de connexion ADO est composée d'une série d'arguments séparés par des point-virgules, qui définissent des paramètres tels que le fournisseur ou l'emplacement de la source de données. ADO utilise des chaînes pour identifier le fournisseur qui est un composant exposant des informations sur la source de données sous forme de RecordSet (jeu d'enregistrements).

Voici quelques chaînes de connexion OLE DB utilisées par ADO :

Source de données | Chaîne de connexion OLE DB
Microsoft® Access | Provider=Microsoft.Jet.OLEDB.4.0;Data Source=chemin du fichier .mdb
Microsoft SQL Server | Provider=SQLOLEDB.1;Data Source=nom de la base de données
Oracle | Provider=MSDAORA.1;Data Source=nom de la base de données
Microsoft Indexing Service | Provider=MSIDXS.1;Data Source=chemin du fichier

Note : Toutes les anciennes chaînes de connexion ODBC sont encore supportées par un fournisseur OLE DB et peuvent être utilisées avec ADO. Ces chaînes de connexion seront aussi générées par les assistants d'eMill. Pour plus d'informations sur ADO et OLE DB, consultez le site Web de Microsoft.

Se connecter à une source de données depuis les scripts :

Un projet de mailing est lié à une source de données au moyen d'une chaîne de connexion ADO et de requêtes SQL. Nous avons vu que tous les enregistrements sélectionnés sont affichés dans la vue Destinataires, et que la collection Fields de l'objet Record vous laisse appeler instantanément les valeurs des champs de l'enregistrement depuis vos scripts.

Cependant, vous risquez de devoir manipuler un ensemble d'enregistrements pour certaines applications, ou d'acquérir des champs additionnels qui ne sont pas sélectionnés par la chaîne de connexion du projet. Par exemple, si votre application nécessite que vous calculiez les résultats de différents champs, ou si les champs dont vous avez besoin ne se trouvent pas dans la table ou dans la procédure stockée courante, vous devrez ouvrir une connexion à la base de données depuis vos scripts.

ADO possède un objet connection pour établir et gérer les connexions entre vos applications et la source de données compatible OLE DB ou ODBC. L'objet connection a des propriétés et des méthodes que vous pouvez utiliser pour ouvrir et fermer vos connexions avec la base de données, et pour exécuter des requêtes de mise à jour d'informations. Pour établir une connextion avec une base de données, commencez par créer une instance de l'objet Connection :

<%
  'Crée un objet connection
  Set cnn = Server.CreateObject("ADODB.Connection")
  'Ouvre la connection en utilisant une chaîne de connection OLE DB.
  cnn.Open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Donnees\Base.mdb"
%>

La propriété ConnectString de l'objet Mailing vous permet d'optenir la chaîne de connexion stockée dans le fichier .mil du projet. Cela vous permet de vous dispenser d'utiliser l'objet ADO Connection pour accéder à la source de données à laquelle est lié votre projet. L'exemple suivant montre plusieurs méthodes pour accéder à la source de données.

Nous supposerons que la source de données est une base de données relationnelle Microsoft Access avec une table Contact (champs ContactId, Prénom et Nom) et une table Balance (champs ContactID, Description, Emprunt, Paiements et Versements). Le projet était initialement lié à la table Contact.

Premier cas - Vous pouvez assigner les valeurs à des variables au moyen de l'objet Record si ces valeurs proviennent de champs de la table à laquelle est lié votre projet :
<%
  'Utilisez les valeurs des champs directement depuis l'objet Record
  'Le projet est lié à la table Contact contenant les champs
  Response.Write "<B>Prénom : </B>" & Record.Fields("Prenom") & "<BR>"
  Response.Write "<B>Nom : </B>" & Record.Fields("Nom") & "<BR>"
%>
Deuxième cas - Pour récupérer les valeurs depuis les champs situés à l'intérieur d'autres tables de la base de données, ouvrez une nouvelle connexion en utilisant la propriété ConnectString de l'objet Mailing, et créez des objets recordset pour manipuler les données :
<%
  'Créer un recordset pour stocker les valeurs des champs d'autres tables
  'Ouvrir la connexion en utilisant la chaîne de connexion du projet (Mailing.ConnectString)
  'Définir l'instruction SQL SELECT et énumérer les valeurs des champs
  '
  'Define SQL SELECT statement and list tables including the fields.
  Set rst = CreateObject("ADODB.Recordset")
  rst.Open "SELECT Balance.Versements, Balance.Description, Balance.Paiements, Balance.Emprunt FROM Contact INNER JOIN Balance ON Balance.ContactID=Contact.ContactID WHERE Contact.ContactID="&Record.Fields("ContactID")&";", Mailing.ConnectString
  If rst.BOF Then
    Response.Write "Pas d'enregistrement disponible pour ce Client"
    Response.End
  Else
    sDescription = rst.Fields("Description")
    sInstallments = rst.Fields("Versements")
    sPayments = rst.Fields("Paiements")
    sLoan = rst.Fields("Emprunt")

    Response.Write "<B>" & sDescription & " :</B> " & sInstallments & "<BR>"
    Response.Write "<B>Paiements reçus :</B> " & sPayments & "<BR>"
    Response.Write "<B>Total perçu :</B> " & (sPayments * sInstallments) & "<BR>"
    Response.Write "<B>Emprunt :</B> " & -sLoan & "<BR>"
    Response.Write "<B>Reste dut : </B>" & -(sPayments * sInstallments) + sLoan & "<BR>"

  End If

  rst.Close
  Set rst = nothing
%>
Troisième cas - Pour écrire dans une autre source de données non liée au projet, ouvrez une autre connexion avec la chaîne appropriée. Ce qui suit stocke des informations au sujet des destinataires du mailing ci-dessus dans un fichier Excel :
<%
  'Ecrit le rapport d'expédition dans un fichier Excel non lié au projet
  'Définit la chaîne de connexion OLE DB et le chemin d'accès au fichier
  strExcelConnect = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Mailings\55072\rapport.xls;Extended Properties=""Excel 8.0;"""

  'Instancie l'objet Connection et ouvre une connexion avec la base de données
  Set cnn = Server.CreateObject("ADODB.Connection")
  cnn.Open strExcelConnect
  'Définit l'instruction SQL INSERT.
  strSQL = "INSERT INTO [Sheet1$] (Email, Prenom, Nom, DernierEnvoi) VALUES ('" & Record.Fields("Email") & "','" & Record.Fields("Prenom") & "','" & Record.Fields("Nom") & "','" & Now & "');"
  'Utilise la méthode Execute pour exécuter la requête SQL sur la base de données
  cnn.Execute strSQL,,adCmdText + adExecuteNoRecords

  cnn.Close
  Set cnn = Nothing
%>

Exécuter des requêtes SQL :

Les 4 instructions SQL les plus importantes sont :

  • SELECT: utilisée pour récupérer des données depuis une ou plusieurs tables.
    Cette requête retournera le nom et l'adresse email de tous les homme de 65 ans de la table Contact. Nom, Email, Genre et Age sont les champs de la table Contact :
    SELECT Nom, Email FROM Contact WHERE Contact.Age = 65 AND Contact.Genre = 'M'
  • INSERT: utilisée pour ajouter de nouveaux enregistrements à une table.
    Cette requête ajoute à la table Rapport les enregistrements générés par la source de données du projet de mailing :
    INSERT Rapport (NomEnvoi, PrenomEnvoi) VALUES ('<%Record.Fields("Nom")%>',  '<%Record.Fields("Prenom")%>')
  • DELETE: utilisée pour détruire des enregistrement d'une table.
    Cette requête détruit toutes les rangées de la table Contact où le champ Email est vide (NULL) :
    DELETE * FROM Contact WHERE Email = IS NULL
  • UPDATE: utilisée pour mettre à jour des champs individuels dans un ou plusieurs enregistrements.
    Cette requête met à jour le champ DernierEnvoi de la table Contact avec la date du serveur retournée par la fonction Now :
    UPDATE Contact SET Contact.DernierEnvoi = ('<%Now%>')
IMPORTANT : Les commandes AMS ci-dessus ne doivent pas inclure les délimiteurs de script quand la requête est utilisée à l'intérieur du script. Vous devez remplacer ...
('<%Record.fields("Nom")%>', ...)
... par :
"('" & Record.Fields("Nom") & "', " & "..." & ")"

Vous trouverez de bonnes références sur instructions SQL de base et leur mots- clé sur le site DevGuru.

Note: les méthodes ReceiversQuery et ReceiversCountQueryEx de l'objet AMS Mailing retournent la requête SQL retournant la liste des destinataires et la requête optionnelle retournant le nombre de destinataires.

Utiliser les Recordset pour manipuler les résultats :

ADO fournit l'objet Recordset pour récupérer ou modifier les enregistrements de la base de données (row). Les recordsets reçoivent les enregistrements retournés par la requête SQL, maintenant leur position et vous permettant d'énumérer chaque row. L'exemple ci-dessus vous montre comment utiliser la méthode Open de l'objet Recordset pour établir une connexion à la base de données. Pour plus d'informations sur les méthodes et propriétés, visitez le site de Microsoft.

Modifier les enregistrements de la base de données :

AMS appelle des évenements permettant de changer les enregistrements de la base de données après chaque mailing. L'exemple suivant met à jour les champs de la base après que le mailing ait été généré :

Sub Mailing_OnEndRender()
  Dim sSentDate
  Dim sQuery
  Dim Conn

  sSentDate = Date
  Set Conn = CreateObject("ADODB.Connection")
  Conn.Open Mailing.ConnectString
  sQuery = "UPDATE Contact " & "SET DernierEnvoi = #" & sSentDate & "#;"
    Mailing.AppendToLog sQuery
    Conn.Execute sQuery 'Execute la requête
    Conn.Close 'Ferme la connexion
    Set Conn = Nothing
End Sub

Pour automatiquement mettre à jour la base de données à partir de réponses au mailing, consultez les événements Mailing_OnAcceptMail et Mailing_OnReceiveMail de l'exemple WebLetter qui illustre comment automatiser les cas REMOVE, UNSUBSCRIBE, SUBSCRIBE et UPDATE. Vous devrez définir une file d'attente entrante et abonner votre projet à celle-ci.

Personnaliser les accès à la source de données via l'objet DataSource :

eMill se connecte habituellement aux bases de données via ADO. Cependant, si vous devez personnaliser l'accès à la base, ou si la source de données n'est pas compatible avec ADO, vous pouvez utiliser l'objet DataSource depuis le script global en cochant l'option Utiliser le script global pour accéder à la source de données de la boîte de dialogue Propriétés du projet/Destinataires. L'exemple XMLDatabase vous montre comment utiliser l'objet DataSource et ses méthodes pour se connecter à une base de données XML.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Déboguer AMS

Lors de la phase de conception, vous pouvez utiliser l'aperçu pour tester instantanément vos scripts et contenus. Si une erreur s'est produite lors de l'exécution d'un script AMS, l'application affiche une Erreur d'exécution. Le nom du fichier de contenu contenant l'erreur est affiché, ainsi que la location et la description du problème :

Ce message révèle un bogue dans le fichier "statement.htm".

  • Cliquez sur Continuer pour ignorer le bogue et revenir à l'aperçu.
  • Cliquez sur Fin pour abandonner l'aperçu et éditer l'erreur.
  • Clicuer sur Déboguer pour lancer le débogeur par défaut.

Microsoft Script Debugger :

Si votre débogeur par défaut est Microsoft Script Debugger (recommendé), ce dernier chargera les modules en cours d'exécution dans eMill. Un des modules est le code VBScript qui, une fois exécuté, produira le contenu MIME du message que le destinataire sélectionné recevra :

Les destinataires sont sélectionnés individuellement depuis l'aperçu, via les commandes de l'éditeur d'enregistrements.

L'autre module est le code du script global VBScript qui appelle les événements des objets Mail et Mailing :

Le débogueur mettra un point d'arrêt à l'endroit où l'erreur s'est produite. Vous pourrez résoudre le problème depuis le débogueur. Notez que les modifications du code depuis le débogueur ne modifieront pas le code source d'eMill.

Important: Utilisez l'option "Stop Debugging' pour retourner à eMill depuis le débogueur. Si vous quittez ce dernier sans stopper le déboguage, eMill risque de générer une erreur et de se fermer (avec Microsoft Visual InterDev).
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Scripting Object Reference Cards

eMill implements the following built-in object classes. These objects are accessible by script-enabled content files.
Class | Use to
Mailing | Access information about your mailing project.
 | Name, Path, ConnectString, ReceiverQuery, BlackListConnectString, BlackListQuery, CodePage, LCID, Published
 | AbortRender, CreateMail, SubmitMail, RemoveReceivedMail
Mail | Access information about the mail currently being processed.
 | Headers, Receivers, Tos, CCs, Contents, CodePage, LCID, Sender, From, Subject, Date, Priority, AbortRender
 | OnEndRender, OnStartRender
Record | Call the collections, methods and properties of the record object.
 | Headers, Receivers, Tos, CCs, Contents, CodePage, LCID, Sender, From, Subject, Date, Priority, AbortRender
Application | Share information among all sessions of a given mailing project.
Request | Retrieve the values that the client passed to the server during an HTTP request.
Response | Send output to the rendered content.
 | Headers, Receivers, Tos, CCs, Contents, CodePage, LCID, Sender, From, Subject, Date, Priority, AbortRender
Server | Access to methods and properties on the server.
 | Headers, Receivers, Tos, CCs, Contents, CodePage, LCID, Sender, From, Subject, Date, Priority, AbortRender
Session | Store information needed during rendering for a particular receiver.
Soap | Call web service methods through the SOAP protocol.
eMill global script component:
DataSource | Implement data access to any non-ADO database.
eMill implements the following helper functions. These functions are accessible from any script.
Function | Use to
CSafeStr | Returns an expression that has been converted to a Variant or subtype String.
DefaultStr | Returns a default string if the passed expression is empty or null.
HtmlToText | Returns a text string from an HTML text.
EncodeBase64Str | Returns a base64 text string from any text string.
DecodeBase64Str | Returns a text string from a base64 encoded text string.
FormatEmailAddress | Returns a properly formatted email address.
ExtractEmailAddresses | Returns on or more email addresses from any text.
CreateUniqueID | Returns a 128 bit unique identifier formatted as a string.
GetHttpFile | Returns a Variant of subtype Byte array or String that contains the result of the HTTP request.
DecodeInternetDate | Convert an RFC822 datetime string to a variant of subtype Date.
IsJokerMatch | Dertermines if a string matches a pattern.

You can read the VBScript Reference guide at http://msdn.microsoft.com/scripting

Script Enabled Content File: A text file that contains script to be executed within <% %> delimiters, or a .vbs file.
©2001-2015 eMill . All trademarks property of their owners.


Mailing Object

You can use the Mailing object to access information about your mailing project.

Syntax

Mailing.collection|property|method

Properties
Name | Gets the project name.
Path | Gets the project root path.
ConnectString | Gets the ADO connect string.
ReceiversQuery | Gets the SQL query that returns the list of receivers records.
BlackListConnectString | Gets the ADO connect string.
BlackListQuery | Gets the SQL query that returns the list of blacklist records.
ListName | Gets the current receivers list name.
CodePage | Sets the default code page for this mailing. The code page tells eMill how to encode characters for different languages.
LCID | Sets the default LCID for this mailing. The LCID refers to how dates, times, and currency are formatted for a specific geographical locale.
Published | Gets the mailing published status.
Preview | Gets the rendered message preview status.
Profile | Gets the mailing configuration object.
Methods
AbortRender | This method aborts the entire mailing rendering process.
CreateMail | This method creates a new Mail object
SubmitMail | This method submits a Mail to the Outbox folder.
RemoveReceivedMail | This method removes the received message from the Inbox folder.
MoveReceivedMail | This method moves the received message to an Inbox sub folder.
AppendToLog | This method adds a string to the end of mailing log.
GetValue | This method gets a value from the mailing profile (the .mil file)
Events
Mailing_OnEndRender | This event is invoked when the mailing rendering has completed.
Mailing_OnStartRender | This event is invoked when a mailing is about to be rendered.
Mailing_OnAcceptMail | This event is invoked when a message is about to be received
Mailing_OnReceiveMail | This event is invoked when a message has been received.
Mailing_OnMailStatus | This event is invoked when a message status is changing.
Mailing_OnUrlClicked | This event is invoked when a receiver has clicked on a link within a tracked mail content or when a mail content was opened.

© 2001-2015 eMill . All trademarks property of their owners.


Session Contents Collection

The Session.Contents collection contains all of the items that have been established for a session. Information stored in the Session collections is available during a receiver session. The collection can be used to determine the value of a specific session item, or to iterate through the collection and retrieve a list of all items in the session. See the Collection Object for standard collection properties and methods.

Syntax

Item = Session.Contents(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Settings and Return Values

Sets or returns a Variant value.

Remarks

The Contents collection is the Session object implicit collection. Therefore you do not need to specify .Contents when accessing the collection.

Example

Sub Mail_OnStartRender
Session("Credits") =
Record.Fields("Credits") * Application("CreditRatio")
End Sub

Applies to

Session Object

See Also

Application Contents Collection

©2001-2015 eMill . All trademarks property of their owners.


Mailing.ProjectName

Name

The Name property returns the mailing project name.

Return Value

Returns a String value.

Applies To

Mailing Object

See Also

Path

©2001-2015 eMill . All trademarks property of their owners.


Mailing.Path

Path

The Path property returns the mailing root path.

Return Value

Returns a String value.

Applies To

Mailing Object

See Also

Name

©2001-2015 eMill . All trademarks property of their owners.


ConnectString

The ConnectString property contains the information used to establish a connection to an ADO data source that stores the Receivers recordset.

Return Value

Returns a String value.

Remarks

See the ADO ConnectionString property for more details.

Applies To

Mailing Object

See Also

ReceiversQuery

©2001-2015 eMill . All trademarks property of their owners.


Mailing.ReceiversQuery

ReceiversQuery

The ReceiversQuery property returns the SQL query that returns the list of receivers.

Return Value

Returns a String value.

Applies To

Mailing Object

See Also

ConnectString

©2001-2015 eMill . All trademarks property of their owners.


Mailing.BlackListConnectString

BlackListConnectString

The BlackListConnectString property contains the information used to establish a connection to an ADO data source that stores the black list.

Return Value

Returns a String value.

Remarks

See the ADO ConnectionString property for more details.

Applies To

Mailing Object

See Also

BlackListQuery

©2001-2015 eMill . All trademarks property of their owners.


Mailing.BlackListQuery

BlackListQuery

The BlackListQuery property returns the SQL query that returns the list of receivers.

Return Value

Returns a String value.

Applies To

Mailing Object

See Also

BlackListConnectString

©2001-2015 eMill . All trademarks property of their owners.


ListName

The ListName property contains the name of the receivers list currently used to render the message.

Return Value

Returns a String value.

Remarks

This property may be useful to perform certain operations that are list specific when the mailing project use more than one receivers list.

Applies To

Mailing Object

See Also

ReceiversQuery

©2001-2015 eMill . All trademarks property of their owners.


Mailing.CodePage

CodePage

The CodePage property specifies how strings are encoded in the intrinsic objects. A code page is a character set that can include numbers, punctuation marks, and other glyphs. Codepages are not the same for each language. Some languages such as Japanese and Korean have multi-byte characters, while others like English and German only need one byte to represent each character.

Settings and Return Value

Sets or returns an Integer value

Remarks

Setting Mailing.CodePage explicitly affects the default code page for the mailing, where Mail.CodePage affects all content of a mail message.
You can find codepage values at MSDN Web Workshop under the column for FamilyCodePage.

Applies To

Mailing Object

See Also

Mail.CodePage , Response.CodePage

©2001-2015 eMill . All trademarks property of their owners.


Mailing.LCID

LCID

The LCID property specifies how dates, times, and currencies are formatted. LCIDs are not the same for each geographical locale. Some locales format dates as YY-MM-DD and some format dates as MM-DD-YYYY.

Settings and Return Values

Sets or returns an Integer value.

Remarks

Setting Mailing.LCID explicitly affects the default LCID for the mailing.

Response.LCID can be set multiple times in one content, and the date can be displayed each time; however, the codepage must be set once to show all the characters.

You can find locale integers at MSDN Library.

Applies To

Mailing Object

See Also

CodePage , Mail LCID, Response LCID

©2001-2015 eMill . All trademarks property of their owners.


Mailing.Published

Published

The Published property indicates whether the mailing project is running in design mode or if the project published.

Return Value

Returns a Bool value.

Comments

Returns True if the current mailing project is running in design mode, False if the project is published.

Applies To

Mailing Object

©2001-2015 eMill . All trademarks property of their owners.


Mailing.Preview

Preview

The Preview property indicates whether the message is rendered for preview.

Return Value

Returns a Bool value.

Comments

Returns True if the message is rendered for preview, False if the message is rendered in the Outbox queue folder for sending.

Applies To

Mailing Object

©2001-2015 eMill. All trademarks property of their owners.


Mailing.Profile

Profile

The Profile property returns the mailing configuration object, as an MS XML object.

Return Value

Returns an Object value.

Comments

The returned object is the Mailing configuration object. It allows direct access to the whole Mailing properties. Do not modify it, or the Mailing project may behave incorrectly.

Applies To

Mailing Object

©2001-2015 eMill. All trademarks property of their owners.


Mailing.AbortRender

AbortRender

The AbortRender method will abort the mailing rendering process. Previously rendered receiver will not be aborted.

Syntax

Mailing.AbortRender

Parameters
None
Example

Mail_OnStartRender
...
If bSomeFailure Then
Mailing.AbortRender
End If
End Sub

Applies To

Mailing Object

See Also

Mail.AbortRender

©2001-2015 eMill . All trademarks property of their owners.


CreateMail

The CreateMail method will create a new Mail Object.

Syntax

Mailing.CreateMail MailTemplate

Parameters
MailTemplate
An optional Variant that contains either a Mail Object, an RFC822 content stored in a Content Object or a path to an .eml file.
Remarks

This method can only be called during OnReceiveMail, OnMailStatus and OnUrlClicked events.

Example

See the OnReceiveMail example

Applies To

Mailing Object

See Also

RemoveMail, OnReceiveMail

©2001-2015 eMill . All trademarks property of their owners.


Mailing.SubmitMail

SubmitMail

The SubmitMail method will submit a message to the Outbox folder.

Syntax

Mailing.SubmitMail Mail

Parameters
Mail
A Mail Object
Remarks

This method can only be called during OnReceiveMail, OnMailStatus and OnUrlClicked events.

Example

See the OnReceiveMail example

Applies To

Mailing Object

See Also

RemoveMail, OnReceiveMail

©2001-2015 eMill . All trademarks property of their owners.


Mailing.RemoveMail

RemoveReceivedMail

The RemoveReceivedMail method will remove the received message from the Inbox folder.

Syntax

Mailing.RemoveReceivedMail

Parameters
None
Remarks

This method can only be called when processing a message during the OnReceiveMail event

Example

See the OnReceiveMail example

Applies To

Mailing Object

See Also

SubmitMail, OnReceiveMail

©2001-2015 eMill . All trademarks property of their owners.


Mailing_MoveReceivedMail

MoveReceivedMail

The MoveReceivedMail method will move the received message from the Inbox folder to a sub-folder of the Inbox folder.

Syntax

Mailing.MoveReceivedMail

Parameters
FolderPath
A String that indicates the path of the destination folder.
Remarks

Folder names must be separated using a forward slash (eg. "Sales/Jim").
The folder will be created if it does not exist.
This method can only be called when processing a message during the OnReceiveMail event.

Example

See the OnReceiveMail example

Sub Mailing_OnReceiveMail
If DSNType<>0 Then
MoveReceivedMail "DSN"
End If
End Sub

Applies To

Mailing Object

See Also

RemoveReceivedMail, OnReceiveMail

©2001-2015 eMill . All trademarks property of their owners.


Mailing.AppendToLog

AppendToLog

The AppendToLog method adds a string to the end of the mailing log.

Syntax

Mailing.AppendToLog string

Parameters
string
The text to append to the log file. The text does not have to end with a CR LF.
Remarks

The log file is named log.txt and is located in the mailing project folder.
This method may be called from any eMill script context.

Example

Sub Mailing_OnMailStatus(Status)
For Each sReceiver in Mail.Receivers
Mailing.AppendToLog "Receiver: " & sReceiver & " Status Code: " & Status
Next
End Sub

Applies To

Mailing Object

©2001-2015 eMill . All trademarks property of their owners.


GetValue

The GetValue method returns a value from the mailing profile (the .mil file).

Syntax

Mailing.GetValue section, key

Parameters
section
String that specifies the name of the section containing the key.
key
String that specifies the name of the key whose associated string is to be retrieved
Return Value

A Variant that contains the value

Example

sProjectDesc = Mailing.GetValue("Project", "Description")

Applies To

Mailing Object

©2001-2015 eMill . All trademarks property of their owners.


Mailing_OnEndRender

The Mailing_OnEndRender event occurs when rendering has completed.

Syntax

Sub Mailing_OnEndRender
. . .
End Sub

Parameters
None
Example

Sub Mailing_OnEndRender()
 Mailing.AppendToLog "Render has completed at " & Now
End Sub

Applies To

Mailing Object

See Also

Mailing_OnStartRender

©2001-2015 eMill . All trademarks property of their owners.


Mailing_OnStartRender

The Mailing_OnStartRender event occurs when rendering starts for a mailing. The Mailing_OnStartRender event is a good time for you to set any mailing-wide variables, because they will be set before any receiver is rendered.

Syntax

Sub Mailing_OnStartRender
. . .
End Sub

Parameters
None
Example

Sub Mailing_OnStartRender
Mailing("StockRate") =
GetStockRate("HOTJ")
End Sub

Remarks

[Remarks goe here].

Applies To

Mailing Object

See Also

Mailing_OnEndRender, Mail_OnStartRender

©2001-2015 eMill . All trademarks property of their owners.


Mailing_OnAcceptMessage

Mailing_OnAcceptMail

The Mailing_OnAcceptMail event occurs when a mail is about to be received. The mail message can be accessed using the intrinsic Mail object.

Syntax

Sub Mailing_OnAcceptMail(Accept)
. . .
End Sub

Parameters
Accept
A Boolean variable that should be set to True if the mail is accepted
Example

Sub Mailing_OnAcceptMail(Accept)
If Mail.Receivers(0) = "sales@emilltest.com"
Then
Accept = True
End If
End Sub

Remarks

When accessing a POP3 queue, the Mail Object will only be initialized with the mail header, the Contents collection will always be empty.
If the message is not accepted, the Accept variable should never be set to False, it should be left unmodified.

See Also

Mailing_OnReceiveMail

©2001-2015 eMill . All trademarks property of their owners.


Mailing_OnReceiveMail

The Mailing_OnReceiveMail event occurs after a message has been accepted. The mail message can be accessed using the intrinsic Mail Object.

Syntax

Sub Mailing_OnMailReceive
. . .
End Sub

Parameters
None
Example

Sub Mailing_OnReceiveMail
' Create a backup of the received message
Dim NewMail
Set NewMail = Mailing.CreateMail(Mail)
NewMail.Receivers.RemoveAll
NewMail.Receivers.Add , "backup@emilltest.com"
NewMail.Subject = Mail.Subject & " Received on: " & Now
Mailing.SubmitMail NewMail
Set NewMail = Nothing
' Forward the original mail to the sales department
 Mail.Receivers.RemoveAll
Mail.Receivers.Add , "sales@emilltest.com"
Mailing.SubmitMail Mail
Mailing.RemoveReceivedMail
End Sub

Remarks

A mailing project can listen to more than one incoming queue, mails arriving from all queues will trigger this event.

Applies To

Mailing Object

See Also

Mailing_OnAcceptMail, SubmitMail, RemoveReceivedMail

©2001-2015 eMill . All trademarks property of their owners.


Mailing_OnMailStatus

The Mailing_OnMailStatus event occurs when a message is being moved from the Outbox folder to either the Sent or Aborted folder. The Mailing_OnMailStatus event is a good time for you to place some code to update the receiver database. The intrinsic Mail Object will reflect the aborted or sent message.

Syntax

Sub Mailing_OnMailStatus(Status)
. . .
End Sub

Parameters
Status
The message status. It can be one of the following values:
11 = The message was successfully sent
12 = The message was partially sent
13 = The message was aborted
Remarks
The X-Receiver-Status header field contains detailed information about the failure reason.
Example

Sub Mailing_OnMailStatus(Status)
If Status = 13 Then
DisableContactEMail(Mail.Headers("X-Contact-ID"))
End If
End Sub

Remarks

The Mail Object is only initialized with the mail header; the Contents collection is empty.
The DataSource object is not available at this point. Direct Database access should be used.

©2001-2015 eMill . All trademarks property of their owners.


Mailing_OnUrlClicked

The Mailing_OnUrlClicked event occurs when a receiver has clicked on a link within a tracked mail content or when a mail content was opened.

Syntax

Sub Mailing_OnUrlClicked()
. . .
End Sub

Remarks

The Record collection exposes all fields that where selected in the Tracking fields setting.
You may use the Request.ServerVariables method to query information about the clicked URL and various other details:
Request.ServerVariables("URL") : Returns the URL that was clicked. If the URL is equal to "open" then it indicates that the user has opened the email in it's mail client.
Request.ServerVariables("URL_NAME") : Returns the link name.
Request.ServerVariables("REMOTE_ADDR") : Returns the IP address of the receiver who has clicked on the link.
Request.ServerVariables("HIT_DATE") : Returns the date of the link click or message opening.
Request.ServerVariables("HTTP_REFERER") : Returns a string containing the URL of the page that referred the request to the redirector.
Request.ServerVariables("HTTP_USER_AGENT") : Returns a string describing the client mail software that sent the request.

Example

Sub Mailing_OnUrlClicked()
If Record.Email = "jim@emilltest.com"
and Request.ServerVariables("URL") = "open" Then
Mailing.AppendToLog "Jim has opened
our mail"
End If
End Sub

See Also

Record collection, Request.ServerVariables

©2001-2015 eMill . All trademarks property of their owners.


Mail Object

You can use the Mail object to access information about the mail currently being processed. This can either be an outgoing message that is being rendered or an incoming message.

Syntax

Mail.collection|property|method

Collections
Headers | Contains the list of header fields
Receivers | Contains the list of receivers that will receive the mail
Tos | Contains the list of receivers that are displayed in the To: field
CCs | Contains the list of receivers that are displayed in the CC: field
Contents | Contains the list of content items (body and attachments).
DSNHeaders | Contains the list of DSN headers
DSNReceivers | Contains the list of DSN receivers
Fields | Contains the list of body fields
Properties
CodePage | Sets the default CodePage for all contents in the current mail. The codepage tells eMill how to encode characters for different languages.
LCID | Sets the default LCID for all contents in the current mail. The LCID refers to how dates, times, and currency are formatted for a specific geographical locale.
Sender | Sets the SMTP sender. By default the sender will be initialized using the From: field.
From | Sets the From: field.
Subject | Sets or gets the message subject.
Date | Sets or gets the message date.
SendDate | Sets or gets the message send date.
Priority | Sets or gets the message priority.
DSNEnvID | Sets the DSN ENVID parameter.
DSNReturn | Sets the DSN RET parameter.
DSNNotify | Sets the DSN NOTIFY parameter.
DSNType | Gets the DSN type.
Data | Sets or gets the MIME content.

Additional header fields can be set using the Headers collection

Methods
AbortRender | Aborts rendering for the current receiver.
Save | Saves the mail to the disk (.eml file).
Events
Mail_OnEndRender | This event is invoked when the mail has been rendered.
Mail_OnStartRender | This event is invoked when the mail is about to be rendered.
Remarks

When rendering a mailing, all receivers associated with the current DataSource record will be added to the Receivers collection. Attachments will also be added to the Contents collection. The Mail_OnStartRender event is a good place to perform any receiver specific initialization such as adding user specific mail attachment or changing some header fields.

©2001-2015 eMill . All trademarks property of their owners.


Mail Headers Collection

The Mail.Headers collection contains all message headers. The collection can be used to determine the value of a specific header item, or to iterate through the collection and retrieve a list of all items in the message header. See the Collection Object for standard collection properties and methods.

Syntax

Item = Mail.Headers(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a variant.

Remarks

The key should not contain the column character ':'

Example

In the following example, a Reply-To: header field is set on the Mail_OnStartRender event

Sub Mail_OnStartRender
Mail.Headers("Reply-To") = """Jim Wilson"" <jim.wilson@emilltest.com>"
End Sub

In the following example, the Reply-To: header field is removed on the Mail_OnStartRender event

Sub Mail_OnStartRender
Mail.Headers.Remove("Reply-To")
End Sub

Applies To

Mail Object

©2001-2015 eMill . All trademarks property of their owners.


Mail Receivers Collection

The Mail.Receivers collection contains all message receivers. The collection can be used to determine the value of a specific receiver item, or to iterate through the collection and retrieve a list of all receivers. See the Collection Object for standard collection properties and methods.

Syntax

Item = Mail.Receivers(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a Variant of type String

Remarks

The Receivers collection contains the list of email address that will actually receive the mail message, whereas the Tos and CCs collection contains the list of receivers displayed in the mail message.

Example

In the following example, a receiver is added on the Mail_OnStartRender event

Sub Mail_OnStartRender
Mail.Receivers.Add "TheBoss","bigboss@emilltest.com"
Mail.CCs.Add "TheBoss","bigboss@emilltest.com"
End Sub

Applies To

Mail Object

See Also

Tos, CCs, Collection Object

©2001-2015 eMill . All trademarks property of their owners.


Mail Tos Collection

The Mail.Tos collection contains the list of receivers displayed in the To: field of an email message. The collection can be used to determine the value of a specific To item, or to iterate through the collection and retrieve a list of all To receivers. See the Collection Object for standard collection properties and methods.

Syntax

Item = Mail.Tos(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a Variant of type String.

Remarks

The Tos collection contains the list of email address that will be displayed in the To: field of an email message, where as the Receivers collection contains the list of receivers that will actually receive the message.

Example

The following example sets the To: field as "<Undisclosed Recipients>"

Sub Mail_OnStartRender
Mail.Tos.RemoveAll
Mail.Tos.Add "<Undisclosed Recipients>"
End Sub

The following example returns all items in Tos collection separated by commas.

Response.Write Mail.Tos

Applies To

Mail Object

See Also

Receivers, CCs, Collection Object

©2001-2015 eMill . All trademarks property of their owners.


Mail CCs Collection

The Mail.CCs collection contains the list of receivers displayed in the CC: field of an email message. The collection can be used to determine the value of a specific CC item, or to iterate through the collection and retrieve a list of all CC items. See the Collection Object for standard collection properties and methods.

Syntax

Item = Mail.CCs(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a Variant of type String.

Remarks

The CCs collection contains the list of email address that will be displayed in the CC: field of an email message, where as the Receivers collection contains the list of receivers that will actually receive the message.

Example

The following example adds a CC: and a BCC: receiver to the mail message

Sub Mail_OnStartRender
Mail.CCs.Add "ceo@emilltest.com"
Mail.Receivers.Add "ceo@emilltest.com"
Mail.Receivers.Add "spy@emilltest.com"
End Sub

Applies To

Mail Object

See Also

Tos, Receivers, Collection Object

©2001-2015 eMill . All trademarks property of their owners.


Mail Contents Collection

Contents Collection

The Contents collection contains all content files. The collection can be used to determine the value of a specific content item, or to iterate through the collection and retrieve a list of all items in the message.

Syntax

Content = Object.Contents(key|index)

Parameters
key
The name of the content to retrieve.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a Content Object

Examples

In the following example, a specific content is removed on the Mail_OnStartRender event

Sub Mail_OnStartRender
If Record.Fields("Details") = False Then
Mail.Contents.Remove("Details")
End If
End Sub

In the following example, a content is added on the Mail_OnStartRender event

Sub Mail_OnStartRender
Set oContent = Mail.Contents.Add "My new content" 'Add a content named "My new content"
oContent.Data = "Hello this is a test message" 'Add the text data inside of it
oContent.Type = "text/plain" 'Set the content-type
oContent.Headers("X-Body") = 1 'Specify that the content is part of the body
End Sub

Applies To

Mail Object, Mailing Object

See Also

Content Object

©2001-2015 eMill . All trademarks property of their owners.


Mail DSNHeaders Collection

The Mail.DSNHeaders collection contains the list of header fields contained in a DSN message. See the Collection Object for standard collection properties and methods.

Syntax

Item = Mail.DSNHeaders(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a Variant of type String.

Remarks

The DSNHeaders collection may contain the following field:

Original-Envelope-ID | Contains an "envelope identifier" which uniquely identifies the transaction during which the message was submitted. This fields correspond to what is set using the Mail.DSNEnvID property.
Reporting-MTA | Indicates the MTA which attempted to perform the delivery, relay, or gateway operation described in the DSN. This field is always present.
DSN-Gateway | Indicates the name of the gateway or MTA which translated a foreign (non-Internet) delivery status notification into this DSN
Received-From-MTA | Indicates the name of the MTA from which the message was received.
Arrival-Date | Indicates the date and time at which the message arrived at the Reporting MTA.

See RFC1894 for details about DSN messages.

Example

The following example uses the Original-Envelope-ID to link back to the original receivers database record

Sub Mail_OnReceiveMail
If Mail.DSNHeaders("Original-Envelope-ID") <>
"" Then
sSQL = "SELECT * FROM MyContacts
WHERE ContactID=" & Mail.DSNHeaders("Original-Envelope-ID")
' Execute SQL
query...
' Update
record...
End If
End Sub

Applies To

Mail Object

See Also

DSNReceivers, DSNEnvID, Collection Object

©2001-2015 Active+ Software . All trademarks property of their owners.


Mail DSNReceivers Collection

The Mail.DSNReceivers collection contains the list of header fields contained in a DSN message. See the Collection Object for standard collection properties and methods.

Syntax

Item = Mail.DSNReceivers(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a Variant of type String.

Remarks

The DSNReceivers collection may contain the following field:

Original-Recipient | Indicates the original recipient address as specified by the sender of the message for which the DSN is being issued. (e.g. "jim@emilltest.com")
X-DB-Original-Recipient | This field is an eMill private field. It will only be available in DSNs generated by the Fax and SMS gateways. It contains the original phone number as it is in the receiver list and can be used to know who was the original recipient of the Fax or the SMS.
Final-Recipient | Indicates the recipient for which this set of per-recipient fields applies. The Final-Recipient address may differ from the address originally provided by the sender, because it may have been transformed during forwarding and gatewaying into an totally unrecognizable mess. (e.g. "jim@server1.mail.emilltest.com")
Action | Indicates the action performed by the Reporting-MTA as a result of its attempt to deliver the message to this recipient address.The action-value may be one of the following: failed, delayed, delivered, relayed, expanded
Status | Contains a transport-independent status code which indicates the delivery status of the message to that recipient. See RFC1893 for details.
Remote-MTA | Contains a printable ASCII representation of the name of the "remote" MTA that reported delivery status to the "reporting" MTA.
Diagnostic-Code | Contains the actual diagnostic code issued by the mail transport
Last-Attempt-Date | Gives the date and time of the last attempt to relay, gateway, or deliver the message (whether successful or unsuccessful) by the Reporting MTA
Will-Retry-Until | Gives the date after which the Reporting MTA expects to abandon all attempts to deliver the message to that recipient.

See RFC1894 for details about DSN messages.

Example

The following example uses the Original-Envelope-ID to link back to the original receivers database record

Sub Mail_OnReceiveMail
If Mail.DSNType<>0 Then
For Each rcv In Mail.DSNReceivers
If Mail.DSNReceivers(rcv)("Original-Recipient") <> "" And LCase(Mail.DSNReceivers(rcv)("Action")) = "failed" Then
aEmail = Split(Mail.DSNReceivers(rcv)("Original-Recipient"), ";") ' Format rfc822;user@domain.com
 sSQL = "SELECT * FROM MyContacts WHERE email='" & Trim(aEmail(1)) & "'"
' Execute SQL query...
' Update record ...
End If
Next
Else
Mailing.MoveReceivedMessage "Sales"
End If
End Sub

Applies To

Mail Object

See Also

DSNHeaders, DSNEnvID, Collection Object

©2001-2015 Active+ Software . All trademarks property of their owners.


Mail Fields Collection

The Mail.Fields collection contains all message body fields. The collection can be used to determine the value of a specific field item, or to iterate through the collection and retrieve a list of all items in the message body. See the Collection Object for standard collection properties and methods.

Syntax

Item = Mail.Fields(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value

Returns a variant.

Remarks

The field collection is filled only on incoming message processing, that is, eventually during the Mailing_OnAcceptMail event if the whole message is available, or during the Mailing_OnReceiveMail event.

A body field is composed of a field name, followed by the : or = char, eventually followed by a field value. The body field name is composed of any alphanumeric char, plus the _ . - chars. It can also contains white spaces between other chars. The field value is composed of chars remaining until the end of line or a quoted value (using double quote as quoting char).

Applies To

Mail Object

©2001-2015 eMill . All trademarks property of their owners.


CodePage

The CodePage property specifies how strings are encoded in the intrinsic objects. A code page is a character set that can include numbers, punctuation marks, and other glyphs. Codepages are not the same for each language. Some languages such as Japanese and Korean have multi-byte characters, while others like English and German only need one byte to represent each character. The CodePage property is read/write.

Settings and Return Values

Sets or returns an Integer value.

Remarks

Setting Mail.CodePage explicitly affects the default code page for all content of a mail message.
You can find codepage integers at MSDN Web Workshop under the column for FamilyCodePage.

Applies To

Mail Object

See Also

Mailing.CodePage , Response.CodePage

©2001-2015 eMill . All trademarks property of their owners.


LCID

The LCID property specifies how dates, times, and currencies are formatted. LCIDs are not the same for each geographical locale. Some locales format dates as YY-MM-DD and some format dates as MM-DD-YYYY. The LCID property is read/write.

Settings and Return Values

Sets or returns an Integer value.

Remarks

Setting Mail.LCID explicitly affects all contents of a mail, where Response.LCID affects a single content of a mail message.

Response.LCID can be set multiple times in one content, and the date can be displayed each time; however, the codepage must be set once to show all the characters.

You can find locale integers at MSDN Library.

Applies To

Mail Object

See Also

CodePage, Mailing.LCID, Response.LCID

©2001-2015 eMill . All trademarks property of their owners.


Sender

The Sender property specifies the SMTP sender. The Sender property is a shortcut to the Headers("X-Sender") collection item.

Settings and Return Values

Set or returns a String value.

Remarks

The Sender property must be formatted using the user@domain format. It must not contain any display name such as "Sender Name" <user@domain>
If the Sender property is not set, the Sender property will be initialized using the email part of the From property.

Applies To

Mail Object

See Also

From

©2001-2015 eMill . All trademarks property of their owners.


From

The From property specifies the message From field. The From property is a shortcut to the Headers("From") collection item.

Settings and Return Values

Sets or returns a String value

Remarks

This string must be formatted using the "Sender Name" <user@domain> format.

Applies To

Mail Object

See Also

Sender

©2001-2015 Active+ Software . All trademarks property of their owners.


CodePage

Subject

The Subject property specifies the message subject. The Subject property is a shortcut to the Headers("Subject") collection item.

Settings and Return Values

Sets or returns a String value.

Remarks

If the subject contains special characters, they will be encoded using the current codepage.

Example

In the following example, the subject is customized with the receiver's name and the text is based on the receiver's language.

Sub Mail_OnStartRender
If Record.Field("Country") = "France" Then
Mail.Subject = "Relance à l'attention de " & Record.FullName
Else
Mail.Subject = "Billing reminder to the attention of " & Record.FullName
End If
End Sub

Applies To

Mail Object

©2001-2015 eMill . All trademarks property of their owners.


Date

The Date property specifies the message date and time. The Date property is a shortcut to the Headers("Date") collection item.

Settings and Return Values

Sets or returns a Date value. The date may be a Variant of type Date or String. The string may specify a classic date/time format or an rfc822 date/time format. If the time is specified but not the date, the date will be set with the current system date.

Remarks

When a new mail is created, the date property is initialized using the current system date. The time zone used is the system time zone.

Applies To

Mail Object

©2001-2015 eMill . All trademarks property of their owners.


Mail Priority

Priority

The Priority property specifies the message priority. The Priority property is a shortcut to the Headers("X-Priority") collection item.

Settings and Return Values

Sets or returns an Integer value.

Remarks

By default, the optional Priority filled is not set.
Set 1 for very high priority, 3 for normal priority and 5 for very low priority.

Applies To

Mail Object

©2001-2015 eMill . All trademarks property of their owners.


Mail DSNEnvID

DSNEnvID

The DSNEnvID property specifies the message envelope ID as defined in RFC1891.

Settings and Return Values

Sets or returns a String value.

Remarks

The String may contain up to 100 characters (any ASCII characters between "!" (33) and "~" (126), except for "+" and "=")

DSN stands for "Delivery Status Notifications", it is an ESMTP extension that is implemented by most modern SMTP servers. See RFC1891 for details.

Examples

Sub Mail_OnStartRender()
' Save the database contact ID in the ESMTP DSN Envelope-ID to
' update the database later using the DSN message
Mail.DSNEnvID = Record.Fields("ContactID")
Mail.DSNNotify = "SUCCESS,FAILURE"
End Sub

Applies To

Mail Object

©2001-2015 Active+ Software . All trademarks property of their owners.


Mail DSNReturn

DSNReturn

The DSNReturn property specifies whether or not the message should be included in any failed DSN issued for this message transmission.

Settings and Return Values

Sets or returns a String value.

Remarks

The DSNReturn property may be set with on of the following keyword:

FULL requests that the entire message be returned in any "failed"
delivery status notification issued for this recipient.

HDRS requests that only the headers of the message be returned.

The FULL and HDRS keywords may be spelled in any combination of upper
and lower case letters.

DSN stands for "Delivery Status Notifications", it is an ESMTP extension that is implemented by most modern SMTP servers. See RFC1891 for details.

Applies To

Mail Object

©2001-2015 Active+ Software . All trademarks property of their owners.


Mail DSNNotify

DSNNotify

The DSNNotify property specifies whether or not the message should be included in any failed DSN issued for this message transmission.

Settings and Return Values

Sets or returns a String value.

Remarks

The DSNNotify property may be set with on of the following keywords:

NEVER requests that a DSN not be returned to the sender under any conditions
SUCCESS requests that a DSN be issued on successful delivery.
FAILURE requests that a DSN be issued on delivery failure.
DELAY requests that a DSN be issued if the message has been delayed for an unusual amount
of time.

Multiple keywords, separated by commas, may be set; however, the NEVER keyword MUST appear by itself.

DSN stands for "Delivery Status Notifications", it is an ESMTP extension that is implemented by most modern mail servers. See RFC1891 for details.

Applies To

Mail Object

©2001-2015 Active+ Software . All trademarks property of their owners.


Mail DSNType

DSNType

The DSNType property returns whether or not the message is a DSN.

Return Values

Returns an Integer value.

Remarks

The DSNType property may return on of the following values:

0 The message is not a DSN
1 The message is a standard DSN (see RFC1894 for details)
2 The message is a simulated DSN constructed from a non standard failure notification message.

Whenever possible, eMill will try to simulate a DSN message based on various format that older mail server sends out.

DSN stands for "Delivery Status Notifications", it is an ESMTP extension that is implemented by most modern mail servers. See RFC1891 and RFC1894 for details.

Example

Sub Mailing_OnReceiveMail
 If Mail.DSNType<>0 Then ' Remove delivery status notifications messages
Mailing.RemoveReceivedMail
Else ' Forward to sales department
Mail.Receivers.RemoveAll
Mail.Receivers.Add "sales@emilltest.com"
Mailing.SubmitMail Mail
End If
End Sub

Applies To

Mail Object

©2001-2015 Active+ Software . All trademarks property of their owners.


AbortRender

The AbortRender method will abort the rendering process for the current mail.

Syntax

Mail.AbortRender

Parameters
None
Example

Mail_OnStartRender
...
If bSomeFailure Then
Mail.AbortRender
End If
End Sub

Applies To

Mail Object

See Also

Mailing.AbortRender

©2001-2015 eMill . All trademarks property of their owners.


Mail_OnEndRender

The Mail_OnEndRender event occurs when rendering ends for the current receiver.

Syntax

Sub Mail_OnEndRender
. . .
End Sub

Parameters
None
Applies To

Mail Object

See Also

Mail_OnStartRender

©2001-2015 eMill . All trademarks property of their owners.


Mail_OnStartRender

The Mail_OnStartRender event occurs when rendering starts for a mailing receiver. The Mail_OnStartRender event is a good time for you to set any receiver-wide variables, because they will be set before any contents are rendered.

Syntax

Sub Mail_OnStartRender
. . .
End Sub

Parameters
None
Example

Sub Mail_OnStartRender()
' Sets a X-Subscriber-ID: header field
to trace the subscriber if the mail fails
Mail.Headers("X-Subscriber-ID") =
Record.Fields("ContactID")
' Sets that today's subject
Mail.Subject = FormatDateTime(Date,2) & ":
Today's F1 racing news"
' Remove non necessary mail contents
If Record.Fields("PreferredFormat") = "PDF"
Then
Mail.Contents.Remove("HtmlNews")
Mail.Contents.Remove("TextNews")
Else If Record.Fields("PreferredFormat") =
"HTML" Then
Mail.Contents.Remove("PDFNews")
Mail.Contents.Remove("TextNews")
Else ' The subscriber wants a text based email
Mail.Contents.Remove("PDFNews")
Mail.Contents.Remove("HtmlNews")
End If
End Sub
Remarks

Receivers set in the Record object as well as predefined content files will be added before Mail_OnStartRender is called.

Applies To

Mail Object

See Also

Mail_OnEndRender, Mailing_OnStartRender

©2001-2015 eMill . All trademarks property of their owners.


Content Object

You can use the Content object to access information about a Mail content.

Syntax

Content.collection|property|method

Collections
Headers Contains the list of headers field.
Properties
CID | Gets or Sets the MIME content ID.
Data | Gets or Sets the content data.
Type | Gets or Sets the MIME content type.
TransferEncoding | Gets or Sets the MIME transfer encoding.
URL | Gets or Sets the content URL.

Additional content header fields can be set using the Headers collection

Methods
CreateCID | This method will create a unique content identifier
Save | Saves the content to the disk.
See Also

Contents Collection

©2001-2015 eMill . All trademarks property of their owners.


Content Headers Collection

The Content.Headers collection contains all message part headers. The collection can be used to determine the value of a specific header item, or to iterate through the collection and retrieve a list of all items in the message part header. See the Collection Object for standard collection properties and methods.

Syntax

Content.Headers(key|index)[(subkey)]

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
subkey
The identifier for the sub item to return. An empty string will return the primary item.
Remarks

The key should not contain the column character ':'
eMill implements the following internal header fields (these fields will never appear in the MIME encoded mail) :
X-Enabled: Set to 1 if the content should be included in the final rendered message, set to 0 otherwise.
X-Body: Set to 1 if the content is the body part of the message. This property only applies to text/plain and text/html contents. A body part is the part that is first displayed when a message is opened.
X-PDF: Set to 1 if the content should be converted to the Acrobat PDF format. Only text/plain and text/html contents can be converted to PDF.
X-ZIP: Set to 1 if the content should be converted to the ZIP format.
X-Render: Set to 1 if the source contains script to be executed. The script should be within <% and %> delimiters.
X-Wrap-Text: Set to n (76 is the recommended value) to limit the number of characters per line in a text/plain content.
X-Href-Prefix: Specify a prefix to set on all http:// urls in a text/html content. Can be used to implement a URL tracking system.
X-Href-Suffix: Specify a suffix to set on all http:// urls in a text/html content. Can be used to implement a URL tracking system.
X-Embed-Images: Set to 1 if the images referenced in the HTML content should be embedded within the message, set to 0 otherwise.
X-Tracking: Set to 3 to enable openings and clicks tracking, set to 2 to enable clicks tracking, set to 1 to enable openings tracking or set to 0 to disable tracking for this content.
X-Disable-Merge-Fields: Set to 1 to disable merge fields replacement for text contents.

The X-PDF and X-ZIP header fields support a "filename" subkey that can be used to specify the resulting file name. The X-ZIP field support a "password" subkey that can be used to password protect the resulting zip file.

Example

In the following example, a customized Content-Disposition header field is set on the Mail_OnStartRender event

Sub Mail_OnStartRender
With Mail.Contents("Invoice")
.Headers("Content-Disposition") = "attachment"
.Headers("X-PDF") = "1" ' The html invoice will be converted to PDF (Content-Type: application/pdf)
.Headers("X-PDF")("filename") = "Invoice.pdf" ' Optional attribute to specify the PDF filename
End With
End Sub

In the following example, we read the charset from the content type using a subkey

If the "Content-Type" contains: "text/html; charset=iso-8859-1"
Mail.Contents("NewsLetter").Headers("Content-Type")("charset")
    ' Returns iso-8859-1
Mail.Contents("NewsLetter").Headers("Content-Type")("")
    ' Returns text/html
Mail.Contents("NewsLetter").Headers("Content-Type") '
    Returns text/html; charset=iso-8859-1

Applies To

Content Object

©2001-2015 eMill. All trademarks property of their owners.


CID

The CID property sets or gets the content identifier.

Settings and Return Values

Sets or returns a String value.

Remarks

A CID should only be set if the content is referenced in a URI of a text/html content type.

Example

Code in the Mail_OnStartRender handler:

Mail.Contents.Add("chart")
Mail.Contents("chart").URL = "http://www.emilltest.com/chartapp/renderpie.asp?v1=12&v2=38&v3=50"
Mail.Contents("chart").CreateCID

Some content:

<body>
See the following pie chart: <img src=<%="CID:" & Mail.Contents("chart").CID%>>
</body>

Applies To

Content Object

See Also

Contents Collection

©2001-2015 eMill . All trademarks property of their owners.


Data

The Data property sets or gets the content data.

Settings and Return Values

Sets or returns a Variant of subtype String if the Content Type is text based (text/*) or a Variant of subtype Array of Byte if the data is binary.

Remarks

The Data property cannot be set if the URL property is set.

Example

Mail.Contents("Body").Type = "text/html"
Mail.Contents("Body").Data = "Hello<BR>What's the weather like today?<BR>Regards,<BR>John<BR>"
Mail.Contents("Body").TransferEncoding = "quoted-printable"

Applies To

Content Object

See Also

URL, Type, TransferEncoding

©2001-2015 eMill . All trademarks property of their owners.


Type

The Type property sets or gets the MIME content type and sub type.

Settings and Return Values

Sets or returns a String value.

Remarks

Click here to see a list of MIME Content Types

Applies To

Content Object

See Also

TransferEncoding

©2001-2015 eMill . All trademarks property of their owners.


TransferEncoding

The TransferEncoding property sets or gets the MIME transfer encoding.

Settings and Return Values

Sets or returns a String value.

Remarks

eMill supports the following transfer encoding:
base64
quoted-printable
8bit
7bit

base64 encoding will work with any kind Content Type
quoted-printable, 8bit and 7bit should be used with text/ based contents

Setting the property to Auto will instruct eMill to compute the best possible encoding for the content.

Applies To

Content Object

See Also

Type

©2001-2015 eMill . All trademarks property of their owners.


URL

The URL property sets or gets the content path. The URL property is the default Content Object property.

Settings and Return Values

Sets or returns a String value.

Remarks

The path can be absolute or relative to the project root path, and can specify any types of files including Unicode text files.
Parameters can be passed to any script enabled content file using a question mark. E.g. file.vbs?id=12345678
The Server.URLEncode method can be used to encode parameters (parameters with spaces, etc.).
If the path is set to an http URL, the Content object will dynamically fetch the data from a web server.

Examples

Mail.Contents("News") = "c:\newsletter\20010601.html"
Mail.Contents("News").TransferEncoding = "base64"

Mail.Contents("PieChart") = "http://www.emilltest.com/chartapp/renderpie.asp?v1=12&v2=38&v3=50"
Mail.Contents("PieChart").TransferEncoding = "base64"

Applies To

Content Object

See Also

Contents Collection, Request.QueryString , Server.URLEncode

©2001-2015 eMill . All trademarks property of their owners.


CreateCID

The CreateCID method will create and set a unique content identifier.

Syntax

Content.CreateCID

Parameters
None
Remarks

If a CID is already set in the content, the CID will be replaced with the new CID.

Applies To

Content Object

See Also

CID

©2001-2015 eMill . All trademarks property of their owners.


Save

The Save method will create and set a unique content identifier.

Syntax

Content.Save(FileName)

Parameters
FileName
A String specifying the new filename for the content to be saved.
Remarks

If the file already exists, the file will be overwritten.

Applies To

Content Object

See Also

Mail.Save

©2001-2015 eMill . All trademarks property of their owners.


Record Object

You can use the Record object at render time to access the current DataSource record fields.

Syntax

Record.collection|property|method

Collections
Fields Contains the list of field if the record
Properties
SentenceCase | Sets or Gets how the receiver name should be formatted.
Trim | Sets or Gets how record fields are trimmed.
EmailAddress | Gets the displayable email address.
Email | Gets the email address.
FullName | Gets the full name.
FirstName | Gets the first name.
LastName | Gets the last name.
Fax | Gets the fax number.
Mobile | Gets the mobile phone number.
Remarks

The Record field is initialized by the DataSource object. Calculated Properties (EmailAddress, Email, FullName, etc.) will be automatically set before Mail_OnStartRender gets called.

Example

<html>
Dear <%=Record.FirstName%><br>
I was wondering about what the weather's like in <%=Record.Fields("City")%>?<br>
Regards,<br>
<%=Record.Fields("AccountManager")%>
</html>

See Also

DataSource Object

©2001-2015 eMill . All trademarks property of their owners.


Record Fields Collection

The Fields collection contains all record fields for the current receiver.

Syntax

Item = Record.Fields(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Field object properties
Name | Gets or sets the record field name.
Value | Gets or sets the record field value. This is the default property.
Type | Gets or sets the record field ADO type.
DefinedSize | Gets or sets the record field size.
Attributes | Gets or sets the record field ADO attributes.
Changed | Gets or sets the record field Changed value. When the record value is modified, Changed is automatically set to TRUE.
BaseTable | Gets or sets the record field base table. Can be empty if the field does not come from a database column.
BaseColum | Gets or sets the record field base column. Can be empty if the field does not come from a database column.
Remarks

Field properties are automatically set by eMill during the rendering process. However, when using Global Script to access data source, it is up to the global script to fill these properties.

See the Collection Object for standard collection properties and methods.

Examples

The following example will list all the fields in a record

For Each item In Record.Fields
sFieldName = item.Name
sFieldValue = item.Value
Next

The following example gets a specific field value

sFieldValue = Record.Fields("ZipCode")

Applies To

Record Object

See Also

DataSource Object

©2001-2015 eMill . All trademarks property of their owners.


Record.SentenceCase

SentenceCase

The SentenceCase property specifies how the receiver name is formatted.

Settings and Return Values

Sets or returns a Boolean Value.

Remarks

Set to True to have the first letter of each word in upper case and the following letters in lowercase, set to False to leave unchanged.

Examples

In the following examples the SentenceCase property is to True

Record: FullName="jim smith"
Result: "Jim Smith"

Record: FullName="jean-baptiste DURAND"
Result: "Jean-Baptiste Durand"

Applies To

Record Object

©2001-2015 eMill . All trademarks property of their owners.


Record.LastName

LastName

The LastName property returns the receiver first name.

Return Value
Returns a String value.
Applies To

Record Object

©2001-2015 eMill . All trademarks property of their owners.


Record.EmailAddress

EmailAddress

The EmailAddress property returns a displayable email address.

Return Value
Returns a String value.
Examples

Record: Email="jim@emilltest.com" FirstName="Jim" LastName="Smith"
Result: "Jim Smith" <jim@emilltest.com>

Record: Email="jim@emilltest.com" FirstName="" LastName=""
Result: jim@emilltest.com

Applies To

Record Object

See Also

Email

©2001-2015 eMill . All trademarks property of their owners.


Record.Email

Email

The Email property returns the email part of an email address.

Syntax

=Record.Email

Return Value
A String that specify an email address
Examples

Record: Email='<jim@emilltest.com>'
Result: jim@emilltest.com

Record: Email='"Jim Smith" <jim@emilltest.com>'
Result: jim@emilltest.com

Record: Email='mailto:jim@emilltest.com'
Result: jim@emilltest.com

Applies To

Record Object

See Also

EmailAddress

©2001-2015 eMill . All trademarks property of their owners.


Record.FullName

FullName

The FullName property returns the receiver full name.

Return Value
Returns a String value.
Applies To

Record Object

©2001-2015 eMill . All trademarks property of their owners.


Record.FirstName

FirstName

The FirstName property returns the receiver first name.

Return Value
Returns a String value.
Applies To

Record Object

©2001-2015 eMill . All trademarks property of their owners.


Record.Trim

Trim

The Trim property specifies if fields are trimmed or not.

Settings and Return Values

Sets or returns a Boolean Value.

Remarks

Set to True to remove both leading and trailing spaces from all record fields, set to False to leave unchanged. The default value is True.

Applies To

Record Object

©2001-2015 eMill . All trademarks property of their owners.


Application Object

You can use the Application object to share information among all session of a given mailing project.

Syntax

Application.collection

Collections
Contents Contains all of the items that have been added to the application through script commands.
Remarks

You can store values in the Application Collections. Information stored in the Application collections is available throughout the mailing session.

Example
Sub Mailing_OnStartRender
  Application("ReceiverCount") = 0
End Sub
Sub Mail_OnStartRender
  Application("ReceiverCount") = Application("ReceiverCount") + 1
End Sub
' Some content
<%
  Response.Write "Receiver # " & Application("ReceiverCount") & "<br>"
%>
See Also

Session Object

©2001-2015 eMill . All trademarks property of their owners.


Application Contents Collection

The Contents collection contains all the items that have been added to the application through a script command. Information stored in the Application collections is available throughout the mailing session. You can use the Contents collection to obtain a list of items that have been given application scope, or to specify a particular item to be the target of an operation. See the Collection Object for standard collection properties and methods.

Syntax

Item = Application.Contents(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Settings and Return Values

Sets or returns a Variant value.

Remarks

The Contents collection is the Application object implicit collection. Therefore you do not need to specify .Contents when accessing the collection.

Example

Application("SomeValue") = "13456789"

Applies To

Application Object

See Also

Session Contents Collection

©2001-2015 eMill . All trademarks property of their owners.


Request Object

The Request object retrieves the values that the client browser passed to the server during an HTTP request.

Syntax

Request[.collection|property|method](variable)

Collections
QueryString | The values of variables in the HTTP query string.
ServerVariables | The values of predetermined environment variables.

Variable parameters are strings that specify the item to be retrieved from a collection or to be used as input for a method or property. For more information about the variable parameter, see the individual collection descriptions.

Remarks

If the specified variable is not in one of the preceding five collections, the Request object returns EMPTY.

All variables can be accessed directly by calling Request(variable) without the collection name. In this case, eMill searches the collections in the following order.

  1. QueryString
  2. ServerVariables

If a variable with the same name exists in more than one collection, the Request object returns the first instance that the object encounters.

It is strongly recommended that when referring to members of a collection the full name is used. For example, rather than Request.(SERVER_NAME) use Request.ServerVariables(SERVER_NAME). This will allow the server to locate the item more quickly.

See Also

Response Object

©2001-2015 eMill . All trademarks property of their owners.


QueryString

The QueryString collection retrieves the values of the variables in the content query string. The content query string is specified by the values following the question mark (?). Several different processes can generate a query string. For example, the anchor tag

<A HREF= "invoice.vbs?id=12345678">Click here to open your invoice</A>

generates a variable named id with the value "12345678"

Syntax

Request.QueryString(variable)[(index)|.Count]

Parameters
variable
Specifies the name of the variable in the content query string to retrieve.
index
An optional parameter that enables you to retrieve one of multiple values for variable. It can be any integer value in the range 1 to Request.QueryString(variable).Count.
Remarks

The QueryString collection is a parsed version of the QUERY_STRING variable in the ServerVariables collection. It enables you to retrieve the QUERY_STRING variable by name. The value of Request.QueryString(parameter) is an array of all of the values of parameter that occur in QUERY_STRING. You can determine the number of values of a parameter by calling Request.QueryString(parameter).Count. If a variable does not have multiple data sets associated with it, the count is 1. If the variable is not found, the count is 0.

To reference a QueryString variable in one of multiple data sets, you specify a value for index. The index parameter can be any value between 1 and Request.QueryString(variable).Count. If you reference one of multiple QueryString variables without specifying a value for index, the data is returned as a comma-delimited string.

When you use parameters with Request.QueryString, the server parses the parameters sent to the request and returns the specified data. If your application requires unparsed QueryString data, you can retrieve it by calling Request.QueryString without any parameters.

Example

The mail body links to the invoice content

invoice.vbs?id=12345678
results in the following Request.QueryString("id") value:
12345678

If the following script is used:

The unparsed query string is: <%=Request.QueryString%>
The output would be
The unparsed query string is: id=12345678
Applies To

Request Object

See Also

ServerVariables

©2001-2015 eMill . All trademarks property of their owners.


ServerVariables

The ServerVariables collection retrieves the values of predetermined server environment variables.

Syntax

Request.ServerVariables (server environment variable)

Parameters
server environment variable
Specifies the name of the server environment variable to retrieve. It can be one of the following values.
Variable | Description
APPL_PHYSICAL_PATH | Retrieves the physical path corresponding to the metabase path. IIS converts the APPL_MD_PATH to the physical (directory) path to return this value.
PROJECT_PATH | Returns the path to the published project.
CONTENT_NAME | Returns the name of the current content.
HIT_DATE | [Tracking only] Return the date of the click or open event.
HTTP_REFERER | [Tracking only] Returns a string containing the URL of the page that referred the request to the redirector.
HTTP_USER_AGENT | [Tracking only] Returns a string describing the client mail software that sent the request.
LOGON_USER | The Windows account that the user is logged into.
PATH_INFO | Extra path information as given by the client. You can access scripts by using their virtual path and the PATH_INFO server variable. If this information comes from a URL, it is decoded by the server before it is passed to the CGI script.
PATH_TRANSLATED | A translated version of PATH_INFO that takes the path and performs any necessary virtual-to-physical mapping.
QUERY_STRING | Query information stored in the string following the question mark (?) in the HTTP request.
REMOTE_ADDR | [Tracking only] Returns the IP address of the receiver who as clicked on the link.
SCRIPT_NAME | Gives the base portion of the script being executed.
SERVER_NAME | The server's host name, DNS alias, or IP address as it would appear in self-referencing URLs.
SERVER_SOFTWARE | The name and version of the server software that answers the request and runs the gateway. The format is name/version.
URL Gives the base portion of the URL.
[Tracking] Returns a string containing either open when a message is open or the link URL when a link is clicked.
URL_NAME | Gives the name of the link that has been clicked, or an empty string if the link does not have a name.

Example

This example uses the For Each loop to iterate through each existing server variable name. Some will be empty if you have Anonymous Access enabled. The following script prints out all of the server variables in a table:

<TABLE BORDER="1">
<TR><TD><B>Server Variable</B></TD><TD><B>Value</B></TD></TR>
<% For Each strKey In Request.ServerVariables %>
<TR>
<TD><%= strKey %></TD>
<TD><%= Request.ServerVariables(strKey) %></TD>
</TR>
<% Next %>
</TABLE>
Applies To

Request Object

See Also

QueryString

©2001-2015 eMill . All trademarks property of their owners.


Response Object

You can use the Response object to send output to the rendered content.

Syntax

Response.collection|property|method

Properties
Charset | Sets the MIME part charset header. The character set tells the mail client how to display characters.
CodePage | Sets the Codepage for data in the intrinsic objects for one response. The codepage tells eMill how to encode characters for different languages.
ContentType | Specifies the MIME part content type for the response.
LCID | Sets the LCID for data for one response. The LCID refers to how dates, times, and currency are formatted for a specific geographical locale.
Methods
AddHeader | Adds MIME part header name to value.
BinaryWrite | Writes the given information to the current content output without any character-set conversion.
Clear | Erases any buffered content output.
End | Stops processing the content file and returns the current result.
Flush | Sends buffered output immediately.
Write | Writes a variable or text to the current content output as a string.
See Also

Request Object

©2001-2015 eMill . All trademarks property of their owners.


Charset

The Charset property appends the name of the character set (for example, ISO-LATIN-7) to the Content-Type header in the response object. Setting the CodePage will automatically set the Charset. To specify a specific charset, the Charset property should be set after the CodePage property.

Settings and Return Values

Sets or returns a String value.

Remarks

This function sets any string in the MIME part header, regardless of whether it represents a valid character set or not.

Applies To

Response Object

See Also

CodePage

©2001-2015 eMill . All trademarks property of their owners.


CodePage

The CodePage property specifies how strings are encoded in the intrinsic objects. A code page is a character set that can include numbers, punctuation marks, and other glyphs. Codepages are not the same for each language. Some languages such as Japanese and Korean have multi-byte characters, while others like English and German only need one byte to represent each character. The CodePage property is read/write.

Settings and Return Values

Sets or returns an Integer value.

Remarks

Setting Response.CodePage explicitly affects the current content, where Mail.CodePage affects all content of a mail message.
Settings the CodePage will automatically set the corresponding Charset, however the Charset can be specifically specified if needed.
You can find codepage values at MSDN Web Workshop under the column for FamilyCodePage.

Applies To

Response Object

See Also

Charset , Mail.CodePage, Mailing.CodePage

©2001-2015 eMill . All trademarks property of their owners.


ContentType

The ContentType property specifies the HTTP content type for the response. If no ContentType is specified, the default comes from the content which is rendering.

Settings and Return Values

Sets or returns a String value.

Remarks

The ContentType string is usually formatted type/subtype where type is the general content category and subtype is the specific content type. For a full list of supported content types, see your Web browser documentation or the current HTTP specification.

Example

The following example sets the content type to JPEG image.

<% Response.ContentType = "image/jpeg" %>

The following examples set the ContentType property to other common values.

<% Response.ContentType = "text/html" %>
<% Response.ContentType = "image/GIF" %>
<% Response.ContentType = "text/plain" %>
Applies To

Response Object

©2001-2015 eMill . All trademarks property of their owners.


LCID

The LCID property specifies how dates, times, and currencies are formatted. LCIDs are not the same for each geographical locale. Some locales format dates as YY-MM-DD and some format dates as MM-DD-YYYY. The LCID property is read/write.

Settings and Return Values

Sets or returns an Integer value.

Remarks

Setting Response.LCID explicitly affects the current content, where Mail.LCID affects all contents of a mail message.

Response.LCID can be set multiple times in one content, and the date can be displayed each time; however, the codepage must be set once to show all the characters.

You can find locale integers at MSDN Library.

Example

The following example displays. The home page is saved in UTF-8 format so characters from all languages can be shown.

--- Content_Response_LCID.vbs ---

Response.Codepage = 65001
Response.Charset = "utf-8"

ShowDateTimeCurrency 1033, "North America"
ShowDateTimeCurrency 1041, "Japan"
ShowDateTimeCurrency 1049, "Russia"
ShowDateTimeCurrency 1031, "Germany"
ShowDateTimeCurrency 1025, "Saudi Arabia"
ShowDateTimeCurrency 1081, "India"
ShowDateTimeCurrency 2052, "China"
ShowDateTimeCurrency 1042, "Korea"

Sub ShowDateTimeCurrency(iLCID, sLocale)
  Response.LCID = iLCID
  Response.Write "<B>" & sLocale & "</B><BR>"
  Response.Write FormatDateTime(Date, 1) & "<BR>"
  Response.Write FormatDateTime(Time, 3) & "<BR>"
  Response.Write FormatCurrency(1000) & "<BR>"
  Response.Write FormatNumber(50, 3, 0, 0, -1) & " & " & FormatNumber(.02, 3, 0, 0, -1) & "<BR><BR>"
End Sub
Applies To

Response Object

See Also

CodePage , Charset

©2001-2015 eMill . All trademarks property of their owners.


AddHeader

The AddHeader method adds a new MIME header and value to the rendered content. It does not replace an existing header of the same name. Once a header has been added, it cannot be removed.

Syntax

Response.AddHeader name, value

Parameters
name
A string that indicates the name of the new header.
value
A string that indicates the initial value of the new header.
Example

You can use AddHeader to embed some internal data that may be needed at a later time (mail forwarding, etc.)

<% Response.Addheader "X-Invoice-ID", "12345678" %>
Applies To

Response Object

©2001-2015 eMill . All trademarks property of their owners.


BinaryWrite

The BinaryWrite method writes the specified information to the current content output without any character conversion. This method is useful for writing non-string information such as binary data required by a custom application.

Syntax

Response.BinaryWrite data

Parameters
data
The data to write to the content output. This parameter will be of type VT_ARRAY | VT_UI1, which is a variant array of unsigned one-byte characters.
Example

If you have an object that generates an array of bytes, you can use the following call to BinaryWrite to send the bytes to a custom application.

<%
  Set objBinaryGen = Server.CreateObject("ChartGenerator.Pie")
  vntPicture = objBinaryGen.MakeChart
  Response.ContentType = "image/gif"
  Response.BinaryWrite vntPicture
%>
Applies To

Response Object

See Also

Write

©2001-2015 eMill . All trademarks property of their owners.


Clear

The Clear method erases any buffered output. However, the Clear method erases only the response body; it does not erase response headers. You can use this method to handle error cases.

Syntax

Response.Clear

Applies To

Response Object

See Also

End, Flush

©2001-2015 eMill . All trademarks property of their owners.


End

The End method causes eMill to stop processing the script and return the current result. The remaining contents of the file are not processed.

Syntax

Response.End

Applies To

Response Object

See Also

Clear, Mail.AbortRender

©2001-2015 eMill . All trademarks property of their owners.


Flush

The Flush method sends buffered output immediately to the disk.

Syntax

Response.Flush

Applies To

Response Object

©2001-2015 eMill . All trademarks property of their owners.


Write

The Write method writes a specified string to the current content output.

Syntax

Response.Write variant

Parameters
variant
The data to write. This parameter can be any data type supported by the Visual Basic Scripting Edition VARIANT data type, including characters, strings, and integers.
Notes

If you do not want to use the default language codepage, output from Response.Write can be encoded using different codepages by setting Response.CodePage, Session.CodePage. For more information, see CodePage and Charset.

Example

The following example uses the Response.Write method and plain HTML to send output to the client.

<H3 align=center>The date is <% Response.Write Date %> <BR>

The following example uses <%= instead of Response.Write.

The date is: <%= Date %> <BR>

The following example adds an HTML tag to the Web page output. Because the string returned by the Write method cannot contain the character combination %>, the escape %\> has been used instead. The following script

<% Response.Write "<TABLE WIDTH = 100%\>" %>

Produces the output:

<TABLE WIDTH = 100%>
Applies To

Response Object

See Also

BinaryWrite, Charset, CodePage.

©2001-2015 eMill . All trademarks property of their owners.


Server Object

The Server object provides access to methods and properties on the server. Most of these methods and properties serve as utility functions.

Syntax

Server.property|method

Properties
ScriptTimeout The amount of time that a script can run before it times out.
Methods
CreateObject | Creates an instance of a server component.
Execute | Executes an .asp file.
HTMLEncode | Applies HTML encoding to the specified string.
MapPath | Maps the specified virtual path, either the absolute path on the current server or the path relative to the current page, into a physical path.
Transfer | Sends all of the current state information to another script enabled file for processing.
URLEncode | Applies URL encoding rules, including escape characters, to the string.

©2001-2015 eMill . All trademarks property of their owners.


ScriptTimeout

The ScriptTimeout property specifies the maximum amount of seconds a script can run before it is terminated.

The timeout will not take effect while a server component is processing.

Settings and Return Values

Sets or returns an Integer value.

Remarks
Specifies the maximum number of seconds that a script can run before the server terminates it. The default value is 90 seconds.
Example

The following example causes scripts to time out if the server takes longer than 100 seconds to process them:

<% Server.ScriptTimeout = 100 %>

The following example retrieves the current value of the ScriptTimeout property and stores it in the variable TimeOut.

<% TimeOut = Server.ScriptTimeout %>
Applies To

Server Object

©2001-2015 eMill . All trademarks property of their owners.


CreateObject

The CreateObject method creates an instance of a server component.

Syntax

Server.CreateObject( progID )

Parameters
progID
Specifies the type of object to create. The format for progID is [Vendor.]Component[.Version].
Remarks

By default, objects created by the Server.CreateObject method have content file scope. This means that they are automatically destroyed by the server when it finishes processing the current content file.

Example
<% Set MyChart = Server.CreateObject("SuperChart.Pie") %>

The preceding example creates a server component, MyChart, as a SuperChart.Pie component that can be used to render a pie chart within an html content.

Applies To

Server Object

©2001-2015 eMill . All trademarks property of their owners.


Execute

The Execute method calls a script enabled content file and processes it as if it were part of the calling script. The Execute method is similar to a procedure call in many programming languages.

Syntax

Server.Execute( Path )

Parameters
Path
A string specifying the location of a script enabled content file to execute. The Path parameter may be for either an absolute or a relative path.
Remarks

The Server.Execute method provides a way of dividing a complex application into individual modules. By employing the Server.Execute method, you can develop a library of .vbs files that you can call as needed. This approach is an alternative to server-side includes. The major difference is that you can dynamically call a script enabled file with Server.Execute.

After eMill processes the script enabled content file specified in the input parameter to Server.Execute, the response is returned to the calling script.

Collections and properties available to the executed file are:

  • Application variables, even if they are set in the calling page.
  • Session properties, even if they are set in the calling page.
  • Server variables and properties, even if they are set in the calling page.
  • Request collections and properties, even if they are set in the calling page. This includes Form and QueryString data passed to the calling page.
  • Response collections and properties. The executed .asp file may modify HTTP headers. However, as with any .asp file, if the executed .asp file attempts to modify HTTP headers after it sends a response to the client, it will generate an error.

If a file is included in the calling page with #include, the executed .asp will not see it. For example, you may have a subroutine in a file that is included in your calling page, but the executed .asp will not recognize the subroutine name. You must include the file in each executed .asp that requires the subroutine.

If either the calling or called .asp file contains a transaction directive, the status of the transaction will apply to the .asp file that contains the directive. For example, if ASP1 below calls ASP2 and the transaction is aborted while ASP2 is being processed, ASP2's OnTransactionAbort (if present) will be called. After ASP2 completes processing, ASP1's OnTransactionAbort (if present) will be called.

ASP1:
<%@ Transaction=Required %>
<%
  Server.Execute ("ASP2.asp")
  Sub OnTransactionAbort
  Sub OnTransactionCommit
%>

ASP2.asp:
<%@ Transaction=Required %>
<%
  Sub OnTransactionAbort
  Sub OnTransactionCommit
%>
Example

In the following example, the browser language determines which .asp file is executed. The output from these scripts on a US system is:

Company Name

Welcome to my website!

The output from these scripts on a German system is:

Company Name

Willkommen zu meinem website!

The output from these scripts on a Spanish system is:

Company Name

Recepción a mi website!

(Languages with multi-byte characters have not been included in this example because CodePage incompatibilities.)

Welcome.asp

<HTML>
<BODY>
<H1>Company Name</H1>
<%
  AcceptLang = Request.ServerVariables("HTTP_ACCEPT_LANGUAGE")
  Lang = Left(AcceptLang, 2)
  Server.Execute(Lang & "Welcome.asp")
%>
</BODY>
</HTML>

enWelcome.asp

<% Response.Write "Welcome to my website!" %>

deWelcome.asp

<% Response.Write "Willkommen zu meinem website!" %>

esWelcome.asp

<% Response.Write "Recepción a mi website!" %>
Applies to

Server Object

See Also

Transfer

©2001-2015 eMill . All trademarks property of their owners.


HTMLEncode

The HTMLEncode method applies HTML encoding to a specified string.

Syntax

Server.HTMLEncode( string )

Parameters
string
Specifies the string to encode.
Example

The following script

<%= Server.HTMLEncode("The bold tag: <B>") %>

Produces the output:

The bold tag: &lt;B&gt;
Applies To

Server Object

See Also

URLEncode

©2001-2015 eMill . All trademarks property of their owners.


MapPath

The MapPath method maps the specified relative path to the corresponding physical directory on the server.

Syntax

Server.MapPath( Path )

Parameters
Path
Specifies the relative path to map to a physical directory. If Path starts with either a forward (/) or backward slash (\), the MapPath method returns a path as if Path is a full path. If Path doesn't start with a slash, the MapPath method returns a path relative to the directory of the content file being processed.
Remarks

The MapPath method does not check whether the path it returns is valid or exists on the server.

Because the MapPath method maps a path regardless of whether the specified directories currently exist, you can use the MapPath method to map a path to a physical directory structure, and then pass that path to a component that creates the specified directory or file on the server.

Example

For the examples below, the file data.txt is located in the directory, C:\Inetpub\Wwwroot\Script, as is the test.asp file that contains the following scripts. The C:\Inetpub\Wwwroot directory is set as the server's home directory.

The following example uses the server variable PATH_INFO to map the physical path of the current file.

<%= Server.MapPath(Request.ServerVariables("PATH_INFO"))%><BR>

The preceding script produces the output

c:\inetpub\wwwroot\script\test.asp<BR>

Because the path parameters in the following examples do not start with a slash character, they are mapped relative to the current directory, in this case C:\Inetpub\Wwwroot\Script.

<%= Server.MapPath("data.txt")%><BR>
<%= Server.MapPath("script/data.txt")%><BR>

The preceding scripts produce the following output

c:\inetpub\wwwroot\script\data.txt<BR>
c:\inetpub\wwwroot\script\script\data.txt<BR>

The next two examples use the slash characters to specify that the path returned should be looked up as complete virtual paths on the server.

<%= Server.MapPath("/script/data.txt")%><BR>
<%= Server.MapPath("\script")%><BR>

The preceding scripts produce the following output

c:\inetpub\wwwroot\script\data.txt<BR>
c:\inetpub\wwwroot\script<BR>

The following examples demonstrate how you can use either a forward slash (/) or a backslash (\) to return the physical path to the home directory of the Web site root.

<%= Server.MapPath("/")%><BR>
<%= Server.MapPath("\")%><BR>

The preceding scripts produce the following output

c:\inetpub\wwwroot<BR>
c:\inetpub\wwwroot<BR>

The following examples demonstrate how you can use relative pathing to return the relative physical path to the page that is being viewed in the Web browser.

<%= Server.MapPath("../")%><BR>
<%= Server.MapPath("..\")%><BR>
Applies To

Server Object

©2001-2015 eMill . All trademarks property of their owners.


Transfer

The transfer method sends all of the information that has been assembled for processing by one script enabled content file to a second script enabled content file.

Syntax

Server.Transfer (path)

Parameters
Path
The location of a script enabled content file file to which control should be transferred.
Remarks

When you call Server.Transfer, the state information for all the built-in objects will be included in the transfer. This means that any variables or objects that have been assigned a value in session or application scope will be maintained. In addition, all of the current contents for the request collections will be available to the .asp file receiving the transfer.

If the path you specify in the input parameter is for an .asp file in another application, the .asp file will execute as if it were in the application that contains the Server.Transfer command. In other words, all variables and objects that have been given application scope either by other .asp files in the application or by the application's Global.asa file will be available to the called .asp file. However, the path parameter must not contain an query string or ASP returns an error.

Server.Transfer acts as an efficient replacement for Response.Redirect. Response.Redirect tells the browser to request a different page. Since a redirect forces a new page request, the browser has to make two round trips to the Web server, and the Web server has to handle an extra request. IIS 5.0 introduced a new function, Server.Transfer, which transfers execution to a different ASP page on the server. This avoids the extra round trip, resulting in better overall system performance, as well as a better user experience.

Example

The following example demonstrates transferring from one .asp file to another, as well as sending the session identifier to the client.

The output from these scripts will be:

A session ID

I am going to ASP2

The same session ID

ASP1

<HTML><BODY><%  Dim sessvar1  Response.Write Session.SessionID
  Response.Write ("<BR>")
  Response.Write("I am going to ASP2 <BR>")
  Server.Transfer("/Myasps/ASP2.asp")
%>

ASP2

<HTML>

<BODY><% Response.Write Session.SessionID %></BODY></HTML>

Applies To

Server Object

See Also

Execute, Application Object

©2001-2015 eMill . All trademarks property of their owners.


URLEncode

The URLEncode method applies URL encoding rules, including escape characters, to a specified string.

Syntax

Server.URLEncode( string )

Parameters
string
Specifies the string to encode.
Example

The following script

<%Response.Write(Server.URLEncode("http://www.activeplus.com"))%>

Produces the output:

http%3A%2F%2Fwww%2Eactiveplus%2Ecom
Remarks

See RFC2396 for more details about how to encode a URL.

Applies To

Server Object

See Also

HTMLEncode

©2001-2015 eMill . All trademarks property of their owners.


Session Object

You can use the Session object to store information needed during rendering for a particular receiver. Variables stored in the Session object are available within all content files when rendering a receiver.

Syntax

Session.collection|property|method

Collections
Contents Contains the items that you have added to the session with script commands.
Remarks

You can store values in the Session object. Information stored in the Session object is available during rendering of a particular receiver.

Example

The following script demonstrates storage of two types of variables.

Sub Mail_OnStartRender()
  Session("username") = "Michelle"
  Session("age") = 22
End Sub
See Also

Application Object

©2001-2015 eMill . All trademarks property of their owners.


Soap Object

You can use the Soap object to call a web service method through the SOAP protocol.

Syntax

Soap.property|method

Properties
Version | Contains the SOAP protocol version to use.
Url | Contains the web service URL.
Namespace | Contains the web service namespace.
UserName | Contains the user name used to authenticate eMill during the method call.
Password | Contains the password used to authenticate eMill during the method call.
Methods
CreateObject | Creates and returns a new standalone Soap object.
CreateParams | Creates and returns a Params object used to pass web service method parameters.
Call | Calls the web service method and return the method result.
Remarks

The Soap object properties are read only. When rendering a mailing, these properties are initialized with the active list corresponding parameters (if this list is a SOAP based XML list). If the active list is not a SOAP based XML list or if the Soap object is used out of a mailing render context, any attempt to call Call will generate an error.
The properties of the standalone Soap objects returned by CreateObject are not read only. They must be initialized before calling Call. The standalone Soap objects can be used in every eMill script.

©2001-2015 eMill . All trademarks property of their owners.


Version property

Version

The Version property sets or gets the SOAP protocol version to use. This property can be set either with the value "1.1" or "1.2". Default value is "1.2".

Settings and Return Values

Sets or returns a String value.

Remarks

The Version property can only be set to standalone Soap object.

Example
            Set oSoap = soap.CreateObject
oSoap.Version = "1.1"     'Force
            usage of SOAP protocol version 1.1
oSoap.Url = "http://optin.emill.net/service/services/list.asmx"
oSoap.Namespace = "http://optin.emill.net/service/services"
oSoap.UserName = "test_account@emilltest.com"
oSoap.Password = "pwd"
Set oXmlNode = oSoap.Call("GetLists",, 2)
Applies To
Soap Object
See Also

Url, Namespace, UserName, Password

©2001-2015 eMill . All trademarks property of their owners.


Url property

Url

The Url property sets or gets the Soap web service URL.

Settings and Return Values

Sets or returns a String value.

Remarks

The Url property can only be set to standalone Soap object.

Example
Set oSoap = soap.CreateObject
Set oParams = soap.CreateParams("listId", "2319f42-ab2d-9278-691c-d61cf42ec2dfe")
oSoap.Url = "http://optin.emill.net/service/services/list.asmx"
oSoap.Namespace = "http://optin.emill.net/service/services"
oSoap.UserName = "test_account@emilltest.com"
oSoap.Password = "pwd"
Set oRst = oSoap.Call("GetList", oParams)
Applies To
Soap Object
See Also

Version, Namespace, UserName, Password

©2001-2015 eMill . All trademarks property of their owners.


Namespace property

Namespace

The Namespace property sets or gets the Soap web service namespace.

Settings and Return Values

Sets or returns a String value.

Remarks

The Namespace property can only be set to standalone Soap object. If this properties is empty, it will default to the Url property value.

Example
Set oSoap = soap.CreateObject
Set oParams = soap.CreateParams
oSoap.Url = "http://optin.emill.net/service/services/list.asmx"
oSoap.Namespace = "http://optin.emill.net/service/services"
oSoap.UserName = "test_account@emilltest.com"
oSoap.Password = "pwd"
oParams.Add "listId", "2319f42-ab2d-9278-691c-d61cf42ec2dfe"
Set oRst = oSoap.Call("GetList", oParams)
Applies To
Soap Object
See Also

Version, Url, UserName, Password

©2001-2015 eMill . All trademarks property of their owners.


UserName property

UserName

The UserName property sets or gets the user name value used to authenticate eMill during the method call.

Settings and Return Values

Sets or returns a String value.

Remarks

The UserName property can only be set to standalone Soap object.

Example
Set oSoap = soap.CreateObject
oSoap.Url = "http://optin.emill.net/service/services/list.asmx"
oSoap.Namespace = "http://optin.emill.net/service/services"
oSoap.UserName = "test_account@emilltest.com"
oSoap.Password = "pwd"
Set oRst = oSoap.Call("GetList", soap.CreateParams("listId", "2319f42-ab2d-9278-691c-d61cf42ec2dfe"))
Applies To
Soap Object
See Also

Version, Url, Namespace, Password

©2001-2015 eMill . All trademarks property of their owners.


Password property

Password

The Password property sets or gets the password value used to authenticate eMill during the method call.

Settings and Return Values

Sets or returns a String value.

Remarks

The Password property can only be set to standalone Soap object.

Example
Set oSoap = soap.CreateObject
oSoap.Url = "http://optin.emill.net/service/services/list.asmx"
oSoap.Namespace = "http://optin.emill.net/service/services"
oSoap.UserName = "test_account@emilltest.com"
oSoap.Password = "pwd"
Set oXmlNode = oSoap.Call("GetLists",, 2)
Applies To
Soap Object
See Also

Version, Url, Namespace, UserName

©2001-2015 eMill . All trademarks property of their owners.


CreateObject method

CreateObject

The CreateObject method creates a new standalone Soap object.

Syntax

Soap.CreateObject

Return value

A new standalone Soap object.

Remarks

The new Soap object properties are not read-only and must be initialized before calling Call.

Example
Set oSoap = soap.CreateObject
oSoap.Url = "http://optin.emill.net/service/services/list.asmx"
oSoap.Namespace = "http://optin.emill.net/service/services"
oSoap.UserName = "test_account@emilltest.com"
oSoap.Password = "pwd"
Set oRst = oSoap.Call("GetList", "listId", "2319f42-ab2d-9278-691c-d61cf42ec2dfe")
Applies To
Soap Object
See Also

CreateParams, Call

©2001-2015 eMill . All trademarks property of their owners.


CreateParams method

CreateParams

The CreateParams method create a new Params collection.

Syntax

Soap.CreateParams param1, value1, param2, value2, ..., param10, value10

Parameters
paramX
Optional Variant of subtype String. Adds a new item named paramX with valueX value to the Params collection.
valueX
Optional Variant representing the paramX value.
Return value

A new Params collection.

Remarks

The Params collection is used to pass parameters to the Call method. A Params item can contain a Params sub-collection to form a complex type.

Example
Set oParams = soap.CreateParams("UPC", "745883561292")
oParams.Add "price", "39.99"
oParams.Add "description", soap.CreateParams("shortDesc", "WCF54G-EU", "longDesc", "Linksys PCI Wifi Adapteur WCF54G-EU")
Set oRst = oSoap.Call("method", oParams)
Applies To
Soap Object
See Also

CreateObject, Call

©2001-2015 eMill . All trademarks property of their owners.


Call method

Call

The Call method call a web service method using the SOAP protocol.

Syntax

Soap.Call method, parameters, returnType

Parameters
method
A mandatory String that contains the name of the web service method to call.
parameters
An optional Variant of subtype Params that contains the list of parameters to pass to the web service method.
returnType
An optional Variant of subtype Long defining the type of result to return:
  • 0 = Returns either an ADO Recordset object or a String (default)
  • 1 = Returns the result as a String
  • 2 = Returns the XML node object of the web service method result
  • 3 = Returns an ADO Recordset object if the web service method returns a .NET Dataset, throw an error otherwise
Example
'We assume the active list is an eMill Optin Service subscribers list, so the Soap
'object can initialize its properties using the list corresponding parameters.
Set oParams = soap.CreateParams("listId", "2319f42-ab2d-9278-691c-d61cf42ec2dfe")
Set oRst = soap.Call("GetList", oParams)
Applies To
Soap Object
See Also

CreateObject, CreateParams

©2001-2015 eMill . All trademarks property of their owners.


Json Object

You can use the Json object to parse, manipulate, or serialize data in JSON format.

Syntax

Json.property|method

Methods
CreateObject | Creates and returns a new standalone Json object.
Parse | Convert a JSON string into a variable.
Stringify | Serialize a variable as a JSON string.
Remarks

The Json object properties are added or deleted dynamically using affectations. To add a property to a JSON object, simply affect it to a non empty value. To remove a property, affect it to Empty. Json object properties can also be accessed or affected using the array item syntax. Property names of Json object can be enumerated using the For Each jsoinstruction.

Example
' Creates a Json object named oJson
oJson = JSON.CreateObject()

' Creates a property named api_version and set it to 3
oJson.api_version = 3

' Creates a property named api_url and set its value
oJson("api_url") = "http://api.json.demo/"

' Removes a property named useless
oJson.useless = Empty

' Enumerates the Json object properties by name
For Each name In oJson
   Response.Write "Propery name: " & name & " - Property value: " & oJson(name) & "<br>"
Next
©2001-2015 eMill . All trademarks property of their owners.


CreateObject method

CreateObject

The CreateObject method creates a new standalone Json object.

Syntax

Json.CreateObject

Return value

A new standalone Json object.

Example
Set oJson = Json.CreateObject
Applies To
Json Object
See Also

Parse, Stringify

©2001-2015 eMill . All trademarks property of their owners.


Parse method

Parse

The Parse method convert the a JSON string representation into a variable.

Syntax

Json.Parse json_string

Parameters
json_string
Mandatory Variant of subtype String that contains a JSON serialization string.
Return value

If the JSON string represents an object, JSON.Parse will create a Json object and will populate its properties according to the JSON string. If the JSON string represents an array or a simple type (string, integer, float or boolean), JSON.Parse will return a variable of the corresponding VBScript type. Parse method is fully recursive and can parse nested objects and arrays.

Example
aColors = Json.Parse("[ { color: ""red"", value: &HFF0000 }, { color: ""green"", value: &H00FF00 }, { color: ""blue"", value: &H0000FF } ]")
Applies To
Json Object
See Also

CreateObject, Stringify

©2001-2015 eMill . All trademarks property of their owners.


Stringify method

Parse

The Stringify method convert a variable into its JSON representation.

Syntax

Json.Stringify value

Parameters
value
Mandatory Variant that contains the variable to serialize in JSON format.
Return value

A string representing the convertion of the given value in the JSON serialization format.

Remarks

Stringify method can only convert simple variable types (string, integer, float, boolean and null), arrays and Json objects into a JSON string. Any variable that cannot be represented as a JSON object will trigger an invalid argument error, especially any objects of type not Json. Stringify is fully recursive, it can serialize Json objects and array variables that contain other Json objects or other arrays.

Applies To
Json Object
See Also

CreateObject, Parse

©2001-2015 eMill . All trademarks property of their owners.


DataSource Object

The DataSource object was implemented to avoid eMill from being restricted to one data access technology. eMill includes source code to access any ADO compatible data source. Developers could replace this code with their own code to implement data access to any non ADO database.

Syntax

DataSource.collection|property|method

Properties
BOF | Indicates that the current record position is before the first record.
EOF | Indicates that the current record position is after the last record.

Additional header fields can be set using the Headers collection

Methods
Open | This method opens the data source.
Close | This method closes the data source.
GetRowCount | Returns the number of records in the data source.
CanMovePrevious | Returns True if the record position can move backward.
MoveFirst | Moves the record position to the first record.
Move | Moves the position of the current record.
CanDelete | Returns True if records can be deleted.
Delete | Deletes the current record.
AddNew | Prepares a new empty record.
Update | Updates the current record.
CanUpdate | Returns True if records can be updated.
CancelUpdate | Cancel any pending updates due to a AddNew operation.
Remarks

The DataSource object cannot be accessed directly. The Record object should be used to exchange data between the DataSource object and a script enabled content file.

See Also

Record Object

©2001-2015 eMill . All trademarks property of their owners.


BOF

Specifies whether the current record position is before the first record.

Return Value

Returns a Boolean value.

Remarks

If the returned value is True, the current record is positioned before the first record. Otherwise the returned value is False.

Applies To

DataSource Object

See Also

EOF

©2001-2015 eMill . All trademarks property of their owners.


EOF

Specifies whether the current record position is after the last record.

Return Value

Returns a Boolean value.

Remarks

If the returned value is True, the current record position is after the last record. Otherwise the returned value is False.

Applies To

DataSource Object

See Also

BOF

©2001-2015 eMill . All trademarks property of their owners.


Open

The Open method will open the data source.

Syntax

Sub DataSource_Open()
End Sub

Parameters
None
Applies To

DataSource Object

See Also

Close

©2001-2015 eMill . All trademarks property of their owners.


Close

The Close method will close the data source.

Syntax

Sub DataSource_Close()
End Sub

Parameters
None
Applies To

DataSource Object

See Also

Open

©2001-2015 eMill . All trademarks property of their owners.


GetRowCount

The GetRowCount method returns the number of records in the data source.

Syntax

Function DataSource_GetRowCount()
DataSource_GetRowCount = RecordCount
End Function

Parameters
None
Applies To

DataSource Object

©2001-2015 eMill . All trademarks property of their owners.


CanMovePrevious

The CanMovePrevious method returns True if the record position can be moved backward, otherwise the return value is False.

Syntax

Function DataSource_CanMovePrevious()
DataSource_CanMovePrevious = True/False
End Function

Parameters
None
Remarks
If the record position cannot move backwards, eMill will do a MoveFirst followed by a Move(n)
Applies To

DataSource Object

©2001-2015 eMill . All trademarks property of their owners.


MoveFirst

The MoveFirst method will moves the record position to the first record. If there is no first record, then BOF should return True.

Syntax

Sub DataSource_MoveFirst()
End Sub

Parameters
None
Applies To

DataSource Object

See Also

Move

©2001-2015 eMill . All trademarks property of their owners.


Move

The Move method will move the position of the current record

Syntax

Sub DataSource_Move(NumRecords)
End Sub

Parameters
NumRecords
A signed Long expression that specifies the number of records that the current record position moves.
Remarks

If the NumRecords argument is greater than zero, the current record position moves forward (toward the end of the DataSource). If NumRecords is less than zero, the current record position moves backward (toward the beginning of the DataSource).

Applies To

DataSource Object

See Also

MoveFirst

©2001-2015 eMill . All trademarks property of their owners.


CanDelete

The CanDelete method returns True if the record can be deleted, otherwise False is returned.

Syntax

Function DataSource_CanDelete()
DataSource_CanDelete = True/False
End Function

Parameters
None
Applies To

DataSource Object

See Also

Delete

©2001-2015 eMill . All trademarks property of their owners.


Delete

The Delete method will delete the current record.

Syntax

Sub DataSource_Delete()
End Sub

Parameters
None
Applies To

DataSource Object

See Also

CanDelete

©2001-2015 eMill . All trademarks property of their owners.


AddNew

The AddNew method will creates a new record.

Syntax

Sub DataSource_AddNew
End Sub

Parameters
None
Remarks

The AddNew method should initialize the Record object fields to default values. If the AddNew operation is canceled, CancelUpdate will be called.

Applies To

DataSource Object

See Also

Update, CancelUpdate, CanUpdate

©2001-2015 eMill . All trademarks property of their owners.


Update

The Update method saves any changes you make to the Record object

Syntax

Sub DataSource_Update()
End Sub

Parameters
None
Remarks

Use the Update method to save any changes you make to the current Record object since calling the AddNew method or since changing any field values in an existing record.

Applies To

DataSource Object

See Also

AddNew , CanUpdate

©2001-2015 eMill . All trademarks property of their owners.


CanUpdate

The CanUpdate method returns True if the record can be updated.

Syntax

Function DataSource_CanUpdate()
DataSource_CanUpdate = True/False
End Function

Parameters
None
Applies To

DataSource Object

©2001-2015 eMill . All trademarks property of their owners.


CancelUpdate

The CancelUpdate method will cancel any pending updates due to a AddNew operation.

Syntax

Sub DataSource_CancelUpdate()
End Sub

Parameters
None
Applies To

DataSource Object

See Also

AddNew

©2001-2015 eMill . All trademarks property of their owners.


CSafeStr

CSafeStr returns an expression that has been converted to a Variant of subtype String. CSafeStr is similar to CStr except that the expression can be set to Null or Empty.

Syntax

CSafeStr(expression)

Parameters
expression
Any kind of Variant. The Variant can be of type Null or Empty
Return Value

A Variant of subtype String. If the expression is Null or Empty, an empty string ("") is returned.

Example

<%
sName = CSafeStr(Record.Fields("Name"))
%>

See Also

VBScript Reference

© 2001-2015 eMill . All trademarks property of their owners.


DefaultStr

DefaultStr returns a default Variant of subtype String if the passed expression is a Variant of subtype Null or Empty, or if the passed string expression is empty.

Syntax

DefaultStr(expression, default)

Parameters
expression
Any kind of Variant. The Variant can be of type Null or Empty
default
Any kind of Variant
Return Value

A Variant of subtype String.

Example

Dear <%=DefaultStr(Record.Fields("Name"), "Customer"%>,

See Also

VBScript Reference

© 2001-2015 eMill . All trademarks property of their owners.


HtmlToText

Converts HTML or XHTML encoded text to plain text.

Syntax

HtmlToText(html)

Parameters
html
A Variant of subtype String or an Array of Byte
Return Value

A Variant of subtype String.

Example

<%Response.Write HtmlToText(Mail.Contents("HTMLNote").Data)%>

©2001-2015 eMill . All trademarks property of their owners.


EncodeBase64Str

EncodeBase64Str returns a Variant of subtype String that contains the passed string as Base64 encoded.

Syntax

EncodeBase64Str(expression)

Parameters
expression
A Variant of subtype String.
Return Value

A Variant of subtype String.

Remarks
EncodeBase64Str does not directly encode the passed string to a Base64 string. It first converts it to a utf-8 string, encode the utf-8 string to base64 and return the base64 string in a BSTR.
Therefore a string in any language (asian, arabic, european,...) may be converted to the base64 format.
Example

<%
Mail.Headers("X-ProjectName") = EncodeBase64Str("Picasso est né le 25 octobre 1881 à Malaga")
' base64 string = "UGljYXNzbyBlc3QgbsOpIGxlIDI1IG9jdG9icmUgMTg4MSDDoCBNYWxhZ2E="
%>

See Also

VBScript Reference, DecodeBase64Str

 ©2001-2015 eMill . All trademarks property of their owners.


DecodeBase64Str

DecodeBase64Str returns a Variant of subtype String that contains decoded version of a base64 encoded expression.

Syntax

DecodeBase64Str(expression, charset)

Parameters
expression
A Variant of subtype String.
charset
An optional Variant of subtype String that contains the charset of the string that was encoded.
Return Value

A Variant of subtype String.

Remarks
If charset is not specified, the function use utf-8. If the encoded string was a 2 bytes unicode string, the charset must be of type utf-16.
Example

<%
sProjectName = DecodeBase64Str(Mail.Headers("X-ProjectName"))
%>

See Also

VBScript Reference, EncodeBase64Str

 ©2001-2015 eMill . All trademarks property of their owners.


FormatEmailAddress

FormatEmailAddress returns a Variant of subtype String that contains a formatted email address.

Syntax

FormatEmailAddress(email, firstName, LastName)

Parameters
email
A Variant of subtype String.
firstName
An optional Variant of subtype String.
lastName
An optional Variant of subtype String.
Return Value

A Variant of subtype String.

Remarks
The email parameter must be valid otherwise FormatEmailAddress will throw an error.
FormatEmailAddress builds a display name using the firstName and lastName parameters. Extra spaces are removed and the first letter of each word is set to uppercase, and the following letters are set to lowercase.
If both firstName and lastName are missing or invalid, FormatEmailAddress just returns the email parameter.
Example

<%
Mail.From = FormatEmailAddress("jim.clark@emilltest.com", "jim", "clark")
' returns a string containing "Jim Clark" <jim.clark@emilltest.com>
%>

See Also

VBScript Reference, ExtractEmailAddresses

©2001-2015 eMill . All trademarks property of their owners.


ExtractEmailAddresses

ExtractEmailAddresses returns a Variant of subtype String or Array of strings that contains all the addresses found in the buffer parameter.

Syntax

ExtractEmailAddresses (buffer, asArray)

Parameters
buffer
A Variant of subtype String or Array of bytes
asVariant
An optional Variant of subtype Bool.
Return Value

A Variant of subtype String or Array of strings.

Remarks
If asArray is missing or set to False, ExtractEmailAddresses returns the extracted email addresses as comma separated, otherwise, ExtractEmailAddresses returns the extracted email addresses as a string array.
If no addresses are found, or if buffer is not a string or a byte array, ExtractEmailAddresses returns either an empty string or an empty string array.
Example

Sub Mailing_OnReceiveMail()
    Dim sUnsubscribeEmail

    If InStr(1, UCase(Mail.Subject), "UNSUBSCRIBE", vbTextCompare) > 0 Then
        sUnsubsribeEmail = ExtractEmailAddresses(Mail.Subject)
    End If

    ...
End Sub

See Also

VBScript Reference, FormatEmailAddress

 ©2001-2015 eMill . All trademarks property of their owners.


CreateUniqueID

Generates a 128 bit unique identifier in form of a string of 26 characters in length. All characters are in upper case (A-Z, 0-9).

Syntax

CreateUniqueID()

Parameters
none
Return Value

A Variant of subtype String.

Example

<%Response.Write "A unique id: " & CreateUniqueID()%>

©2001-2015 eMill . All trademarks property of their owners.


GetHttpFile

GetHttpFile returns a Variant of subtype Byte array or String that contains the result of the HTTP request.

Syntax

GetHttpFile(url, userName, password, fields, charset)

Parameters
url
A Variant of subtype String.
userName
An optional Variant of subtype String.
password
An optional Variant of subtype String.
fields
An optional Variant of subtype String or String array.
charset
An optional Variant of subtype String.
Return Value

A Variant of subtype String if the HTTP server returns a content of type text, a Byte array otherwise.

Remarks
The url parameter must be a valid HTTP or HTTPS url. Both userName and password can be provided to perform HTTP authentication. The field parameter contains the data to post to the url resource. It is either a string of field: value pair separated by carriage return or a string array of field: value pair. field data is encoded using the current charset or using the charset parameter if provided.
Example
<%
    Response.Write GetHttpFile("http://www.emill.net")
    ' Write a string containing the http://www.emill.net page content.
%>
See Also

VBScript Reference

© 2001-2015 eMill . All trademarks property of their owners.


CreateUniqueID

DecodeInternetDate

Convert an RFC822 datetime string to a DATE variant.

Syntax

DecodeInternetDate(internetDate)

Parameters
date
Return Value

A Variant of subtype Date. An error is thrown if the convertion fails

Example

<% Response.Write "An internet datetime: " & DecodeInternetDate("13 Dec 2010 08:00:02 +0100") %>

©2001-2015 eMill . All trademarks property of their owners.


CreateUniqueID

IsJokerMatch

Determines if a string matches a pattern.

Syntax

IsJokerMatch(string, pattern)

Parameters
string
A String to be checked.
pattern
A String pattern to check for match against string.
Return Value

A Variant of subtype Bool equals to True is string matches pattern, False otherwise.

Note

pattern string can contain * and ? jokers. The * joker matches any string char zero or more times. The ? joker matches any string char exactly one time. Other characters match their case insensitive equivalent.

Examples

IsJokerMatch("abcd", "a*d") returns True.
IsJokerMatch("abc", "a?c") returns True.
IsJokerMatch("abc", "a??c") returns False.
IsJokerMatch("john@emilltest.com", "*??@??*.??*") returns True.
IsJokerMatch("a@b.c", "*??@??*.??*") returns False.

©2001-2015 eMill. All trademarks property of their owners.


Exemples de Scripts Serveur

Des exemples sont fournies avec eMill dans le dossier Mes documents\Projets eMill\Exemples.

©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Première Utilisation

Pour créer un nouveau projet d'emailing, vous pouvez :

- Lancer l'assistant Nouveau Projet de Publipostage, une série de boîtes de dialogue qui vous guide pour les configurations de base. Tous les paramètres et les fichiers créés par l'assistant demeurent accessibles et peuvent être modifiés à tout moment. Si vous désirez démarrer un projet à partir d'un fichier email reçu par Internet, l'assistant Nouveau Projet de Publipostage vous permet d'utiliser le modèle de message optionnel.

- Dupliquer un projet existant à partir du menu Fichier en sélectionnant Dupliquer le projet sous.

- Créer un nouveau projet mailing vide.

Après la création de votre nouveau projet, créez un nouveau contenu à partir des éditeurs d'eMill. Si vous désirez importer des fichiers existants, utilisez l'option nouveau contenu à partir d'un fichier.

Vous avez également la possibilité d'utiliser uniquement eMill en tant qu'éditeur en créant un nouveau fichier HTML ou Texte ou un nouveau fichier script. Vous pourrez ensuite inclure ces fichiers à un projet en utilisant l'option nouveau contenu à partir d'un fichier.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Importer du Presse-Papiers

Si eMill n'est pas capable d'importer des adresses d'un fichier (les données ne sont pas reconnues parmi les informations), vous pouvez ouvrir le fichier dans son application native et copier le contenu dans le presse-papiers. eMill extraira alors les adresses à partir du presse-papiers.

  • Ouvrir le fichier dans son application et copier le contenu dans le presse-papiers.
  • Lorsque vous lancez un nouveau projet, cocher Importer d'un fichier texte non structuré, dans la boîte de sélection des sources de données et sélectionner Importer les adresses du Presse-papiers :

Le nombre total d'adresses email importées dans la base du nouveau projet est affiché. Cette base ne comprend que le champ "adresse email". Vous pouvez importer des données de différents fichiers en sauvant dans une base différente à chaque fois et en les associant toutes ensuite dans database.mdb depuis la vue destinataires ou en utilisant Microsoft Access.

©2001-2015 eMill . Toutes les marques citées sont la propriété de leurs ayants droit.


Utilisation d'ojets et de composants

Utilisation d'objets et de composants

Les composants COM sont la clé pour construire de puissantes applications Web. Les composants vous procurent des fonctionnalités permettant à vos script d'exécuter des tâches telles que des transactions financières ou de la validation de données. ASP fourni un ensemble de composants de base que vous pouvez utiliser pour améliorer vos scripts.

A propos des composants :

Un composant COM est un objet réutilisable qui contient du code pour exécuter une ou plusieurs actions. Les composants peuvent être combinés entre eux (même au travers de réseaux) pour créer des application Web. Les composants COM exécutent des tâches courantes que vous n'aurez pas besoin de réécrire. Par exemple, vous pouvez utiliser un composant pour afficher les derniers cours d'actions sur une page Web. Il serait difficile de créer un script qui apporte les même fonctionnalités. De plus, le script ne pourrait pas être aussi réutilisable qu'un composant.

Si vous débutez dans la programmation script, vous pouvez écrire des scripts utilisant des composants sans rien connaître de leur fonctionnement. ASP apporte une base de composants que vous pouvez utiliser immédiatement. Par exemple, vous pouvez utiliser les composant ActiveX Data Objects (ADO) pour connecter vos pages Web à des bases de données. Des composants additionnels peuvent aussi être obtenus auprès de développeurs tierce-partie.

Si vous êtes un développeur d'applications Web, les composants sont la meilleure façon d'encapsuler votre logique d'entreprise dans des modules sûrs et réutilisables. Par exemple, vous pouvez utiliser un composant qui vérifie les numéros de cartes bancaires depuis un script qui traite les commandes. De plus, puisque les composants COM sont réutilisables, vous pouvez les utiliser dans d'autres scripts et applications. Après avoir installé un composant sur votre serveur Web, vous pouvez l'appeler depuis un script serveur ASP, une extension ISAPI, un autre composant sur le serveur ou un programme écrit dans un langage compatible COM.

Vous pouvez créer des composants dans n'importe quel langage de programmation supportant le Component Object Model (COM), tel que C, C++, Java, Visual Basic ou d'autres nombreux langages (Si vous êtes familier avec la programmation COM, les composants COM sont aussi connus sont le nom de serveurs Automation). Pour s'exécuter sur un serveur Web, votre composant COM ne doit pas avoir d'éléments d'interface graphique, tel la fonction Visual Basic MsgBox. Les éléments d'interface graphique ne seraient visibles que sur le serveur, pas sur le navigateur.

Créer une instance d'Objet :

Un composant est fait de code exécutable contenu dans une bibliothèque à liaison dynamique (fichiers .dll) ou un fichier exécutable. Les composants comportent un ou plusieurs objets, des unités de code exécutant des fonctions spécifiques dans le composant. Chaque objet a des méthodes (procédures programmées) et des propriétés (attributs comportementaux). Pour utiliser un objecte fourni par un composant, vous créez une instance de l'objet et vous assignez cette instance à un nom de variable. Utilisez le méthode ASP Server.CreateObject ou le tag html <OBJECT> pour créer une instance d'objet. Utilisez l'instruction d'assignation de votre langage de script pour donner un nom à l'instance de votre objet. Quand vous créez une instance d'objet, vous devez fournir son nom d'enregistrement (ProgID). Vous pouvez vous procurer les ProgID des objets de base fournis avec ASP sur les pages de références d'ASP.

Par exemple, le composant Ad Rotator permet d'afficher de façon aléatoire une publicité graphique parmis un certain nombre. Le composant Ad Rotator fournit un objet, appelé Ad Rotator Object, dont le ProgID est "MSWC.AdRotator". Pour créer une instance de cet objet, utilisez les instructions suivantes :

VBScript:

<% Set MyAds = Server.CreateObject("MSWC.AdRotator") %>

JScript:

<% var MyAds = Server.CreateObject("MSWC.AdRotator") %>

Si vous êtes déjà familiarisé avec VBScript ou JScript, notez que vous n'utilisez pas les fonctions du langage pour créer de nouvelles instances d'objets (CreateObject en VBScript ou new en JScript). Vous devez utilisez la méthode ASP Server.CreateObject, sinon, ASP ne pourra pas suivre l'utilisation des objets dans vos scripts.

Vous pouvez aussi utiliser le tag html <OBJECT> pour créer une instance d'objet. Vous devez spécifier l'attribut RUNAT avec pour valeur Server, et vous devez renseigner l'attribut ID avec le nom de la variable que vous utiliserez dans vos scripts. Vous identifierez l'objet en utilisant soit son nom d'enregistrement (ProgID), soit son numéro d'enregistrement (CLSID). L'exemple suivant se sert du ProgID pour créer une instance de l'objet Ad Rorator.

<OBJECT RUNAT=Server ID=MyAds PROGID="MSWC.AdRotator"></OBJECT>

L'exemple suivant utilise le numéro d'enregistrement (CLSID) pour créer une instance de l'objet Ad Rotator :

<OBJECT RUNAT=SERVER ID=MyAds
CLASSID="Clsid:1621F7C0-60AC-11CF-9427-444553540000"></OBJECT>

Utiliser le script pour créer des composants COM :

ASP supporte Windows Script Components, une technologie puissante de Microsoft que vous pouvez utiliser pour créer des composants COM. Plus précisement, vous pouvez encapsuler des scripts communs, tels ceux utilisés pour accéder à une base de données ou pour générer un contenu, dans des composants réutilisables par n'importe quel fichier ASP ou programme. Vous pouvez aussi incorporer Windows Script Components dans des programmes écrits dans des langages compatibles COM, tels Visual Basic, C++ ou Java.

L'exemple suivant écrit en VBScript utilise Windows Script Components. Il définit deux méthodes pour convertir des températures entre degrés Fahrenheit et Celsius :

<SCRIPTLET>

<Registration
    Description="ConvertTemp"
    ProgID="ConvertTemp.Scriptlet"
    Version="1.00"
>
</Registration>

<implements id=Automation type=Automation>
    <method name=Celsius>
        <PARAMETER name=F/>
    </method>
    <method name=Fahrenheit>
        <PARAMETER name=C/>
    </method>
</implements>

<SCRIPT LANGUAGE=VBScript>

  Function Celsius(F)
      Celsius = 5/9 * (F - 32)
  End Function

  Function Fahrenheit(C)
      Fahrenheit = (9/5 * C) + 32
  End Function

</SCRIPT>
</SCRIPTLET>

Avant d'implémenter ce composant, vous devez sauver ce fichier avec une extension .sct et, à l'aide de l'Explorateur Windows, faites un clic droit sur ce fichier et sélectionnez Inscrire. Pour utiliser un composant Windows Script Component dans une page Web, vous devez utiliser un langage de script serveur comme dans l'exemple suivant :

<%
  Option Explicit

  Dim objConvert
  Dim sngFvalue, sngCvalue

  sngFvalue = 50
  sngCvalue = 21

  Set objConvert = Server.CreateObject("ConvertTemp.Scriptlet")
%>

<%= sngFvalue %> degrés Fahrenheit est équivalent à <%= objConvert.Celsius(sngFvalue) %> degrés Celsius<BR>

<%= sngCvalue %> degrés Celsius est équivalent à <%= objConvert.Fahrenheit(sngCValue) %> degrés Fahrenheit<BR>

Utiliser les Objets Intégrés d'ASP :

ASP fournit aussi des objets intégrés pour exécuter certaines tâches qui simplifient le développement Web. Par exemple, vous pouvez utiliser l'objet Request pour accéder facilement à des informations associées à une requête HTTP, telles que les données provenant d'un formulaire HTML ou des cookies. A l'inverse des objets fournis par un composant COM, vous n'avez pas besoin de créer une instance des objets ASP intégrés que vous utilisez dans vos scripts. Ces objets sont automatiquement créés au début du traitement de la requête ASP. Vous accédez aux méthodes et aux propriétés des objets intégrés de la même façon que vous accédez aux méthodes et aux propriétés des objets COM.

Appeler les Méthodes d'un Objet :

Une méthode est une action que vous pouvez exécuter sur un objet ou via un objet. La syntaxe pour appeler une méthode est :

Objet.Methode paramètres

Les paramètres dépendent de la méthode.

Par exemple, vous pouvez utiliser la méthode Write de l'objet Response intégré pour envoyer des informations au navigateur web :

<% Response.Write "Bonjour tout le monde" %>

Affecter les Propriétés d'un Objet :

Une propriété est un attribut qui décrit l'objet. Les propriétés définissent les caractéristiques de l'objet, tel que le type de l'objet, ou décrivent l'état de l'objet, tel que activé ou désactivé. La syntaxe est :

Objet.Propriété

Vous pouvez parfois lire et affecter la valeur d'une propriété. De plus, pour certains objets, vous pouvez aussi ajouter de nouvelles propriétés.

Par exemple, l'objet Ad Rotator à une propriété Border, qui spécifie si l'encart affiché aura une bordure et l'épaisseur de cette dernière. L'expression suivante précise qu'il n'y a pas de bordure.

<% MyAds.Border = 0 %>

Pour certaines propriétés, vous pouvez afficher la valeur courante en utilisant la directive de sortie d'ASP. Les instructions suivantes retournent VRAI si le navigateur est encore connecté au serveur Web.

<%= Response.IsClientConnected %>
©2001-2015 eMill. Toutes les marques citées sont la propriété de leurs ayants droit.


Add

The Add method adds an item to a collection.

Syntax

Collection.Add([key][, value])

Parameters
key
The unique key for the item to add. This parameter is optional.
value
The value to set
Example

The following example adds an item to the Receivers collection.

<%
   Mail.Receivers.Add "jim@emilltest.com"
%>

The following example adds an item with a key to the Receivers collection.

<%
   Mail.Receivers.Add "jim", "jim@emilltest.com"
   sJimEmail = Mail.Receivers("jim")
%>
Remarks

An alternative method to add an item is use an explicit key. e.g:
Mail.Receivers("joe") = "joe@emilltest.com"

Applies To

Collection Object

©2001-2015 eMill . All trademarks property of their owners.


Count

Returns the number of items in a collection.

Syntax

Collection.Count

Return Value

Returns a Long value.

Example

Response.Write "We have " & Family.Childrens.Count & " kids and they are named:<br>"

For iItem = 0 to Family.Childrens.Count-1
  Response.Write Family.Childrens(iItem) + "<br>"
Next

The same could be written using the For Each syntax:

 For Each child In Family.Childrens
  Response.Write Family.Childrens(child) + "<br>"
Next

Remarks

Because numbering for members of a collection begins with zero, you should always code loops starting with the zero member and ending with the value of the Count property minus 1. In VBScript it is preferable to use the For Each ... Next syntax.

Applies To

Collection Object

©2001-2015 eMill . All trademarks property of their owners.


Collection Object

All collections in eMill use the the following syntax and methods

Syntax

Item = Object.Collection(key|index)

Parameters
key
The identifier for the item to return.
index
An index offset indicating which item in the list to return. The index starts at 0
Return Value
A Variant that contains the value stored in the collection. The Variant can be of any type.
Properties
Count Returns the number of items in the collection.
Methods
Remove | Deletes an item from the collection.
RemoveAll | Deletes all items from the collection.
Add | Add an item to the collection.

©2001-2015 eMill . All trademarks property of their owners.


Contents

Remove

The Remove method deletes an item from a collection.

Syntax

Collection.Remove(key|index)

Parameters
key
The identifier for the item to remove.
index
An index offset indicating which item in the list to remove.
Remarks

The Remove method takes either a string or an integer as an input parameter. If the input parameter is a string, the method will search the contents collection for an item with that name and remove it. If the input parameter is an integer, the method counts that number of items from the start of the collection, and removes the corresponding item.

Example

The following example adds two items to the Application.Contents collection and removes the second one.

<%
   Record.Fields("strFirst")=("First thing")
   Record.Remove("strFirst")
%>
Applies To

Collection Object

See Also

RemoveAll

©2001-2015 eMill . All trademarks property of their owners.


Contents

RemoveAll

The RemoveAll method removes all items that have been added to the collection.

Syntax

RemoveAll()

Applies To

Collection Object

See Also

Remove

©2001-2015 eMill . All trademarks property of their owners.


Data

The Data property is used to access the MIME source.

Settings and Return Values

Set or returns a String value that contains the MIME source.

Remarks

It is also possible to set this property with a Variant of subtype Array of Byte.

Applies To

Mail Object

See Also

Content.Data

©2001-2015 eMill. All trademarks property of their owners.


Save

The Save method will save the Mail Object as a MIME file (.eml).

Syntax

Mail.Save(FileName)

Parameters
FileName
A String specifying the new file name for the mail to be saved.
Remarks
Mail Contents that include VBScript code will be rendered at that time.
Example

Mail_OnReceiveMail
Mail.Save "c:\temp\mail.eml"
End Sub

Applies To

Mail Object

See Also

Content.Save

©2001-2015 eMill . All trademarks property of their owners.


Date

SendDate

The SendDate property specifies the date and time the message should be sent.

Settings and Return Values

Sets or returns the Date value. The date may be a Variant of type Date or String. The string may specify a classic date/time format or an rfc822 date/time format. If the time is specified but not the date, the date will be set with the current system date.

Applies To

Mail Object

©2001-2015 eMill . All trademarks property of their owners.